Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zugriff auf Server fällt kurzzeitig aus (keine Erreichbarkeit der Dienste)

Frage Microsoft Windows Server

Mitglied: alex-tech

alex-tech (Level 1) - Jetzt verbinden

02.07.2013 um 09:02 Uhr, 2031 Aufrufe, 14 Kommentare

Hallo,

ich habe ein seltsames Phänomen an einem Server.

Es handelt sich um einen HP-Server mit Windows 2008 R2. Auf dem Server läuft die Software "HP Network" mit der 4 Netzwerkkarten zu einem Team verbunden sind (Load Balance und Fault Tolerance). Die 4 Netzwerkkarten sind mit einem Switch verbunden auf dessen Ports Link Aggregation eingerichtet ist. (Bei anderen Server die mit dem gleichen Switch verbunden sind habe ich die gleiche Konfiguration und keine Probleme.)

Das Problem ist folgendes:
Die Verbindung zum Server geht alle 15-30 Minuten für ein paar Sekunden verloren. D.h. meine Remotesession verliert die Verbindung und unser Netzüberwachungstool meldet, dass die Dienste auf dem Server nicht mehr erreichbar sind. Seltsamerweise habe ich keine Ping-Verluste. Daher glaube ich, dass es sich nicht um ein Netzwerk, sondern um ein Windowsproblem handelt.

In der Ereignisanzeige konnte ich keinen besondere Meldung oder Fehler entdecken. Lediglich das Microsoft Überwachungsprogramm meldet wenn die Remotesitzung beendet wurde und eine neue hergestellt wurde.


Für Ideen, wo ich den Fehler finden könnte wäre ich dankbar.

Vielen Dank.
Mitglied: certifiedit.net
02.07.2013 um 09:23 Uhr
Hallo,

eine Möglichkeit wäre die Dienste lokal mit zu loggen. Dh auf localhost : Port Anfragen, wie mit dem Monitoringtool zu schicken.

Grüße
Bitte warten ..
Mitglied: alex-tech
02.07.2013 um 11:31 Uhr
Gibt es dafür ein Tool welches die Dienste lokal überwachen und dies aufzeichnen kann? Ich kann mir den Status zwar anzeigen lassen, aber sobald ich die Verbindung verliere sehe ich ja nichts mehr. Und mir eine Mail von einem lokalen Überwachungsprogramm schicken zu lassen würde wahrscheinlich auch nicht gehen.

Viele Grüße.
Bitte warten ..
Mitglied: goscho
02.07.2013 um 12:45 Uhr
Hallo,
Zum Überwachen der Dienste kann der Sysinternal Process Monitor genutzt werden.
Der zeichnet auch auf, kann aber schnell Gigabyte an Daten verursachen.
Bitte warten ..
Mitglied: DerWoWusste
02.07.2013 um 14:29 Uhr
Hi.

Du hast doch schon einen Ansatz: RDP bricht zusammen, während ping geht.
Teste also z.B. per portping, ob die Ports für RDP (3389) und Deine Dienste (?) durchgängig erreichbar sind.
http://www.tkolb.de/portping-13-36.html
Bitte warten ..
Mitglied: alex-tech
03.07.2013 um 12:03 Uhr
Hallo,

Danke für die Vorschläge. Mit dem Process Monitor kam ich nicht viel weiter. Die Log-Datein wurde trotz Filter zu groß um den mal eine Nacht laufen zu lassen.
Ich habe jetzt die Dienste mittels Portping sowohl Remote als auch lokal die Nacht über überwacht. Mir wurde durchgängig gemeldet, dass die Ports offen sind.

Mir ist jetzt noch etwas aufgefallen. Sollte ich keine Remote- oder Freigabeverbindung haben und ich den Server daraufhin pinge habe ich danach wieder Zugriff. Nach einer Weile komme ich dann wieder nicht drauf.
Bitte warten ..
Mitglied: certifiedit.net
03.07.2013 um 12:08 Uhr
Hallo,

du solltest das auch nicht eine Nacht machen, das wurde aber schon angemerkt.

Laut deinen Infos tritt das Problem aber doch halbstündlich auf - eine Stunde loggen sollte daher genügen?

Grüße,

Christian
Bitte warten ..
Mitglied: alex-tech
03.07.2013 um 12:32 Uhr
Naja, den Process Monitor hatte ich auch gute 2,5 Stunden laufen. Nur ist in dieser Zeit tatsächlich die Verbindung (zwischen meinem Arbeitsplatz und dem Server) nicht weg gewesen. Wie ich jetzt festgestellt habe hat, während ich von einem Rechner auf den Server zugreifen konnte, ein anderer Rechner nicht mehr drauf zugreifen können bis er den selbigen gepingt hat.

Die Ports sind weiterhin offen. (Portping läuft)
Vielleicht doch ein Netzwerkproblem? Die Rechner/Server sind im gleichen Netz Firewall gibt es nicht.
Bitte warten ..
Mitglied: DerWoWusste
03.07.2013 um 12:46 Uhr
Während der Ausfälle meldet portping, dass die ports erreichbar sind?
Bitte warten ..
Mitglied: alex-tech
05.07.2013 um 12:23 Uhr
Entschuldigt, dass ich mich erst jetzt wieder melde. Ich habe in der Zwischenzeit das HP-Teaming deaktiviert und den Trunk auf dem Switch, so dass ich jetzt "normal" mit einem Kabel eine Netzwerkverbindung hergestellt habe. Desweiteren habe ich den Virenscanner deinstalliert. Und mir ist aufgefallen, dass der Server als Netzwerkverbindung "öffentliches Netzwerk" angezeigt hat. Mittlerweile hat er erkannt, dass er in einer Domäne hängt und zeigt "Domänen Netzwerk" an.

In einem anderen Forum habe ich gelesen, dass jemand ein ähnliches Problem über die TCP-Chimneyabladung lösen konnte: http://support.microsoft.com/kb/951037/de
Ich habe es versucht hat aber auch nichts gebracht.

Die DNS Einträge habe ich kontrolliert und nochmal neu gesetzt. Auflösung funktioniert von allen Seiten (auch Reverse).

Zu den Ports: Wenn ich beispielsweise von meinem Rechner auf die Freigabe nicht draufkomme dann komm ich von meinem Rechner nicht auf Port 445. Aber ein anderer Rechner kommt Problemlos dran. Und ich komm mit meinem Rechner Remote dran (aber auch eben nur manchmal).

Ein andere Server hat eine Freigabe des betroffenen Servers als Netzlaufwerk verbunden. Alle ca. 10 min. Wird das Netzlaufwerk als "nicht aktiv" angezeigt und man kommt nicht mehr drauf. Nach ein paar weiteren Minuten geht es wieder.

Vielleicht noch zur Info: Auf dem Server läuft eine DFS-Replikation
Bitte warten ..
Mitglied: DerWoWusste
05.07.2013, aktualisiert um 12:53 Uhr
Wenn PC A also keinen Freigabezugriff mehr hat, ist auch portping auf 445 unterbrochen, wie zu erwarten ist. Jedoch geht portping 445 von einem anderen Rechner aus - das lässt doch nur den Schluss zu, dass firewalltechnisch irgendwas instabil läuft, entweder am Client oder am Server.

Zum Netzwerkprofil: prüf mal, ob die Firewall in allen Profilen gleich eingestellt ist, vielleicht liegt es am Profilwechsel, warum auch immer dieser geschieht.
Bitte warten ..
Mitglied: alex-tech
05.07.2013 um 13:51 Uhr
Die Firewall habe ich auf allen Profilen deaktiviert. Die Rechner hängen alle im gleichen Netz und sonst keine Firewall dazwischen.

Am Client liegt es nicht. Da diese Probleme ja mit allen Clients zu beobachten sind.
Bitte warten ..
Mitglied: DerWoWusste
05.07.2013 um 13:54 Uhr
Am Client liegt es nicht
Echt? Du sagtest doch, an einem Client geht es nicht, "Aber ein anderer Rechner kommt Problemlos dran" - das klingt nach client- oder serverseitiger Instabilität, jedenfalls für mich.
Bitte warten ..
Mitglied: alex-tech
05.07.2013 um 14:02 Uhr
Ja,, damit wollte ich nur sagen, dass diese Probleme nicht unbedingt zwei Clients gleichzeitig haben. Das ganze ist eher ein Zufallsprinzip: Manchmal gehts von Client A nicht, manchmal von Client B nicht. Manchmal von beiden nicht. Wobei ich es nicht nur mit zwei Clients getestet habe und alle haben das Problem.

Ich dachte erst vielleicht noch an sowas wie einer Loop im Netzwerk o.ä. aber STP u.ä. ist auf unseren Switchen standardmäßig deaktiviert. Außerdem hängt auf dem gleichen Switch wie der fehlerhafte Server ein weiterer Server mit einer ähnlichen Konfiguration und der funktioniert Problemlos.
Bitte warten ..
Mitglied: alex-tech
05.07.2013 um 15:42 Uhr
Ok. hiermit bedanke ich mich recht herzlich für die Hilfe. Ich konnte den Fehler ausfindig machen.
Manchmal sieht man den Wald vor lauter Bäumen nicht.

Ein Kollege von mir hat (unachtsamerweise) einen alten Switch in das Netzwerk gehängt ohne die IP abzuändern. Dieser hatte unglücklicherweise die IP meines Servers.

IP angepasst jetzt läuft ^^ ... Man eh ihr glaubts nicht....
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange Dienst fällt aus
gelöst Frage von racer1601Exchange Server4 Kommentare

Guten Morgen ich habe ein Problem mit einem Mail Proxy. erstmal zum Konstrukt. Hinter der Watchguard Firewall hängt für ...

Windows Netzwerk
Erreichbarkeit freigegebene Ordner und Server
Frage von racer1601Windows Netzwerk3 Kommentare

Hallo Kollegen, ich hätte da noch ein Problem das schon länger besteht. Also eigentlich seit dem diese Firma ihre ...

Exchange Server
Exchange-Server-Erreichbarkeit von aussen instabil
Frage von coltseaversExchange Server2 Kommentare

Hallo zusammen, es geht um einen Windows SBS2008 mit Exchange 2007. Seit einigen Tagen sind die Dienste des Servers ...

Server-Hardware
USV fällt aus
Frage von MarkowitschServer-Hardware6 Kommentare

Hallo liebe ITler, an einem HP Proliant ML350p G8 hängt eine APC Smart-UPS 1500VA LCD, USB/seriell (SMT1500I/FJT1500I). Seit kurzem ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 2 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 2 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 14 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 21 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement17 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...