Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zugriff auf Server langsam - bei einer CPU auslastung unter 5 Prozent

Frage Microsoft Windows Server

Mitglied: KV17uwe

KV17uwe (Level 1) - Jetzt verbinden

29.04.2008, aktualisiert 15.05.2008, 8500 Aufrufe, 17 Kommentare

Hallo,

wir haben einen W2K3 Server mit 2 XEON Prozeesoren 3,0 GHz und 4 GB RAM. Das Ganze läuft auf einen RAID5e Verbund.

Unser problem ist das es ab und zu vorkommt das der Zugriff auf dem Server fast stehenbleibt. Bei einer Auslastung von unter 5%. Also er macht eigentlich nichts. Nach 5-10 Minuten legt sich das wieder. So erst dachte ich es liegt am Switch und habe diese Ausgetauscht, aber auch das hat das problem nicht behoben.

Server -> Switch -> Switch -> Arbeitsplätze
_____________ -> Switch -> Arbeitsplätze
_____________ -> DSL Router


Weis nicht was ich noch machen kann ??

Habt ihr eine Löung ?

MFG

Uwe
Mitglied: Raanubis
29.04.2008 um 10:45 Uhr
Hallo Uwe,

Infos:
wenn ich fragen darf, welche Dienste hat der Server eigentlich zu verrichten?
Ich nehme schon mal an, laut Ausstattung das dort auch eine DB läuft, die Anmeldung und DNS.
wieviele Clients sind angeschlossen?

Möglichkeiten:
Ist Wins deaktiviert ist? wenn nein, in einem dns gesteuertem netzwerk bringt dieses propietäre protokoll nix, deshalb deaktivieren

Desweiteren, schau mal in deinen logs (auf dem Server -> Systemsteuerung / Verwaltung / Ereignisse bei Anwendungen und System) nach ob zu dem Zeitpunkt wo das Netzwerk langsamer wird nicht ein Dienst aktiviert worden ist.

ps: mir fällt zwar noch ein bissel was ein, brauch aber bissel mehr infos ^^ (die infos zu den Diensten)

mfg
raanubis
Bitte warten ..
Mitglied: Raanubis
29.04.2008 um 11:08 Uhr
Mir ist noch etwas eingefallen, damit entfällt wireshark. da keine nutzerdaten ausgelesen werden können, sondern nur das was uns interessiert.

Start -> (Einstellungen-> Systemverwaltung) Verwaltung -> Leistung

Bei Systemmonitor drauf, in der rechten seite des Fensters ist ein "+"-Zeichen, dort kann man Leistungsüberwachungen hinzufügen.
Einstellungen:

Datenobjekt: TCP
-> Verbindungsfehler

mit Hinzufügen bestätigen, um nachzuschauen ob ein Netzwerkproblem besteht, das gleiche mit UDP (nur das sich das dort-> Erhaltene Datagramme, Fehler/kein Port nennt)

man kann dort noch einiges mehr nachschauen und somit zumindest die entsprechende Problemzone eingrenzen.

PS: Falls du das Problem dann findest, bitte hier rein-posten, des interessiert mich auch, weil will mir demnächst Windows Server 2008 Testrechner aufbauen, und ne entsprechende Knowledge DB 'zusammenbauen' ;)

mfg
Raanubis
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 11:18 Uhr
Hallo,

Danke schon mal für deine Antwortem,

Auf dem Server läuft eine Domäne, Und DNS verrichtet er auch. Sonst nur als Daten Server.

MFG

Uwe
Bitte warten ..
Mitglied: Raanubis
29.04.2008 um 11:36 Uhr
Ich nehme mal an das alle Clients als dns und gateway nur den Server eingetragen haben,

und der Server den dns und das gateway vom Router holt .
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 12:03 Uhr
Die Clients Haben als Gateway und DNS denn Server

und der Server Holts sich es vom Router. Richtig
Bitte warten ..
Mitglied: Raanubis
29.04.2008 um 12:39 Uhr
Wenn man ausschliessen kann das fremde im Netzwerk innen herumfuchteln können, dann Deaktiviere SMB-Signing, unter:

Verwaltung
Lokale Sicherheitsrichtlinien
Sicherheitseinstellungen
Lokale Richtlinien
Sicherheitsoptionen
dort findet man die Optionen

Serverkommunikation digital signieren (immer)
Serverkommunikation digital signieren (wenn möglich)

Clientkommunikation digital signieren (immer)
Clientkommunikation digital signieren (wenn möglich)

erst ab Server der Version 2008 braucht man des nicht mehr auszuschalten, da kommt eine bessere und perfomantere, sowie überarbeitete Version des SMB Protokolls zum Einsatz, allerdings wird es erst die Zeit bringen wie wenig bugs diese Version hat ;),

ansonsten hab ich die DNS mit dem ADS und dem Domänen-Controller in Verdacht, das soetwas wie eine aktualisierung stattfindet, und dann für den genannten Zeitraum das Netz lahm legt, schau mal wenn du DHCP hast das die Lease-Zeiten nicht zu niedrig eingestellt sind.

Desweiteren noch die frage, sind die Profile auf dem Server ausgelagert oder nur lokale Profile?

mfg
Raanubis
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 13:26 Uhr
So zu dem Fehlerprotokoll

Verbindungsfehler ist die Ganze Zeit auf 100 und bei durschnitt steht 2846

UDP Erhaltene Datagramme UDP 24

Keine Ports steht bei 0,05

Profile liegen Lokal auf denn Rechnern,

Wie kann ich denn Fehle suchen fall es am DNS und ADS liegt.

MFG

Uwe
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 13:38 Uhr
HAb noch folgende Fehlermeldungen in der Eregnissanzeige gefunden

Die dynamische Registrierung des DNS-Eintrags 'xxx.inhouse. 600 IN A 192.168.199.1' ist auf folgendem DNS-Server fehlgeschlagen:

DNS-Server IP-Adresse: <UNAVAILABLE>
Verbindungsantwortcode (RCODE): 0
Zurückgegebener Statuscode: 0

Dieser Eintrag muss in der DNS registriert sein, damit Computer und Anwender diesen Domänencontroller lokalisieren können.

Die dynamische Registrierung des DNS-Eintrags 'gc._msdcs.xxx.inhouse. 600 IN A 192.168.199.1' ist auf folgendem DNS-Server fehlgeschlagen:

DNS-Server IP-Adresse: <UNAVAILABLE>
Verbindungsantwortcode (RCODE): 0
Zurückgegebener Statuscode: 0

Dieser Eintrag muss in der DNS registriert sein, damit Computer und Anwender diesen Domänencontroller lokalisieren können.

BENUTZERAKTION
Ermitteln Sie, was diesen Fehler verursacht hat. Beheben Sie das Problem und initialisieren Sie die Registrierung der DNS-Einträge durch den Domänencontroller. Um festzustellen, was diesen Fehler verursacht hat, führen Sie DCDiag.exe aus. Sie können dieses Programm auf der Windows Server 2003-Installations-CD im Ordner "Support\Tools\support.cab" finden. Weitere Informationen über DCDiag.exe finden Sie im Hilfe- und Supportcenter. Um die Registrierung der DNS-Einträge durch diesen Domänencontroller zu initialisieren, führen Sie "nltest.exe /dsregdns" in der Befehlszeile des Domänencontrollers aus, oder starten Sie den Anmeldedienst neu. Nltest.exe befindet sich auf der Microsoft Windows Server Resource Kit-CD.
Andernfalls können Sie die Einträge manuell zu DNS hinzufügen. Dieser Schritt wird jedoch nicht empfohlen.

ZUSÄTZLICHE DATEN
Fehlerwert: Der Host war bei einem Socketvorgang nicht erreichbar.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

Das war die Diagnose von dcdiag

C:\Programme\Support Tools>dcdiag

Domain Controller Diagnosis

Performing initial setup:
Done gathering initial info.

Doing initial required tests

Testing server: Standardname-des-ersten-Standorts\SERVER
Starting test: Connectivity
SERVER's server GUID DNS name could not be resolved to an
IP address. Check the DNS server, DHCP, server name, etc
Although the Guid DNS name
(2481e89b-8a81-4b9e-babd-0c31ba8d674d._msdcs.xxx.inhouse) couldn't be
resolved, the server name (server) resolved to the IP address
(192.168.1.1) and was pingable. Check that the IP address is
registered correctly with the DNS server.
......................... SERVER failed test Connectivity

Doing primary tests

Testing server: Standardname-des-ersten-Standorts\SERVER
Skipping all tests, because server SERVER is
not responding to directory service requests

Running enterprise tests on : pgn.inhouse
Starting test: Intersite
......................... xxx.inhouse passed test Intersite
Starting test: FsmoCheck
......................... xxx.inhouse passed test FsmoCheck
Bitte warten ..
Mitglied: Raanubis
29.04.2008 um 13:52 Uhr
DNS mit falscher IP-Verbunden, oder 2 DNS einträge drin?

Testing server: Standardname-des-ersten-Standorts\SERVER
Starting test: Connectivity
SERVER's server GUID DNS name could not be resolved to an
IP address. Check the DNS server, DHCP, server name, etc
Although the Guid DNS name
(2481e89b-8a81-4b9e-babd-0c31ba8d674d._msdcs.xxx.inhouse) couldn't be
resolved, the server name (server) resolved to the IP address
(192.168.1.1) and was pingable. Check that the IP address is
registered correctly with the DNS server.
......................... SERVER failed test Connectivity

Die dynamische Registrierung des DNS-Eintrags 'gc._msdcs.xxx.inhouse. 600 IN A 192.168.199.1' ist auf folgendem DNS-Server fehlgeschlagen:

DNS-Server IP-Adresse: <UNAVAILABLE>
Verbindungsantwortcode (RCODE): 0
Zurückgegebener Statuscode: 0

das sind 2 unterschiedliche Subnetze, wenn das routing nicht gelegt ist funnktioniert das nicht, bzw kurzzeitig und macht dank automatischer suche nach netzwerken das was man machen will.

also wenn nicht 2 netze vorhanden sind, sollte alle netze im gleichen bereich liegen.

bsp 192.168.1.1 oder 192.168.199.1

weil der dns kann den server ,mit der ip-adresse 192.168.199.1 nicht erreichen und somit registrieren.

der rechner kann den server mit adressee 192.168.1.1 erreichen aber nicht den dns, weil der dns auf 192.168.199.1 zeigt
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 14:13 Uhr
Es ist so !

Der Server hatt zwei NICs, die eine 192.168.1.1 ist die, die mit den Arbeitsplätzen und dem Internet Router verbunden ist.

Die 192.168.199.1 ist eine Directverbindung zu einem Backupserver, wir haben ihn in ein anderes Netz gelegt damit er von den AP nicht erreichbar ist.

Habe eine Reparatur mit nltest.exe /dsregdns durhcgeführt nun sieht das Protokoll von dcdiag so aus.
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 14:15 Uhr
Domain Controller Diagnosis

Performing initial setup:
Done gathering initial info.

Doing initial required tests

Testing server: Standardname-des-ersten-Standorts\SERVER
Starting test: Connectivity
The host 2481e89b-8a81-4b9e-babd-0c31ba8d674d._msdcs.xxx.inhouse could
not be resolved to an
IP address. Check the DNS server, DHCP, server name, etc
Although the Guid DNS name
(2481e89b-8a81-4b9e-babd-0c31ba8d674d._msdcs.xxx.inhouse) couldn't be
resolved, the server name (server) resolved to the IP address
(192.168.1.1) and was pingable. Check that the IP address is
registered correctly with the DNS server.
......................... SERVER failed test Connectivity

Doing primary tests

Testing server: Standardname-des-ersten-Standorts\SERVER
Skipping all tests, because server SERVER is
not responding to directory service requests

Running partition tests on : ForestDnsZones
Starting test: CrossRefValidation
......................... ForestDnsZones passed test CrossRefValidation

Starting test: CheckSDRefDom
......................... ForestDnsZones passed test CheckSDRefDom

Running partition tests on : DomainDnsZones
Starting test: CrossRefValidation
......................... DomainDnsZones passed test CrossRefValidation

Starting test: CheckSDRefDom
......................... DomainDnsZones passed test CheckSDRefDom

Running partition tests on : Schema
Starting test: CrossRefValidation
......................... Schema passed test CrossRefValidation
Starting test: CheckSDRefDom
......................... Schema passed test CheckSDRefDom

Running partition tests on : Configuration
Starting test: CrossRefValidation
......................... Configuration passed test CrossRefValidation
Starting test: CheckSDRefDom
......................... Configuration passed test CheckSDRefDom

Running partition tests on : xxx
Starting test: CrossRefValidation
......................... xxx passed test CrossRefValidation
Starting test: CheckSDRefDom
......................... pgn passed test CheckSDRefDom

Running enterprise tests on : xxx.inhouse
Starting test: Intersite
......................... xxx.inhouse passed test Intersite
Starting test: FsmoCheck
......................... xxx.inhouse passed test FsmoCheck
Bitte warten ..
Mitglied: Raanubis
29.04.2008 um 14:16 Uhr
dann ist der dns der auf 192.168.199.1 gelegt ist, falsch. der muss auf den adapter von 192.168.1.1 zeigen. dieser hat dann wahrscheinlich auch den gateway und den dns von aussen.
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 14:20 Uhr
Die NIC zum Backupserver hat keinen Gateway und auch keinen DNS eintrag. Ich dachte bräuchte man nicht.

Habe auch noch einen neuen Fehler bzw Warnung in der Protokollanzeige

MS DTC konnte das Höher-/Tieferstufen eines Domänencontrollers nicht ordnungsgemäß verarbeiten. MS DTC funktioniert weiterhin und verwendet die vorhandenen Sicherheitseinstellungen. Fehler: d:\nt\com\complus\dtc\dtc\adme\uiname.cpp:9351, Pid: 3108
No Callstack,
CmdLine: C:\WINDOWS\system32\msdtc.exe

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

Was bedeutet das denn nun wieder ?
Bitte warten ..
Mitglied: Raanubis
29.04.2008 um 14:25 Uhr
Die NIC zum Backupserver hat keinen Gateway
und auch keinen DNS eintrag. Ich dachte
bräuchte man nicht.

Habe auch noch einen neuen Fehler bzw
Warnung in der Protokollanzeige

MS DTC konnte das Höher-/Tieferstufen
eines Domänencontrollers nicht
ordnungsgemäß verarbeiten. MS DTC
funktioniert weiterhin und verwendet die
vorhandenen Sicherheitseinstellungen. Fehler:
d:\nt\com\complus\dtc\dtc\adme\uiname.cpp:9351,
Pid: 3108
No Callstack,
CmdLine: C:\WINDOWS\system32\msdtc.exe

Weitere Informationen über die Hilfe-
und Supportdienste erhalten Sie unter
http://go.microsoft.com/fwlink/events.asp.

Was bedeutet das denn nun wieder ?

dazu siehe hier: http://www.administrator.de/SBS_2003_MS_DTC_konnte_das_H%C3%B6her-Tiefe ...
Bitte warten ..
Mitglied: Raanubis
29.04.2008 um 14:28 Uhr
Die NIC zum Backupserver hat keinen Gateway und auch keinen DNS eintrag. Ich dachte bräuchte man nicht.
braucht man auch nicht aber die eine Fehlermeldung besagt:
Die dynamische Registrierung des DNS-Eintrags 'gc._msdcs.xxx.inhouse. 600 IN A 192.168.199.1' ist auf folgendem DNS-Server fehlgeschlagen:

DNS-Server IP-Adresse: <UNAVAILABLE>
Verbindungsantwortcode (RCODE): 0
Zurückgegebener Statuscode: 0
und damit ist es im DNS, warum auch immer, eingebunden, und muss raus. Ansonsten versucht er immer wieder eine Anfrage auf diesen Adapter und da das timeout, ziemlich lang gesetzt ist, dauert es entsprechend lange bis der Server weiter arbeiten 'will'.

Sollte der adapter nun ganz raus sein aus der dns, musst du einen dns verweis auf den adapter 192.168.1.1 legen, dann sollte de mit dem dns wieder funktionieren
Bitte warten ..
Mitglied: KV17uwe
29.04.2008 um 14:35 Uhr
Danke,

habs wegbekommen. Mal sehen ob das mit dem DNS nun auch geht.

Danke schonmal für deine hilfe.

MFG

Uwe
Bitte warten ..
Mitglied: KV17uwe
15.05.2008 um 08:15 Uhr
und damit ist es im DNS, warum auch immer,
eingebunden, und muss raus. Ansonsten
versucht er immer wieder eine Anfrage auf
diesen Adapter und da das timeout, ziemlich
lang gesetzt ist, dauert es entsprechend
lange bis der Server weiter arbeiten
'will'.

Woran sehe ich wo das timeot steht ? und wie kann ich das ändern ?
Bitte warten ..
Ähnliche Inhalte
Microsoft
Server 2012 cpu Auslastung durchgehend bei 10 prozent
Frage von thomasreischerMicrosoft1 Kommentar

Hallo, Ich habe hier einen bare metal Server 2012, auf dem die Rollen Ad, dns, dhcp und rdp laufen. ...

Windows Server
DCOM-Serverprozess Widows Server 2016 50 Prozent CPU Auslastung
Frage von KisteWindows Server3 Kommentare

Hallo zusammen, wir betreiben eine RDS Server Sammlung bestehend aus dem Connection Broker und 2 Sitzungshosts. Das ganze ist ...

Windows Server
Windows 2012 R2 Server CPU 100 Prozent Auslastung
gelöst Frage von SindaxWindows Server6 Kommentare

Seit einigen Tagen macht unserer Windows 2012 R2 Server Probleme. Seine CPU Auslastung liegt bei 100%, schuld ist der ...

Windows 7
RAM Auslastung bei 80 Prozent
gelöst Frage von xbast1xWindows 79 Kommentare

Hallo zusammen, ein Kollege hat das Problem, dass seit einer Woche das Notebook oft langsam ist. Ich habe festgestellt, ...

Neue Wissensbeiträge
Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 3 StundenInternet2 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 6 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 7 StundenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 10 StundenVerschlüsselung & Zertifikate

Interessant Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows SSH-Kommando in CMD.exe und PowerShell

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server19 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...