Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zugriff auf Storage nach Umzug sporadisch nur per IP, nicht per Name

Frage Microsoft Windows Netzwerk

Mitglied: masterhinz

masterhinz (Level 1) - Jetzt verbinden

20.08.2014 um 14:53 Uhr, 1885 Aufrufe, 9 Kommentare, 1 Danke

Hallo Zusammen,

ich habe gestern Abend einen Umzug von einer alten NetApp FAS2020 auf eine FAS2240 vollzogen.
Die Volumes habe ich per SnapMirror migriert.
Als letztes habe ich die IP auf der 2020 durch eine andere ersetzt und die alte IP der 2240 gegeben.
Meine Tests anschließend haben alle funktioniert - von meinem Rechner aus.

Ping an die IP und auf den Namen OK (DNS definitiv OK!)
Zugriff auf die CIFS Freigaben über IP und Namen OK
Zugriff auf Netzlaufwerke OK

Soweit so gut.
Heute morgen habe ich von einigen Kollegen den Hinweis bekommen dass sie nicht mehr auf ihre Netzlaufwerke zugreifen können.

Bei den Kollegen habe ich als Workaround die Netzlaufwerke über die IP eingerichtet - das funktioniert dann, obwohl er auch über den richtigen Namen die richtige IP auflöst.

Bei anderen Workstations funktionieren die Netzlaufwerke auch über den Namen. Ich kann leider keine Regel oder Übereinstimmungen erkennen, an welchen Workstations es über Namen funktioniert und an welchen nicht.

DNS Eintrag habe ich vorsichtshalber erneuert.
ipconfig /flushdns & ipconfig /registerdns habe ich mal auf einer betroffenen WS ausgeführt. Keine Besserung.

Domäne ist Windows 2008 R2 und die Workstations sind alle Windows 7 Pro.

Da mir das Alles total unlogisch vorkommt weiß ich nicht richtig wo ich noch ansetzen soll. Ein Case habe ich parallel bei NetApp aufgemacht, wobei mein Bauchgefühl mir eher sagt, dass das irgendeine Windows Marotte ist.
Gibt es in Windows so etwas wie beim SSH, dass er erkennt dass der Name auf einmal einen anderen Hash hat und wegen der Sicherheit die Freigabe nicht aufruft?

VG
Mhinz
Mitglied: emeriks
20.08.2014 um 15:00 Uhr
Hi,
schon mal im DNS / WINS nachgeschaut, dass dort tatsächlich nur jeweils ein Eitrag mit der korrektemn Adresse drin ist und nicht etwa noch ein alter mit der alten IP?

E.
Bitte warten ..
Mitglied: masterhinz
20.08.2014 um 15:08 Uhr
Hi emeriks,
der Storagename taucht im DNS tatsächlich nur ein mal mit der korrekten IP auf.
Theoretisch habe ich ja auch nichts anderes gemacht, als die IP Adresse vom alten Storage auf das neue Storage zu ziehen.
Der Name bleibt deswegen ja auch identisch - es sollte sich für die Clients nichts ändern.

Einen WINS Server haben wir nicht im Einsatz...
Bitte warten ..
Mitglied: emeriks
20.08.2014 um 15:18 Uhr
Zitat von masterhinz:
Theoretisch habe ich ja auch nichts anderes gemacht, als die IP Adresse vom alten Storage auf das neue Storage zu ziehen.
Theoretisch? Hast Du oder hast Du nicht?

Der Name bleibt deswegen ja auch identisch - es sollte sich für die Clients nichts ändern.
Du hast aber nur was von "IP-Adresse übertragen" geschrieben, nicht Name. Hat der neue Filer den Namen des alten erhalten? Und der alte hat jetzt einen neuen Namen oder ist er gar nicht mehr online?

Ist der Filer AD-integriert?

E.
Bitte warten ..
Mitglied: IT-Nerds
20.08.2014 um 15:22 Uhr
Wir haben genau das selbe Problem an einem PC. Dies ist lediglich beim Zugriff auf ein Linuxsystem. Die Auflösung der IP funktioniert auch ohne Probleme. Die Dateifreigeben kann ich mit IP zugreifen mit dem Namen nicht. Da öffnet sich das leere Explorerfenster und nach einiger Zeit kommt die Meldung Auf ... kann nicht zugegeriffen werden. Sie haben eventuell keine Berechtigung diese Netzwerkressource zu verwenden. Der Benutzername konnte nicht gefunden werden. Über die IP geht's. Von allen andren Clients geht es auch mit dem Namen. Aufgefallen ist mir, wenn ich nun im DNS-Server einfach einen nichtvorhandenen Namen z.B. Linuxserver auf die IP verweise und ich es mit dem Namen versuchen funktioniert es auch bei dem Client.
Bitte warten ..
Mitglied: Pjordorf
20.08.2014 um 15:23 Uhr
Hallo,

Zitat von masterhinz:
Die Volumes habe ich per SnapMirror migriert.
Der Hostname (der Name deiner NetApp) wird dann auch migriert?

Meine Tests anschließend haben alle funktioniert - von meinem Rechner aus.
Statische IP oder per DHCP?

Ping an die IP und auf den Namen OK (DNS definitiv OK!)
WAS steht IM DNS Server tatsächlich drin (Forward und Reverse Lookup Zone)?

DNS Eintrag habe ich vorsichtshalber erneuert.
Im DNS Server oder nur auf den Clients?

ipconfig /flushdns
Löscht DNS Einträge NUR am aufrufenden Client

& ipconfig /registerdns habe ich mal auf einer betroffenen WS ausgeführt. Keine Besserung.
Registriert den aufrufenden Client neu im angegebenen (IPConfig /all) DNS Server. hat mit dein Problem NULL zu tun.

Da mir das Alles total unlogisch vorkommt weiß ich nicht richtig wo ich noch ansetzen soll
Was sagt dein Kabelhai dazu was dein Client machen will?

irgendeine Windows Marotte ist.
Welche Marotten deines OS kennst du denn? http://de.wikipedia.org/wiki/Marotte

und wegen der Sicherheit die Freigabe nicht aufruft?
Nein. Aber Zertifikate.... Wir wissen nichts über dein System und meine Glaskugel ist zur Generalüberholung im Walhalla (jede Ferien)

Nutze deinen Kabelhai und schau was die Clients den beim Verbinden tun wollen. Dann weist du was da schieflief / läuft.

Gruß,
Peter
Bitte warten ..
Mitglied: masterhinz
20.08.2014 um 15:34 Uhr
Hi emeriks,

ich habe nur die Volumes migriert und die IP Adresse dem alten Filer entzogen und dem neuen zugeteilt. Mehr nicht.
Da der neue Filer bereits für andere Systeme Produktiv läuft, habe ich den nicht umbenannt. Macht man ja bei einem einfachen IP Umzug auf einem Server auch nicht.
Sprich der alte Filer heißt weiterhin Lexus (ist aber nicht mehr erreichbar im Netz) und der neue heißt weiterhin storage1office.

Eventuell ist das das Problem. Windows erwartet beim Aufbau der Verbindung eine Antwort vom Server der Lexus heißt. Der Server hat aber nicht den Namen und antwortet mit einem anderen und deswegen kommt die Verbindung nicht zu stande?

Der Filer ist AD integriert.
Bitte warten ..
Mitglied: masterhinz
20.08.2014 um 15:41 Uhr
Hey Peter,

danke für deine ausführliche Antwort.
Marotte ist eine Redensart ;D
Nein, der Hostname wurde nicht migriert. Nur die IP. So machen wir das üblicherweise auf unseren CentOS Systemen... da sind IP Umzüge nichts ungewöhnliches.

im DNS steht:
(Forward) Name: Lexus.domäne | Typ: Host (A) | Daten: 172.20.100.10 | Zeitstempel: static
(Reverse) Name: 172.20.100.10 | Typ: Zeiger (PTR) | Daten: Lexus.domäne | Zeitstempel: static

Unsere Clients haben alle DHCP.

DNS habe ich nur auf dem DC aktualisiert.

Merkwürdig ist einfach , dass es auf manchen Rechnern funktioniert und manchen nicht.

Wireshark habe ich noch nicht mitlaufen lassen. Werde ich gleich mal mit meinem Netzwerkadministrator zusammen machen. danke für den Tipp!

VG
Mhinz
Bitte warten ..
Mitglied: masterhinz
20.08.2014, aktualisiert um 16:21 Uhr
Hallo Zusammen,

wir haben das Problem darüber gelöst dass wir folgenden Befehl einmal ausgeführt haben:

"Net use x: \\lexus\home\%USERNAME% * /user:%USERNAME%"

anschließend funktioniert auch der einfache Aufruf über den Namen wieder, sprich \\lexus , wo er dann auch alle anderen volumes anzeigt.
Ich erkenne keine Logik dahinter, bin aber dennoch zufrieden so ein lästiges Problem gelöst zu haben.
Bitte warten ..
Mitglied: IT-Nerds
20.08.2014 um 16:23 Uhr
Super! Vielen Dank! Funktioniert bei uns auch mit dem Befehl!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
gelöst IIS Zugriff über Zertifikat oder IP Restriction (3)

Frage von Broderick zum Thema Windows Server ...

Switche und Hubs
gelöst IP Cam außen am Haus Zugriff sichern über Firewall ACL (6)

Frage von TimMayer zum Thema Switche und Hubs ...

Router & Routing
Zugriff auf Netzwerk ohne public-IP (14)

Frage von tr1plx zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...