Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zwei Netzwerke miteinander verbinden Teil II

Frage Netzwerke Router & Routing

Mitglied: Matischack

Matischack (Level 1) - Jetzt verbinden

19.01.2008, aktualisiert 23.01.2008, 10466 Aufrufe, 9 Kommentare

Folgende Problemstellung:

1x Router (FritzBox 7270 mit der IP-Adresse 192.168.178.1), DHCP ist aktiviert, die IP-Adressen werden also automatisch vergeben.

1x Notebook, das per WLAN die IP-Adresse automatisch bezieht.

1x Server, der woanders steht und ebenfalls per WLAN ebenfalls die IP-Adresse von der Fritzbox automatisch bezieht.

An diesem Server per LAN angeschlossen ist eine NAS-Box mit 750GB-HDD, die als Grund-IP-Adresse ein anderes Netzwerk nutzt (Grund-IP-Adresse: 192.168.123.254).

Notebook Server und NAS-Box befinden sich in der selben Arbeitsgruppe "Heimnetzwerk".

Ich kann vom Notebook auch problemlos drahtlos auf den Server zugreifen. Allerdings kann ich nicht drahtlos auf die Daten der NAS-Box zugreifen, da die NAS-Box ja ein anderes Netzwerk nutzt.

Ich möchte natürlich auch gern drahtlos vom Notebook auf die Daten der NAS-Box zugreifen.

Jetzt aber das Problem:

Ich hatte vor, die NAS-Box im selben Netzwerk wie das der Fritzbox, also im IP-Bereich 192.168.178.* zu integrieren, um dann vom Notebook drahtlos auf die Daten der NAS-Box zugreifen zu können. Dazu hatte ich die NAS-Box IP auf 192.168.178.4 gesetzt und die des LAN-Anschlusses vom Server auf 192.168.178.3

Sobald ich aber die LAN-IP umgestellt hatte, bekam ich nicht nur keine Verbindung zur NAS-Box (konnte also nicht auf deren Daten zugreifen), sondern hatte auch vom Notebook keine Verbindung mehr zum Server.

Was ist geschehen?

Die IP der WLAN-Schnittstelle des Servers hatte sich beim Umstellen der LAN-IP des Servers geändert. Und zwar wandelte sie sich automatisch in die eines anderes Netzwerkes, nämlich in 192.168.0.1

War natürlich klar, dass ich dann vom Notebook aus kein Zugriff mehr hatte.

Natürlich "bastelte" ich noch, vergab also für die WLAN-Schnittstelle des Servers eine statische IP (192.168.178.2), vergab auch IP-Adressen der WLAN-/ LAN- und NAS-Box-Schnittstelle des Servers in andere zulässige Bereiche der FritzBox (192.168.178.20 und aufwärts).

Alles aber ohne Erfolg.

Was also kann ich tun, damit ich auch drahtlos von meinem Notebook auf die Daten der am Server per LAN angeschlossenen NAS-Box zugreifen kann?

Weiß jemand Abhilfe? Bin nämlich was die Netzwerkkonfiguration angeht nicht so ganz firm.

Ich weiß, dass die Beitragsbezeichnung "Zwei Netzwerke miteinander verbinden Teil II) nicht so ganz zutreffend ist, ich wusste aber nicht, wie ich´s anders ausdrücken sollte. Ich bitte das zu entschuldigen.

Trotzdem vielen Dank vorab für eure Hilfe.
Mitglied: aqui
19.01.2008 um 15:38 Uhr
Dieses Tutorial sollte dein Problem sofort lösen:

http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...
Bitte warten ..
Mitglied: Matischack
20.01.2008 um 12:11 Uhr
Dieses Tutorial sollte dein Problem sofort
lösen:

http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...


Ich hatte das Tutorial vorab schon gelesen und denke auch, dass es die Lösung meines Problems sein wird. Allerdings hapert es trotz sehr guter Beschreibung dieses Tutorials an der Umsetzung.

Ich möchte gern die 1. Alternative davon zur Anwendung bringen.

Da wäre also auf der linken Seite, dort wo skizzenmäßig die Workstations stehen, mein Notebook mit WLAN-Verbindung zur FritzBox und auf der rechten Seite, mein per WLAN verbundener Server und daran angeschlossen per LAN die NAS-Box.

Ich habe allerdings nicht den in der Skizzierung dargestellten Adressenbereich genommen, sondern habe die standardgemäße Adresse des Routers auf 192.168.178.1 belassen. Dann habe ich fürs Notebook 192.168.178.2, für den Server-WLAN 192.168.178.3 (Gataway 192.168.178.1, DNS 192.168.178.1), für den Server-LAN 192.168.123.1 (Gataway ohne, DNS ohne) und für die NAS-Box 192.168.123.2 (Gataway 192.168.123.1, DNS 192.168.178.1) genommen.

Darüber hinaus habe ich in der FritzBox die statische IP 192.168.123.0 mit Gataway 192.168.178.3 genommen.

Mmh, was mach ich falsch. Ich kann vom Notebook aus noch immer nicht auf die Daten der NAS-Box zugreifen, sehe also die NAS-Box nicht in der Internetverbindung.

Ich habe hier teils gelesen, dass ich im Verschlüselungsverfahren Ad-Hoc einstellen muss. Ich hab´s auf TKIP stehen. Muss das wirklich auf Ad-Hoc gestellt werden, liegt da vielleicht der Fehler?

Ich hoffe, mir kann jemand weiterhelfen.
Bitte warten ..
Mitglied: aqui
20.01.2008 um 13:38 Uhr
Wenn so alles richtig ist, sollte dein Netzwerk so aussehen:

6633daaf446c76cfd6449cd2a91fd213-fribo - Klicke auf das Bild, um es zu vergrößern

Es ist nicht nötig den Server am WLAn Adapter als auch den Laptop in den Ad Hoc Modus zu stellen ! Das wäre nur erforderlich wenn du keinen Accesspoint hättest aber den hast du ja mit der Fritzbox so das du hier den normalen Infrastruktur Modus nutzen kannst der auch im Default aktiviert ist.
Von den IP Adressen ist soweit alles richtig. Sehr wichtig ist das du wie im Tutorial beschrieben das IP Forwarding auf dem PC/Server (Registry Eintrag XP/2000) in der Mitte aktivierst, denn sonst ist eine Verbindung nicht möglich !!
Achte auch drauf das die lokale Firewall hier entsprechend angepasst ist oder ggf. zum Testen erstmal ausgeschaltet ist !
Zum Testen gehts du folgendermaßen vor:

  • Ping vom Laptop 192.168.178.2 auf den Router 192.168.178.1 muss klappen !
  • Ping vom Laptop 192.168.178.2 auf den PC/Server (WLAN Nic) 192.168.178.3 muss klappen !
  • Ping vom Laptop 192.168.178.2 auf den PC/Server (LAN Nic) 192.168.123.1 muss klappen !

Wenn das alles klappt, dann muss auch ein
  • Ping vom Laptop 192.168.178.2 auf das NAS 192.168.123.2 klappen !

Was sagen diese Pings ? Was funktioniert, was nicht ?!
Bitte warten ..
Mitglied: Matischack
20.01.2008 um 21:55 Uhr
Dankeschön für die nette Hilfe und sehr übersichtliche Skizzierung.

Also die Pings gehen alle gut durch, bis auf die zur NAS.

Da schreibt er mir immer "Zeitüberschreitung der Anforderung"

Der Eintrag in der regedit wurde vorgenommen und die Windows eigene Firewall habe ich deaktiviert.

Die NAS selbst hat keine Hardwarefirewall.

Es muss also irgendwas an den IP-Einstellungen zwischen LAN des Servers und am Server hängende NAS sein.

Hier noch mal die dort eingetragenen Einstellungen

LAN:

IP-Adresse: 192.168.123.1
Subnetzmaske: 255.255.255.0
Standardgateway: (ohne)
Bevorzugter DNS-Server: (ohne)
Alternativer DNS-Server: (ohne)

NAS-Box:

IP-Adresse: 192.168.123.2
Subnetzmaske: 255.255.255.0
Standardgateway: 192.168.123.1
Bevorzugter DNS-Server: 192.168.178.1 (= Grundadresse der Fritzbox)
Alternativer DNS-Server (ohne)

Der IP-Pool der NAS Box ist von 50 - 199

Ich habe die IP´s also außerhalb des Pools bezogen, ebenso wie bei der Fritzbox, bei der der IP-Pool von 20 - 253 reicht.

Mmh, echt doof, habe schon alles mögliche an Einstellungen versucht.

Aber ich denke, ich bin ganz, ganz nah dran...
Bitte warten ..
Mitglied: Matischack
21.01.2008 um 00:43 Uhr
Ich danke Dir nocheinmal für Deine super Hilfe Aqui.

Ich habe bis jetzt rumgefummelt, leider bekomme ich aber den vierten Ping, also den zum NAS, nicht hin.

Also im NAS habe ich die IP auf statisch und nicht auf Client gestellt. Damit kanns doch aber auch eigentlich nichts zu tun haben.

Die Firewall habe ich jetzt generell aus. Wie konfiguriere ich sie, dass sie lediglich die WLAN- und LAN-Schnittstellen ausnimmt, ohne das ich die systemeigene Firewall von Windows gänzlich deaktivieren muss?

Deiner Skizze kann ich entnehmen, dass dort 192.168.178.0/24 bei der WLAN des Servers und 192.168.123.0/24 bei dem LAN des Servers steht. Hat das irgendeine Bedeutung für meine derzeitige Konfiguration? Liegt dort vielleicht der Fehler?

Muss ich vielleicht noch weitere Routen in der FritzBox außer der 192.168.123.0 freigeben? Eigentlich doch nicht...

Aber das Wichtigste, wie bekomme ich den Ping zur NAS-Box hin, so dass diese beim Notebook unter Netzwerkverbindungen sichtbar wird?

Aqui weiß sicherlich die Lösung, ich bin natürlich auch für jede weitere Hilfestellung dankbar.
Bitte warten ..
Mitglied: Matischack
21.01.2008 um 01:43 Uhr
Jetzt wird der Hund in der Pfanne verrückt.

Auch den vierten Ping vom Notebook aus zur NAS-Box bekomme ich hin.

Ich hatte ein Image auf dem Server zurückgespielt und alles nochmal neu eingespielt. Dann klappte es.

Aber:

Ich kann immer noch nicht in meinem Notebook unter Netzwerkverbindungen die NAS-Box sehen. Ich sehe lediglich nach wie vor den Server.

Komisch. Denn auch ein Ping vom Server zum Notebook klappt wunderbar.

Ich bin auch mit Server, mit NAS-Box und mit Notebook in derselben Arbeitsgruppe "HEIMNETZWERK".

Es besteht defintiv kein Rechtschreibfehler.

Was kann denn jetzt noch los sein???
Bitte warten ..
Mitglied: aqui
22.01.2008 um 15:07 Uhr
OK, der Ping musste funktionieren, denn du hast netztechnisch alles richtig gemacht...gut wenn es jetzt klappt !

Das du das NAS nicht sehen kannst in der Netzwerkumgebung ist normal, denn es macht sich per Broadcast in seinem Netz bekannt und das geht nun mal nicht über Routing Grenzen. Aber keine Angst es gibt eine Lösung !

Ein Zwangsconnect mit Start -> Ausführen -> \\192.168.123.2 sollte dich in jedem Falle auf dein NAS bringen. Ebenso wenn du fest ein Laufwerk verbindest über die IP Adresse als Ziel.
Damit du auch den Namen des NAS eingeben kannst solltest du es statisch in die Datei lmhosts unter c:\windows\system32\drivers\etc\ eintragen.
Die Datei ist selbsterklärend wenn du sie mit dem Editor editierst. Es reicht den Namen und die IP einzutragen.
Bitte warten ..
Mitglied: Matischack
22.01.2008 um 20:58 Uhr
Hey super.

Danke Aqui, das war die Lösung.

Recht herzlichen Dank noch einmal für die spontane und äußerst qualitativen Hilfen!!!

Gruß,

Matthias
Bitte warten ..
Mitglied: aqui
23.01.2008 um 11:21 Uhr
Kein Problem, dafür ist ein Forum ja da
Bitte dann
http://www.administrator.de/index.php?faq=32
nicht vergessen.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Zwei interne Netzwerke miteinander über das Internet verbinden
gelöst Frage von madonischerLAN, WAN, Wireless10 Kommentare

Guten Tag die Damen und die Herren ich habe in zwei Filialen jeweils einen W-Lan Router der ein eigenes ...

Netzwerkmanagement
Zwei Switches miteinander verbinden - kein Internet
Frage von deckard2019Netzwerkmanagement14 Kommentare

Hallo. Ich habe ein Problem mit meinem Netzwerkaufbau. Der Aufbau sieht folgendermaßen aus: Am Router (FritzBox 6360 Cable Unitymedia) ...

Netzwerkmanagement
OpenVPN mehrere Netzwerke miteinander verbinden
gelöst Frage von warbyrdNetzwerkmanagement6 Kommentare

Hallo zusammen, kann mir vielleicht jemand helfen und sagen ob meine Überlegungen richtig sind und so funktionieren (bevor ich ...

Router & Routing
Zwei FitzBox-Netzwerke verbinden?
Frage von McLionRouter & Routing9 Kommentare

Hallo, stehe aktuell auf nem Schlauch und komme nicht weiter. Also ich habe eine FB-A und FB-B, die wie ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Sicherheitslücke Spectre und Meltdown: Status prüfen

Anleitung von Frank vor 1 StundeErkennung und -Abwehr

Nach all den Updates der letzten Woche sollte man unbedingt auch den Status prüfen, ob die Sicherheitslücke Spectre und ...

Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 1 TagMicrosoft Office9 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner15 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...