Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zwei Netzwerkkarten in einem Rechner - Problem mit dem Routing

Frage Netzwerke

Mitglied: 5717

5717 (Level 1)

19.10.2004, aktualisiert 21.10.2004, 20949 Aufrufe, 10 Kommentare

Hallo,
ich hoffe, hier kann mir jemand helfen.

Ich habe zwei PCs. Einen Shuttle und einen herkömlichen Rechner.
Hab in beiden Rechnern jeweils eine 10/100 NIC und eine 10/100/1000 NIC.
Die 10/100 hab ich um über meinen Netgear RP114 Router mit beiden Rechnern ins web zu gehen. Klappt auch einwandtfrei. Die GigabitKarten habe ich per Patchkabel verbunden um Daten direkt ohne Umweg über den Router, der eh nur 10/100 kann, mit Gigabitspeed zu übertragen.

Mein Problem ist nun, dass die meisten Dateien nur mit 100 Megabit übertragen werden.
Ein Freund meinte etwas davon, dass man das ganze irgendwie routen koenne.

Ich habe zwei Netze eingerichtet:

Netz 1:
192.168.0.

Netz 2:
192.168.1.


Die Subnetmask ist bei beiden:
255.255.255.0

Hab ihr einen Tip wie ich endlich meine Daten mit full speed übertragen kann.

cu und danke
Andreas
Mitglied: Mr.Floppy2
19.10.2004 um 21:37 Uhr
Das Problem kann man leicht überwinden. Du hast sicherlich auf jedem Rechner eine Freigabe über die Du Daten austauschst?

Gib in der MS-Dos Eingabeaufforderung folgenden Befehl ein:

net use * \\192.168.1.1\Freigabe

Wenn das Gigabit-Netz das 192.168.1.x ist sonst das 192.168.0.x

Auf dem anderen Rechner wiederhole den Befehl mit der anderen IP-Adresse des 2. PCs.

Somit hast Du eine Verbindung geschaffen die über einen festen Weg (nämlich 192.168.1.x) gehen muß und 1 Gbit schnell ist.
Bitte warten ..
Mitglied: Atti58
19.10.2004 um 22:28 Uhr
Hast Du zur Verbindung der beiden Rechner ein gekreuztes Patchkabel verwendet - sonst kann es nicht gehen ...

Die Route müsste im Netz 2 (1GBit ?):
auf Rechner 1

route add -p 192.168.1.0 mask 255.255.255.0 IP-Rechner1/1GB-Karte

lauten. Auf Rechner 2 analog ...

Gruß

Atti
Bitte warten ..
Mitglied: 5717
20.10.2004 um 06:31 Uhr
Hallo,

danke, der erste Tip schein gegeht zu haben.
Hab heute morgen (05:55 Uhr) mal eine Datei vom Shuttle zum PC verschoben.
Die 700 MB-Datei ging in 20 Sekunden rüber.
Hab währende des Verschiebens mal das Kabel aus dem Router gezogen.
Sonst hatter er an dieser Stelle immer abgebrochen. Jetzt nicht. super.

Mir stellt sich jetzt nur die Frage, wie das ganze permanent eingerichtet wird.
Gibt es da eine Autostartfunktion oder wie funktioniert das.
Oder ne Art Batchdatei.

Viele Gruesse
Andreas
Bitte warten ..
Mitglied: 5717
20.10.2004 um 06:33 Uhr
Hallo,

wo ist der Unterschied zwischen dem Tip oben und deinem.
Was DosBefehle angeht, bin ich leider ein absoluter Laie.
Der einzige Befehl, der mir wirklich geläufig ist, ist format C:

Viele Gruesse

Andreas
Bitte warten ..
Mitglied: Mr.Floppy2
20.10.2004 um 06:59 Uhr
Hallo Andreas,

kommt auf Dein Betriebsystem an. Wenn es Windows 2000 oder XP ist, dann ist das Laufwerksmapping schon permanent und sollte bei jedem Neustart wieder vorhanden sein.

Bei Windows 98 mußt Du eine Batch-Datei schreiben und in den Autostart-Ordner legen.

Wenn Du aber auf der ganz sicheren Seite bei Windows 2000/XP sein willst, hänge an den net use Befehl /persistent:yes ans Ende, das bedeutet dann ausdrücklich "dauerhaft".

Wenn Du auf Batch-Dateien stehst ;) dann schreib Dir eine mit folgendem Inhalt und kopier die Batch in den Autostart (für jeden Rechner wieder die richtige IP für den anderen PC)

net use * \\192.168.1.1\freigabe /persistent:no

Damit gilt dieses Mapping nur für 1 Mal und da Du die Batch im Autostart hast, wird das Laufwerk bei jedem Starten neu gemappt. Kannst auch gerne einen festen Laufwerksbuchstaben eintragen anstelle des * dann würde es x: heißen.
Bitte warten ..
Mitglied: linkit
20.10.2004 um 08:07 Uhr
Zu deinem Problem:

Es klappt nur deshalb nicht, weil der Rechner immer die nächst verfügbare Route nimmt, aus diesem Grund hast du einemal Gigabit und einmal nur 1/10 davon.


Zu deiner Frage:

Der Unterschied zwischen Floppy und Atti ist, daß Floppy das Probem dadurch behebt, daß er die Freigabe über eine IP-Adresse anspricht, die im Netz der Gigabitkarte liegt. Somit werden hier die Daten per Gigabit übertragen. Atti defeniert statische Route zum anderen Rechner, so daß der Vekehr immer über diese Route fließt.
Bitte warten ..
Mitglied: Atti58
20.10.2004 um 08:15 Uhr
@cm

... danke, besser hätte ich es auch nicht sagen können ...

Gruß

Atti
Bitte warten ..
Mitglied: Atti58
20.10.2004 um 08:22 Uhr
... hinzufügen könnte man noch: sobald sich die IP einer der 1-Gigabit-Karten (aus welchen Gründen auch immer, z.B. DHCP-Lease abgelaufen) ändert, muss auch das Netzwerklaufwerk neu gemappt werden, während der Rechner beim Setzen statischer Routen auch dann noch über das 1GBit-Netz erreichbar ist ...

Gruß

Atti
Bitte warten ..
Mitglied: linkit
20.10.2004 um 09:05 Uhr
@Atti:


grüß dich atti... grins.... gern gemacht..... (hab allerdings zweimal für die Erklärung angefangen - schäm )


also falls du mal eine Rede vorbereitet brauchst oder eine Ansprache halten mußt..... kannst du dich gerne als Ghostwriter an mich wenden.... lol



grüße


cm (linkit)
Bitte warten ..
Mitglied: 5717
21.10.2004 um 15:16 Uhr
Hi,

danke fuer eure Tips.

Die haben mich wirklich gerettet.

Hätte mich auch tierisch geärgert, wenn ich trotz Gigabit-NIC, die Daten nur mit 100MBit hätte übertragen können.

cu
Andreas

P.S. Könnt ihr mir denn auch noch ein Tool empfehlen mit dem ich die Geschwindigkeit im Netzwekr messen kann.
Bitte warten ..
Ähnliche Inhalte
Netzwerke
gelöst Switch Cisco SG550XG und 2960X L3 und L2 VLAN Routing Problem (6)

Frage von Jimmysozinho zum Thema Netzwerke ...

Router & Routing
Routing Problem (Windows Server Routing und RAS) (5)

Frage von filou204 zum Thema Router & Routing ...

Router & Routing
Routing Problem VLANS Internet (67)

Frage von Cyberurmel zum Thema Router & Routing ...

Router & Routing
gelöst Mikrotik Switching und Routing Problem (11)

Frage von aqui zum Thema Router & Routing ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (50)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...