Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zweite Standort in AD, Exchange findet den DC nicht mehr

Frage Microsoft Exchange Server

Mitglied: Diespiter

Diespiter (Level 1) - Jetzt verbinden

04.03.2013, aktualisiert 17:33 Uhr, 2861 Aufrufe, 10 Kommentare

kann mir jemand bei folgendem Problem helfen.
Ich habe einen Standort A. Dort sind 2xDC(DC1, DC2) installiert, aber die PCs bekommen IP und usw. von DNS und DHCP Linux Server. Außerdem sind 2x Exchange Server 2010 SP2 mit DAG an diesem Standort vorhanden. Standort A hat das Netz 192.168.1.0/22 und die Domäne firma.local. Ich habe ein DC3 für Standort B in der Domain am Standort A vorbereiten,aufgestellt und konfiguriert. Alle Server in der Domain funktioniert einwandfrei.

Es sollte Standort B aufgebaut werden und diese in die Domäne eingebunden werden und auch die Exchangen von Standort A verwenden. In Standort B ist bisher kein Server vorhanden aber der DC3 sollte für diese Standort B benutzen werden. Standort B hat das Netz 192.168.100.0/24

Die beiden Netze werden per Site to Site VPN verbunden. OA wird über in VPN für Standort B zur Verfügung stellen.

Das Problem ist. Ich hatte den Standort B zur Vorbereitung in der Domain hinzugefügt mit Subnetz für Standort B. Obwohl der DC3 noch im Standort A ist. Für Standort A habe ich so gelassen keine Veränderung und auch keine extra Subnetz hinzugeführt.

Aber dann funktioniert der Exchange DAG nicht mehr. Die MS Exchange AgeSynce und ein Paar andere DAG Dienste starten einfach nicht mehr. Ich habe das Gefühlt, dass der Exchange sucht nach DC aber es findet den DC einfach nicht.

Sobald ich den DC3 zurück zum Standort A verschieben und den Standort B und Subnetzt für Standort B löschen. Dann funktioniert der Exchange wieder.

Meine Frage ist, warum? Was habe ich falsch gemacht? Wie kann ich das Problem löschen, mein Kopf platzen gleich.

Herzlichen Dank schon mal für eure Hilfe

Grüße,
Diespiter
Mitglied: Diespiter
04.03.2013 um 18:36 Uhr
Kann eine von euch mir helfen ?
Bitte warten ..
Mitglied: filippg
04.03.2013 um 20:36 Uhr
Hallo,

was passiert denn, wenn du den Standort B (inkl. Subnetz) anlegst, und den DC nicht dahin verschiebst? Dann funktioniert wahrscheinlich alles. Und wenn dem so ist, legt das ja irgendwie nahe, dass du den DC falsch verschoben hast.
Siehe dazu http://technet.microsoft.com/en-us/library/cc759326%28v=ws.10%29.aspx und http://technet.microsoft.com/de-de/library/dd378844%28v=ws.10%29.aspx.
Außerdem änderst du in dem Zuge ja die IP, deswegen könnte auch http://technet.microsoft.com/en-us/library/cc758579%28WS.10%29.aspx hilfreich sein - inbesondere die Hinweise auf ipconfig /registerdns und dcdiag /fix.
Last but not least: auch Exchange sollte darauf "hingewiesen" werden, dass einer seiner DCs möglicherweise woanders ist - am besten wohl durch einen Serviceneustart.

Gruß

Filipp
Bitte warten ..
Mitglied: Diespiter
04.03.2013, aktualisiert um 21:00 Uhr
Hallo Filipp,

danke für deine Antwort.

Ich hatte Standort B inklusive Subnetz angelegt ohne den DC3 zu verschieben. Nach ca. 5 Minute. Ist es wieder passiert. MS Exchnage EndgeSynce Dienste will nicht starten. Und ich habe kein Zugang zu Exchane mehr(Outlook kann keine email senden oder empfangen mehr).

Was habe ich wieder falsch gemacht ?

Danke für deine Hilfe
Bitte warten ..
Mitglied: filippg
04.03.2013 um 21:11 Uhr
Hallo,

aber die IP-Adresse vom Exchange liegt nicht im Subnetz von Standort B?
Lief den EdgeSync vorher? Benötigt wird er ja nur, wenn man auch einen Edge-Server hat.

Was sagt denn das Eventlog? Da stehen ja manchmal ganz hilfreiche Dinge drin...

Gruß

Filipp
Bitte warten ..
Mitglied: Diespiter
04.03.2013, aktualisiert um 21:43 Uhr
Hallo,

nein ,der Exchange DAG liegt in einem DMZ mit anderem IP und Subnetz.
Sie sind zwar am Standort A aber Sie haben andere Subnetzmaske und andere IP-Bereicht.

Liegt es daran ? Muss ich das Subnetz von Exchange Server auch legen ? Wenn es ist in dem AD eintragen, würde es eine Sicheheitlücke geben ?

Ich kann nicht mehr klar denken !

Danke für deine Hilfe noch mal.

Gruß
Bitte warten ..
Mitglied: filippg
04.03.2013 um 22:22 Uhr
nein ,der Exchange DAG liegt in einem DMZ mit anderem IP und Subnetz. [...]
Muss ich das Subnetz von Exchange Server auch legen ?
Verstehe ich nicht ganz.

Exchange muss einer Site zugeordnet sein (und es würde mich ziemlich wundern, wenn Exchange vorher ohne Site-Zuordnung funktioniert hätte). In der Site muss es einen (beschreibbaren) DC/GC geben. Exchange in einer DMZ ist nicht die allerbeste Idee, weil er doch vielfältige Kommunikationsbeziehungen hat. Aber das war vorher auch so, du hast alle benötigten Ports freigeschaltet (?).

Gruß

Filipp
Bitte warten ..
Mitglied: Diespiter
04.03.2013, aktualisiert um 22:31 Uhr
Exchange war schon immer mit einem Site zugeordnet und ist in der DMZ und funktioniert auch gut.

Jetzt habe ich Subnetz von Exchange in Standort A angelegt und funktioniert die Kommunikation zwischen Exchange und DC wieder.

Ich mache mir nur sorgen um die Sicherheitslücke. Weil ich nicht sicher bin, ob es eine gute Idee ist. Subnetz des Exchange in AD einzutragen, wo der Exchange in DMZ ist ?

Gruße
Bitte warten ..
Mitglied: filippg
04.03.2013 um 23:00 Uhr
Hallo,

die Zuordnung zu einer Site im AD ist erstmal gar keine Sicherheitslücke, weil damit keine Berechtigungen z.B. auf der Firewall gesetzt werden. Es geht mehr darum, Objekte in eine Verwaltungsstruktur einzuordnen. Und Exchange nutzt diese Informationen um sich selbst zu strukturieren (etwa Zugehörigkeit von CAS-Servern zu MBX-Servern, Mailrouting...) Wenn es sich selbst nicht einer Site zuordnen kann (evtl. ordnet es sich, wenn es nur eine Site gibt, unabhängig von IP-Netzen in diese ein), kann es sich selbst auch nicht mehr organisieren. Im Eventlog müssten aber entsprechende Fehler von Netlogon und Exchange (ADTopologyService, wahrscheinlich) verzeichnet sein.

Gruß

Filipp
Bitte warten ..
Mitglied: Diespiter
05.03.2013 um 09:02 Uhr
Gute morgen,

gestern habe ich mich so früh gefreut ;-(

Jetzt tauchen wieder ein neues Problem aus. Exchange funktioniert zwar einwandfrei aber DFS nicht mehr. DFS erkennt den Standort einfach nicht mehr und steht Status vom Standort als "Unknow". Ich hatte den Fileserver in DFS mal aktualisiert, deaktiviert dann neu aktiviert, löschen und neu hinzufügen. Es hat leider nicht funktioniert, DFS erkennt den Standort A einfach nicht(Standort B weiß ich nicht ,weil ich noch keine DC im Standort B verschoben habe)aber sobald ich die Standort B rausnehmen, erkennt der DFS sofort wieder sein Standort A ohne dass ich was machen muss.

Was habe ich wieder falsch gemacht?
Bitte warten ..
Mitglied: Diespiter
06.03.2013 um 15:26 Uhr
Kann mir niemanden weiter helfen ? ;-(
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst Exchange 2016 Mailbox aktivieren und vorhandene Mailadresse aus AD übernehmen (3)

Frage von chrismass zum Thema Exchange Server ...

Windows Server
gelöst Exchange nach Migration in SBS2011 deaktiviern wenn SBS mit AD bestehen bleibt (5)

Frage von martinz zum Thema Windows Server ...

Windows Server
gelöst Schemaerweiterung - Office 365 - Exchange Online mit lokalem AD (1)

Frage von chb1982 zum Thema Windows Server ...

Windows Server
AD DC Failover zeitintensiv und DHCP repliziert nicht (10)

Frage von JiggyLee zum Thema Windows Server ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(6)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Linux
gelöst Google Chrome startet nicht (12)

Frage von Thomas91 zum Thema Linux ...