Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
Kommentar vom Moderator Dani am 25.05.2014 um 13:12:10 Uhr
Formatierung hinzugefügt.
GELÖST

Zwischen VLANs routen (Cisco)

Frage Hardware Switche und Hubs

Mitglied: teret4242

teret4242 (Level 1) - Jetzt verbinden

25.05.2014, aktualisiert 13:11 Uhr, 4500 Aufrufe, 15 Kommentare

Hallo zusammen,

habe zwei Switches (Cisco 3560-PS) via Trunkport verbunden.
Auf den beiden Switches sind jeweils die gleichen VLANs (2 = PC; 3 = NB) definiert.
Der Kommunikatrion innerhalb der VLANs auf dem gleichen Switch wie auch über den Trunkport hinweg funktioniert einwandfrei.
Lediglich die Kommunikation zwischen den VLANs funktioniert weder auf dem gleichen Switch noch über den Trunkport hinweg - was auch soweit logisch ist, da kein Routing definiert ist.

Was ich mich nun frage ist, wo setze ich mit dem Routing an?
Muss auf beiden Switches das Routing definiert werden, oder, oder...


Konfig der beiden Switches:


Switch-01:
01.
02.
version 12.2 
03.
no service timestamps log datetime msec 
04.
no service timestamps debug datetime msec 
05.
no service password-encryption 
06.
07.
hostname SW01 
08.
09.
10.
spanning-tree mode pvst 
11.
12.
13.
interface FastEthernet0/1 
14.
 switchport access vlan 2 
15.
 switchport mode access 
16.
17.
interface FastEthernet0/2 
18.
 switchport access vlan 2 
19.
 switchport mode access 
20.
21.
interface FastEthernet0/3 
22.
 switchport access vlan 3 
23.
 switchport mode access 
24.
25.
interface FastEthernet0/4 
26.
 switchport access vlan 3 
27.
 switchport mode access 
28.
29.
interface FastEthernet0/5-24 
30.
31.
interface GigabitEthernet0/1 
32.
 switchport trunk allowed vlan 1-3 
33.
 switchport trunk encapsulation dot1q 
34.
 switchport mode trunk 
35.
36.
interface GigabitEthernet0/2 
37.
38.
interface Vlan1 
39.
 no ip address 
40.
 shutdown 
41.
42.
line con 0 
43.
44.
line aux 0 
45.
46.
line vty 0 4 
47.
 login 
48.
49.
50.
end
Switch-02:
01.
02.
version 12.2 
03.
no service timestamps log datetime msec 
04.
no service timestamps debug datetime msec 
05.
no service password-encryption 
06.
07.
hostname SW02 
08.
09.
10.
spanning-tree mode pvst 
11.
12.
13.
interface FastEthernet0/1 
14.
 switchport access vlan 2 
15.
 switchport mode access 
16.
17.
interface FastEthernet0/2 
18.
 switchport access vlan 2 
19.
 switchport mode access 
20.
21.
interface FastEthernet0/3 
22.
 switchport access vlan 3 
23.
 switchport mode access 
24.
25.
interface FastEthernet0/4 
26.
 switchport access vlan 3 
27.
 switchport mode access 
28.
29.
interface FastEthernet0/5-24 
30.
31.
interface GigabitEthernet0/1 
32.
 switchport trunk allowed vlan 1-3 
33.
 switchport trunk encapsulation dot1q 
34.
 switchport mode trunk 
35.
36.
interface GigabitEthernet0/2 
37.
38.
interface Vlan1 
39.
 no ip address 
40.
 shutdown 
41.
42.
line con 0 
43.
44.
line aux 0 
45.
46.
line vty 0 4 
47.
 login 
48.
49.
50.
end
60c36422114ee39ed78860e735606390 - Klicke auf das Bild, um es zu vergrößern


Gruß
Mitglied: Dani
LÖSUNG 25.05.2014, aktualisiert 27.05.2014
Hallo,
mit einem einfachen "ip routing" wird die Funktion aktiviert.
Wenn du mehr darüber wissen willst, kannst du es hier nachlesen.


Grüße,
Dani
Bitte warten ..
Mitglied: teret4242
25.05.2014, aktualisiert um 13:39 Uhr
Zitat von Dani:
mit einem einfachen "ip routing" wird die Funktion aktiviert.

Danke, aber mir fehlt dazu noch irgendwie das Verständnis auf welchem Switch die Funktion überhaupt aktiviert werden muss.
Sprich muss "ip routing" dann auf jedem Switch aktiviert werden bei dem auch die VLANs vorhanden sind, oder nur bei einem?
Oder stellt man dazu am besten einen zentralen Switch zur Verfügung der das Routing übernimmt?


Gruß
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.05.2014, aktualisiert 27.05.2014
Du musst jedem VLAN auch ein Layer 3 Interface zuordnen, also ein IP Interface, denn du musst ja zw. den VLANs routen um kommunizieren zu können. Damit hängst du auf dem Switch quasi ein Routing Interface in das jeweilige VLAN.
Alle VLAN Endgeräte bekommen dann diese IP als Gateway IP konfiguriert im jeweiligen VLAN und et voila.... schon ist die Connectivity da zw. den VLANs

Grundlagen dazu findest du auch hier:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Allerdings bezieht sich der Schwerpunkt dort auf externens Routing nicht routingfähiger VLAN Switches.
Deinen 3550er können ja selber Routing benötigen also keinen externen Router. Nur die entsprechenden "vlan x" Interfaces wobei das "x" identisch ist zur VLAN ID.
Deine Konfig sieht dann so aus:
!
interface Vlan1
ip address 172.16.1.254 255.255.255.0
no shutdown
!
interface Vlan2
ip address 172.16.2.254 255.255.255.0
!
interface Vlan3
ip address 172.16.3.254 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 <ip_adress_internet-router>
--> Default Router zum Internet Router oder Firewall !

Nochwas:
Wenn du beide Switches in ein HA (High Availability = Hochverfügbarkeit) Design bringen willst, also das beide Switches zwischen den VLANs redundant routen sollen, dann solltest du auf den vlan Interfaces noch zwingend HSRP oder den Standard VRRP konfigurieren.
Dann sähe deine Konfig so aus:
Switch 1:
!
interface Vlan1
ip address 172.16.1.253 255.255.255.0
standby 1 ip 172.16.1.254
no shutdown
!
interface Vlan2
ip address 172.16.2.253 255.255.255.0
standby 1 ip 172.16.2.254
!
interface Vlan3
ip address 172.16.3.253 255.255.255.0
standby 1 ip 172.16.3.254
!
ip route 0.0.0.0 0.0.0.0 <ip_adress_internet-router>


Switch 2:
!
interface Vlan1
ip address 172.16.1.252 255.255.255.0
standby 1 ip 172.16.1.254
no shutdown
!
interface Vlan2
ip address 172.16.2.252 255.255.255.0
standby 1 ip 172.16.2.254
!
interface Vlan3
ip address 172.16.3.252 255.255.255.0
standby 1 ip 172.16.3.254
!
ip route 0.0.0.0 0.0.0.0 <ip_adress_internet-router>


Hier zeigt das Gateway der Endgeräte dann immer auf die Standby IP. Das ist eine virtuelle Gateway IP zwischen beiden Layer 3 Switches. Nun kann entweder dereine oder der andere Switch als Router zw. den VLANs ausfallen und du kannst immer noch kommunizieren zw. den VLANs !
Damit ist dein VLAN Routing dann redundant.

Mit show standby kannst du dir dein HSRP Design dann ansehen ob es sauber rennt !
Bitte warten ..
Mitglied: teret4242
25.05.2014, aktualisiert um 14:01 Uhr
Zitat von aqui:

Du musst jedem VLAN auch ein Layer 3 Interface zuordnen, also ein IP Interface, denn du musst ja zw. den VLANs routen um
kommunizieren zu können. Damit hängst du auf dem Switch quasi ein Routing Interface in das jeweilige VLAN.

Erstellt dabei der Switch dann eigenständig die Routing-Einträge zu den anderen VLANs, oder muss man das manuell vornehmen?

Muss ich dann quasi das IP-Interface auf jedem Switch erstellen, oder reicht das auf einem für das Routing? Da blick ich momentan noch nicht so wirklich durch...


Deine Konfig sieht dann so aus:
!
interface Vlan1
ip address 172.16.1.254 255.255.255.0
no shutdown
!
interface Vlan2
ip address 172.16.2.254 255.255.255.0
!
interface Vlan3
ip address 172.16.3.254 255.255.255.0
!


...müssen die beiden Interface "Vlan2" + "Vlan3" nicht auf "no shutdown" gesetzt werden?
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.05.2014, aktualisiert 27.05.2014
Erstellt dabei der Switch dann eigenständig die Routing-Einträge zu den anderen VLANs, oder muss man das manuell vornehmen?
Routing Einträge sind doch vollkommen überflüssig, denn die IP Netze sind doch DIREKT am Switch angeschlossen (VLANs) !!
Der Switch "kennt" also alle Routings deshalb. Statische Routing Einträge wären damit Blödsinn. Weisst du aber vermutlich selber ?!
Du kannst die Routing Tabelle selber mit show ip route ansehen auf dem Switch !
Einzig die Default Route auf den Internet Router oder Firewall muss konfiguriert sein damit der L3 Switch weiss wo er hinrouten muss wenn es in andere VLANs als seine eigenen gehen muss !

...müssen die beiden Interface "Vlan2" + "Vlan3" nicht auf "no shutdown" gesetzt werden?
Ja, natürlich ! Sonst ist das deaktiviert wie das Kommando schon selbst sagt... !
Wenn du dir die Threadantwort oben mal wirklich durchgelesen hättest, dann hättest du gesehen das da unübersehbar "no shutdown" auf dem einen Interface steht.
Deine Intelligenz vorausgesetzt haben wir jetzt mal gedacht das du das analog dann für alle L3 Interfaces übernimmst ?!

"no shutdown" ist der Default und Default Settings werden in der Cisco Konfig in der Regel der Übersicht halber nicht angezeigt. Deshalb sind sie an den anderen Interfaces entfernt
Bitte warten ..
Mitglied: teret4242
25.05.2014, aktualisiert um 14:34 Uhr
Zitat von aqui:
Routing Einträge sind doch vollkommen überflüssig, denn die IP Netze sind doch DIREKT am Switch angeschlossen
(VLANs) !!
Der Switch "kennt" also alle Routings deshalb. Statische Routing Einträge wären damit Blödsinn. Weisst du
aber vermutlich selber ?!
Du kannst die Routing Tabelle selber mit show ip route ansehen auf dem Switch !
Einzig die Default Route auf den Internet Router oder Firewall muss konfiguriert sein damit der L3 Switch weiss wo er hinrouten
muss wenn es in andere VLANs als seine eigenen gehen muss !

Stimmt

Allerdings ist mir das mit dem Routing-Interface immer noch nicht so wirklich klar...
Ich mein wenn eine Firma z.B. 10 VLANs hat, die sich über 100 Switches hinweg erstrecken, dann wird doch bestimmt nicht auf jedem Switch für jedes VLAN ein IP-Interface erstellt oder?

Wenn du dir die Threadantwort oben mal wirklich durchgelesen hättest, dann hättest du gesehen das da unübersehbar
"no shutdown" auf dem einen Interface steht.
Deine Intelligenz vorausgesetzt haben wir jetzt mal gedacht das du das analog dann für alle L3 Interfaces übernimmst ?!

"no shutdown" ist der Default und Default Settings werden in der Cisco Konfig in der Regel der Übersicht halber
nicht angezeigt. Deshalb sind sie an den anderen Interfaces entfernt

Natürlich habe ich deine Antwort wirklich durchgelesen - habe mich aber in dem Moment gewundert, warum nur das eine Interface auf "no shutdown" gesetzt ist...
Bitte warten ..
Mitglied: martin-s
25.05.2014 um 14:41 Uhr
Hi!

Wenn eine Firma so viele Switches einsetzt gibt es quasi ein drei Schichtenmodell:

1.) Core Layer
Hier wird das Routing für die ganzen VLANs vorgenommen. Es sind auch eigene
Switches im Einsatz die für Routing gedacht sind und die Routingengine in Hardware
implementiert haben.

2.) Distribution Layer
Quasi eine Schicht zwischen Core Layer und Access Switches. Dieser Layer verbindet
den Access Layer mit dem Core Layer

3.) Access Layer
Auf diesem Switch werden dann die Accessgeräte angeschlossen. Auf den einzelnen
Ports werden dann meist die VLANs untagged konfiguriert. Möglich ist noch, dass ein
VoiceVLAN getagged konfiguriert wird.

Switches für den Access Layer haben die Routingengine meist nur in Software implementiert
und können d.h. nicht so schnell Routen wie die Core Geräte.

Schöne Grüße
Martin
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.05.2014, aktualisiert 27.05.2014
Ich mein wenn eine Firma z.B. 10 VLANs hat, die sich über 100 Switches hinweg erstrecken, dann wird doch bestimmt nicht auf jedem Switch für jedes VLAN ein IP-Interface erstellt oder?
Doch, ganz genau so !
Solche klassischen LAN Campus Designs sehen dann immer so aus:

b7cb8a40e8086f71cf1ec244f022bfbe-redswitch - Klicke auf das Bild, um es zu vergrößern
Im Access und Distribution Bereich macht man L2 mit redundanten Links auf die L3 Cores und dort werden dann zentral alle VLANs geroutet.
Natürlich kannst du das auch anders machen und gleich am Anfang routen, das erfordert dann aber ein vollständig geroutetes Netzwerk mit dem du dann transparent keine VLANs mehr übertragen kannst.
Auch das geht natürlich, keine Frage. Die meisten Netzwerker wollen das aber oft nicht, da sie VLANs transparent im ganzen Backbone haben möchten und so greift dann wieder das erste Design... !
Kommt eben etwas auf das jeweilige individuelle Netzwerk Design an und wohin man damit will bzw. was man damit erreichen will.
Bitte warten ..
Mitglied: teret4242
25.05.2014, aktualisiert um 15:28 Uhr
Zitat von aqui:
Im Access und Distribution Bereich macht man L2 mit redundanten Links auf die L3 Cores und dort werden dann zentral alle VLANs
geroutet.

Ahhh, dann macht das natürlich wieder Sinn ... habe mir quasi vorgestellt, dass schon auf jedem Access-Switch die einzelnen IP-Interface der VLANs definiert werden.

Das Routing ZWISCHEN den VLANs funktioniert übrigens noch nicht...

Vielleicht hilft nochmals die Konfig der beiden Switches:

Switch 1:
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/5-24
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 1-3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 10.0.2.254 255.255.255.0
!
interface Vlan3
ip address 10.0.3.254 255.255.255.0
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end


Switch 2:
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/5-24
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 1-3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 10.0.2.253 255.255.255.0
!
interface Vlan3
ip address 10.0.3.253 255.255.255.0
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end


...das Gateway ist auf den Endgeräten eingetragen...
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.05.2014, aktualisiert 27.05.2014
Das vom Kollegen Dani oben angemerkte globale Kommando ip routing hast du ausgeführt in der Konfig ?!
Ansonsten spielt dir dann vermutlich die lokale Firewall der Endgeräte einen Streich !
Normalerweise blocken die ALLE Pakete die NICHT von Absendern aus ihrem eigenen lokalen LAN kommen.
Hast du das berücksichtigt ?!

Du hast zudem kein Portfast auf den Ciscos aktiviert auf den Access Ports. Bedenke dann auch das der STP Learning Prozess bei Cisco ca. 40 bis 45 Sekunden benötigt bevor diese Ports in den Forwarding Modus gehen !!
Über diese Zeitspanne lassen die keine Pakete durch !
Willst du das unterbinden musst du auf dem Port spanning-tree portfast konfigurieren.
Auf den Uplink Ports zwischen Switches solltest du das aber niemals machen um Loops zu verhindern !
Bitte warten ..
Mitglied: shjiin
25.05.2014 um 20:13 Uhr
Auch wenns für eine Packet Tracer Übung egal ist. Bei einer "echten" Umgebung solltest du "spanning-tree mode rapid-pvst" in den global config mode eingeben. Da beträgt die Konvergenz Zeit etwa 5 sek, wenn ich mich noch recht erinnere.
Bitte warten ..
Mitglied: aqui
25.05.2014, aktualisiert 26.05.2014
Die RSTP Konvergenzzeit im Redundazfalle hat hier aber rein gar nichts mit dem Portfast Feature zu tun, das nur nebenbei.
Im Normalfall durchläuft ein Switchport beim Aktivieren die Phasen des Spanning Tree Protokolls: Blocking, Listening, Learning und Forwarding. Dadurch dauert es etwa 35 Sekunden bis der Port Nutzdaten transportiert. Mit Portfast deaktiviert man diesen Lernprozess und so wechselt der Port von Blocking direkt zu Forwarding. Für Edge Ports ist das OK auf Uplink Ports sollte man es generell wegen der latenten Loop Gefahr niemals machen.

Abgesehen davon beträgt die RSTP Konvergenz weit unter einer Sekunde (deshalb das "Rapid" im Namen !!) und keine 5 Sekunden. Das ist so oder so nicht genau zu definieren, denn es ist in erheblichem Maße vom Netzdesign des LANs abhängig. In fehlerhaften bzw. für Ethernet sehr unvorteilhaften Ring Designs oder Kaskaden mit mehr als 3 Switches kann sie auch mal bis zu 10 Minuten dauern.
In der Beziehung ist dieses Stament hier zum Teigentlichen Topic "Routing" irgendwie etwas sinnfrei... Es hat damit nicht das Geringste zu tun ! Aber nett das man darüber auch mal diskutiert hat....

Sinnvoll wäre vom TO nun mal zu wissen ob er sein VLAN Routing endlich zum Fliegen gebracht hat...eigentlich eine Sache von 3 Minuten (höchstens) auf dem Cisco Switch !
Bitte warten ..
Mitglied: aqui
26.05.2014, aktualisiert um 21:02 Uhr
Gibts denn nun noch ein Update hier für die Forumscommunity oder wars das nun... ??

Wenn ja denn war bitte dann auch
http://www.administrator.de/faq/32
Nicht vergessen !
Bitte warten ..
Mitglied: teret4242
27.05.2014 um 13:15 Uhr
Zitat von aqui:
Gibts denn nun noch ein Update hier für die Forumscommunity oder wars das nun... ??

Natürlich gibt es das - aber man sollte auch auf eine gewisse Balance zwischen Real Life und virtueller Welt achten aqui

Problem war das "ip routing".
Dies hatte ich wohl aktiviert, aber blöderweise vergessen die Konfig zu sichern bevor ich den Switch neu gebootet hab...

Vielen Dank für deine ausführlichen und hilfreichen Antworten!!!
Bitte warten ..
Mitglied: aqui
27.05.2014 um 18:56 Uhr
Das wr sollte einem in den Fingern fest eingebrannt werden beim Konfigurieren

Gut wenn nun alles klappt wie es soll !
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkprotokolle
gelöst Problem bei VLAN Trunk mit LACP zwischen HP und Cisco (11)

Frage von markuswo zum Thema Netzwerkprotokolle ...

Firewall
gelöst Site-to-Site-VPN und Cisco VPN-Client von gleicher IP (2)

Frage von TripleDouble zum Thema Firewall ...

LAN, WAN, Wireless
gelöst 1 Port in mehreren VLANs? (7)

Frage von mario87 zum Thema LAN, WAN, Wireless ...

Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (7)

Frage von Kroeger02 zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...