Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit mehreren Exchange-Konten in Outlook 2010 gelöst

Mitglied: StefanKittel

StefanKittel (Level 4) - Jetzt verbinden

23.09.2011, aktualisiert 03.10.2011, 36418 Aufrufe, 5 Kommentare, 3 Danke

Beim Senden als anderer Benutzer bleiben Nachrichten im Postausgang "hängen", wenn das Konto des anderen Benutzers als vollwertiges Exchange Konto in Outlook 2010 eingerichtet wird.
Außerdem kann man keine Suchordner für die anderen Konten hinzufügen.

Ist ein langer Titel, ich weiß. Beschreibt aber genau das Problem das ich letztens bei einem unserer Kunden zu lösen hatte...

Zusätzlich löst diese Anleitung das Problem, dass man Suchordner für die anderen Konten nicht anlegen kann.

Umgebung: Exchange 2010 SP1 RU3v3 und Outlook 2010. Da eine VDI Infrastruktur im Einsatz ist, sind die meisten Outlook Clients nicht mit Cache Mode angebunden. Der Kunde macht extrem viel Gebrauch von der neuen Outlook Funktion mehrere Exchange Konten einzubinden. Was im Prinzip ja auch gut funktioniert...

In diesem Fall blieben allerdings bei einigen Konten Nachrichten im Postausgang "hängen", wenn man mit der Email Adresse eines anderen Benutzers Nachrichten verschickt. Nach einiger Zeit wurden die Nachrichten dann zugestellt, waren aber noch immer im Postausgang zu sehen. Das fördert nicht unbedingt das Vertrauen ins Produkt...

Das Einspielen von Outlook 2010 SP1 sowie Exchange 2010 SP1 RU4 hat den Fehler nicht behoben. Auch nach langem hin und her probieren mit Online und Cache Mode kamen wir auch auf keinen grünen Zweig. Nur durch Zufall sind wir draufgekommen was das Problem verursacht...

Wenn man in Exchange 2010 SP1 Vollzugriffsrechte auf ein Postfach erteilt, so wird im AD ein Attribut mit einem Link auf dieses Postfach beim berechtigten Benutzer befüllt. Dieses Attribut liest Autodiscover aus und schickt Outlook die Info über das zusätzlich zu verbindende Postfach(genauso funktioniert übrigens das 2010er Archiv). Und Outlook verbindet automatisch das Postfach. An und für sich eine coole Sache. Wenn da nicht ein Bug wäre...

Wenn nämlich ein Benutzer das Postfach auf das er zusätzlich Vollzugriffsrechte hat, explizit als eigenes(!) Exchange Konto im Outlook hinzufügt, dann kommt es zu oben beschriebenem Problem.

Anscheinend gibt es da keinen Check im Code und Outlook verbindet das Postfach über Autodiscover und hat noch zusätzlich das explizite Konto. Ein veritabler Bug, würde ich sagen. Oder doch, wie man bei MS so oft, hört "by Design"?

Was lernen wir daraus? Ganz einfach: Wenn einem Benutzer Vollzugriffsrechte auf ein Postfach erteilt werden und dieses Postfach soll im Outlook als vollwertiges(!) Konto zur Verfügung stehen, dann muss der Link im Attribut beim User entfernt werden. Ist mühsam ich weiß...

Welches Attribut ist gemeint? Das ist auch wieder so eine Sache...denn es ist ein so genannter Backlink der da angelegt wird. Also wie bei Member und MemberOf - das eine zeigt aufs andere. Wenn ich das eine entferne, entferne ich auch das andere. Nun aber zu den besagten Attributen:

1) msExchDelegateListLink
2) msExchDelegateListLinkBL

Das erste Attribut wird beim Postfach befüllt auf das Berechtigt wurde. Und hier(!) muss auch der Eintrag entfernt werden. Das Entfernen des zweiten Attributs braucht Ihr erst gar nicht versuchen - das funktioniert nicht. Also immer(!) beim Postfach auf das Berechtigt wurde die Bereinigung durchführen.

So nachdem ich Euch jetzt mit einer Litanei gequält habe...ich habe für die Vergabe von Berechtigungen ohne das Erstellen eines Links ein Script "aufgetrieben" Im Blogeintrag

http://www.stevieg.org/tag/add-mailboxpermission/

findet Ihr das Script AddMailboxpermissionNoLink.ps1. Also wenn Du Berechtigungen vergeben willst ohne das so ein Link erstellt wird, benutzt das Script. Doch ein bisschen einfacher, oder? Die Bereinigung spart man sich trotzdem nicht, sorry

Quelle: http://www.ntx.at/blog/Lists/Beitraege/Post.aspx?ID=258
Mitglied: 7Gizmo7
03.10.2011 um 13:22 Uhr
Hallo Stefan


Zitat von StefanKittel:


Wenn nämlich ein Benutzer das Postfach auf das er zusätzlich Vollzugriffsrechte hat, explizit als eigenes(!) Exchange
Konto im Outlook hinzufügt, dann kommt es zu oben beschriebenem Problem.

Ist dem User dann nicht auch das Passwort des Kontos bekannt und wenn ich dem User die Vollzugriffsrechte entziehe, werden die Attribute dann nicht entfernt.

Das heißt doch ich füge über Autodiscover das Postfach mit dem bekannten Passwort hinzu oder habe ich das jetzt falsch verstanden ?
Wie fügts du das zweite Postfach hinzu mit dem Passwort des Primär User ?

So nachdem ich Euch jetzt mit einer Litanei gequält habe...ich habe für die Vergabe von Berechtigungen ohne das
Erstellen eines Links ein Script "aufgetrieben" Im Blogeintrag

http://www.stevieg.org/tag/add-mailboxpermission/

Der Link hat sich geändert :
http://www.stevieg.org/2011/02/disable-exchange-2010-sp1s-auto-shared-m ...

findet Ihr das Script AddMailboxpermissionNoLink.ps1. Also wenn Du Berechtigungen vergeben willst ohne das so ein Link erstellt
wird, benutzt das Script. Doch ein bisschen einfacher, oder? Die Bereinigung spart man sich trotzdem nicht, sorry

Quelle: http://www.ntx.at/blog/Lists/Beitraege/Post.aspx?ID=258
Bitte warten ..
Mitglied: StefanKittel
03.10.2011 um 13:27 Uhr
Hallo,

das Problem sieht folgendermaßen aus.

Im Exchange-Server füge ich den Benutzer A als Vollzugriff und Senden als für ein Postfach B hinzu.
Wenn ich nun ein Outlook-Profil für A erstellen, erscheint Postfach B ganz automatisch, ohne dass ich es als weiteres Konto oder Postfach hinzugefügt habe. Dies nennt sich Autodiscover.

Ich habe Zugriff auf das Konto und kann den Absender auswählen, indem ich das "Von"-Feld verwenden.
Ich kann aber keine Suchordner anlegen.

Wenn ich nun B als weiteres Exchange-Konto hinzufüge kann ich der Dropdown-Box den Absender auswählen.
Das ist natürlich viel angenehmer.

Aber ich kann keine Suchordner anlegen für B und Emails werden teilweise erst nach Stunden gesendet und verbleiben solange im Postausgang.

Stefan
Bitte warten ..
Mitglied: 7Gizmo7
03.10.2011 um 13:41 Uhr
Hallo Stefan

Um was es geht ist mir schon klar.
Meine Frage ist wie fügst du das Postfach B ( eigentlich auch per Autodiscover denk ich ) beim Benutzer A hinzu und welches Passwort nimmst du für das Postfach B ?
Bitte warten ..
Mitglied: StefanKittel
03.10.2011 um 13:49 Uhr
Hallo,
ich bin verwirrt. Ich füge einfach ein 2. Exchange-Konto hinzu über die Kontoverwaltung in Outlook. Da ich Vollzugriff darauf habe benötige ich kein Kennwort.
Stefan
Bitte warten ..
Mitglied: 7Gizmo7
03.10.2011 um 13:58 Uhr
Ah okay , das wusste ich nicht....dann wird also die Authentifizierung des Benutzer A für das Postfach B genutzt.

Wie verhält es sich aber wenn ich das zweite Konto nicht über den Vollzugriff hinzufüge, sonder (lass es ein Sammelpostfach sein , wo ich das Password kenne )
habe ich dann auch keine Suchordner und werden dann die Mails nicht gleich versandt ?
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail

Outlook 2007 zu 2010 und zurück unter Exchange 2010

Anleitung von TechnoXOutlook & Mail4 Kommentare

Wir haben hier ein immer mal wieder auftretendes Szenario. Wir haben mehrere Outlook Versionen im Einsatz. Vorwiegend 2007 & ...

Outlook & Mail

Outlook 2016 - Exchange 2010 Verbindungsprobleme

Tipp von 0l1v3rOutlook & Mail1 Kommentar

Ab Outllook 2016 funktionierte die Kommunikation zwischen den Windows Fat-Clients und dem Exchange 2010 nicht mehr. Beim Einrichten von ...

Exchange Server

Nach Umzug der Postfächer von Exchange 2010 nach Exchange 2016 keine Verbindung zum Postfach mit Outlook 2010 und 2013 möglich

Tipp von diemilzExchange Server1 Kommentar

Hallo zusammen, ich bin gestern bei unserer Exchange-Umstellung über einen nervigen Fehler gestolpert, der mich einen Teil meiner Nerven ...

Windows Server

Standarddrucker Terminalserver 2012R2 verstellt sich bei jeder neuen Anmeldung - gelöst

Anleitung von ONIG-OCWindows Server2 Kommentare

Problem: der Anwender meldet sich auf dem Terminalserver an der Standarddrucker ist verstellt und muss neu eingerichtet werden nach ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement14 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...