Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Seltsame DNS-Probleme bei W2K3

Tipp Microsoft Windows Server

Mitglied: jhinrichs

jhinrichs (Level 2) - Jetzt verbinden

17.08.2009, aktualisiert 19.08.2009, 9834 Aufrufe

Ich habe das im folgenden beschriebene Problem gehabt und musste mich durch eine Reihe Foren wühlen, bis ich - obwohl das Problem öfter geschildert wurde - eine, wenn auch nicht ganz befriedigende - Lösung gefunden hatte. Die sollte aber auch in einem so kompetenten Forum wie administrator.de zu finden sein, daher der Tipp.

Es war einmal der Tag, an dem die erste Instanz des virtuellen IMAP-Servers auf unserem SBS2003R2 nicht mehr automatisch startete, ein anschließender manueller Start gelang problemlos.

Im Ereignisprotokoll fanden sich folgende Meldungen:
MSExchangeFBPublish (Id: 8213)
Der Systemaufsichtsdienst konnte die Sitzung für den virtuellen Computer SERVER nicht erstellen. Die Fehlernummer ist 0xc10306ce.
Weitere Informationen erhalten Sie unter http://www.microsoft.com/contentredirect.asp.
Und zwei weitere ExchangeMU-Fehler mit den Ids 1042 und 1047.

Der DNS-Server startete unauffällig.

Letztlich fiel im Diagnosetool netdiag folgende Ausgabe auf:
'server.mydomain.local.'. [WSAEADDRNOTAVAIL ]
The name 'server.mydomain.local.' may not be registered in DNS.
[WARNING] Cannot find a primary authoritative DNS server for the name
'server.mydomain.local.'. [ERROR_TIMEOUT]
The name 'server.mydomain.local.' may not be registered in DNS.
[WARNING] The DNS entries for this DC are not registered correctly on
DNS server '0.0.0.0'. Please wait for 30 minutes for DNS server replication.
[FATAL] No DNS servers have the DNS records for this DC registered.

Das Eigenartige daran: Der DNS-Server war korrekt konfiguriert, ebenso die TCP/IP-Einstellungen des Netzwerkinterfaces, natürlich war nirgendwo ein DNS-Server "0.0.0.0" eingetragen. Die Ausgaben von
01.
ipconfig /all
zeigte auch korrekte DNS- und Domäneneinstellungen.
01.
netdiag /fix
und
01.
ipconfig /registerdns
Schließlich fand sich irgendwo in einem Forum die vage Aussage "IPv6 auf W2K3 ist nicht unproblematisch", aber IPv6 war gar nicht "offiziell" installiert, tauchte auch in den Eigenschaften der Netzwerkverbindungen nicht auf, konnte also auch nicht deinstalliert werden.
Andererseits ergab ipconfig /all auch die IPv6-Adressen der Adapter, und das bei nicht vorhandenem IPv6?

Aus Verzweiflung habe ich dann zunächst IPv6 installiert, aber nur, damit es angezeigt wird und ich es dann wieder deinstallieren kann, was ich dann auch getan habe (jeweils mit Reboot).
Und siehe da: Fehlermeldungen weg, Exchange tut wieder alles, was er soll!

Falls jemand eine intelligentere Lösung hat, bin ich für Anregungen dankbar!
Ähnliche Inhalte
Windows Server
Seltsame DNS-Probleme (4)

Frage von Leo-le zum Thema Windows Server ...

Drucker und Scanner
Ein Druckserver verhält sich seltsam?! (7)

Frage von Y3shix zum Thema Drucker und Scanner ...

Windows Server
gelöst Hyper V seltsame Fehlermeldungen (3)

Frage von BiGnoob zum Thema Windows Server ...

Neue Wissensbeiträge
Virtualisierung

Docker Monitoring und Steuerung per "sen"

Tipp von Frank zum Thema Virtualisierung ...

Viren und Trojaner

Neues Botnetz über IoT-Geräte

(6)

Information von certifiedit.net zum Thema Viren und Trojaner ...

Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Heiß diskutierte Inhalte
Windows Installation
Windows 10 neu installieren (18)

Frage von imebro zum Thema Windows Installation ...

Router & Routing
Externe IP von innen erreichbar machen (15)

Frage von Windows10Gegner zum Thema Router & Routing ...

Windows 7
Abbruch bei Brennvorgang (14)

Frage von Simulant zum Thema Windows 7 ...