Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 7 Professional fährt nicht mehr hoch (Windows 7 Startbildschirm) - classpnp.sys ist letzter Eintrag

Mitglied: compugo

compugo (Level 1) - Jetzt verbinden

20.07.2012 um 21:19 Uhr, 17784 Aufrufe, 3 Kommentare

Wir haben hier auf einen HP 6200 Pro Desktop PC o.g. Problem und bei der Lösungssuche im Internet habe ich gesehen, dass viele Leute (mit anderen Rechnern) ähnliche Schwierigkeiten haben.

Vielleicht hilft jemandem ja dieser Ansatz.

Fehlerbeschreibung:

Rechner fährt nur noch bis zum Bildschirm "Windows wird gestartet" hoch, danch geht die HDD-LED aus und der Rechner bleibt so stehen. (wir haben 4 Stunden gewartet)
Im abgesicherten Modus fährt der Rechner hoch
Im Abgesicherten Modus mit Netzwerk-Umgebung wird als letztes der Treiber classpnp.sys geladen, dann bleibt der Rechner stehen.

Unsere Lösung war ein BIOS-Update des Systems.

Hinweis:
AMT, die Vorgehensweise beim BIOS-Update usw. treffen sicherlich nicht auf jeden PC zu - hier die Herstellerangaben befolgen
.
Grundsätzlich kann es aber nicht verkehrt sein,
1. das Dateisystem / den Datenträger zu prüfen
2. die Systemdateien zu prüfen mit sfc bzw. den grafischen Reparatur-Tools von Windows 7 Setup
3. Nicht benötigte Geräte abschalten oder trennen (auch USB-Geräte beachten)

wenn alles nichts hilft, BIOS-Reset, BIOS-Update durchzuführen.

Viel Erfolg!




Im Einzelnen wurden folgende Schritte durchgeführt:

Ich habe probiert:
Von Windows 7-CD / Reparaturkonsole sfc /scannow /offbootdir=D:\ /offwindir=D:\Windows
(je nach Laufwerksbuchstabe)
-> kein Erfolg

scnadisk /f /v /r durchgeführt -> keine Fehler gefunden, Ergebnisse konnten jedoch nicht gespeichert werden

Im Internet gefunden, dass man classpnp.sys umbenennen soll (C:\Windows\System32\Drivers) -> kein Erfolg (stattdessen Bluescreen), also wieder rückgängig gemacht.

Startprotokollierung eingeschaltet und in der ntbtlog.txt gesehen, dass vga.sys und diverse andere Treiber (Netzwerk z.B.) nicht geladen werden konnten.

Daher die Idee, im BIOS alle nicht benötigten Geräte abzuschalten. Unser Gerät hat eine onBoard-Grafik. Zusätzlich habe ich DVD-Laufwerk und internen Cardreader getrennt.

BIOS Einstellungen kontrolliert und alles, was ging, abgeschaltet. Leider war es nicht möglich, die Netzwerkkarte abzuschalten, da Hinweis kam, man solle erst AMT abschalten. Einen Menüpunkt AMT gab es aber im BIOS nicht.

Per msconfig (im abgesicherten Modus) alles abgeschaltet, was nach Grafiktreiber klingt (Intel gfx....) + zusätzlich HP Druckertreiber, da die häufig Probleme bereiten etc.

--> kein Erfolg

--> Download BIOS-Update (damals Ver. 2.21):
-> Das *.bin File aus dem DOS-Verzeichnis auf einen USB-Stick kopiert (root-Pfad)

-> Rechner neu gestartet im BIOS den Menüpunkt "Flash ROM" o.ä. gestartet und das BIOS geflasht (Das funktioniert so nicht bei jedem Rechner, man hätte auch eine DOS-Startdisk erstellen können etc.)

-> AMT ist nun vorhanden

---> Rechner startet wieder ganz normal

--> msconfig wieder ausgeführt, alles wieder aktiviert

-> alles OK



Mitglied: Memphis81
07.08.2012 um 09:50 Uhr
Das liegt meistens am AHCI Treiber...
Gibt 2 Möglichkeiten das System zum laufen zu kriegen.

1. Im Bios auf IDE stellen.

2. Wenn das System sich irgendwie booten lässt,
z.B.
- im abgesichertem Modus
- mit Boot CD / Rescue CD / Recovery CD

den Registry-Editor (regedit.exe) mit Administratorrechten öffnen und zum Schlüssel HKEY_LOCAL_MACHINE\System\CurrentControlSet\services\msahci wechseln. Dort den Schlüssel „Start“ vom jeweils voreingestellten Wert auf „0“ oder "1" setzen. Danach den Editor schließen und Reboot.
Bitte warten ..
Mitglied: compugo
07.08.2012 um 11:11 Uhr
Im BIOS auf IDE Modus umzustellen brachte bei uns leider sofort einen Bluescreen (auch im abgesicherten Modus).

Hängt sicherlich von der individuellen Konfiguration ab.
Bitte warten ..
Mitglied: Memphis81
07.08.2012 um 11:13 Uhr
Zitat von compugo:
Im BIOS auf IDE Modus umzustellen brachte bei uns leider sofort einen Bluescreen (auch im abgesicherten Modus).

Hängt sicherlich von der individuellen Konfiguration ab.

Ich habe auch mehrere Anläufe gebraucht bis es dann mal ging. Sonst bleibt nur noch der CD boot...
Bitte warten ..
Ähnliche Inhalte
Windows 7

Ohne Virenscanner keine Windows (7) Updates

Tipp von mathuWindows 72 Kommentare

Wenn auf Windows 7 Systemen keine Windowsupdates aktuell (ab Januar 2018) mehr laufen, kann es daran liegen, daß kein ...

Windows 7

Windows 7 zeigt keine Netzwerkverbindungen an

Tipp von ApophisWindows 72 Kommentare

Hallo, vielleicht erspart das Folgende ja dem einen oder anderen langes Suchen bzw. eine Neuinstallation. Nach einem Stromausfall konnte ...

Windows 10

Windows 10 Version 1703 Home oder Professional Adware-Schutz fuer Defender

Tipp von BassFishFoxWindows 10

Hallo, Der eigentlich nur fuer Unternehmesnetze gedachte Adware-Schutz von W10 funktioniert auch mit Home oder Professional-Editionen. Darueber wurde vor ...

Windows 7

Windows 7 mit Intel Skylake CPU

Tipp von KuemmelWindows 75 Kommentare

Moin, wie vielleicht schon die ein oder anderen von euch wissen, ist es mit einem Intel-Skylake-CPU (6.Generation) und Windows ...

Neue Wissensbeiträge
CPU, RAM, Mainboards
Neverending story
Tipp von keine-ahnung vor 19 StundenCPU, RAM, Mainboards1 Kommentar

Da kommt man mit dem fixen gar nicht mehr hinterher und die CPU erreichen wieder Rechenleistungen im Bereich des ...

Multimedia & Zubehör
AVM Fritz USB WLAN Sticks schneller einschalten
Tipp von NetzwerkDude vor 2 TagenMultimedia & Zubehör4 Kommentare

Die AVM Fritz WLAN Sticks haben in der Firmware 2 Modis: Einmal als Massenspeicher und einmal als WLAN Netzwerkkarte ...

Windows Server

Windows Server Backup schlägt fehl - Lösung 2008-2016

Tipp von BiGnoob vor 2 TagenWindows Server

Hi zusammen , ich möchte gerne einen Lösungstipp abgeben für folgenden Fehler: Lösung ist folgende:

Humor (lol)
Telekom vs. O2 - 3:2
Erfahrungsbericht von the-buccaneer vor 3 TagenHumor (lol)4 Kommentare

Unglaublich aber wahr: Nachdem mein privater Anschluss am 19.04.18 auf VOIP und VDSL umgestellt wurde, hatte ich seitdem 1,5 ...

Heiß diskutierte Inhalte
PHP
Nach Umzug zu 1und1 bekomme ich beim Eintrag in die DB Tabelle folgenden Fehler
gelöst Frage von jensgebkenPHP35 Kommentare

INSERT command denied to user 'dbo45342345342231244'@'112.127.102.073' for table 'orders'

Rechtliche Fragen
DSGVO - Impressum und Datenschutz auf Anmeldeseiten notwendig?
Frage von StefanKittelRechtliche Fragen16 Kommentare

Hallo, was mit gerade eingefallen ist. Muss man auf Anmeldeseiten auch ein Impressum und Datenschutzhinweis haben? Auch hier wird ...

Windows Userverwaltung
Problem mit Benutzerprofil
Frage von lieferscheinWindows Userverwaltung12 Kommentare

Guten Tag liebe Community, folgendes Problem habe ich: User meldet sich auf Client A an - sein Homelaufwerk verbindet. ...

Windows Server
2003er RDS Server lässt alten ThinClient nach Updates nicht mehr anmelden
Frage von KnorkatorWindows Server9 Kommentare

Hallo zusammen, wir hatten die Aufgabe, ein System (keine Domänenanbindung) zu virtualisieren welches mehrere Jahre keine Updates gesehen hat. ...