Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WMI Filter mit Server 2008R2 und Windows 7

Tipp Microsoft Windows Server

Mitglied: dassven

dassven (Level 1) - Jetzt verbinden

21.03.2012, aktualisiert 28.03.2012, 8181 Aufrufe, 2 Kommentare

mit einigen WMI Filtern gibt es anscheinend nur Probleme, deswegen ein kleine Info, wie diese WMI's auch aussehen können

Ich hab einige Zeit verbracht, den SBS 2011 aufgesetzt, weil so ziemlich jegliche Anleitung bei meine einfachen WMI Filtern versagt habt. Mein Problem hat sich bevorzugt auf Windows 7 ausgewirkt. WMI Abfragen mit der Versionsnummer ging permanent in die Hose. Letztlich bin ich nur bei "BuildNumber" stehen geblieben. Seltsamer Weise war die Abfrage select * from Win32_OperatingSystem WHERE Version....... mit allen werten falsch. Egal ob der zu prüfende Wert '6.1.7600' oder '6.1.7601' war. Stehen geblieben bin ich bei folgenden Abfragen, die bei mir dann endlich liefen.

Windows 7 32-bit ohne SP1:
select * from Win32_OperatingSystem Where BuildNumber = '7600' AND ProductType = '1' AND NOT OSArchitecture = '64-bit'

Window 7 32-bit mit SP1:
select * from Win32_OperatingSystem Where BuildNumber = '7601' AND ProductType = '1' AND NOT OSArchitecture = '64-bit'

Windows 7 64-bit ohne SP1:
select * from Win32_OperatingSystem Where BuildNumber = '7600' AND ProductType = '1' AND OSArchitecture = '64-bit'

Windows 7 64-bit mit SP1:
select * from Win32_OperatingSystem Where BuildNumber = '7601' AND ProductType = '1' AND OSArchitecture = '64-bit'

So hat also die 'Version' nichts gebracht, nur die 'BuildNumber'
Hoffe es hilft euch weiter.

Good Luck Das Sven
Mitglied: CrazyThom
28.03.2012 um 11:16 Uhr
Hi,

versuch mal die Kombination aus ProductType und Version.
Das hat bei uns geholfen.

ProductType:
Clientversionen von Windows 1
Serverversionen von Windows, die als Domänencontroller ausgeführt werden 2
Serverversionen von Windows, die nicht als Domänencontroller ausgeführt werden (i. d. R. als Mitgliedsserver bezeichnet) 3

Version:
Windows Server 2008 R2 oder Windows 7 6.1%
Windows Server 2008 oder Windows Vista 6.0%
Windows Server 2003 5.2%
Windows XP 5.1%
Windows 2000 5.0%

Das % Zeichen ist ein Platzhalter.
Bitte warten ..
Mitglied: dassven
28.03.2012 um 15:26 Uhr
Hi Crazy,
genau so wie Du es beschrieben hast habe ich es in unendlichen versuchen probiert. Theoretisch sind die Zahlen nur werte die ausgelesen werden. Bei mir gab es immer die Bemerkung, dass die GPO nicht greift, weil der Wert falsch ist (WMI Wert und Rückgabewert vom OS).
einziges, die Buildnumber hat er in vernünftigen Werten zurück geliefert. Unterm Strich funktioniert es, und so lange ich Win 7 in 32 und64 bit und XP mit den WMI's erfolgreich auseinander halten kann paßt es bei mir. Alle sind glücklich und die Welt is wieder schön ;)

Gruß. Das Sven
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Server
Anbindung SSO über Typo3 an Windows Server 2008R2 (8)

Frage von Coreknabe zum Thema Windows Server ...

Windows Server
gelöst SQL Server 2008R2 Update über Windows Microsoft Updates wird nicht mehr angeboten (4)

Frage von TimSterntaler zum Thema Windows Server ...

Windows Server
BPA bei Windows Server 2008R2 Standard (15)

Frage von MiSt zum Thema Windows Server ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (23)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (19)

Frage von smartino zum Thema Mac OS X ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...

Linux Netzwerk
DHCP IP-vergabe erst nach 1-2 Minuten (11)

Frage von Maik82 zum Thema Linux Netzwerk ...