Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2 Netzwerkkarten in einem Rechner

Mitglied: 27186

27186 (Level 1)

08.06.2006, aktualisiert 19:12 Uhr, 5728 Aufrufe, 3 Kommentare

Hallo!

Folgendes:

1 PC (Win XP Home SP2)
2 Netzwerkkarten (WLAN, LAN)
1 WLAN Router
1 NAS 192.168.0.110

WLAN: DHCP; IP 192.168.0.101; NM 255.255.255.0; GW 192.168.0.1; DNS 192.168.0.1

LAN; IP (FEST) 192.168.0.201; NM 255.255.255.0

NAS; 192.168.0.110; NM 255.255.255.0; GW 192.168.0.1; DNS 192.168.0.1

Ich hatte, seit ich WLAN nutze, die interne NIC des PCs deaktiviert. Jetzt wollte ich meine NAS mal direkt an den Rechner anstatt über den WLAN-Router anschließen.
Am Rechner habe ich die oben angegebene IP an der LAN Karte fest vergeben.
Soweit alles gut, smb-Freigabe auf der NAS, wunderbar.
Doch plötzlich tat es das Internet nicht mehr, will heißen das meine Applikationen wie Trillian und Skype sehr wohl noch Verbindung hatten (Chat war möglich), aber der Internet Explorer hat keine Webseiten mehr angezeigt, und auch Outlook war mit dieser Situation überfordert.
Mir ist auch klar, das sich beide NICs im gleichen Netzwerk befinden. Mir ist jedoch unklar warum das ein Hinderniss darstellen sollte?
Ich wollte allerdings nicht die IP der NAS ändern, da ich sie ja nur vorübergehend direkt an den Rechner anschließe.
Dann habe ich nur die Netzwerkkarte LAN auf IP (FEST) 192.168.1.201; NM 255.255.255.0, also anderes Netz eingestellt. Internet ging dann auch wieder wie gewohnt über WLAN trotz aktivierter LAN Karte.
Aber dann hatte ich natürlich keinen Zugriff mehr auf die NAS wg. X.X.0.110 anstatt X.X.1.110.
Da habe ich folgenden Eintrag in der Routingtabelle vorgenommen:

route add -p 192.168.0.110 netmask 255.255.255.255 192.168.1.201

aber so wollte es auch nicht...

Wie und wo kann ich XP mitteilen, das es doch bitte die Internetverbindung über den gewohnten Weg beibehalten soll?
Und warum gehen Trillian, Skype und Co., aber kein ie und Outlook?
Warum findet es die Einstellungen nicht bei der automatischen Suche?
Oder sind etwa meine Einträge in der Routingtabelle fehlerhaft?
Mitglied: aqui
08.06.2006 um 18:14 Uhr
Deine Annahme ist richtig ! Eins der klassischen Probleme hier im Netzwerk Forum !

Beide Adapter befinden sich im gleichen IP Netzwerk und das ist nicht erlaubt bzw. nicht vorgesehen in einem sauberen IP Design. Das Problem ist das dein TCP Kernel im Rechner jetzt nicht mehr weiss über welchen Adapter er gehen soll denn beide sind ja im gleichen IP Netz. Schickt er sie auf den Adapter wo dein NAS dranhängt, landen sie im Nirwana denn da ist dein Router ja nicht dran. Schickt der Frames die fürs NAS sind auf die "Internet" Karte...dasgleiche Verhalten !! (Dein Problem)
Der PC fuktioniert NICHT wie eine Bridge ! Die Lösung ist aber recht einfach und du hast sie intuitiv auch schon (fast) richtig gemacht. Richtig ist es die beiden Adapter in unterschiedliche IP Netze zu bringen was du ja auch schon gemacht hast:
Internet Segment: 192.168.0.0 / 255.255.255.0 und das "NAS" Segment: 192.168.1.0 / 255.255.255.0
Die Route im PC ist überflüssig denn der PC "kennt" ja beide Netze, da sie an ihm selber direkt angeschlossen sind. Die kannst du also getrost löschen aber da du eh vergessen hast sie mit dem "-p" (permanent) Tag zu versehen ist sie nach dem nächsten Reboot auch sowieso wieder weg.
Checken kannst du das mit "route print" in der Eingabeaufforderung.
Der Fehler den du gemacht hast ist das NAS Device auf dem .0er Netz zu lassen !!!
Das musst du natürlich nun in seinem Setup AUCH addresseitig auf dein neues IP Netzwerk bringen, ihm also die Adresse 192.168.1.110 geben.
Dann kannst du es über ein Crossoverkabel direkt oder über einen kleinen Switch an deine NIC im PC anschliessen.

Dein PC fungiert nun auch als Router obwohl (wichtig !!) XP per default die Routingfunktion abgeschaltet hat !!!
Mit einem kleinen Registry Eingriff bringst du ihm das aber bei:

www.microsoft.com/windows2000/de/server/help/default.asp?url=/windows2000/de/server/help/sag_TCPIP_pro_EnableForwarding.htm

Achtung !!! Dies ist aber NUR nötig willst du dem NAS auch Internetzugriff gewähren oder übers Internet auf das NAS zugreifen !!!
Im NAS musst du dann nur als default Gateway die LAN IP des PC in diesem Segment also nach deinem Setup die 192.168.1.201 eintragen, denn der routet die NAS Packete ja weiter in die Welt !
Auf dem PC selber gibst du in den IP Settings auf diesem Adapter die Adresse des Routers an also die 192.168.0.1

Einen Haken hat die ganze Sache noch bevor es problemlos funktioniert: Dein Router "kennt" natürlich nun nicht dein Netz "hinter" dem PC, also das 192.168.1er Segment. Das musst du ihm noch beibringen !!!
Dafür haben so gut wie alle Router eine Eingabemaske im Setup unter statische Routen oder zusätzliche Routen. Dort trägt man dann ein:

Zielnetz: 192.168.1.0 Maske 255.255.255.0 Gateway: 192.168.0.201

Et voila... Damit ist dann IP technisch alles sauber bei dir und du solltest problemlos mit NAS und Internet arbeiten können !

Zum Verständnis der IP Adressvergabe und des Routings hilft dir Attis Tutorial hier im Forum:
(Routing Variante ist hier immer vorzuziehen !)

www.administrator.de/Zwei_Netze_%FCber_WLAN_miteinander_verbinden.html
Bitte warten ..
Mitglied: 27186
08.06.2006 um 18:53 Uhr
Danke erst mal für die gute Erklärung!

Der PC fuktioniert NICHT wie eine Bridge !

Gesetzt dem Fall ich überbrücke die beiden Karten, dann funktioniert das ganze ja doch wie eine Bridge.
Was passiert aber wenn ich eine WLAN- und eine LAN-Karte überbrücke?

Wer ist denn jetzt DHCP und DNS, bzw. GW?
Normalerweise trage ich das ja dann als Brückendaten ein, funktioniert die Brücke dann auch wie ein WLAN-Device oder als "normales" LAN-Device?

da du eh vergessen
hast sie mit dem "-p" (permanent) Tag zu versehen ist sie nach dem
nächsten Reboot auch sowieso wieder weg.

Stimmt so nicht ganz. Siehe oben

Der Fehler den du gemacht hast ist das NAS
Device auf dem .0er Netz zu lassen !!!

Ja, wenn XP die Routingfunktionalität besitzt, wieso kann es dann nicht durch einen statischen Eintrag vom .0er-Netz aufs .1er -Device "zeigen"?
Bitte warten ..
Mitglied: aqui
08.06.2006 um 19:12 Uhr
Sorry für den -p Fauxpas...da saß wohl meine Brille nicht richtig. Dann musst du die Router aber wieder mit route delete löschen...

"Was passiert aber wenn ich eine WLAN- und eine LAN-Karte überbrücke?" :

Ich meine das geht auch über die XP interne "Bridge" Funktion. Dann sind beide Segmente aus MAC Adress Sicht (OSI Layer 2) verbunden. Der PC "schaut" dann nur auf die MAC Adressen und entscheidet dann wo ein Packet hinmuss, die IP Adresse ist ihm dann egal bzw. muss aus dem Segment kommen indem er selber drin ist.
In diesem Falle MÜSSEN alle IP Adressen GLEICH sein (Im Netzwerkteil ! Die Host Adressen sind unterschiedlich) und für alle Segmente gilt dann als Gateway die Adressen des Routers.
Von diesem Betriebsmodus ist aber generell abzuraten, da der Rechner dann auch alle Broadcasts und Unicasts (und das sind nicht gerade wenig in einem Windows Netz) permanent übertragen muss. Jedes Packet erzeugt einen Interrupt an beiden Karten und kann deine Rechner in die Knie zwingen. Deshalb ist die Routing Variante sauberer und immer vorzuziehen.

Die statische Host Route die du eingetragen hast würde theoretisch gehen ist aber IP designtechnisch ein Fehler. Wahrscheinlich forwardet sie auch Packete an das NAS das ja mit der falschen Adresse im .1er Netz sitzt, aber mit eine Quelladresse ebenfalls aus dem .1er Netz was ja auch verständlich ist. Dieses Packet landet jetzt durch die "Zwangsroute" auf dem NAS und das wiederum versucht dann wiederum das Antwortpacket an den Absender mit der .1er Adresse zu senden.
Das gelingt ihm aber nun nicht, denn du wirst dem NAS sicher kein Default Gateway konfiguriert haben oder hast als Gateway die 192.168.0.1 drin aus dem falschen Segment.

Ist kein Gateway drin verwirft das NAS das Packet, da es das Ziel nie erreichen kann. Ist das falsche Gateway drin, wird er es in seiner Verzeifelung dahin schicken aber das landet dann ebenfalls im Nirwana, da das NAS sich ja im .1er Segment befindet und weit und breit kein Router mit der .0.1 zu erreichen ist, denn der PC forwardet das nicht ! Kann er auch nicht für ihn ist das ein falsches IP Packet im falschen Segment.
Wenn du nun als Gateway dann richtig die 192.168.1.201 konfiguriert hättest müsste dir das NAS Setup eine Fehlermeldung geben denn das next Hop Gateway muss sich immer im gleichen Segment befinden in dem auch die Endgeräte Adresse ist und das wäre bei deinem NAS ja so nicht der Fall.
Auch wenn es klappen würde, was ich bezweifel, würde dein Packet sinnloserweise unter diesen Adaptern zirkulieren und nutzlosen Traffic erzeugen.

Mit der sauberen Routing Lösung sollte alles problemlos klappen
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Ubuntu - Routing mit 2 Netzwerkkarten?
Frage von gabrixlUbuntu13 Kommentare

Hei Folgende Situation: Ich habe zwei virtuelle Maschinen: 1 - Server für DHCP, DNS und Routing - Netzwerkkarte 1: ...

LAN, WAN, Wireless
DHCP Gerät mit 2 Netzwerkkarten
gelöst Frage von VerwirrterUserLAN, WAN, Wireless10 Kommentare

Hallo zusammen, im bezug zu meiner anderen Frage nun die Speziellere Frage die sich rausgestellt hat. Ist es möglich ...

Netzwerkgrundlagen

1 Rechner, 2 Netzwerkkarten (LAN, WLAN) im selben Subnetz, aber nur eines mit Inet Zugang

gelöst Frage von MarcoNBNetzwerkgrundlagen15 Kommentare

Hallo, ja das Problem ist schwer vernünftig in den Titel zu bringen, also: Ich habe einen Rechner (Laptop). In ...

Router & Routing

Ein Server. 2 Netzwerkkarten und 2 Router .Routing Problem

Frage von darksoul666Router & Routing7 Kommentare

Hallo! Dies ist mein erster Beitrag hier und ich hoffe, ich mach nicht alles falsch ;-) Es geht um ...

Neue Wissensbeiträge
Windows Server
Erneutes Release von WS2019 und Win10 v1809
Tipp von IT-Pro vor 4 StundenWindows Server2 Kommentare

Hi, nachdem der Windows Server 2019 und Windows 10 in der Version 1809 aufgrund von verschwinden von Dateien nach ...

CPU, RAM, Mainboards
Spectre Update Tool für ältere PCs
Information von sabines vor 7 StundenCPU, RAM, Mainboards6 Kommentare

Mit Hilfe eines Tools wird der betreffende PC permanent von einem USB Stick gestartet, der ein passendes Microcode Update ...

Windows 10
Windows 10 Oktober 2018 Update: Es ist wieder da
Tipp von Bowsette vor 15 StundenWindows 101 Kommentar

Ein neuer Versuch von Microsoft das Windows 10 Oktober 2018 Update, auch bekannt als 1809, an den Mann zu ...

Windows Server

Windows Server 2016: Achtung - ab heute gibt es wieder Express Updates

Information von kgborn vor 1 TagWindows Server1 Kommentar

Kurze Info für Administratoren, die Windows Server 2016 per WSUS/SCCM mit Updates betanken. Ab heute gibt es für Windows ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 mit CRITICAL PROCESS DIED
Frage von liquidbaseWindows 1028 Kommentare

Das aktuelle Problem was ich habe steht bereits im Threadtitel. Etwas mehr zum Hintergrund soll nun folgen. Problemkind ist ...

Windows Server
Windows Server 2016 Lizenzierung - 7 Hyper V VMs
Frage von staybbWindows Server18 Kommentare

Hallo zusammen, wir haben zwei HP Server gekauft mit jeweils pro Server 2 CPUs à 10 Cores. Also insgesamt ...

Batch & Shell
Ordnernamen mit String aus Ziffern-Zahlenkombination erstellen
Frage von MmarKussBatch & Shell15 Kommentare

Hallo zusammen, ich habe ein etwas komplexeres Problem, welches ich selbst mittels einer Batch-Datei lösen will / muss, da ...

Windows Server
Lohnt sich eine Domäne für uns?
Frage von BowsetteWindows Server12 Kommentare

Hallo, ich arbeite in einem kleinen Unternehmen mit mehr als 5 und weniger als 10 Mitarbeitern, also Small Business ...