Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Apache in VMWare

Mitglied: thecaptain

thecaptain (Level 1) - Jetzt verbinden

05.11.2008, aktualisiert 07.11.2008, 5625 Aufrufe, 8 Kommentare

Hallo,

ich habe mir hier ein Testsystem auf einem WinXP SP3 gebaut: Installiert ist ein VMWare Server 2.0 auf dem ein OpenSuse 10.3 mit Nagios v3.03 läuft. Ich habe die virtuelle Maschine per Bridge in das normale Netzwerk und Domäne eingebunden und kann von Linux ins Netzwerk und umgekehrt problemlos pingen. Nagios mit Webinterface über Apache2 ist ebenfalls korrekt eingerichtet.

Wenn ich innerhalb von Linux den Browser öffne und per http://Suse-IP-Adresse/nagios das Webinterface aufrufe, klappt das optimal. Wenn ich es aber von einem anderen PC aus versuche, kann ich das Webinterface nicht ansprechen. Zur Erinnerung: Das Pingen von außen auf eben diese IP klappt.

Hat jemand eine Ahnung, bei welchen Einstellungen ich zuerst suchen sollte und den Web-Zugriff von außen zu ermöglichen? Liegt das Problem eher in der Suse, bei VMWare oder beim Hostsystem?
Mitglied: Alphavil
05.11.2008 um 14:10 Uhr
Hallo,

Mit OpenSuse 10.3 hab ich schon meine schlechten Erfahrungen gemacht. die 11er is da deutlich besser. Ich tippe auf Firewall, die ist bei Suse oft das Problem.

Einfach mal stoppen:

/etc/init.d/SuSEfirewall2_init stop
/etc/init.d/SuSEfirewall2_setup stop

Wenns danach geht weist an was es gelegen hat Falls es dann noch immer nicht geht weist zumindest an was es nicht gelegen hat


Greetz André
Bitte warten ..
Mitglied: thecaptain
05.11.2008 um 14:24 Uhr
Hallo,

ich bin in Sachen Linux noch nicht so firm. Die Shell-Skripte habe ich gefunden, aber wie führe ich sie aus?
Bitte warten ..
Mitglied: Alphavil
05.11.2008 um 14:55 Uhr
Wenn du im Ordner /etc/init.d/ drin bist gebe folgendes ein:

./SuSefirewall2_init stop

./SuSefirewall2_setup stop
Bitte warten ..
Mitglied: thecaptain
05.11.2008 um 15:38 Uhr
Ja, das war es! Liegt das an einer fehlenden Portweiterleitung oder wie? Welche Ports braucht Nagios? Ohne Firewall möchte ich das System dann doch nicht betreiben...
Bitte warten ..
Mitglied: Alphavil
05.11.2008 um 16:54 Uhr
uii da frägst mich was,

da ich für Nagios ausschließlich Ubuntu benutze und da noch nie Probleme hatte, hab ich mir noch keine Gedanken darüber gemacht.

Aber schau doch mal hier vorbei: http://www.nagios-portal.org

Dort findest du mehr Hilfe als hier (Dieser Satz ist auf Nagios bezogen )
Bitte warten ..
Mitglied: thecaptain
06.11.2008 um 08:13 Uhr
Hm, ich hatte die Suse nur deshalb eingesetzt, weil für die 10.3 recht schnell eine vernünftige Installationsanleitung für Nagios im Netz gefunden habe (Link).

Meinst du, die Installation unterscheidet sich großartig von der bei Ubuntu? Rein zufällig habe ich nämlich die 8.10 grade zur Hand...
Bitte warten ..
Mitglied: Alphavil
06.11.2008 um 11:12 Uhr
schau mal hier: http://nagios.sourceforge.net/docs/3_0/quickstart-ubuntu.html

Oder wenn du schon Ubuntu 8.10 hast kannst direkt per Kommandozeile installieren(ist in den Sourcen mit drin)

Befehl: apt-get install nagios 3
Bitte warten ..
Mitglied: thecaptain
07.11.2008 um 08:11 Uhr
Hallo,

es hat sich jetzt erledigt und funktioniert auch mit Suse richtig:

YAST2 -> Security and Users -> Firewall -> Bei "Allowed Services" "HTTP" und "HTTPS" hinzufügen

Für Anwendungen wie Nagios muss man später dann wohl auch noch SNMP, SMTP, etc. hinzufügen.

Danke für die Hilfe.

EDIT
Bei OpenSuse 11.0 geht es anders:
YAST2 -> Sicherheit und Benutzer -> Firewall -> Individuelle Regeln -> Hinzufügen ->

meineServerIP, TCP, Zielport 80
UND
meineServerIP, TCP, Zielport 443

Einstellungen übernehmen und testen. Wenn man einen Proxy einsetzt, muss man im Browser evtl. noch die Server-IP als Proxy-Ausnahme eintragen. Beim Firefox geht das in den Einstellungen beim Reiter "Erweitert" -> "Netzwerk" -> "Einstellungen" -> Feld "kein Proxy für:"
Bitte warten ..
Ähnliche Inhalte
RedHat, CentOS, Fedora
Installation von Apache
Frage von Marcel1707RedHat, CentOS, Fedora10 Kommentare

Hallo, Ich habe letztens ein Beispiel bekommen, bei dem ich gewissen Anwendungen auf RedHat 6.2 installieren muss. Über eine ...

Apache Server
Apache und WebDAV
Frage von crazymarc1989Apache Server1 Kommentar

Hallo zusammen, derzeit versuche ich über meinen Server eine WebDAV-Verbindung als Netzlaufwerk herzustellen. Dies funktioniert soweit alles korrekt, wenn ...

Apache Server

Wie aktiviere ich HTTP2 auf meinem Apache?

gelöst Frage von lupitaApache Server6 Kommentare

Hi zusammen Hab mich ein wenig in das Thema eingelesen. Was weiss ich? - HTTP2 oder HTTP/2 oder HTTP ...

Apache Server

Apache lässt für andere Clients den Zugriff nicht zu

gelöst Frage von M.MarzApache Server10 Kommentare

Hallo zusammen, ich habe moodle auf ubuntu 14.04 lts auf einem apache2 installiert und soweit konfiguriert das die seite ...

Neue Wissensbeiträge
Multimedia & Zubehör
AVM Fritz USB WLAN Sticks schneller einschalten
Tipp von NetzwerkDude vor 1 StundeMultimedia & Zubehör

Die AVM Fritz WLAN Sticks haben in der Firmware 2 Modis: Einmal als Massenspeicher und einmal als WLAN Netzwerkkarte ...

Windows Server

Windows Server Backup schlögt Fehl -Lösung 2008-2016

Tipp von BiGnoob vor 3 StundenWindows Server

Hi zusammen , ich möchte gerne einen Lösungstipp abgeben für folgenden fehler: lösung ist folgende:

Humor (lol)
Telekom vs. O2 - 3:2
Erfahrungsbericht von the-buccaneer vor 16 StundenHumor (lol)3 Kommentare

Unglaublich aber wahr: Nachdem mein privater Anschluss am 19.04.18 auf VOIP und VDSL umgestellt wurde, hatte ich seitdem 1,5 ...

Batch & Shell

Windows 10 Heimnetzgruppe abgeschaft. Ein Script für einfache Netzwerk - Freigabe im Heimnetzwerk

Anleitung von treehe vor 18 StundenBatch & Shell3 Kommentare

Anleitung für eine einfache Netzwerkfreigabe unter Windows 10 Wie weiter hab mal ein kleines CMD - Script gebastelt. Womit ...

Heiß diskutierte Inhalte
Netzwerke
IP-Adresse am zweiten Domänencontroller fest vergeben - Server verschwunden
gelöst Frage von DanielG1974Netzwerke19 Kommentare

Ich hab ein Problem, was ich bisher noch nicht erlebt habe Ich habe erfolgreich einen zweiten Server mit ActiveDirectory ...

Firewall
Sophos SG 125 nicht mehr erreichbar
Frage von GwaihirFirewall14 Kommentare

Hallo zusammen, ausgerechnet über die Feiertage stimmt etwas mit meiner Firmen-Firewall nicht. Es ist eine Sophos SG 125 und ...

Windows Tools
Virtueller Drucker gesucht (Schnittstelle: USB oder Seriell)
Frage von chrisButterflyWindows Tools14 Kommentare

Hi, ich suche einen virtuellen Drucker, den ich über eine USB oder serieller Schnittstelle ansprechen kann. Dieser Drucker soll ...

Windows Server
Windows Server 2012 - Update - Beim Booten bleibt der Server beim Windows Zeichen stehen
Frage von KeilbachWindows Server14 Kommentare

Hallo Zusammen, ich grüße euch, mein Name ist Michele. Ich bin hier ganz Neu - da ich einfach nicht ...