Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

AT-Job startet nicht

Mitglied: Grmlrckr

Grmlrckr (Level 1) - Jetzt verbinden

25.05.2005, aktualisiert 19:13 Uhr, 12256 Aufrufe, 6 Kommentare

Ich habe unter NT4SP6a zwei AT-Jobs angelegt die zu einer bestimmten Zeit eine Batch-Datei ausführen sollen. Nur werden die nicht gestartet.

Hallo zusammen,
ich hab hier ein kleines Problem mit einem NT4-Server in einer Domäne. Ich habe zwei AT-Jobs angelegt die zu einer bestimmten Zeit eine Batch-Datei ausführen sollen. Nur werden die nicht gestartet. AT macht einfach nix. Keine Fehlermeldung, keine Reaktion, kein garnichts... Der Schedule-Dienst ist gestartet und läuft, die Batch-Dateien funktionieren auch wenn man sie per Hand aufruft. Warum funktioniert aber nun das Ganze als AT-Job nicht? Auf einem anderen Server in der gleichen Domäne läuft auch ein AT-Job. Der rennt tadellos wie er soll.

Die Batch-Dateien sind übrigens nix besonderes. Die eine macht einen Ping, die andere startet einen Kopiervorgang. An denen kann es also nicht liegen.

Achja, den AT-Job habe ich mit dem Tool "WinAT" angelegt. Sowohl auf dem Server auf dem nix geht, aber auch auf dem Server auf dem es funktioniert. An dem Programm kann es also auch nicht liegen.

Any hints?
Mitglied: schneidergoe
25.05.2005 um 13:45 Uhr
Hallöle,

beim Befehl copy unter nt und win2k gibts wohl in Verbindung mit nem at-befehl Probleme.

Die MS-Knowledge-Base empfiehlt folgende Syntax zur Behebung des Problems: Zitat:

"To run any internal command from the AT command use "CMD /C" syntax. For example:

AT 10:00 CMD /C COPY C:\*.* C:\TEMP

Zitat Ende.

Der Link zum Artikel (in Englisch, die automatisch generierte Übersetzung ist für´n Ar....m ):

http://support.microsoft.com/kb/119919/en-us

Hoffe, das hilft weiter.

mfg
Heiko
Bitte warten ..
Mitglied: Grmlrckr
25.05.2005 um 14:01 Uhr
Hm, erstmal danke für den Link, werde ich mir anschauen. Ich bin aber skeptisch, obs daran liegt. Denn eine test.bat die lediglich "ping www.domain.de" als Inhalt hat wird auch nicht ausgeführt Also nix mit "copy"...

Grüße,
Alsion
Bitte warten ..
Mitglied: schneidergoe
25.05.2005 um 15:02 Uhr
Sorry, da hab ich wohl zu schnell gelesen.

Hätte da ne andere Idee. Meines Wissens laufen die at-jobs unter der Berechtigung des Taskplaners und nicht unter dem beim Eingeben eingeloggten Benutzer ab.

Guck mal unter Dienste, die Eigenschaften des Taskplaners, unter dem Reiter "Anmelden" (Win2k, ob das identisch bei nt4.0 weiss ich net genau im Moment). Da ist normalerweise localSystem eingetragen, hier ein lokales AdminKonto eintragen (mit dem du beim at-job eingeben angemeldet bist) könnte weiterhelfen.

mfg
Heiko
Bitte warten ..
Mitglied: Grmlrckr
25.05.2005 um 15:26 Uhr
Daran hatte ich auch schon gedacht. Aber egal mit welchem Konto ich den Dienst laufen lasse - völlig ohne Ergebnis bzw. Änderung.

Grüße,
Alsion
Bitte warten ..
Mitglied: nopain
25.05.2005 um 18:35 Uhr
.....soviele RE, muß man nicht erst Contra sagen.... ähhh ich schweife ab...

Moin Leute,

der gute alte NT 4.0 Server - ja ja - meine Erfahrungen mit dem NT 4.0 Server in Verbindung mit dem AT-Befehl sind leider exakt die gleichen und ich habe damals keine Lösung dazu gefunden. Mal funxt es, mal nicht... teilweise auch garnicht. Logs gab es dazu auch nicht. Lediglich die auszuführenden Bat-Dateien kann man mit Logfunktionen versehen, aber die ergaben auch immer nur, daß diese nicht gestartet wurden. Leider kann ich Dir nur sagen, daß ich es damals aufgegeben habe.

Neben diesem Mist, hat NT 4.0 ja noch so ein paar andere Schwächen. Beispielsweise dreht NT 4.0 irgendwann durch, wenn man es als Printserver im größeren Maße einsetzt.... äähh ich schweife schon wieder.

Könnte Dir als Workaround nicht auch eine andere x-beliebige Win2000-Pro-Kiste dienen. Der unter Win2000 vorhandene Zeitplandienst funktioniert sehr zufriedenstellend. Er hat zwar auch so seine Macken, aber die lassen sich dann wenigstens ergründen. Denn ein Ping-Befehl soll vermutlich eine Art Verbindungstest zu irgendwas sein und von wo aus Du einen Copy-Befehl abgibst ist ja auch egal, solange nicht unendliche viele GBs übertragen werden sollen.

Gruß
nopain
Bitte warten ..
Mitglied: Atti58
25.05.2005 um 19:13 Uhr
... muss es denn dieser leidige AT Job sein, wir benutzen das Freeware-Tool "JIT Schedule 4.0", mit dem man recht komfortabel benutzer- oder systemabhängge Tasks erstellen kann. Wenn Du das Tools nicht mehr findest, kannst Du mir eine E-Mail mit Deiner E-Mail-Adresse an meine Nachrichtenbox schicken, ich würde es Dir dann zukommen lassen,

Gruß

Atti.
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
Der Job als Systemadministrator
Frage von samet22Windows Netzwerk32 Kommentare

Hallo liebe Leute:) Ich wollte euch mal meine Situation näher bringen und eure Meinung zu dem Job Systemadministrator fragen. ...

Server-Hardware

Virtualiserungsserver für Spielwiese (at Home)

gelöst Frage von Phill93Server-Hardware17 Kommentare

Hallo, ich suche zur Zeit einen Ersatz für den Virtualisierungsserver meiner Spielwiese. Zur Zeit verrichtet da ein HP Microserver ...

Off Topic

Regelung AT Home Arbeit

gelöst Frage von neooenOff Topic13 Kommentare

Hallo Zusammen, ich habe seit 2 Monaten eine neue Stelle angenommen und bin nun IT-Admin in einem Wohnungsunternehmen. Mein ...

Exchange Server

Postmaster at Domain.com umleiten

gelöst Frage von xbast1xExchange Server6 Kommentare

Hallo zusammen, mein Provider hat mich informiert, dass er Meldungen bekommt, dass Postmaster E-Mails keine Weiterleitungsadresse hatten. Mein Vorgänger ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 10 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 16 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

SAN, NAS, DAS
Qnap TS-453S Pro - Anbindung Active Directory
Frage von JuckieSAN, NAS, DAS13 Kommentare

Hallo zusammen, ich habe hier eine Qnap TS-453S Pro die sich mal so absolut gar nicht in das Active ...