Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Befehl funktioniert unter Windows 7 nicht sauber

Mitglied: FRAD

FRAD (Level 1) - Jetzt verbinden

17.01.2011, aktualisiert 09:34 Uhr, 7352 Aufrufe, 10 Kommentare

Befehl funktioniert unter Windows 7 nicht sauber. Befehle wie attrib oder xopy mit dem Parameter H laufen nicht sauber

Hi,

ich möchte mittels folgendem Befehl Dateien auf mein USB Laufwerk sichern...

for %%i in (jpg) do xcopy /ehry /exclude:%LW%\_Exclude.txt C:\*.%%i %LW%\_backupfolder\

Leider bricht das Batchfile mit folgender Meldung ab: Zugriff verweigert - Verzeichnis kann nicht erstellt werden - F:\backup\Documents and Settings

Wenn ich den Parameter "h" weglasse, funktioniert es - jedoch werden nicht die versteckten Dateien berücksichtigt. Dies möchte ich aber.


Zweites Problem...

Ich möchte für alle Ordner unterhalb F:\backup das Attribut "Schreibgeschützt" entfernen.

attrib -r -a F:\backup /s /d

Lasse ich diesen Befehl ausführen, tritt zwar kein Fehler auf, aber das Attribut "Schreibgeschützt" sitzt immer noch.

EDIT: Wenn ich das Attribut manuell lösche ist es auf einmal wieder da... komisch....

OS: Windows 7 64Bit


Grüße
Mitglied: vossi31
17.01.2011 um 09:53 Uhr
Hallo,

für beide Probleme könnte die Lösung sein, das CMD-Fenster oder das Script "als Administrator ausführen", also nicht nur als Admin angemeldet sein.

Gruß
Bitte warten ..
Mitglied: FRAD
17.01.2011 um 10:14 Uhr
habe ich schon probiert. leider ohne erfolg...
Bitte warten ..
Mitglied: 60730
17.01.2011 um 11:23 Uhr
moin,

deine Überschrift Befehl funktioniert unter Windows 7 nicht sauber ist irreführend...

for %%i in (jpg) do
funktioniert "so" auf keinem OS aus Redmont, das ich kenne
01.
for /?
attrib -r -a F:\backup /s /d
genauso...
attrib /? 
/snip 
 /S   Verarbeitet übereinstimmende Dateien im aktuellen Ordner 
      und in allen Unterordnern. 
  /D  Verarbeitet auch die Ordner.
attrib -r -a F:\backup\*.* /s /d

Gruß
Bitte warten ..
Mitglied: FRAD
17.01.2011 um 11:39 Uhr
Hi,

hier das vollständig Script:

rem Funktioniert unter Windows 7
set LW=
for %%i in (D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\_kennung.dat set LW=%%i:
if not defined LW echo Laufwerk nicht erkannt! & goto :eof

for %%i in (jpg) do xcopy /dehry /exclude:%LW%\_Exclude.txt C:\*.%%i %LW%\_backupfolder\
Bitte warten ..
Mitglied: 60730
17.01.2011 um 11:55 Uhr
Salü,
Zitat von FRAD:
Hi,

hier das vollständig Script:
das ist ja auch vom Bastla und war mal um einen bestimmten USB Stick zu finden

rem Funktioniert unter Windows 7
set LW=
for %%i in (D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\_kennung.dat set LW=%%i:
if not defined LW echo Laufwerk nicht erkannt! & goto :eof

for %%i in (jpg) do xcopy /dehry /exclude:%LW%\_Exclude.txt C:\*.%%i %LW%\_backupfolder\

  • probier mal
For /?
  • bzw
for %i in (jpg) do echo %i
  • in einer Dosbox aus

Gruß

Bitte warten ..
Mitglied: FRAD
17.01.2011 um 12:15 Uhr
Hi,

das Problem tritt auch bei diesem einfachen Befehl auf:

xcopy /ehry C:\*.jpg F:\_backupfolder\

Wenn ich das "h" aus den Parametern entferne, funktioniert - jedoch ohne die versteckten Dateien....

Das ist mein eigentliches Problem...
Bitte warten ..
Mitglied: Biber
17.01.2011 um 12:51 Uhr
Moin FRAD,

ändert sich das XCopy-Verhalten, wenn du den Schalter /e durch Schalter /s ersetzt?

Grüße
Biber
Bitte warten ..
Mitglied: bastla
17.01.2011 um 13:34 Uhr
@T-Mo
Nur als Anmerkung:
for %%i in (jpg)
ist hier ein Überbleibsel / eine Vorstufe zur Verarbeitung unterschiedlicher Dateitypen - daher wäre die passende Demo:
for %%i in (jpg) do dir *.%%i
Grüße
bastla
Bitte warten ..
Mitglied: FRAD
17.01.2011 um 14:42 Uhr
Das Xcopy Verhalten habe ich nun in den Griff bekommen. Ich ignoriere einfach die Meldung und dann kopiert das Script weiter...

Nächstes Problem ;(

Nach ca. 2340 Dateien bricht das Script mit der Meldung: Nicht genügend Arbeitsspeicher ab.

In meinem Rechner schlummern 4GB RAM
Bitte warten ..
Mitglied: Biber
17.01.2011 um 18:37 Uhr
Moin FRAD,

Zitat von FRAD:
Das Xcopy Verhalten habe ich nun in den Griff bekommen. Ich ignoriere einfach die Meldung und dann kopiert das Script weiter...

Toller Plan.

Wenn die Kleine aus der Sushi-Bar mich ignoriert, dann frag ich die aus'm Penny-Markt.

Wenn sich bei dir der XCopy-Befehl "irgendwie anders" verhält als bei 87 Mio glücklichen und schmerzfreien Windows-Userinnen,
dann hast du
  • entweder eine Win7-Montagsproduktion erwischt
-oder-
  • auf einem Teleshoppingsender bestellt, weil du unbedingt die große Katzenbregen-Klingelton-CD als einer der ersten 100 Anrufer ergattern wolltest
-oder aber, was mein sein Verdacht ist-
  • noch ein paar unwesentliche Details nicht genannt.

Unabhängig von Windows XP oder 7 oder 8 -- ich hatte dir empfohlen, mal den Schalter /e durch Schalter /s zu ersetzen.
MACH DOCH MAL bitte.

Mit deinem Schalter /e fasst du logischerweise in die Grütze, wenn du in einem QUELL-Rootverzeichnis mit Sichern anfängst ohne dass du die Rechte in allen Unterordnern hast.
--> Das wird bei "c.\Dokumente und sowas" relativ schnell der Fall sein als "normaler User".

Nächstes Problem ;(
Ist auch nicht IM Computer, sondern 40cm westlicher.

Nach ca. 2340 Dateien bricht das Script mit der Meldung: Nicht genügend Arbeitsspeicher ab
Nach 2340 *.jpg-Dateien.....
....für eine Sicherung.....
...du änderst also täglich auf dem Rechner 2340 *.jpg-Dateien, die bei jeder Sicherung gesichert werden müssen???
Mit der Pumpgun oder wie schaffst du das zeitlich?
Schau dir bitte die Schalter von XCopy an, insbesondere /D und /Z oder besser alle zwischen /A und /Z.

In meinem Rechner schlummern 4GB RAM
Na, VOR dem Rechner schlummern auch noch Potentiale im GB-Bereich....

Grüße
Biber

P.S. Hab gerade noch den Brüller das Feature für User mit deiner Herangehensweise gefunden:
XCOPY Quelle [Ziel] [/A | /M] [/D[:Datum]] [/P] [/S [/E]] [/V] [/W] 
                    [/C] [/I] [/Q] [/F] [/L] [/G] [/H] [/R] [/T] [/U] 
                    [/K] [/N] [/O] [/X] [/Y] [/-Y] [/Z] 
                    [/EXCLUDE:Datei1[+Datei2][+Datei3]...] 
.... 
  
  /C        Setzt das Kopieren fort, auch wenn Fehler auftreten. 
....
Bitte warten ..
Ähnliche Inhalte
Windows 7
Windows 7 Bedienung funktioniert nicht
gelöst Frage von GeforceWindows 73 Kommentare

Frage an alle Computer-Experten: Ich verwende Windows 7 und habe seit ein paar Tagen Start-Probleme, genauer gesagt ich kann ...

Batch & Shell

Warum Funktioniert der tokens befehl nicht

gelöst Frage von DomiZone1Batch & Shell5 Kommentare

Hallo liebe Administartor Community Ich Beis gleich in mein nicht vorhandenes lenkrad :D der befehl: for /f "delims=: tokens1,2" ...

Windows 7

AT-Befehl funktioniert nicht

gelöst Frage von simonfcz1996Windows 76 Kommentare

Hallo zusammen Ich habe ein kleines Script geschrieben welches regelmässig ausgeführt werden soll. Das wollte ich mit dem AT-Befehl ...

Windows Netzwerk

Copy Befehl in einer batch funktioniert nicht.

gelöst Frage von Pauli-HWindows Netzwerk3 Kommentare

Hallo zusammen. Folgender Befehl will die Datei nicht kopieren, weil sie nicht existieren soll. DIe Datei ist in dem ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs9 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Debian
Wie finde ich den betroffenen user
Frage von ProtectedDebian8 Kommentare

Hallo, Wie kann ich den User finden der dies verursacht hat? Betriebsystem ist Debian 7 your Server/Customer with the ...

Voice over IP
Vodafone IP Anlagenanschluss - TK-Anlage einrichten
Frage von BytedreherVoice over IP8 Kommentare

Moin Zusammen, wir hatten gestern bei uns die Umstellung auf den neuen IP Anschluss bei Vodafone. Vodafone IP Anlagenanschluss ...