Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Bootprobleme mit Windows XP

Mitglied: ottscho

ottscho (Level 2) - Jetzt verbinden

29.05.2008, aktualisiert 30.05.2008, 5328 Aufrufe, 11 Kommentare

Hallo zusammen,

ich habe einen 2 Monate frischen Windows XP SP3 Rechner, welcher eben nach einen Neustart nicht mehr wollte.

Fehlermeldung:
NTLDR ist missing

Nach Versuchen mit fixmbr und kopieren der i386\ntdlr und i386\ntdetect.com wurde das Problem scheinbar gelöst.

Nun kommt bei einem Reboot für ca. 2 Sekunden die Meldung:
Fehlerhafte Datei BOOT.INI
Starten von C:\Windows\.

Danach steht dies auf dem Bildschirm:
Windows konnte nicht gestartet werden, da folgende Datei
fehlt oder beschäftigt ist:
<windows root>\system32\hal.dll
Installieren sie ein Exemplar der oben genannten Datei
erneut.


Nun habe ich zwei Partitionen, dass komische ist, dass die Systempartition in der Reperaturconsole als D: eingebunden wird, und die erweiterte Partition als C:

Nun habe ich versucht die fehlende Datei wieder herzustellen:
copy e:\i386\hal.dl_ d:\windows\system32\hal.dll

Nach einem erneuten Reboot keine Änderung.

boocfg /list bringt kein Ergebniss und bootcfg /rebuild bringt eine fehlermeldung, dass die Festplatte nicht dach Betriebsystemen durchsucht werden kann. Man solle chdsk anwenden. Leider bringt dies auch nichts

Jmd eine Idee, was ich noch machen könnte?

Danke
Gruß
ottscho
Mitglied: 60897
29.05.2008 um 14:15 Uhr
Jepp, eine Idee ist immer drin.

Organisier' Dir ein Bart's PE oder ähnliches und lass Deine Festplatte überprüfen (scandisk) und alles automatisch reparieren. Oder häng' die Platte in einen anderen Rechner rein.

Hatte ich vor ein paar Wochen mit dem identischen Fehlerbild, die gleichen Versuche. Es wurde ein Fehler gefunden, repariert und alles war gut. Viel Glück!

Bonkers
Bitte warten ..
Mitglied: paulepank
29.05.2008 um 14:30 Uhr
Hallo,

Nun habe ich versucht die fehlende Datei wieder herzustellen:
copy e:\i386\hal.dl_ d:\windows\system32\hal.dll

nicht COPY sondern EXPAND
Bitte warten ..
Mitglied: ottscho
29.05.2008 um 14:31 Uhr
danke für die AW.
habe gerade gesehen, dass ich keine BOOT.INI mehr habe
aber verstehe trotzdem nicht, warum der Befehl bootcfg /rebuild dann auf einen Fehler stosst...

habe gerade Bart's PE nicht zur Hand. (die muss ich auch noch erzeugen, oder gibt es da ein fertiges ISO) aber ich werde mein Glück mal mit Knoppix versuchen.
Bitte warten ..
Mitglied: ottscho
29.05.2008 um 14:57 Uhr
wo liegt der unterschied von copy und expand?

Ich habe nun mal die hal.dll neu erstellt. Aber leider ohne Erfolg, die Meldung mit der beschäftigten Datei kommt immer noch.

Die BOOT.INI Meldung bin ich los, habe eine BOOT.INI von einem anderen Rechner kopiert...

Hat jmd noch Erfahrungen mit der c:\windows\system32\hal.dll ?
Bitte warten ..
Mitglied: ottscho
29.05.2008 um 15:10 Uhr
also ich komme nicht weiter.
Der Festpalltencheck unter Knoppix ist gut, und die Datei wurde ersetzt.
Trotzdem erscheint die Meldung

Ich würde nur sehr ungern meinen PC neuinstallieren, da er noch sehr frisch ist....
Bitte warten ..
Mitglied: 60897
29.05.2008 um 15:34 Uhr
Zuerst was leichtes: der Unterschied zwischen copy und expand ist: copy = kopieren, expand = expandieren, also entpacken, ähnlich wie auch zip arbeitet.

Jetzt das schwierigere:
Die hal.dll, die Du da kopiert hast sollte von einem Rechner mit gleichem Betriebssystem und gleichem Servicepack- sowie Updatestand kommen.
Die hal.dll ist der (H)ardware(A)bstraction(L)ayer, da steht drin, welche Hardware in welcher Konfiguration läuft, u.a. auch solche Sachen wie ACPI-Modus, Prozessoranzahl und so Kleinigkeiten. Wenn die nicht passt, könnte das schon mal ein Problem werden. Wenn Du also die Installations-CD ohne Servicepack hast oder mit SP1 und jetzt nach Installation, ein halbes GB Updates später also Probleme damit hast, ist das fast verständlich.

Warum machst Du nicht einfach eine Reparaturinstallation? Sichere Dir vorher C:\Windows\System32\config weg, da ist die aktuelle Registry drin, falls Du schon viele andere Programme installiert hast und die nicht einwandfrei funktionieren. Kannst Du nur bei Start von CD komplett kopieren. Und wenn Du die wieder herstellen willst, ebenfalls Start von CD. Sichere Dir dann aber vorher die dann aktuelle Version. Nur vorsichtshalber.

Bonkers
Bitte warten ..
Mitglied: ottscho
29.05.2008 um 15:54 Uhr
Wenn du mir mit der Reparaturinstallation weiterhelfen kannst...
Irgendwie bin ich zu doof, oder habe die noch nie gefunden.
Ich Befolge ganz normal beim booten von der WinCD den Anweisungen (drücke F3 und dann F8)

Nun kommt die auswahl, wo ich Windows installieren möchte, dann wähle ich die Partition aus, welche bereits WIndows installiert hat. Nun sollte doch eigenlich die Meldung kommen, dass bereits ein Windows auf dieser Partition installiert ist etc. Bei mir kommt aber dann die Meldung, wie ich die Partition formatieren möchte, oder ob das Dateisystem so bleiben soll...

Bin ich hier auf dem richtigen Weg? Oder wie komme ich zur Reparaturinstallation?
Danke

EDIT, ich habe es gelöst.
Die Boot.ini konnte ja nicht neu erstellt werden, warum auch immer ^^ ich liebe windows.
Ich habe nun die Boot.ini editiert und eine liste von betriebsystemen erstellet, welche auf verschieden partitionen liegen:

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="1" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="2" /fastdetect
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="3" /fastdetect
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="4" /fastdetect
multi(0)disk(0)rdisk(0)partition(5)\WINDOWS="5" /fastdetect
multi(0)disk(0)rdisk(0)partition(6)\WINDOWS="6" /fastdetect
multi(0)disk(0)rdisk(0)partition(7)\WINDOWS="7" /fastdetect
multi(0)disk(0)rdisk(0)partition(8)\WINDOWS="8" /fastdetect
multi(0)disk(0)rdisk(0)partition(9)\WINDOWS="9" /fastdetect
multi(0)disk(0)rdisk(0)partition(10\WINDOWS="10" /fastdetect

Nun funktioniert die Nummer 2 :D

Danke für eure Unterstützung
Gruß
ottscho
Bitte warten ..
Mitglied: 60897
29.05.2008 um 16:04 Uhr
Stimmt, Du hattest ja auch gleich in Deinem ersten Post geschrieben "Jetzt habe ich zwei Partitionen..." - hätte man drauf kommen können.

Bonkers
Bitte warten ..
Mitglied: ottscho
29.05.2008 um 16:13 Uhr
zufrüh gefreut...
durch das ersetzten der hal.dll stimmen nun die hardwareinformationen nicht mehr und der rechner hängt sich bei laden des profils/hardware auf. gibt es ne möglichkeit diese neu zu erstellen?

wie war dies nun mit der reparaturinstallation?

Danke
Bitte warten ..
Mitglied: 60897
30.05.2008 um 07:54 Uhr
Kannst Du im angesicherten Modus starten?
Bitte warten ..
Mitglied: ottscho
30.05.2008 um 10:09 Uhr
im abgesicherten Modus hat der Rechner sich aufgehängt bzw. wurde immer wieder neu gestartet. Ich habe den Rechner nun platt gemacht, und neu installiert, da ich ihn dringend benötige und leider keine Zeit mehr für versuche habe.

Trotzdem Danke

Gruß ottscho
Bitte warten ..
Ähnliche Inhalte
Windows 7
Eigenartige Bootprobleme
gelöst Frage von 90498Windows 77 Kommentare

Hallo liebe Community, ich hab' wieder so einen Spezialfall, wo ich langsam nicht mehr weiter weiß. Das Problem ist ...

Windows Server

Bootprobleme Dell Server mit Windows Server 2012 Essentials

gelöst Frage von tisibiWindows Server6 Kommentare

Hallo zusammen, mich plagt seit nunmehr acht Monaten ein recht ungewöhnliches Problem mit einem Dell PowerEdge T110 II und ...

Windows XP

Windows XP im Aufwind?

Frage von DerWoWussteWindows XP26 Kommentare

Ich möchte mal anmerken, dass ich diesen Beitrag in "Humor" eingestellt habe, unter "Wissen" würde ich den nicht eingeordnet ...

Windows XP

Windows XP virtualisieren

gelöst Frage von 129995Windows XP10 Kommentare

Hallo, ich habe folgendes Problem. Ich habe ein Acronis 2014 Backup (.tib-Datei) in eine vmdk.Datei umgewandelt um diese einer ...

Neue Wissensbeiträge
Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 1 TagSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 1 TagMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 1 TagHardware12 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++27 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux27 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless22 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL19 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...