Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst CF Raid 0 langsamer als einzelne CF

Mitglied: BitKiller

BitKiller (Level 1) - Jetzt verbinden

14.02.2008, aktualisiert 20:23 Uhr, 4726 Aufrufe, 2 Kommentare

Hallo!
Habe ein seltsames Problem mit einem CF Raid 0 Verbund...

Hardware:

Mainbord: Asus P4P800/GD-EAY
Cardreader: Delock SATA 1.5 Gbps
CF: SanDisk ExtremeIV 4GB/40MBps
BS: XPE (mit XP Pro gleiches Problem)
Treiber: Intel iastor ver.3.5.0.2568, Viaraid VT6410
Chipsatz: 865PE/ICH5R
Im Gerätemanager wird alles erkannt!

0d1fed43d553ed2050f10cb5a20bc0fd-raid - Klicke auf das Bild, um es zu vergrößern

Es sollte doch möglich sein mit Raid 0 an die 70MBps heranzukommen, oder?

Mit normalen SATA HD ohne Raid beträgt der Speed ~60MBps, mit Raid 0 ~85MBps,
also auch weit weg vom Sollwert.
Gleiches Problem auch bei folgenden Boards:
Asus P4P800E
Asrock P4VM900-SATA2

Hat jemand Ideen, Ratschläge oder Tipps?

Grüße, BitKiller
Mitglied: filippg
14.02.2008 um 19:29 Uhr
Hallo,

ein RAID 0 bringt nur dann einen Geschwindigkeitsvorteil, wenn auch ein Cache (auf Controller oder Disk) vorhanden ist.

Damit kann ein Block bereits dann Acknowledget werden, wenn er noch gar nicht auf der Platte, sondern nur im Cache ist. Bei nur einer Platte bringt das nicht unbegrenzt viel, der Cache wird (insbesondere natürlich bei einem Lasttest) schnell vollaufen. Dann können Daten nur noch so schnell an die Platte übertragen werden, wie diese sie auch wirklich schreibt. In dem Moment gewinnt RAID0 an Geschwindigkeit: hier können dann wirklich beide Platten gleichzeitig schreiben.

Hast du keinen Cache, so bringt auch RAID 0 nichts. Ein Datenblock wird erst bestätigt, wenn er wirklich geschrieben wurde. Die andere Platte hat derweil nichts zu tun. Der zweite Datenblock geht dann zwar an die zweite Platte, aber die erste tut derweil wiederum gar nichts.

Daneben kann RAID0 u.U. noch bei der Schreib-/Lesekopfpositionierung punkte, aber das scheidet bei Flash-Medien ohnehin aus. Da hängt es dann auch ziemlich davon ab, wie der Test konzipiert ist. Und bei Flash-Medien spielt das ohnehin keine Rolle.

Was mich nur wundert ist, dass der Durchsatz bei der RAID0-Konfiguration so schwankt. Könnte aber auch an dem Test und am Messverfahren liegen.
Dafür sind 0.3ms Zugriffszeit doch wirklich schick. Ach ja: Flash-Medien überleben glaube ich deutlich weniger schreib-/lese-Zyklen als Platten. Kann aber auch sein, dass sich das mittlerweile geändert hat.

Gruß

Filipp
Bitte warten ..
Mitglied: BitKiller
14.02.2008 um 20:22 Uhr
Danke Filipp!
Klingt ganz logisch mit dem Cache. Wieder was dazugelernt.
Mit anderen Worten: Ich brauche einen Cardreader oder eine CF
mit (Schreib-)Cache um die Raid 0 Performance zu bekommen.
Schade dass es sowas noch nicht gibt...
Bin ich der Zeit vorraus?

Zitat:
Flash-Medien überleben glaube ich deutlich weniger schreib-/lese-Zyklen als Platten. Kann aber auch sein, dass sich das mittlerweile geändert hat.

Möchte folgendes ergänzen:
Ja, das stimmt leider noch immer.

1. XPE als Betriebssystem: Das Image wird einmal von der CF gelesen und in den Arbeitsspeicher geladen.
Die Dateien zum beschreiben sind auf einer Ramdisk (Logs, Profile, Temp, Internetcache u.s.w.)
Da der PC ausschliesslich fürs Internet genutzt wird, wird die CF nur mit Downloads belastet.
Sollte doch eine Weile funktionieren...

2. Der Hersteller gibt 120 Monate Garantie, was soll da schiefgehen?

Vielen Dak für die Antwort!
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
Raid 0 nach stromlos langsamer
gelöst Frage von OldwareServer-Hardware16 Kommentare

Hallo, mein Raid 0 läuft nachdem der PC komplett ohne Strom war um ca.100MB/sec. langsamer. Wenn ich dann einen ...

Festplatten, SSD, Raid

Performancesteigerung durch SSD im RAID-0?

Frage von r1chy2Festplatten, SSD, Raid10 Kommentare

Hallo, ich überlege mir gerade, wie ich auf meinem PC mehr Performance holen kann und dabei ist mir folgende ...

Festplatten, SSD, Raid

SBS 2011 auf einem Raid 0 clonen

Frage von Atti58Festplatten, SSD, Raid12 Kommentare

Hallo an Alle, ich habe einen (noch) funktionierenden SBS 2011 auf einem HP Proliant ML150 G6, der fälschlicherweise auf ...

Festplatten, SSD, Raid

RAID-0-Lfwk wird in Win7pro64b nicht angezeigt

Frage von wiedhalmFestplatten, SSD, Raid8 Kommentare

Hallo! Hatte mit meinem Win7pro64b plötzlich grosse Probleme, so dass ich es neu aufsetzen musste. Ist erfreulicherweise ganz gut ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 10 StundenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 10 StundenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 1 TagDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 1 TagSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
Exchange Server
Exchange Postfach Einbindung Betriebs-rat -Arzt, Bewerbung .
gelöst Frage von YellowcakeExchange Server22 Kommentare

Hey ich habe da mal eine Denksport Aufgabe bekommen Genutzt wird ein Exchange Server 2010. hier gibt es den ...

Datenschutz
Telematikinfrastruktur Erfahrungsaustausch
Frage von MOS6581Datenschutz12 Kommentare

Moin, unter meinen Kunden befinden sich auch einige Ärzte, welche sich künftig mit der Telematikinfrastruktur-Geschichte der Gematik herumärgern dürfen. ...

Windows Server
Delgegierte OU via RDP verwalten - Objektverwaltung zuweisen
gelöst Frage von TOAOICEWindows Server12 Kommentare

Hallo, ich habe folgendes Problem. Ich möchte in meiner Domäne (Server2016), einer Gruppe (OUAdmin) Berechtigungen auf die OU Test ...

Windows Server
Downgrade von Windows Server 2016 auf 2012 - Wie vorgehen?
Frage von EstefaniaWindows Server12 Kommentare

Guten Ich habe eine Frage an Erfahrene unter euch. Durch einen InPlace Upgrade wurde Windows Server 2012 auf die ...