Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst CF Raid 0 langsamer als einzelne CF

Mitglied: BitKiller

BitKiller (Level 1) - Jetzt verbinden

14.02.2008, aktualisiert 20:23 Uhr, 4741 Aufrufe, 2 Kommentare

Hallo!
Habe ein seltsames Problem mit einem CF Raid 0 Verbund...

Hardware:

Mainbord: Asus P4P800/GD-EAY
Cardreader: Delock SATA 1.5 Gbps
CF: SanDisk ExtremeIV 4GB/40MBps
BS: XPE (mit XP Pro gleiches Problem)
Treiber: Intel iastor ver.3.5.0.2568, Viaraid VT6410
Chipsatz: 865PE/ICH5R
Im Gerätemanager wird alles erkannt!

0d1fed43d553ed2050f10cb5a20bc0fd-raid - Klicke auf das Bild, um es zu vergrößern

Es sollte doch möglich sein mit Raid 0 an die 70MBps heranzukommen, oder?

Mit normalen SATA HD ohne Raid beträgt der Speed ~60MBps, mit Raid 0 ~85MBps,
also auch weit weg vom Sollwert.
Gleiches Problem auch bei folgenden Boards:
Asus P4P800E
Asrock P4VM900-SATA2

Hat jemand Ideen, Ratschläge oder Tipps?

Grüße, BitKiller
Mitglied: filippg
14.02.2008 um 19:29 Uhr
Hallo,

ein RAID 0 bringt nur dann einen Geschwindigkeitsvorteil, wenn auch ein Cache (auf Controller oder Disk) vorhanden ist.

Damit kann ein Block bereits dann Acknowledget werden, wenn er noch gar nicht auf der Platte, sondern nur im Cache ist. Bei nur einer Platte bringt das nicht unbegrenzt viel, der Cache wird (insbesondere natürlich bei einem Lasttest) schnell vollaufen. Dann können Daten nur noch so schnell an die Platte übertragen werden, wie diese sie auch wirklich schreibt. In dem Moment gewinnt RAID0 an Geschwindigkeit: hier können dann wirklich beide Platten gleichzeitig schreiben.

Hast du keinen Cache, so bringt auch RAID 0 nichts. Ein Datenblock wird erst bestätigt, wenn er wirklich geschrieben wurde. Die andere Platte hat derweil nichts zu tun. Der zweite Datenblock geht dann zwar an die zweite Platte, aber die erste tut derweil wiederum gar nichts.

Daneben kann RAID0 u.U. noch bei der Schreib-/Lesekopfpositionierung punkte, aber das scheidet bei Flash-Medien ohnehin aus. Da hängt es dann auch ziemlich davon ab, wie der Test konzipiert ist. Und bei Flash-Medien spielt das ohnehin keine Rolle.

Was mich nur wundert ist, dass der Durchsatz bei der RAID0-Konfiguration so schwankt. Könnte aber auch an dem Test und am Messverfahren liegen.
Dafür sind 0.3ms Zugriffszeit doch wirklich schick. Ach ja: Flash-Medien überleben glaube ich deutlich weniger schreib-/lese-Zyklen als Platten. Kann aber auch sein, dass sich das mittlerweile geändert hat.

Gruß

Filipp
Bitte warten ..
Mitglied: BitKiller
14.02.2008 um 20:22 Uhr
Danke Filipp!
Klingt ganz logisch mit dem Cache. Wieder was dazugelernt.
Mit anderen Worten: Ich brauche einen Cardreader oder eine CF
mit (Schreib-)Cache um die Raid 0 Performance zu bekommen.
Schade dass es sowas noch nicht gibt...
Bin ich der Zeit vorraus?

Zitat:
Flash-Medien überleben glaube ich deutlich weniger schreib-/lese-Zyklen als Platten. Kann aber auch sein, dass sich das mittlerweile geändert hat.

Möchte folgendes ergänzen:
Ja, das stimmt leider noch immer.

1. XPE als Betriebssystem: Das Image wird einmal von der CF gelesen und in den Arbeitsspeicher geladen.
Die Dateien zum beschreiben sind auf einer Ramdisk (Logs, Profile, Temp, Internetcache u.s.w.)
Da der PC ausschliesslich fürs Internet genutzt wird, wird die CF nur mit Downloads belastet.
Sollte doch eine Weile funktionieren...

2. Der Hersteller gibt 120 Monate Garantie, was soll da schiefgehen?

Vielen Dak für die Antwort!
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
Raid 0 nach stromlos langsamer
gelöst Frage von OldwareServer-Hardware16 Kommentare

Hallo, mein Raid 0 läuft nachdem der PC komplett ohne Strom war um ca.100MB/sec. langsamer. Wenn ich dann einen ...

Festplatten, SSD, Raid
SBS 2011 auf einem Raid 0 clonen
Frage von Atti58Festplatten, SSD, Raid12 Kommentare

Hallo an Alle, ich habe einen (noch) funktionierenden SBS 2011 auf einem HP Proliant ML150 G6, der fälschlicherweise auf ...

SAN, NAS, DAS

QNAP Raid Level Migration von RAID 0 (TS-651) möglich?

gelöst Frage von StefanKittelSAN, NAS, DAS3 Kommentare

Hallo, weiß Jemand ob man bei einem TS-651 von QNAP von RAID 0 auf RAID 5 Migrieren kann. Die ...

Speicherkarten

Klonen einer CF Karte

gelöst Frage von J.TrollSpeicherkarten11 Kommentare

Hallo liebes Forum Ich beschäftige mich seit ein paar Tagen damit eine bootfähige CF-Karte zu klonen, allerdings bislang ohne ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 14 StundenBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 2 TagenHumor (lol)5 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 2 TagenExchange Server8 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 3 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
Netzwerke
Netzwerk-Architektur mit VLANs
Frage von niLuxxNetzwerke47 Kommentare

Liebe Community, Ich hätte eine kurze Frage an euch. Ich werde in Kürze das Netzwerk unserer (sehr) kleinen Firma ...

Netzwerke
SSH - Wieso werde ich nach VPN Verbindung rausgeschmissen?
Frage von VernoxVernaxNetzwerke10 Kommentare

Hallo, ich habe es endlich geschafft mein Handy mit einer VPN Verbindung an meinen Router anzuschließen. Nach der Login ...

Windows Server
Server 2016 Autotiering Storage Space
Frage von HenereWindows Server9 Kommentare

Servus, ich habe jetzt ein StorageSpace auf einem Server 2016 in Betrieb zum Testen. 1x M2 mit 512GB (970pro) ...

Windows 10
VPN Verbindung Android - Win10 funktioniert nach Update auf Android 8 Oreo nicht mehr
gelöst Frage von OnleinWindows 108 Kommentare

Hallo, SETUP: Ich habe unter Win10 (up to date) einen VPN Server eingerichtet (Eingehende Verbindung). In meinen Routern habe ...