Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco 1700 Router VLan-Routing-Konfiguration

Mitglied: crisan

crisan (Level 1) - Jetzt verbinden

11.04.2011, aktualisiert 20:04 Uhr, 4975 Aufrufe, 2 Kommentare

Moin,

ich habe ein Problem bei der Routerkonfiguration.

Ich habe vor 2 Subnetze auf einem Cisco 1700 Router mit einander zu verbinden.

Subnetz 1 10.1.2.0 255.255.255.252
Subnetz 2 10.1.3.0 255.255.255.0

Dazu haben ich 2 Vlans erstellt.

Meine Konfig schaut bis her so aus:
Router>enable
Router#vlan database

Router(vlan)#
Router(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
Router(vlan)#vlan 3
VLAN 3 added:
Name: VLAN0003
Router(vlan)#exit
APPLY completed.
Exiting....
Router#configure terminal
Router(config)#interface vlan 2
%LINK-5-CHANGED: Interface Vlan2, changed state to up
Router(config-if)#ip address 10.1.2.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface vlan 3
%LINK-5-CHANGED: Interface Vlan3, changed state to up
Router(config-if)#ip address 10.1.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 1
Router(config-if)#switchport access vlan 2
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 2
Router(config-if)#switchport access vlan 3
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 10.1.2.0 255.255.255.252 fastEthernet 2
Router(config)#ip route 10.1.3.0 255.255.255.0 fastEthernet 1
Router(config)#end

Wenn ich jetzt mit show ip route nach den routen gucke, übernimmt er die routen einfach nicht.
Anscheinend fehlt da ein default gateway, das steht zumindestens immer nach der show ip route abfrage.
Ich hatte es auch schon mit "ip classless" probiert, hat aber nichts gebracht.

Weiß da jemand eine Lösung?
Mitglied: dog
11.04.2011 um 20:49 Uhr
Router(config)#ip route 10.1.2.0 255.255.255.252 fastEthernet 2
Router(config)#ip route 10.1.3.0 255.255.255.0 fastEthernet 1

Das kannst du gleich mal streichen.
Der Router sitzt in beiden Subnetzen drin und braucht keine Routen dahin.

ip classless

Das gehört immer in die Router-Konfiguration.

Wenn du jeweils die IPs des Routers bei den Clients einträgst sollten die schon kommunizieren können.
Bitte warten ..
Mitglied: crisan
11.04.2011 um 21:09 Uhr
ah okay,

schon mal vielen Dank. Werde das morgen gleich mal testen.

EDIT:

Also ich habe die Konfiguration jetzt einmal so gelassen und die Clients an die Ports angeschlossen. Ich Kann jetzt mit dem ping befehlt den jeweiligen Port des eigenen und des anderen clients anpingen. Den anderen Client erreiche ich aber nicht. hat das evtl. mit den Vlan-Tags zu tun?

Client 1
ip 10.1.3.2
sub 255.255.255.0
GW 10.1.3.1

Client 2
10.1.2.2
255.255.255.252
GW 10.1.2.1
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Routing zwischen VLAN mit Cisco RV320
gelöst Frage von Reini82Router & Routing7 Kommentare

Hallo allerseits, wir haben uns den Cisco RV320 Dual-WAN Router zugelegt damit wir zum einen unsere beiden DSL-Anschlüsse zusammenlegen ...

Router & Routing
Cisco SG300 - Kein Routing ins VLAN
gelöst Frage von Fluxx1337Router & Routing4 Kommentare

Hallo zusammen, Was ich möchte sieht man gut auf der Skizze. PC1 soll sich im dhcp Netz der Fritzbox ...

Switche und Hubs
Zwischen VLANs routen (Cisco)
gelöst Frage von teret4242Switche und Hubs15 Kommentare

Hallo zusammen, habe zwei Switches (Cisco 3560-PS) via Trunkport verbunden. Auf den beiden Switches sind jeweils die gleichen VLANs ...

Router & Routing

Übungen zu Cisco Router Konfiguration

Frage von M.MarzRouter & Routing3 Kommentare

Hallo zusammen, ich fange bald bei einem Netzwerkunternehmen an, die hauptsächlich mit Cisco Routern arbeiten. Um auch selbstständig was ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 3 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 8 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 22 StundenSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server38 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless21 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...