Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cisco AP541N - wenn WLAN Security aktiviert bekommen Clients keine IP vom DHCP

Mitglied: gieriguru

gieriguru (Level 1) - Jetzt verbinden

16.10.2012, aktualisiert 15:56 Uhr, 3636 Aufrufe, 13 Kommentare

Der Beitragstitel sagt eigentlich schon alles

Hallo,

ich versuche Windows CE Clients über 2 Cisco AP541N und einer Fritzbox miteinandern zu verbinden.

Seltsamerweise erhalten die Windows CE Clients nur IP Adressen zugewiesen wenn ich keine Wireless Verschlüsselung im Cisco AP aktiviert habe.

Ich habe schon WEP und WPA probiert. Bei WEP den 40 bit (5 ASCII Zeichen) bis 128 bit (HEX oder ASCII).

Alles funktioniert nicht

Erst wenn ich wieder die Verschlüsselung rausnehme erhält der mobile Client wieder eine IP von der Fritzbox zugewiesen.

Kennt einer dieses Problem?

Bin für jeden Tipp dankbar.

Gruß
Gieri
Mitglied: brammer
16.10.2012 um 16:00 Uhr
Hallo,

verwendest du im Schlüssel Sonderzeichen oder ungewöhnliche Schriftzeichen?
Hast du es mal mit einfachen Numerischen Schlüssel probiert?

brammer
Bitte warten ..
Mitglied: gieriguru
16.10.2012 um 16:09 Uhr
Hallo brammer,

ja, noch einfacher gings nicht , beim 40 bit ASCII habe ich mal 12345 genommen. Trotzdem keine DHCP IP erhalten.

Ich verstehe auch nicht was die Verschlüsselung mit DHCP zutun hat. Ich habe ja trotzdem 100% Signal und wenn ich die mobile client IP manuel im Profil hinterlege klappts auch nicht mit einem Ping zur Fritzbox.

Gruß
gieri
Bitte warten ..
Mitglied: MrNetman
16.10.2012, aktualisiert um 16:40 Uhr
Hi Gieri,

es gibt noch einen großen, einen riesigen Unterschied.
ASCII oder HEX
und das sind Welten zwischen ASCII 12345 (HEX 31:32:33:34:35) und HEX 12345 (ASCII ?4P).

Die Verschlüsselung findet vor dem Layer2 Request nach einer DHCP Adresse statt.
Also Verschlüsselungsfehler -> kein Netz.

Gruß
Netman
Bitte warten ..
Mitglied: gieriguru
16.10.2012 um 16:45 Uhr
Hi Netman,

OK Layer2 Request, schon wieder was gelernt. Wusste ich nicht... ich habe den Test mit ASCII gemacht. Also beim AP WEP/40bit ASCII beim Key 1 die 12345 eingegeben. Dann beim Windows CE client als Passphrase auch 12345 eingegeben.

Mache ich hier was falsch?

Gruß
gieri
Bitte warten ..
Mitglied: aqui
16.10.2012, aktualisiert um 17:59 Uhr
Bist du schon mal auf die intelligente Idee gekommen dir einmal das Log des Cisco APs anzusehen ??
Das funktioniert mit einem show logg auf dem CLI (Command Line Interface) des Cisco AP.
Dort steht meist ganz genau WO es kneift !
Wichtig ist: KEINE Sonderzeichen in SSID (Name) und WLAN Schlüssel egal ob WEP oder WPA !
Alternativ wäre natürlich mal ein Test mit einem funktionierenden Laptop einmal sinnvoll ob der Zugang bekommt um ein Fehler des APs bzw. seiner Konfiguration ausschliessen zu können.
Letztere wäre auch einmal sehr sinnvoll zu posten hier damit man irgendwelche Konfigfehler von dir entlarven könnte.
Eine funktionierende Cisco AP Konfiguration findest du z.B. hier:
https://www.administrator.de/contentid/110259 --> "Praxisbeispiel"
Bitte warten ..
Mitglied: gieriguru
16.10.2012 um 18:28 Uhr
Hallo aqui,

aus den Logdateien werde ich leider nicht schlau. Das mit dem Laptop habe ich auch schon probiert, da tritt das gleiche Problem auf.

Vielleicht erkennst Du da ja was?

ohne Verschlüsselung:

Dec 31 16:05:11 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 associated with BSSID 64:ae:0c:ed:d5:60
Dec 31 16:05:11 info hostapd wlan0: IEEE 802.11 Assoc request from 00:15:70:21:ed:42 BSSID 64:ae:0c:ed:d5:60 SSID HAP
Dec 31 16:05:11 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 deauthed from BSSID 64:ae:0c:ed:d5:60 reason 3
Dec 31 16:05:06 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 associated with BSSID 64:ae:0c:ed:d5:60
Dec 31 16:05:06 info hostapd wlan0: IEEE 802.11 Assoc request from 00:15:70:21:ed:42 BSSID 64:ae:0c:ed:d5:60 SSID HAP

Logeintrag nachdem ich auf WEP umgestellt habe:
Dec 31 16:07:13 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 deauthed from BSSID 64:ae:0c:ed:d5:60 reason 4


mit 128bit ASCII Verschlüsselung (Phrase 123456789abcd):

Dec 31 16:18:16 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 associated with BSSID 64:ae:0c:ed:d5:60
Dec 31 16:18:16 info hostapd wlan0: IEEE 802.11 Assoc request from 00:15:70:21:ed:42 BSSID 64:ae:0c:ed:d5:60 SSID HAP
Dec 31 16:18:16 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 deauthed from BSSID 64:ae:0c:ed:d5:60 reason 3
Dec 31 16:18:11 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 associated with BSSID 64:ae:0c:ed:d5:60
Dec 31 16:18:11 info hostapd wlan0: IEEE 802.11 Assoc request from 00:15:70:21:ed:42 BSSID 64:ae:0c:ed:d5:60 SSID HAP
Dec 31 16:18:11 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 deauthed from BSSID 64:ae:0c:ed:d5:60 reason 3
Dec 31 16:18:06 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 associated with BSSID 64:ae:0c:ed:d5:60
Dec 31 16:18:06 info hostapd wlan0: IEEE 802.11 Assoc request from 00:15:70:21:ed:42 BSSID 64:ae:0c:ed:d5:60 SSID HAP
Dec 31 16:18:06 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 deauthed from BSSID 64:ae:0c:ed:d5:60 reason 3
Dec 31 16:18:01 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 associated with BSSID 64:ae:0c:ed:d5:60
Dec 31 16:18:01 info hostapd wlan0: IEEE 802.11 Assoc request from 00:15:70:21:ed:42 BSSID 64:ae:0c:ed:d5:60 SSID HAP
Dec 31 16:18:01 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 deauthed from BSSID 64:ae:0c:ed:d5:60 reason 3
Dec 31 16:17:56 info hostapd wlan0: IEEE 802.11 STA 00:15:70:21:ed:42 associated with BSSID 64:ae:0c:ed:d5:60
Dec 31 16:17:56 info hostapd wlan0: IEEE 802.11 Assoc request from 00:15:70:21:ed:42 BSSID 64:ae:0c:ed:d5:60 SSID HAP
Dec 31 16:17:53 info syslog wlan0: DRIVER mode == 0, num_channels = 13, num_rates == 8
Dec 31 16:17:53 info syslog wlan0: DRIVER mode == 3, num_channels = 13, num_rates == 12
Dec 31 16:17:53 info syslog wlan0: DRIVER hostapd_get_hw_features: num_modes == 2, flags == 0 gmode == 1

Machmal erhält der mobile Client wenn ich renew bei DHCP mache eine IP Adresse die mit 169. anfängt und die Subnetmaske 255.255.0.0

Die wird aber auch wieder nach ein paar Sekunden vom mobilen Cleint verworfen und er zeigt wieder überall 0.0.0.0 an

Die Signalstärke ist Excellent und die Macadresse vom AP wird auch korrekt beim mobilen client angezeigt (erkannt).

Es muss also irgend was mit den Schlüsseltechnik zutun haben.

Gruß
gieri
Bitte warten ..
Mitglied: brammer
16.10.2012 um 18:48 Uhr
Hallo,

die 169. er IP Adresse ist ien Apipa oder Zeroconf die sich der Win CE Rechner selber gibt, da er keine zugeteilt bekommt.
Ich vermute dein Problem eher mal bei dem Win CE Rechner...
Treiber ist installiert?
Aktueller Treibe?
Windows CE Version?
WLAN Karte wird von Win CE unterstützt?

brammer
Bitte warten ..
Mitglied: aqui
16.10.2012, aktualisiert um 18:55 Uhr
Eine 169.254er IP Adresse ist eine APIPA Adresse wie ja jeder Netzwerker und Laie mittlerweile weiss:
http://de.wikipedia.org/wiki/Zeroconf
Das bedeutet das der Client keinen DHCP Server "sieht", austimed bei der Suche und sich dann selber eine APIPA Adresse vergibt. Wie das geht hast du ja nun oben gelesen...
Das Verhalten bei dir ist auch logisch und verständlich, da der Client durch die fehlgeschlagene Authentisierung keinen Zugang zum WLAN erhält, folglicherweise dann auch keine IP Adresse mit DHCP !
Leider ist das Log was den Authentisierungsprozess anbetrifft nicht allzu auskunftsfreudig
Du müsstest hier mal den Debugger bemühen !
Mit debug ? kannst du auf dem CLI sehen was für Optionen du hast. debug wpa-cckm-km-dot1x oder debug aaa dürften da weiterhelfen.
Vergiss nicht nach dem debuggen unbedingt mit undebug all das Debugging wieder zu deaktivieren.
Das sollte etwas detailiertere Infos geben.
Weiterhin fehlt ein Konfig Auszug des APs WIE du die Authentisierung in deinem WLAN konfiguriert hast
Also bitte mal ein show run eingeben und den Authentisierungsteil dort hier posten.
Bei WPA sollte da sowas wie hier stehen:
dot11 ssid Mein-WLAN
authentication open
authentication key-management wpa
wpa-psk ascii test123
!
encryption mode ciphers aes-ccm tkip
Bitte warten ..
Mitglied: gieriguru
17.10.2012 um 17:01 Uhr
so, das Problem ist gelöst auch wenn ich kein Netzwerker und evtl. auf der Evolutionsstufe unter einem Laien für manch einen hier bin, habe ich durch weitere Internetrecherge den Fehler gefunden.

Es liegt am Algorithmus den die verschiedenen Geräte zur Berechnung der Schlüssel über ein Passphrase nutzen. Hier kommt es anscheinend zu unterschiedlichen Ergebnissen obwohl WEP etc. ein Standard ist.
Das gleiche Problem gabs ja auch als Bluetooth rauskam.

Nachdem ich den vom mobilen Client errechneten Schlüssel 1:1 im AP eingetragen habe, wurde die IP auch sofort vom DHCP an den Client vergeben.

Bei WPA2 Verschlüsselung ist das wohl etwas besser (fehlertoleranter), aber leider kann der Windows CE client nur max. WEP.

Gruß
gieri
Bitte warten ..
Mitglied: aqui
17.10.2012, aktualisiert um 19:08 Uhr
Wie immer mal wieder ein Winblows Problem... Bei WEP solltest du sehr vorsichtig sein:
http://de.wikipedia.org/wiki/Aircrack
bzw.
http://www.youtube.com/watch?v=WqQDqvqCYqU
Bitte warten ..
Mitglied: MrNetman
17.10.2012 um 21:49 Uhr
Das WPA ist nicht fehlertoleranter. es liegt an der Berechungsmethode für den Schlüssel.
Wer gewohnt ist unter Windows die SHIFT-Taste zu ignorieren wird eben an andere Stelle bestraft Das trifft jetzt aber nicht deine Schreibweise, nur den Schlüssel. Und ganz oben steht, wie man HEX und ASCII unterchiedlich interpretieren kann.

Gruß
Netman
Bitte warten ..
Mitglied: gieriguru
18.10.2012 um 07:59 Uhr
Hallo Netman,

die Shift Taste habe ich auch ausprobiert wiel ich mir auch schon sowas dachte. Aber ich verstehe nicht warum ein 40bit ASCII mit der Zahlenfolge 12345 nicht korrekt sein kann. Liegt das auch am Algo?
Gruß
Gieri
Bitte warten ..
Mitglied: MrNetman
18.10.2012 um 08:04 Uhr
To be ASCII or not to be ASCII
Und da gibt es noch eine 7 bit und eine 8 bit Codierung. MAn braucht ja keine 256 Zeichen um ein Alphabet und zehn Ziffern zweimal abzubilden.
Bitte warten ..
Ähnliche Inhalte
Windows Server

Clients bekommen keine IP vom DHCP Server

gelöst Frage von Jabberwocky86Windows Server8 Kommentare

Hallo Zusammen Ich habe auf einem ESXi drei Server eingerichtet, unter anderem einen Domänencontroller. Komischerweise beziehen die zwei anderen ...

LAN, WAN, Wireless

Cisco WLC, kein DHCP auf WLAN

gelöst Frage von shadynetLAN, WAN, Wireless4 Kommentare

Hello hello, frohe Ostern erstmal. Ich spiele hier gerade etwas mit einem Cisco WLC (Basis ist IOS-XE 3.6.4) herum, ...

Sonstige Systeme

Cisco 1841, dhcp Client keine Adresse

gelöst Frage von rudeboySonstige Systeme33 Kommentare

Mahlzeit! Habe einen Cisco-Router 1841 zum "spielen" bekommen. Erste "Aufgabe" war das secret zurückzusetzen, aber da gibt es ja ...

LAN, WAN, Wireless

IPs vom DHCP kommen nicht bei WLAN Clients an

gelöst Frage von preysaLAN, WAN, Wireless12 Kommentare

Seit einiger Zeit und von heute auf gleich hatten wir Probleme mit unserem DHCP für die Vergabe von IPs ...

Neue Wissensbeiträge
Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 4 StundenWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 14 StundenSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 14 StundenMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 14 StundenHardware11 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

Heiß diskutierte Inhalte
Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux23 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL18 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...

LAN, WAN, Wireless
Kommunikation zwischen verschiedenen IP-Bereichen
Frage von DirkHoLAN, WAN, Wireless13 Kommentare

Hallo zusammen, von Unitymedia habe ich ein neues Modem (Connect Box) erhalten, das u.a. IPv4 aber keinen Bridge Mode ...

Windows Server
Domänencontroller trennen
Frage von Akit57Windows Server13 Kommentare

Hallo, ich hoffe das mir hier jemand meine Frage trotz der spärlichen Informationen die ich geben kann beantworten kann: ...