Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Einloggen in die Community fehlerhaft

Mitglied: Snowboarder1994

Snowboarder1994 (Level 1) - Jetzt verbinden

11.10.2010 um 18:12 Uhr, 2446 Aufrufe, 5 Kommentare

Hallo,

bei diesem Header http://pastebin.com/ivYRmFb7 funktioniert das einloggen und registrieren in meiner Community leider nicht... lade ich aber diesen Header hoch http://pastebin.com/ff3ihwSP , dort funktioniert das einwandfrei. Habe beide Dateien schon verglichen, auch die Datenbankabfrage ist einprogrammiert. Wer könnte mir helfen, den Bug zu suchen?

Wäre echt cool. Danke.
Mitglied: Biber
11.10.2010 um 19:46 Uhr
Moin Schneebrettler,

willkommen im Forum.
Würde es helfen wenn du in diesem Bereich...
01.
.... 
02.
.... 
03.
  $usernasme_session = $_SESSION["username"]; 
04.
  $username_get = $_GET["username"]; 
05.
  
06.
  if($username_session == $username_get){$s = "mp";} 
07.
  
08.
  ###################User Daten########################### 
09.
 
10.
  $abfrage_ud = "SELECT * FROM member WHERE username = '$username_session'"; 
11.
....
....den Variablennamen usernasme_session mit nur 3 statt 4 "s" schreibst?

Grüße
Biber
Bitte warten ..
Mitglied: dog
11.10.2010 um 20:37 Uhr
....den Variablennamen usernasme_session mit nur 3 statt 4 "s" schreibst?

Und da wäre es sehr hilfreich gewesen nicht mit Scheuklappen zu programmieren:

01.
ini_set('display_errors','On'); 
02.
error_reporting(E_ALL|E_STRICT);
Gehört beim Entwicklen an den Anfang jedes PHP-Scripts und Xdebug eigentlich auch noch...
Bitte warten ..
Mitglied: Snowboarder1994
11.10.2010 um 22:02 Uhr
Ok, das "S" wurde entfernt. Danke Top. Hab ich ganz übersehen.

Funktioniert aber leider immer noch nicht...
@dog wo muss der Code von dir hin & was muss geändert werden?
Bitte warten ..
Mitglied: dog
11.10.2010 um 22:24 Uhr
@dog wo muss der Code von dir hin & was muss geändert werden?

Wie ich geschrieben habe: ganz an den Anfang der Datei.
01.
<?php 
02.
ini_set('display_errors','On');  
03.
error_reporting(E_ALL|E_STRICT); 
04.
?>
Danach siehst du alle Fehler.

Zudem kann
include("<?echo $domain;?>/connect.inc.php");

Niemals funktionieren.
Was hier beim Ausführen tatsächlich steht ist:
include("<?echo http://xyz.de ;?>/connect.inc.php");
Das ist gleich doppelt falsch.
Zum einen darfst du kein <?echo $domain;?> innerhalb von PHP benutzen.
Korrekt wäre
include("$domain/connect.inc.php");
gewesen.
Zum anderen darfst du niemals Dateien über eine URL include()n (auch wenn PHP das manchmal erlaubt).
Der Pfad muss lokal sein.
Bitte warten ..
Mitglied: Snowboarder1994
12.10.2010 um 17:24 Uhr
Irgendwie bekomme ich das nicht hin, das man sich mit dieser Header Datei registrieren kann. Was ist falsch, warum funktioniert das bei dem alten?
Bitte warten ..
Ähnliche Inhalte
E-Mail
Erfahrung Zentyal Community Edition
Frage von Fears313E-Mail10 Kommentare

Hallo Zusammen Ich möchte zuhause einen eigenen Mail Server aufsetzen und habe nun häufiger die All-in-One Groupware Zentyal vorgeschlagen ...

Windows Netzwerk

Windows 10 Kann nicht bei Domäne einloggen?

gelöst Frage von Dennis2016Windows Netzwerk35 Kommentare

Hallo Community, Ich habe Zuhause ein kleines Testnetzwerk eingerichtet. Nach dem der Server steht habe ich den DNS und ...

Windows 7

Als Admin einloggen unter Win 7

Frage von FitforLifeWindows 718 Kommentare

Ich hatte eine ganz tolle Idee und habe das Adminkonto beim Anmeldebildschirm ausgeblendet (über Registry-Einträge). Nach dem Abmelden habe ...

Administrator.de Feedback

Codeformatierung fehlerhaft

gelöst Frage von FriemlerAdministrator.de Feedback11 Kommentare

Hallo administrator.de Team, mir fiel schon vor einigen Wochen (nach den letzten Updates) auf, dass die Codeformatierung nicht mehr ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...