Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst ERROR 5 (0x00000005) Changing File Attributes Robocopy auf XFS

Mitglied: anwinkler

anwinkler (Level 1) - Jetzt verbinden

02.05.2011 um 13:21 Uhr, 18585 Aufrufe, 8 Kommentare

hallo, dies Thema ist sicher schon in ähnlicher Form durchgekaut worden aber ich konnte bisher keine Schlußfolgerungen für mich daraus ziehen. Ich hoffe nun jemand kann mir hier helfen.
ich habe eine Datensicherung bei 2 Clients (XP-Home und Win7 Home Premium 64) eingerichtet. das passiert mittels Robocpy.
Spiegelung deswegen weil an diesem Standort kein Server steht und ich die Lokalen Daten noch an zweiter Stelle sichern möchte.
Die Erstsicherung klappte ohne Fehlermeldungen aber danach bekomme ich jedesmach Fehler im Log die ich mir eigentlich nicht erklären kann.
Das Zielsystem ist ein NAS mit einem XFS als Filesystem.

Version XP026

Source : D:\Daten\
Dest : \\buffalo\Manuela\
Files : *.*
Exc Dirs : d:\daten\mails
Options : *.* /NDL /NFL /S /E /COPY:DAT /PURGE /MIR /NP /R:1 /W:1
...dazu das Log:

2011/05/01 17:08:00 ERROR 5 (0x00000005) Changing File Attributes D:\Daten\
Zugriff verweigert
Waiting 1 seconds... Retrying...
2011/05/01 17:08:01 ERROR 5 (0x00000005) Changing File Attributes D:\Daten\
Zugriff verweigert

ERROR: RETRY LIMIT EXCEEDED.
Total Copied Skipped Mismatch FAILED Extras
Dirs : 24 0 24 0 0 0
Files : 434 311 123 0 0 0
Bytes : 118.63 m 81.74 m 36.89 m 0 0 0
Times : 0:00:21 0:00:20 0:00:01 0:00:00

Speed : 4265085 Bytes/sec.
Speed : 244.050 MegaBytes/min.
________________________________________________________________________________________________________________________

Robokopy für Windows7 64bit

Quelle : D:\Benutzer\Marina\Pictures\
Ziel : \\buffalo\marina\Pictures\
Dateien : *.*
Optionen: *.* /NDL /NFL /S /E /COPY:DAT /PURGE /MIR /MT:8 /R:2 /W:2

2011/05/02 09:46:30 FEHLER 5 (0x00000005) Dateiattribute werden ge„ndert \\buffalo\marina\Pictures\LG-StB M„rz 2006\Fachbungsleiter-LG Reha-Sport\
Zugriff verweigert
2 Sekunden wird gewartet... Wiederholung...
2011/05/02 09:46:32 FEHLER 5 (0x00000005) Dateiattribute werden ge„ndert \\buffalo\marina\Pictures\LG-StB M„rz 2006\Fachbungsleiter-LG Reha-Sport\
Zugriff verweigert

....hier sind nun noch sehr viele Meldungen

Insgesamt KopiertšbersprungenKeine šbereinstimmung FEHLER Extras
Verzeich.: 17 0 17 0 0 0
Dateien: 237 116 111 0 10 0
Bytes: 151.70 m 37.40 m 114.07 m 0 235.9 k 0
Zeiten: 0:01:34 0:00:18 0:00:04 0:00:07


eigentlich verstehe ich das nicht da die Erssicherung gut verlaufen ist und offenbar auch alles da ist.
Diese Spiegelung wird beim Start des Rechners ausgeführt.

Passiert wie gesagt bei Windows 7 und bei XP Home. Die Berechtigungen sind voll da da der Task mit Administratorrechten ausgeführt wird. Sollte auch nichts mit dem Filesystem auf dem Nas zu tun haben da die meldung ja die lokalen rechte anspricht. Kann mir dazu jemand was sagen oder ein Hinweis geben wo der Fehler sein kann? Wie gesagt Rechte sind voll da. Ich weis nicht mehr wonach ich suchen soll.
Mitglied: Biber
02.05.2011 um 13:44 Uhr
Moin Anwinkler,

verwende doch mal zusätzlich den Schalter /XJ [eXclude Junctions] und nimm (wegen der Wartbarkeit) die ganzen Doppelmoppel-Parameter raus.
Z.B /MIR ist gleichbedeutend mit /E /Purge.

Grüße
Biber
Bitte warten ..
Mitglied: anwinkler
02.05.2011 um 13:58 Uhr
Hallo,

ja.... der ist aber draußen...das habe ich aus dem Protokoll so abgeschrieben, da wandelt das Robocopy dann um
hier nun mal die vollständigen beiden batches

XP:
@Echo off
set Quelle=D:\Daten
set Ziel=\\buffalo\Manuela

"C:\Windows\system32\robocopy.exe" "%Quelle%" "%Ziel%" /NDL /NFL /S /COPY:DAT /MIR /NP /R:2 /W:2 /XF "*.db" "*.ini" "*.pst" /xd "d:\daten\mails" /Log:"\\192.168.6.6\share\Backuplog\ManuelaPC_%date%.txt"

exit

Win7:
@Echo off
set Quelle1=D:\Benutzer\Marina\Documents
set Ziel1=\\buffalo\marina\Documents

set Quelle2=D:\Benutzer\Marina\Pictures
set Ziel2=\\buffalo\marina\Pictures

"C:\Windows\system32\robocopy.exe" "%Quelle1%" "%Ziel1%" /NDL /NFL /S /COPY:DAT /MIR /NP /MT:8 /R:2 /W:2 /XF "*.db""*.ini" /XD "D:\Benutzer\Marina\Documents\Eigene Bilder" "D:\Benutzer\Marina\Documents\Eigene Musik" "D:\Benutzer\Marina\Documents\Eigene Videos" "D:\Benutzer\Marina\Documents\mails" /Log:"\\192.168.6.6\share\BackupLog\MarinaPC_Doc_%date%.txt"

"C:\Windows\system32\robocopy.exe" "%Quelle2%" "%Ziel2%" /NDL /NFL /S /COPY:DAT /MIR /NP /MT:8 /R:2 /W:2 /XF "*.db""*.ini" /Log:"\\192.168.6.6\share\BackupLog\MarinaPC_PiC_%date%.txt"
exit

"C:\Windows\system32\robocopy.exe" "%Quelle1%" "%Ziel1%" /NDL /NFL /S /E /COPY:DAT /PURGE /MIR /NP /MT:8 /R:2 /W:2 /XF "*.db""*.ini" /XD "D:\Benutzer\Marina\Documents\Eigene Bilder" "D:\Benutzer\Marina\Documents\Eigene Musik" "D:\Benutzer\Marina\Documents\Eigene Videos" "D:\Benutzer\Marina\Documents\mails" /Log:"\\192.168.6.6\share\BackupLog\MarinaPC_Doc_%date%.txt"

"C:\Windows\system32\robocopy.exe" "%Quelle2%" "%Ziel2%" /NDL /NFL /S /E /COPY:DAT /PURGE /MIR /NP /MT:8 /R:2 /W:2 /XF "*.db""*.ini" /Log:"\\192.168.6.6\share\BackupLog\MarinaPC_PiC_%date%.txt"
exit
Bitte warten ..
Mitglied: Nagus
02.05.2011 um 17:29 Uhr
Moin,
wie ich sehe nimmst du den UNC Pfad! Hast Du schon mal probiert das Laufwerk erst zu mappen und dann die Sicherung auszuführen?

Mal abgesehen davon: warum machst Du so ein kompliziertes Script dafür? Bzw. dann hätte ich die Wert für robocopy auch noch in variablen gepackt - ist so unübersichtlich ... Bei XD langt es übrigens wenn *Videos oder etwas in der Art "%Quelle2%\eigene videos" nimmst (ungetestet)

Wenn Du es richtig schick machen willst: frag den %Username% und mach ein goto %username% ...

Gruß
Nagus
Bitte warten ..
Mitglied: anwinkler
03.05.2011 um 07:20 Uhr
Hallo,
betreff Laufwerk erst mappen.
1. ja habe ich ausprobiert...auch das gleiche. Macht für mich kein Sinn das Laufwerk zu mappen
2. betrifft ja nicht das Problem? Robocopy hat ja kein Problem mit den Daten auf dem Zielort sondern mit den Daten auf der Quelle !!

(.....2011/05/01 17:08:00 ERROR 5 (0x00000005) Changing File Attributes D:\Daten\
Zugriff verweigert)

zu dem schicken.....das ist Kosmetik und kann dann angepasst werden wenn es keine Probleme mehr macht. Du schreibst ja selbst "ungetestet"
username brauche ich nicht abfragen....es gibt nur den einen Benutzer auf den jeweiligen Maschinen

>>>>>>Danke bisher an alle....hat denn keiner eine Idee zu dem eigentlichen Problem?<<<<<
Bitte warten ..
Mitglied: Nagus
03.05.2011 um 20:15 Uhr
Zitat von anwinkler:
Hallo,
betreff Laufwerk erst mappen.
1. ja habe ich ausprobiert...auch das gleiche. Macht für mich kein Sinn das Laufwerk zu mappen
2. betrifft ja nicht das Problem? Robocopy hat ja kein Problem mit den Daten auf dem Zielort sondern mit den Daten auf der Quelle
!!

Na so klar ist das nicht aus Deiner Frage raus gekommen. Wen interessiert dann Dein Ziel NAS wenn das Problem die Quelle ist?

Viel spannender sind Antworten auf die folgenden Fragen: von wo startet du das Script? Von dem Client auf dem die User arbeiten oder vom NAS, nur von einem PC? Soweit ich Deinen Fehler oben richtig interpretiere, startets Du das Script vom Win7 64 System. Tritt der Fehler auch auf dem XP System auf? In welchem Kontext startest Du das Script? Als Admin (Win 7 64)? Vielleicht regelt Dir hier die UAC ab ... Wenn ich nämlich auf meinem Win7 64 die Konsole starte, dann bekomme ich Robocopy nur im User Kontext zum laufen - ohne Admin rechte, ob wohl ich die habe ...

Außerdem würde ich mal die Parameter /NDL und /NFL raus nehmen. Es ist irgendwie blöd die Protokollierung für Dateien und Verzeichnisse auszuklammern. Wenn ich mir nämlich die Fehler oben ansehe und die Sonderzeichen sehe .. hmm
Außerdem ist es idiotisch die Parameter /E und /S gleichzeitig zu nutzen: /MIR == /E /Purge
01.
  
02.
/S :: Kopiert Unterverzeichnisse, jedoch keine leeren Unterverzeichnisse. <-- weg lassen! 
03.
/E :: Kopiert Unterverzeichnisse, einschließlich leerer Unterverzeichnisse.



Außerdem:
01.
/COPY:copyflags:: Gibt an, welche Inhalte für Dateien kopiert werden sollen (der Standard ist "/COPY:DAT"). 
02.
                  (Kopierflags : D=Daten, A=Attribute, T=Zeitstempel). 
03.
                  (S=Sicherheit=NTFS-ACLs, O=Besitzerinformationen, U=Überwachungsinformationen).
Wie wäre es du lässt das einfach weg? Die bekommst ja immer einen Attribut Fehler im log ... und mir ist nicht klar wozu das überhaupt mit nimmst. Wofür brauchst Du die Attribute?
Bitte warten ..
Mitglied: anwinkler
04.05.2011 um 07:40 Uhr
Hallo
Na so klar ist das nicht aus Deiner Frage raus gekommen. Wen interessiert dann Dein Ziel NAS wenn das Problem die Quelle ist?
das war auch nur der Vollständigkeit halber. Bin mir sicher wenn ich das nicht hier geschrieben hätte dann wäre das angemahnt worden. Aber egal

Viel spannender sind Antworten auf die folgenden Fragen: von wo startet du das Script? Von dem Client auf dem die User arbeiten oder vom NAS, nur von einem PC?
om jeweiligen User unter Administratorrechten als Task im Hintergrund beim Starten des PC

Soweit ich Deinen Fehler oben richtig interpretiere, startets Du das Script vom Win7 64 System. Tritt der Fehler auch auf dem XP System auf?
Sowohl von XP als auch von Win7 64bit

In welchem Kontext startest Du das Script? Als Admin (Win 7 64)? Vielleicht regelt Dir hier die UAC ab ... Wenn ich nämlich auf meinem Win7 64 die Konsole starte, dann bekomme ich Robocopy nur im User Kontext zum laufen - ohne Admin rechte, ob wohl ich die habe ...
das Script läuft als Administrator im Hintergrund

Außerdem würde ich mal die Parameter /NDL und /NFL raus nehmen. Es ist irgendwie blöd die Protokollierung für Dateien und Verzeichnisse auszuklammern. Wenn ich mir nämlich die Fehler oben ansehe und die Sonderzeichen sehe .. hmm
Das Protokoll war endlos und da ich weis das die Rechte korrekt sind habe ich das so gesetzt. Die Sonderzeichen setzt aber nur Robokopy im Protokoll. Auf dem NAS ist alles Konform. Ich denke ja auch das es damit was zu tun haben könnte. Andererseits meckert Robocopy auf einer XP Maschine jpg Daten an. Die sind frisch von der Kamara gekommen. haben Rechte für alle. Zur Sicherheit habe ich die alle nochmal neu gesetzt ohne anderes Ergebnis.

Außerdem ist es idiotisch die Parameter /E und /S gleichzeitig zu nutzen: /MIR == /E /Purge
01.
  
02.
> /S :: Kopiert Unterverzeichnisse, jedoch keine leeren Unterverzeichnisse. <-- weg lassen! 
03.
> /E :: Kopiert Unterverzeichnisse, einschließlich leerer Unterverzeichnisse. 
04.
...ja hast Du recht, habe ich nicht richtig überlegt. 
05.
 
06.
...da hast du recht 
07.
 
08.
> Außerdem: 
09.
> <code> 
10.
> /COPY:copyflags:: Gibt an, welche Inhalte für Dateien kopiert werden sollen (der Standard ist "/COPY:DAT"). 
11.
>                   (Kopierflags : D=Daten, A=Attribute, T=Zeitstempel). 
12.
>                   (S=Sicherheit=NTFS-ACLs, O=Besitzerinformationen, U=Überwachungsinformationen). 
13.
> 
Wie wäre es du lässt das einfach weg? Die bekommst ja immer einen Attribut Fehler im log ... und mir ist nicht klar wozu das überhaupt mit nimmst. Wofür brauchst Du die Attribute?

ok das probiere ich die Attribute benötige ich nicht. Ich habe gestern mal RSYNC dafür eingerichtet. Da scheint es weniger Probleme zu geben wenn das Fehlerlos bleibt dann lass ich das mit Robocopy. .......Ich melde mich dazu noch einmal.
Danke bis dahin
Bitte warten ..
Mitglied: anwinkler
06.05.2011 um 10:25 Uhr
so wollte mich ja nochmal melden. Also rsync läuft sehr zuverlässig. Hier für alle Nutznießer der Link des Programms welches die Konfiguration sehr einfach macht.
http://www.lupinho.net/rsyncbackup/

das Programm bietet auch den anschließenden Mailversand entweder immer oder nur bei Fehler, wobei kein lokaler Mailserver vorhanden sein muß.
ads Programm lässt keine Wünsche bei mir offen.
Danke noch mal an alle welche Ihr Gehirnschmalz für mich einsezten.
Bitte warten ..
Mitglied: Farbauti
12.06.2011 um 12:11 Uhr
Hallo,

ich hatte das selbe Problem, und bin auf folgende Lösung gekommen:

Das Problem macht das Filesystem, das als Ziel angegeben ist, auch wenn das der Fehlermeldung widerspricht.
Wird der Parameter "/COPY" nicht explizit angegeben, verwendet robocopy den Defaultwert "/COPY:DAT". Hier ist aber das "A" das Problem, da manche (Ziel-)Filesysteme die Attributes nicht richtig verarbeiten können.
Seit ich explizit den Parameter "/COPY:DT" angebe, funktioniert der RC ohne den ERROR 05.

viele Grüße, Farbauti.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Code: 5: Unknown Error
Frage von schauanWindows Server4 Kommentare

Hallo zusammen, ich versuche seit einiger Zeit, zwei Programme auf einem Windows Server 2008 R2 zum Laufen zu bekommen. ...

Windows 8
Error 5: Zugriff verweigert
gelöst Frage von oliverfberlinWindows 85 Kommentare

Guten Morgen, ich habe seit ein paar Wochen das sich Programme nicht Installieren lassen oder nach einem Reboot verschwunden ...

Batch & Shell
Robocopy Fehler 5: Zugriff verweigert
Frage von anmelderBatch & Shell6 Kommentare

Ich kopiere meine Daten auf Festplatte mit: in den Onlinespeicher. Die Dateien haben die gleiche Endung und keine wird ...

Backup

NAS RTRR Backup: Destination does not support changing file owner! Not all attributes are copied

gelöst Frage von Desby2Backup8 Kommentare

Hallo zusammen, ich habe heute eine Frage an euch bezüglich zwei Fehlermeldungen bei einem RTRR Backup. Gegebenheiten: - Quelle: ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Windows Server
NTFS Berechtigungen Ordnerstruktur
Frage von hukahu23489Windows Server11 Kommentare

Hallo, ich bin seit kurzem in einer neuen IT-Abteilung und bin über das Berechtigungskonzept des Unternehmens sehr schockiert. Ich ...

Exchange Server
NDR umleiten
Frage von isomasterExchange Server10 Kommentare

Hallo Kollege, ich habe ein Problem mit dem Exchange Server. Wir haben unsere info@ Adresse als Verteilergruppe eingebunden (so ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...