Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Excel - verweis auf Arbeitsblatt über Zellinhalt

Mitglied: leknilk0815

leknilk0815 (Level 3) - Jetzt verbinden

10.05.2006, aktualisiert 23:45 Uhr, 38663 Aufrufe, 7 Kommentare

Wie läßt sich über einen Zellinhalt ein Verweis auf ein Arbeitsblatt erstellen??

Hallo zusammen!

Ich habe folgendes Problem:

In einem Excel- Sheet befinden sich mehrere Arbeitsblätter, benannt z.B. AAA, BBB, CCC.
Man kann nun einen Verweis in einer Zelle auf eine Zelle in einem anderen Arbeitsblatt mit:
='BBB'!A1 erstellen.
Gibt es eine Möglichkeit, diesen Verweis mittels eines Zellinhaltes zu machen, also z.B.:

In Zelle B2 (Arbeitsblatt AAA) steht "BBB".
Dieses "BBB" möchte ich in die Formel "='BBB'!A1" einbauen.

Geht das und wenn, wie?????
(Würde mir vieles extrem erleichtern, da ich dann nicht in jede Formel den Verweis manuell eintragen müsste, sondern auf Zellinhalt referenzieren könnte)

Danke mal vorab

Gruß - Toni
Mitglied: Biber
10.05.2006 um 14:28 Uhr
Moin Toni.

nimm dazu die Funktion INDIREKT()

=INDIREKT(B2 &"!A1")

...oder mit Vornamen =INDIREKT(AAA!B2 &"!A1")
liefert dann einen Verweis auf das Feld BBB!A1..
.. oder besser ausgedrückt, den Feldinhalt von BBB!A1

Gruß
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 15:12 Uhr
Hallo Biber,

da hab ich mich wohl etwas zu einfach ausgedrückt.
Ich muß diesen Bezug in Formeln einbauen, z.B.:
=SVERWEIS("serial";'31583'!C:D;2;FALSCH)
Das Arbeitsblatt heißt in dem Fall 31583, und dieser Wert (Seriennummer) steht in Zelle D4.
Das heißt, im SVERWEIS müsste statt '31583'! irgendwas mit D4 stehen

Gruß - Toni
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 22:34 Uhr
Hallo Biber,
ich hab jetzt die Lösung:
es geht mit "indirekt" und "verketten".

Danke für Deine Mühe

Gruß - Toni
Bitte warten ..
Mitglied: Biber
10.05.2006 um 22:43 Uhr
Na dann poste doch bitte die ganze Zeile.. *gg

..ich lerne ja auch gern dazu..

Grüße
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 23:00 Uhr
gerne, hier die Zeile (grins...)

{=WENN($D4=SVERWEIS("serial";INDIREKT(VERKETTEN("'"&D4&"'!C:D"));2;FALSCH);LINKS(INDIREKT(VERKETTEN("'"&D4&"'!$F$3"));SUMME(1*(ISTZAHL(LINKS(INDIREKT(VERKETTEN("'"&D4&"'!$F$3"));SPALTE(1:1))*1))))*1;"SN# stimmt nicht überein!")}

Ich benutze das Ding, um die Wartungskosten von HDS- Türmen zu ermitteln. Hierbei sind auf einem Sheet u.a. die SN# hinterlegt, auf mehreren anderen Arbeitsblättern, welche mit den jeweiligen Seriennummern benannt sind, die Daten aus dem autom. Storage Report. Mit dieser Formel brauche ich nun die Verweise nicht mehr von Hand einzutragen und kann die Formel einfach runterziehen. Nachdem mittlerweile knapp 500TB rumstehen, muß man "automatisieren".

Gruß - Toni (und danke nochmal)

Edit: damit mir keine lange Nase wächst: der Tipp mit indirekt verketten kam aus nem Excelforum, der Rest ist von meinem Mist
Bitte warten ..
Mitglied: Biber
10.05.2006 um 23:31 Uhr
Danke Dir auch, Toni,
aber das probier ich morgen mal aus..
IMHO ist dieses geschraubte
.....INDIREKT(VERKETTEN("'"&D4&"'!C:D"));....
gleichbedeutend mit meinem
...INDIREKT(D4&"'!C:D");
(aber schlechter lesbar *gg)
Hab grad kein Excel on board... ich teste es morgen mal.

Gruß
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 23:45 Uhr
Hab ich ausprobiert, geht aber irgendwie nicht. Wäre natürlich einfacher...
Bitte warten ..
Ähnliche Inhalte
Microsoft Office

Zellinhalt in Excel-Kopfzeile übernehmen

gelöst Frage von KyrinjaMicrosoft Office2 Kommentare

Guten Tag, stehe vor dem Problem, das ich Excellisten drucken Soll Welche folgendermaßen aufgebaut sind: Seite Lager von bis ...

Microsoft Office

Excel Arbeitsblätter kopieren sich selbstständig

gelöst Frage von KMP1988Microsoft Office7 Kommentare

Servus, ich habe ein Problem mit Excel 2013. Ein Kunde hat bei sich am PC eine Excel-Datei mit mehreren ...

Microsoft Office

Excel Arbeitsblatt automatisch um Zelle erweitern

gelöst Frage von tom1987Microsoft Office2 Kommentare

Hallo VBA-Profis ;) Ich habe folgendes Problem Bin gerade dabei ein Protokoll zu erstellen, über die %-Auslastung der LKW´s ...

Microsoft Office

Excel einzelnes Arbeitsblatt als PDF speichern

gelöst Frage von FAAB58Microsoft Office4 Kommentare

Hallo Gemeinde, Ich möchte eine einzelnes Arbeitsblatt aus einer Mappe heraus als PDF speichern ich habe ein kleines Problem ...

Neue Wissensbeiträge
Microsoft

Neuigkeiten zu Server und Office 365 was läuft mit was und was nicht

Tipp von AlFalcone vor 1 TagMicrosoft4 Kommentare

Da diese Infos scheinbar unerwünscht sind, habe ich diese wider gelöscht.

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 1 TagSpeicherkarten1 Kommentar

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 1 TagSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 2 TagenHardware2 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Sicherheitsgrundlagen
EuGH-Urteil - Internetanschluss für die ganze Familie - Filesharer haften trotzdem
Frage von StefanKittelSicherheitsgrundlagen40 Kommentare

Hallo, In diesem Artikel geht es darum, dass Jemand aus der Familie ein Hörbuch illegal hochgeladen hat. Der Vater ...

Apple
MacBook Pro 2018 mit 8 GB oder 16 GB
Frage von SysAdm81Apple25 Kommentare

Hallo zusammen, ich steh vor der Überlegung mir ein MacBook Pro 13 (2018) zu kaufen. Bzgl. SSD habe ich ...

Off Topic
SysAdmin im öffentlichen Dienst - jemand Erfahrungen?
Frage von JohnDorianOff Topic19 Kommentare

Hallo zusammen, hat jemand Erfahrung wie es so ist als SysAdmin im öffentlichen Dienst (Landkreis) im Südwesten der Republik ...

TK-Netze & Geräte
Low budget TK-Anlage für KMU
Frage von HeinklugTK-Netze & Geräte16 Kommentare

Hallo Admins, ich bin auf der Suche nach eine kostengünstigen Telefonanlage für mein kleines Büro mit 4-5 Mitarbeitern. Dabei ...