Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2013 CU6 setup auf 2012R2: New-OABVirtualDirectory schlägt fehl

Mitglied: Chibisuke

Chibisuke (Level 1) - Jetzt verbinden

18.11.2014 um 10:20 Uhr, 1219 Aufrufe, 1 Kommentar

Moin zusammen,

gut 4 Jahre nach unserem letzten Desaster mit Exchange versuch ich mich momentan daran Exchange 2013 auf Server 2012R2 zum Laufen zu bekommen, aber schon die Installation scheitert... Einige kleinere Macken, vor allem "Tippfehler" bzw. falsch platzierte Sonderzeichen in der applicationhost.config des IIS bzw. den Config-Files von Exchange selbst (enablef statt enabled, securit{ statt security...), konnte ich schon selbst ausbügeln, aber an einer Stelle komm ich einfach nicht weiter.

Kurz zur Umgebung: Domäne (Funktionslevel 2008) lief bisher mit Server 2008R2 als DC und Ex2010 auf Server 2012 (nicht R2), jetzt kamen 2 frisch installierte 2012R2 dazu. Einer ist schon als DC eingerichtet, der andere soll Exchange laufen lassen wenn die Installation mal klappen würde.

Der riesige Knackpunkt momentan: der Installer versucht in der Default Web site das OAB-VD anzulegen und scheitert damit. Der Setup-Schritt heißt "Clientzugriffsrolle: Clientzugriffs-Front-End-Dienst" und meldet den Fehler:
Der folgende Fehler wurde generiert, als "$error.Clear();  
          $InternalOabUrl = "https://" + $RoleFqdnOrName + "/OAB"; 
          new-OabVirtualDirectory -Role ClientAccess -DomainController $RoleDomainController -InternalUrl $InternalOabUrl; 
          get-OabVirtualDirectory -server $RoleFqdnOrName -DomainController $RoleDomainController | set-OabVirtualDirectory -OAuthAuthentication:$true; 
        " ausgeführt wurde: "System.InvalidOperationException: Fehler beim Erstellen des virtuellen IIS-Verzeichnisses 'IIS://mailserver.domäne.local/W3SVC/1/ROOT/OAB' auf 'mailserver'. ---> System.Runtime.InteropServices.COMException: Die Daten sind unzulässig. (Ausnahme von HRESULT: 0x8007000D) 
   bei System.DirectoryServices.DirectoryEntry.CommitChanges() 
   bei Microsoft.Exchange.Management.Metabase.CreateVirtualDirectory.Execute() 
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.NewExchangeVirtualDirectory`1.CreateToMetabase() 
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.NewExchangeVirtualDirectory`1.InternalProcessRecord() 
   --- Ende der internen Ausnahmestapelüberwachung --- 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target, Boolean reThrow, String helpUrl) 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target) 
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.NewExchangeVirtualDirectory`1.InternalProcessRecord() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)".
Ruf ich das Kommando in der EMS auf sieht es so aus:
[PS] C:\Windows\system32>New-OabVirtualDirectory -Role ClientAccess -InternalUrl https://mailserver.domäne.local/OAB -DomainController DC 
Fehler beim Erstellen des virtuellen IIS-Verzeichnisses 'IIS://mailserver.domäne.local/W3SVC/1/ROOT/OAB' auf 'mailserver'. 
    + CategoryInfo          : InvalidOperation: (mailserver\OAB (Default Web Site):ADObjectId) [New-OabVirtualDirectory], Inv 
   alidOperationException 
    + FullyQualifiedErrorId : [Server=mailserver,RequestId=bca87025-47b7-4fe6-aa60-3fd9efa95b17,TimeStamp=18.11.2014 08:13:29 
   ] [FailureCategory=Cmdlet-InvalidOperationException] B9C0A1A4,Microsoft.Exchange.Management.SystemConfigurationTas 
  ks.NewOabVirtualDirectory 
    + PSComputerName        : mailserver.domäne.local
In beiden Fällen wird das VD zwar im IIS angelegt aber nicht im AD eingetragen. Hab in der EMS schon beide DCs durch probiert, Meldung ist die selbe. Ein grundsätzliches AD-Problem sollte es eigentlich nicht sein, immerhin hat es der Installer ja auch geschafft etliche andere VDs in der default web site und "exchange back end" zu registrieren.

Hab schon einiges recherchiert, man findet nur leider sehr wenig dazu. Die meisten "Treffer" beziehen sich auf das OWA-VD und/oder auf Exchange 2010, hab hier aber bisher keine brauchbaren Ansätze gefunden. Per ADSIedit sehe ich dass keine verwaisten Einträge vorhanden sind, und der IIS metabase explorer (aus dem IIS6 ressource kit) zeigt auch keine Reste wenn ich das VD händisch aus dem IIS lösche.

Habt ihr noch eine Idee woran das liegen könnte? Bin für jeden Tipp dankbar.
Mitglied: Chibisuke
19.11.2014 um 18:54 Uhr
N'Abend zusammen,

Problem nicht gelöst aber "umschifft"... Hab Ex2013 auf der Maschine mittels Konsole und setup.exe /mode:uninstall soweit möglich wieder vom System gekratzt. Er meckerte mitten drin dass er den Server auf unserem DC nicht mehr finden kann und brach ab, per ADSI-Edit konnte ich sehen dass alle Exchange-relevanten Einträge aus dem AD getilgt sein sollten. Hab die Maschine danach auf einen (glücklicherweise vorhandenen) Snapshot der vor den ersten Installationsversuchen lag zurückgesetzt und sie wird jetzt anderweitig verwendet, stattdessen hab ich die Installation dann auf einer anderen VM (2008R2) angestoßen und gehofft dass es hier weniger Probleme gibt. Und siehe da, der Installer lief in einem Rutsch durch und alles scheint auf Anhieb zu funktionieren... Also entweder hat die 2012R2-VM einen gewaltigen Knacks (was ich weniger glaube da ich sie schon 2mal neu aufgesetzt hatte) oder Ex2013 verträgt sich einfach nicht mit 2012R2...

Falls letzteres der Fall sein sollte bin ich heilfroh dass einer unserer Kunden der auch kürzlich auf Ex2013 umgestiegen ist noch bei 2008R2 geblieben ist, will nicht wissen das was für ein Theater gegeben hätte wenn es bei der Installation auch solche Probleme aufgetreten wären...
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Update auf Exchange 2013 CU6 schlägt fehl

gelöst Frage von wolfidwExchange Server

Hallo zusammen, seit gestern versuche ich unseren Exchange 2013 CU5 auf CU6 zu aktualisieren. Leider bricht Setup immer an ...

Exchange Server

Migration Exchange 2007 zu 2013 schlägt fehl

Frage von zimlarsExchange Server1 Kommentar

Hallo Zusammen, vorhandener SBS2008 Server soll durch 2012R2 Server mit Exchange 2013 abgelöst werden. wir hatten im November 2015 ...

Exchange Server

IMAP Verbindung schlägt fehl bei Exchange 2013

gelöst Frage von pablovicExchange Server6 Kommentare

Hi Gemeinde Ich habe ein Problem mit der IMAP Verbindung eines Programms und Exchange. Und zwar soll das Programm ...

Exchange Server

Exchange 2013 Mailbox restoren schlägt fehl

Frage von xbast1xExchange Server

Hallo zusammen, ich wollte eine deaktivierte Mailbox reaktivieren. Wenn ich folgendes CMDlet ausführe Get-MailboxDatabase l DisplayName,MailboxGuid,LegacyDN,Database erhalte ich bereits ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 10 StundenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 10 StundenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 1 TagDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 1 TagSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
Exchange Server
Exchange Postfach Einbindung Betriebs-rat -Arzt, Bewerbung .
gelöst Frage von YellowcakeExchange Server22 Kommentare

Hey ich habe da mal eine Denksport Aufgabe bekommen Genutzt wird ein Exchange Server 2010. hier gibt es den ...

Datenschutz
Telematikinfrastruktur Erfahrungsaustausch
Frage von MOS6581Datenschutz12 Kommentare

Moin, unter meinen Kunden befinden sich auch einige Ärzte, welche sich künftig mit der Telematikinfrastruktur-Geschichte der Gematik herumärgern dürfen. ...

Windows Server
Delgegierte OU via RDP verwalten - Objektverwaltung zuweisen
gelöst Frage von TOAOICEWindows Server12 Kommentare

Hallo, ich habe folgendes Problem. Ich möchte in meiner Domäne (Server2016), einer Gruppe (OUAdmin) Berechtigungen auf die OU Test ...

Windows Server
Downgrade von Windows Server 2016 auf 2012 - Wie vorgehen?
Frage von EstefaniaWindows Server12 Kommentare

Guten Ich habe eine Frage an Erfahrene unter euch. Durch einen InPlace Upgrade wurde Windows Server 2012 auf die ...