Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Hohe CPU-Last von Explorer beim Zugriff auf Samba share

Mitglied: thisadmin78

thisadmin78 (Level 1) - Jetzt verbinden

20.02.2007, aktualisiert 21.02.2007, 5440 Aufrufe, 2 Kommentare

Hallo zusammen,

Ich habe mir einen Fileserver mit Suse Linux 9.1 gebastelt und darauf 2 Samba Shares (gleicher Benutzer/Passwort wie Windows XP Pro) eingerichtet. Das Einbinden der Shares als Netzlaufwerke in Windows funktioniert einwandfrei.
Auf dem Fileserver speichere ich alle meine vom Fernsehen aufgenommenen Filme (alle Files ab 1GB bis 6GB Grösse).
Das Problem ist jetzt, dass schon beim ersten Klick im Windows Explorer auf eines dieser Files auf einem dieser Samba Laufwerke der Prozess explore.exe auf 70% CPU Load springt, in der Spalte E/A-Bytes (Lesen) gleich MegaByte-weise Daten liest und das 100MBit-Netz mit 60% ausgelastet wird. Interessant ist auch, dass Explorer dann sogar mehr Daten liest, als das File eigentlich gross ist. Jeweils nach ca. 10-15 Minuten ist der Spuk vorbei und beginnt beim Anklicken oder öffnen eines anderen Files wieder von vorne.

Hat jemand dazu eine Idee?
Danke!

Mein PC:
Windows XP Pro mit allen aktuellen Patches
2.4G CPU, 2GB RAM, onboard Marvell Yukon 1GBit Eth (aber 100Mbit wegen Linux-Server Eth-Schittstelle)

Linux Server:
Suse Linux 9.1 mit allen aktuellen Updates (Kernel 2.6.5)
Samba 3.0.9 (über Suse-Update aktualisiert)
1.7G CPU, 512MB RAM, Onboard 100Mbit Eth


Edit: Habe noch folgendes getestet:
Problem tritt schon bei Files ab 40MByte auf. Dort jedoch nicht so schlimm, nach ca. 20 sekunden und ca. 100MByte von Explorer gelesenen Daten ists schon fertig.

Hier noch meine smb.conf:
Global parameters
[global]
logon drive = P:
map to guest = Bad User
username map = /etc/samba/smbusers
encrypt passwords = yes
printer admin = @ntadmin, root, administrator
logon home = \\%L\%U\.9xprofile
printcap cache time = 750
cups options = raw
netbios name = fileserver
server string = File Server
ldap suffix = dc=example,dc=com
local master = No
workgroup = MSHEIMNETZ
logon path = \\%L\profiles\.msprofile
os level = 20
printcap name = cups

[homes]
create mask = 0640
comment = Home Directories
directory mask = 0750
valid users = %S
writable = yes

[movie]
force user = root
comment = LVM fuer Filme
delete readonly = yes
write list = "Benutzername"
path = /lvm/movie
force group = root

[data]
force user = root
comment = LVM fuer Daten und MP3
delete readonly = yes
writeable = yes
path = /lvm/data
force group = root
Mitglied: fugu
20.02.2007 um 22:35 Uhr
Ok, komplett lösen kann ich's wahrscheinlich nicht...
Aber ich würde empfehlen, deine smb.conf ein wenig zu schrumpfen. Du machst sicherlich keine Domain-Anmeldung an der Samba-Dose, sonden reinen Fileserver-Zugriff. Dabei würde ich die Includes und noch ein paar andere Einträge weglassen und das OS-Level hochsetzten.

01.
[global] 
02.
map to guest = Bad User 
03.
username map = /etc/samba/smbusers 
04.
encrypt passwords = yes 
05.
netbios name = fileserver 
06.
server string = File Server 
07.
workgroup = MSHEIMNETZ 
08.
os level = 99
Das [homes] Share kannst du doch eigentlich auch löschen, wenn ich dein Anforderungsprofil an die Suse-Dose richtig sehe.

Auf dem Linux-Server müssen natürlich System-User und Samba-User existieren, deren Benutzername und Kennwort gleich den Windows-Usern sind. Ich würde die User dann in eine Gruppe "users" packen.

Weiterhin würde ich auf dem Linux-Server die Besitzrechte von
"/lvm/movie" und "/lvm/data" auf "root" setzen, die Gruppe aber auf "users". Anschliessend einmal die Rechte auf "770" durchvererben auf beide Verzeichnisse.

Das "force user" und "force group" kann ebenfalls weg. Stattdessen würde ich ein "beschreibbar"-Attribut und ein "durchsuchbar"-Attribut setzen.

01.
[movie] 
02.
path = /lvm/movie 
03.
comment = LVM für Filme 
04.
writeable = yes 
05.
browseable = yes 
06.
valid users = @users 
07.
write list = @users
Mit dieser Einrichtung habe ich bislang nie Probleme gehabt.
Greets, tf
Bitte warten ..
Mitglied: thisadmin78
21.02.2007 um 20:12 Uhr
Hi tf,

Danke schon mal für Deine schnelle Antwort.

Deine Annahmen zum Verwendungszweck sind korrekt.
Ich habe smb.conf nach Deinen Angaben geändert. System- und Samba-User sind korrekt konfiguriert (sind auch in der Gruppe "users").

chown und chmod habe ich angepasst.

Aber das Problem besteht noch immer.
Ich denke, dass es womöglich an einer Einstellung in Windows liegt.
Mit meinem Laptop (mit Eingabeaufforderung für Benutzer und Passwort) besteht das Problem auch.

Danke und Grüsse
This
Bitte warten ..
Ähnliche Inhalte
Webbrowser

Firefox längere Zeit geöffnet - hohe CPU-Last und extremer RAM-Verbrauch

gelöst Frage von MOS6581Webbrowser5 Kommentare

Moin Kollegen, seit längerer Zeit fällt mir auf, dass Firefox (aktuelle Version, in diesem Fall 53.0.3 - auch mit ...

Samba

MSSQL auf anonymer samba share

Frage von 8digitSamba2 Kommentare

Hallo, ich versuche eine mssql Datenbank (läuft auf nem Windows Failover Cluster) auf eine samba share umzuziehen, was jedoch ...

Windows Server

Hohe CPU-Auslastung durch EventLog

Frage von gullieWindows Server10 Kommentare

Moin in die Runde, ich habe gerade auf einem Exchange (Server 2012 R2 => VM) das Problem, dass mein ...

Samba

AD-Profil auf Samba-Share

Frage von DeciderSamba8 Kommentare

Guten Morgen, ich besitze ein Windows AD und möchte die Profile meiner Benutzer auf einem Samba-Share speichern. Die Ordner ...

Neue Wissensbeiträge
Netzwerkmanagement
Win 10 - wiederaufnahme in Domäne scheitert
Anleitung von Seesturm vor 3 StundenNetzwerkmanagement1 Kommentar

Ich habe ein kleines Netzwerk mit einem Domänencontroller Server 2012 R2. Die meisten Rechner laufen unter Windows 7. Vor ...

Internet

Europa baut Zensurinfrastruktur auf: EU-Parlament stimmt für Upload-Filter, Leistungsschutzrecht und gegen KI-Forschung

Information von Frank vor 1 TagInternet6 Kommentare

Eine sehr schlechte Entscheidungen für die Zukunft Europas ist gefallen: Der Rechtsausschuss im EU-Parlament stimmte heute morgen in einer ...

Windows 10

Mikrofon von Headset geht nach Update auf Windows 10 1803 nicht mehr

Tipp von Deepsys vor 3 TagenWindows 102 Kommentare

Ich verwende ein Plantronics Headset das per USB mit dem Windows 10 PC verbunden ist. Damit kann ich auch ...

Video & Streaming

Ruckelfreies Fernsehen auf Smartphone oder Tablet - in SD oder gar HD - Eine Alternative zum Fritz DVB-C Receiver

Anleitung von power-user vor 3 TagenVideo & Streaming9 Kommentare

Wer kennt das nicht: Man möchte gemütlich auf dem Balkon sitzen und vielleicht grillen und dabei das WM-Spiel gucken ...

Heiß diskutierte Inhalte
Windows 7
Windows 7 Benutzer wechsel nicht möglich
gelöst Frage von OSelbeckWindows 727 Kommentare

Hallo, ich habe hier einen Windows 7 Rechner, der in der Domäne war. Jetzt passiert beim starten, das ich ...

Instant Messaging
Whats App Business am PC einsetzen
Frage von thomasreischerInstant Messaging27 Kommentare

Hallo zusammen, wir würden demnächst gerne WhatsApp Business verwenden um den Kontakt zwischen Kunden und Mitarbeitern zu erleichtern. Natürlich ...

Windows Netzwerk
IP-Adresskonflikt
Frage von Turbo-MasterWindows Netzwerk24 Kommentare

Hallo zusammen, ich habe ein Problem mit unserem Netzwerk unter Windows Server. Ständig erhalten wir die Meldung, dass ein ...

Festplatten, SSD, Raid
RAID auflösen Synology DS213j!
gelöst Frage von Hendrik2586Festplatten, SSD, Raid19 Kommentare

Guten Morgen meine Lieben! :) Diese Frage wird sich sicherlich schon der ein oder andere gestellt haben. Es geht ...