Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

htacces Problem

Mitglied: FPMH

FPMH (Level 1) - Jetzt verbinden

01.01.2009, aktualisiert 16:40 Uhr, 3451 Aufrufe, 2 Kommentare

Hallo zusammen,

^^zuerst einmal muss ich mich für meinen schlecht gewählten Titel entschuldigen. Mir ist leider kein kurzer prägnanter Titel für mein Problem eingefallen. Ich werde dieses hier jetzt möglichst kurz und einleuchtend erläutern ^ ^

Worum es geht:
Ich möchte auf einer Homepage ein Verzeichnis mit Hilfe von .htaccess mit einem Passwort versehen. Das .htaccess und .htpasswd file wurden erstellt und in das zu Sichernde Verzeichnis kopiert.

.htaccess
01.
AuthUserFile /hp/av/ac/ov/www/vaevictis/privat/.htpasswd 
02.
AuthGroupFile /dev/null 
03.
AuthName "Mitgliederbereich" 
04.
AuthType Basic 
05.
Require valid-user
.htpasswd
01.
test:MTTuFPm3y4m2o
Problem:
Es tritt nun folgendes Problem auf. Wenn ich nun den Gesicherten Bereich aufrufe, öffnet sich das von mir erwünschte Eingabefenster mit Benutzer- und Passwortabfrage. Gebe ich nun den Benutzernamen "test" und das unverschlüsselte Passwort "123" ein, passiert nichts. Das Eingabefenster schließt sich lediglich kurz und öffnet sich dann erneut. Ich habe leider keine Ahnung woran dies liegt. Eine Vermutung wäre, dass das verschlüsselte Passwort nicht stimmt, da ich das Passwort 123 in mehrere Online-MD5-Generatoren eingegeben habe und meist unterschiedliche werte herauskamen.

Daten
Der Server läuft mit der Apacheversion
Apache/2.0.54 (Debian GNU/Linux)

Zur Erstellung der .htaccess und .htpasswd Dateien habe ich mehrere Generatoren versucht und auch die "normale" Eingabe mithilfe eines Editor.
Mitglied: Arano
01.01.2009 um 17:23 Uhr
Hallo Felix,

habe mir deine Direktiven mal kopiert und es nach gebaut, hat wunderbar funktioniert !
Dachte dann noch, das es vielleicht an einer fehlerhaften absoluten Pfadangebe liegen könnte, aber diese würde zu einem "500 Internal Server Error" führen.

Kurz überlegt... eine Einstellung im Firefox geändert und siehe da, selbes verhalten wie du es beschriebst.
Was hatter gemacht, er hat die Cookies deaktiviert.

Überlegung war, das durch das wiedererscheinen der Autorisationsabfrage, die vorher durchgeführt nicht "gespeichert" wurde und so die Abfrage wieder erscheint.
Wo werden die Daten gespeichert, in den Cookies.

Guck mal nach ob dein Browser Cookies akzeptiert.

~Arano
Bitte warten ..
Mitglied: FPMH
01.01.2009 um 20:19 Uhr
Cookies sind akzeptiert. Aber danke für deinen versuch
Bitte warten ..
Ähnliche Inhalte
HTML

HTACCES erstellen für PHP error logs

Frage von istike2HTML

Hallo, ich habe bei Allinkl einen shared Webserver, wo PIWIGO also Fotogalerie-Tool eingerichtet wurde. Da ich einen 500-er Fehlermeldung ...

Server

Problem PHP5.4 Update nun ein Problem

Frage von vServerServer4 Kommentare

Hallo, habe heute auch PHP 5.4 Updatet, nun erhalte ich folgende Meldung: PHP-Quelltext Würde gerne noch auf PHP5.5 ...

Windows Tools

Problem mit excel

Frage von bertaschweigerWindows Tools2 Kommentare

ich habe da mal ein Problem: Excel 2013 / 365 setzt einen Blattschutz, welcher die Zellenbearbeitung (Eingabe) bei ungeschützten ...

PHP

Problem mit php

Frage von jensgebkenPHP4 Kommentare

hallo gemeinschaft ein bekannter hat mir ein kleines script geschrieben in diesem code weerden die variaben f eine sql ...

Neue Wissensbeiträge
Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 StundenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 8 StundenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Microsoft Office

MS Office 2019 ohne OneNote - OneNote App speichert nur in Cloud

Information von Deepsys vor 19 StundenMicrosoft Office2 Kommentare

Microsoft zeigt deutlich wohin alles bei Ihnen geht, OneNote 2019 wird es nicht mehr geben, und die Windows 10 ...

Humor (lol)

Warum man sein Gast-WLAN nicht beliebig nennen sollte

Erfahrungsbericht von Henere vor 1 TagHumor (lol)5 Kommentare

Servus, mal was aus dem Alltag. Zu Hause. Eigentlich wollte ich nur einen weiteren WLAN-AP ins Netz bringen, damit ...

Heiß diskutierte Inhalte
Windows Netzwerk
LAN nur 10MB pro s trotz gb lan
Frage von tsunamiWindows Netzwerk21 Kommentare

Hallo zusammen, ich brauche mal wieder einen Anstoß in die richtige Richtung. Ich habe einen Windows 10 pc mit ...

Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme13 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Windows 10
Windows 10 Startmenü-Einstellungen Systemweit festlegen
Frage von flotautWindows 1013 Kommentare

Guten Morgen liebe Admins, wir möchten bei uns am Lehrstuhl demnächst auf Windows 10 umsteigen. Wir installieren unsere PC's ...