Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Installation PHP auf dem IIS 6

Mitglied: mark78

mark78 (Level 1) - Jetzt verbinden

19.07.2006, aktualisiert 09.08.2006, 3810 Aufrufe, 5 Kommentare

hallo zusammmen

ich bin dran PHP 5 auf unserem IIS 6 zu installieren! Auf der Defaultwebseite funktioniert es auch wunderbar. Jetzt haben wir aber im IIS natürlich einige andrere Seiten, also zusätzliche Webpages!
Bei denen funktioniert das PHP nicht.

Weiss jemand was ich evt. noch anpassen muss im php.ini oder so dass es auch auf allen anderen seiten funktioniert, oder vielleicht muss ich ja auch noch eine anpassung auf den weiteren Webpages im IIS vornehmen!

Besten Dank für Eure Hilfe!

Mark78
Mitglied: HenningD
08.08.2006 um 18:27 Uhr
Hallo,
ich habe genau das gleiche Problem. Hat mittlerweile jemand eine Lösung dafür?

Für die Default Seite funktioniert alles, für neu angelegte Seiten bekomme ich immer eine 404 Fehlerseite.

Für Hilfe wäre ich sehr dankbar!
Bitte warten ..
Mitglied: mark78
09.08.2006 um 09:44 Uhr
Hallo

Leider hat sich das problem bei mir auch noch nicht gelöst!
Habe auch das ganze nochmals durchgeführt wie es in der anleitung steht aber es kommt irgendwie nicht zum laufen!

Falls ich was neues weiss lass ich es dich wissen.
Bitte schreibe auch wenn du was neues weisst!

Gruss
Mark78
Bitte warten ..
Mitglied: HenningD
09.08.2006 um 15:07 Uhr
Hallo

Bei mir waren es 2 "Fehler". Prüf mal bei allen Webseiten nach, ob die php Erweiterung auch die gleichen Einstellungen hat wie die Default WEbseite. Bei der Default Webseite war bei mir phpisapi.dll angegeben, die neu erstellen Webseiten bezogen sich allerdings auf die php-cgi.exe. Warum auch immer.

Ausserdem musst du in der php.ini das doc_root auskommentieren. Danach hat bei mir alles einwandfrei funktioniert. PHP läuft nun auf allen eingerichteten Webseiten ohne Probleme.
Bitte warten ..
Mitglied: mark78
09.08.2006 um 18:00 Uhr
yessssssss....

das mit dem auskommentieren von der doc_root variable hat bei mir voll geholfen.

hast du dann dein wwwroot Verzeichnis auch nicht auf dem C: Laufwerk?
Ich habe es drum auf dem Laufwerk D: und ich könnte mir noch vorstellen dass das zu dem problem geführt hat. Ja nun habe ich einfach kein wert in doc_root un es funktioniert.

Gruss
Mark78
Bitte warten ..
Mitglied: HenningD
09.08.2006 um 18:53 Uhr
Also ich hab mein webroot noch auf C:

Ich denke PHP kommt einfach nicht mit den virtuellen Webseiten klar, wenn doc_root gesetzt ist und die Webseite die mit PHP laufen soll eine Ebene tiefer liegt.

Naja..zumindest funktioniert es nun, und das ist ja die Hauptsache!
Bitte warten ..
Ähnliche Inhalte
RedHat, CentOS, Fedora
PHP Installation unter CentOS 6
gelöst Frage von frank-fRedHat, CentOS, Fedora

Guten Tag allerseits, ich hoffe einer kann mir helfen. Ich versuche auf meinem V-Server mit CentOS 6 PHP zu ...

Hosting & Housing
HTTPS auf IIS 6 deaktivieren
Frage von kochi09Hosting & Housing3 Kommentare

Hallo zusammen, ich suche nach einer Lösung für folgendes Problem: ich habe eine Website auf einem alten IIS6 die ...

Informationsdienste
PHP-IIS 8 Websitefehler
Frage von BlacckyInformationsdienste2 Kommentare

Hallo liebe Forum Nutzer, Und zwar wollte ich Cloud/Mail(Website)/Forum Server jemanden zur Verfügung stellen. Für Tests habe ich die ...

CMS

PHP - WordPress auf Apache schneller als auf IIS?

Frage von Rene1976CMS13 Kommentare

Hallo Gemeinde, wir haben einen Win 2008 R2 RootServer mit Plesk 12.5. Dort laufen auch ASPX Websites drauf. Jetzt ...

Neue Wissensbeiträge
Exchange Server

EDB to PST Konverter - Nicht Gratis aber mit vollem Umfang

Tipp von PixL86 vor 3 StundenExchange Server9 Kommentare

Hallo zusammen, da ich nun ca. eine gefühlte Ewigkeit für einen gratis Konverter (EDB => PST) gesucht habe, möchte ...

Erkennung und -Abwehr
Trendmicro WFBS 10 ist in deutsch verfügbar!
Tipp von VGem-e vor 6 StundenErkennung und -Abwehr

Servus Kollegen, downloadbar unter

Windows Update

MS Patchday Juni 2018 - BSOD, obwohl noch kein Patch freigegeben

Erfahrungsbericht von diemilz vor 7 StundenWindows Update4 Kommentare

Hallo zusammen, wir hatten hier letzte Woche ein massives Problem. Alles begann damit, dass ein Mitarbeiter kurz vor Feierabend ...

Microsoft
Shadow Defender
Tipp von Hyrule vor 19 StundenMicrosoft

Ich denke viele kennen es: Ein Update oder ein neues Programm und vieles funktioniert nicht mehr wie gewünscht. Die ...

Heiß diskutierte Inhalte
Batch & Shell
Powershell Netzwerkdrucker auflisten
gelöst Frage von schiggi85Batch & Shell16 Kommentare

Hallo zusammen, ich möchte mit dem invoke-command bei einem remoteclient die installierten Netzwerkdrucker des Users abfragen. Nur klappt das ...

CPU, RAM, Mainboards
ASUS P5W DELUXE startet nur manchmal und nur mit 2 GraKas
Frage von Windows10GegnerCPU, RAM, Mainboards13 Kommentare

Hallo, ich habe das o.g. Motherboard erhalten. Egal ob C2D 8400, Pentium D 945 oder P4 670, das teil ...

Exchange Server
Exchange 2013 kein Mail-Versand und -Empfang nach Neustart
Frage von AkroshExchange Server11 Kommentare

Hallo zusammen, ich habe hier ein Problem mit unserem Exchange Server 2013 (VM auf ESXi 6.5). Die Festplatten C ...

Virtualisierung
Virtuelle Maschinen langsam unabhängig vom Hypervisor
gelöst Frage von HyruleVirtualisierung10 Kommentare

Hallo, ich möchte gerne zwei bis drei virtuelle Maschinen virtualisieren, darauf sollen jeweils Windows 10 und diverse etwas größere ...