Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Leere Seite mit Frames

Mitglied: Neokadesh

Neokadesh (Level 1) - Jetzt verbinden

05.04.2010 um 20:55 Uhr, 4830 Aufrufe, 8 Kommentare

Hallo,

ich habe zurzeit ein großes Problem mit Frames.
Rufe ich meine selbstgeschriebene Seite mit Frames auf, bekomme ich des öfteren eine
Leere Seite. Das einzige was er mir oben anzeigt, ist der im <title></title> hinterlegten text.

Manchmal zeigt er mir alles richtig an, aber manchmal nur eine leere Seite obwohl ich nichtmal was verändere.
Falls es hilft, ich benutze Apache als Webserver.

<html>
<head>

<title>OK</title>
</head>
<body>
<frameset cols="80px, 20px" rows="60px, 10px" border= "no" >
<frame src="luf.php" name="Navigation">
<frame src="menu.php" name="menu">
<frame src="bearbeitung.php" name="Daten">
<noframes>
<body>
<h1>Alternativ-Inhalt</h1>
<p>Wird angezeigt, wenn der Browser keine Frames darstellen kann.</p>
<p>Mindest-Inhalt sollten eine Kurzbeschreibung und eine Sitemap sein.</p>

</body>
</noframes>


</frameset>
</body>
</html>
Mitglied: StefanKittel
05.04.2010 um 20:58 Uhr
Hallo,

da es eine statische Seite ist, dürfte dies nicht auftreten und ich würde das Problem auf das Netzwerk oder den Indianer schieben.
Wie ist Deine Verbindung zum Apache?
Probier doch mal einen anderen WebServer, Cassini oder irgendwas einfaches (also nicht IIS).

Stefan
Bitte warten ..
Mitglied: dog
05.04.2010 um 21:27 Uhr
Syntax-Fehler:
Es gibt immer nur ein Body-Element und es steht immer unterhalb von html!
Bitte warten ..
Mitglied: Xpl0iT
05.04.2010 um 21:29 Uhr
Frames sollten nicht mehr benutzt werden. Ist schon fast eine Straftat.

Dein Code ist völlig falsch.
Das <frameset> Tag wird geschlossen wenn die Framedeklaration zu Ende ist. Nicht im Body!
In einer Frameset Deklaration kann man entweder nur Spalten oder nur Zeilen deklarieren nicht gleichzeitig.

Um Frames aus mehreren Spalten und Zeilen zu erstellen müsstest du diese Verschachteln.

Du hast 4 frames Definiert, aber nur 3 Quelldateien.


Ansonsten lege ich dir dies zu Herzen: http://www.webdesign.rudomazin.de/tutorials/php-tutorials/php-include-s ...


gruß
Xpl0iT


ps. wenn du mir dein Frame vorhaben genauer erkäutern würdest. Könnte ich dir den Code dazu schreiben.
Bitte warten ..
Mitglied: Neokadesh
05.04.2010 um 22:14 Uhr
Stimmt ich hab zweimal body drin. Mein Fehler.

So hab mein Quelltext angepasst, aber bekomme weiterhin nur eine leere Seite.

So weit ich weiß, kann ich sowohl zeilen als auch spalten in einem Framset hinzufügen.
Hatte nie Probleme damit und ich glaube nicht, dass es was mit meinem problem zu tun hat.

Ich möchte weiterhin den Apache nutzen. Nur weil es gerade nicht funktioniert, wechsel ich nicht.
01.
<html> 
02.
<head> 
03.
 
04.
<title>OK</title> 
05.
</head> 
06.
<body> 
07.
<frameset cols="80px, 20px" rows="60px"  border= "no" > 
08.
  <frame src="luf.php" name="Navigation"> 
09.
    <frame src="menu.php" name="menu"> 
10.
  <frame src="bearbeitung.php" name="Daten"> 
11.
  </frameset> 
12.
  <noframes> 
13.
   
14.
      <h1>Alternativ-Inhalt</h1> 
15.
      <p>Wird angezeigt, wenn der Browser keine Frames darstellen kann.</p> 
16.
      <p>Mindest-Inhalt sollten eine Kurzbeschreibung und eine Sitemap sein.</p> 
17.
 
18.
    
19.
  </noframes> 
20.
</body> 
21.
</html>
Ich würde gerne auf Frames verzichten, benötige aber für mein Vorhaben zwei unabhängige Seiten die sperate aktuallisiert werden.
Bitte warten ..
Mitglied: StefanKittel
05.04.2010 um 23:11 Uhr
Zitat von Neokadesh:
Ich möchte weiterhin den Apache nutzen. Nur weil es gerade nicht funktioniert, wechsel ich nicht.
Sollst Du ja auch nicht. Aber wir wollen einen Fehler finden. Dazu müssen wir ihn eingrenzen.
Stefan
Bitte warten ..
Mitglied: Terminatorthree
05.04.2010 um 23:11 Uhr
Wie Xpl0iT schon geschrieben hat kann eine Frameset Deklaration nur aus Zeilen ODER Spalten bestehen. Beides gleichzeitig wie bei dir geht nicht. Wenn du dennoch beides verwenden willst muss du 2 Framesets schachteln. Des Weiteren hast du ja die sache mit dem Body schon korrigiert. Außerdem, wenn man es ganz genau nimmt, sollte am Anfang natürlich noch der Doctype stehen.

Ich denke dein Problem löst sich aber schon wenn du die Framesetdefinition berichtigst.

z.B.
01.
<html> 
02.
<head> 
03.
 
04.
<title>OK</title> 
05.
</head> 
06.
 <frameset cols="80px, *" border= "no" > 
07.
  <frame src="luf.php" name="Navigation"> 
08.
  <frameset rows="60px,*" border= "no" > 
09.
     <frame src="menu.php" name="menu"> 
10.
     <frame src="bearbeitung.php" name="Daten"> 
11.
  </frameset> 
12.
 <noframes> 
13.
  <body> 
14.
   <h1>Keine Frames</h1> 
15.
  </body> 
16.
</noframes> 
17.
</frameset> 
18.
</html> 
19.
 
Ich hoffe mal das stimmt jetzt soweit

MfG Terminatorthree
Bitte warten ..
Mitglied: Neokadesh
06.04.2010 um 11:25 Uhr
Hi,

danke, funktioniert jetzt.
Es lag tatsächlich an der deklaration der zeilen und spalten.

Ich habe anfangs versucht die Framsets zu schachteln, war aber ohne Erfolg aufgrund der falschen deklaration.

Danke an Terminatorthree und Xpl0iT
Bitte warten ..
Mitglied: Terminatorthree
06.04.2010 um 11:35 Uhr
Kein Problem gerne doch.
Freut mich wenn auch einmal helfen kann hier, woch ich sonst immer die Hilfe brauche.

MfG
Terminatorthree
Bitte warten ..
Ähnliche Inhalte
Ubuntu
PHP - Nur leere Seiten
Frage von UItimateUbuntu6 Kommentare

Hallo. Ich habe gestern auf meinem Raspberry Pi das Betriebssystem Ubuntu MATE 16.04.2 LTS installiert. Apache funktioniert einwandfrei. Wenn ...

PHP

Keywords ins Frame einbauen - Seite ist mit PHP erstellt

Frage von mike7050PHP2 Kommentare

Hallo, ich möchte auf folgender Homepage Keywords und Meta Tags einbauen. Die Seite ist aber mit PHP erstellt. Der ...

Webbrowser

PDF wird im IE11 nicht angezeigt (leere Seite)

gelöst Frage von KMP1988Webbrowser4 Kommentare

Servus, bei einem PC kann ich seit heute nicht mehr im IE 11 eine PDF öffnen (von einer Webseite ...

Webentwicklung

Webseiteeinbettung in Frames

Frage von 118722Webentwicklung11 Kommentare

Hallo, ich hatte vor, diese Webseite in einer Frame auf meiner Webseite einzubetten: , jedoch mit wenig Erfolg, da ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 7 StundenHumor (lol)1 Kommentar

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 20 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 20 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 23 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...