Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Load Balancing so sinnvoll?

Mitglied: ozer

ozer (Level 1) - Jetzt verbinden

26.02.2013, aktualisiert 17:00 Uhr, 3033 Aufrufe, 5 Kommentare

Hallo zusammen,

ich würde von euch gerne mal eure Meinungen zu dem aktuellen Netz und meinem geplanten Umbau dazu haben. Aktuell habe ich das Problem das die Netzgeschwindigkeit weit unter GigaBit liegt (ca. 250-300 Mb/s). Getestet von Server to Server und Client to Server. (Switche und Netzwerkkarten sind natürlich alle Gigabit und verkabelt ist Cat6)

Aktuell ist das Netz so aufgebaut.

dfb65de3a22874af58ccb6ed18e16bf5 - Klicke auf das Bild, um es zu vergrößern

Die Server sind alle per Gigabit und NIC Teaming Tool von Broadcom an Switch 1 angeschlossen.
802.3ad LACP ist hier das von mir gewählte Protokoll auf beiden Seiten (Server und Switch).

Die Swtiche 1-2 sowie 1-3 sind ebenfalls mit jeweils 4 x Cat6 Kabeln untereinander angeschlossen.
Ebenfalls 802.3ad.

Die Clients sind auf allen 3 Switchen verteilt, da wo halt Platz war ;)

Meine Idee wäre jetzt folgende:

6f3030bbd40e7e950a298f973393a29d - Klicke auf das Bild, um es zu vergrößern

Eigentlich das gleiche Netz, wobei ich die zweite NIC der Server an ein extra Gigabit Switch packe und dieses wieder per Link aggregation an Switch2 anschließe.

Meint Ihr dass würde zu einem performance Gewinn führen?
Spanning Tree ist auf allen Switchen aktiviert. Die Switche sind übrigens 2 x 3com Baseline 2946-Sfp+, 1 x Netgear GS700GS (Switch4) und 1 x 3Com 2824 SFP+.

Falls keine der Szenarios was taugt, würde ich mich über verbesserungsvorschläge freuen.
Mitglied: aqui
26.02.2013, aktualisiert um 10:33 Uhr
Das klappt nur wenn die NICs der Server in unterschiedlichen IP Netzen arbeiten ! Du kannst die NICs niemals trennen und dann aber im gleichen IP Netz lassen:
https://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Dein erstes Szenario ist also schon richtig gewesen, wenn du eine dumme flache Layer 2 Struktur hast ohne jegliche VLAN Segmentierung ?! Leider sagst du dazu nichts....
Wenn dem so ist hast du also technisch nur diese Möglichkeit es zu lösen, der "Verschlimmbesserungsvorschlag" oben würde also schon technich scheitern ohne eine IP Segmentierung in VLANs.
Was bitte bedeutet dieser "Kurzschlusslink" über die Server ?? Netzwerktechnisch ist sowas auch ziemlicher Unsinn und den Sinn solltest du hier nochmal erläutern !!

Dein Problem ist vermutlich das das 802.3ad Teaming / Link Aggreagtion nicht richtig funktioniert oder nur einseitig und du vermutlich Loops oder Teilloops im Netz hast.
Du solltest also als erstes strategisch vorgehen und mit den ensprechenden show Kommandos oder im Setup GUI einmal ganz genau checken ob deine jeweiligen LADs überhaupt im "Operational" Mode sind also sauber aufgebaut wurden.
Hier wird sehr viel falsch gemacht.
Nicht so oft in der Link Aggregation zwischen Switches, denn da kann man nicht viel falsch machen wenn man weiss was man tut. Ausnahme ist hier LAGs zwischen unterschiedlichen Herstellern, da ist LACP immer Pflicht !
Mehr falsch wird auf seiten der Server gemacht, denn dort gibt es Active/Active, Active/Passive Szenarien und eben auch LADs nach 802.3ad mit LACP. Oft ist das für Laien verwirrend.
Zwingend ist hier aber auch immer ein Link Aggregation nach den obigen Standards.
Checke also erstmal ganz genau auf den Switches ob diese einzelnen LAGs überhaupt richtig gebildet wurden und ob es auch ein aktives Load Balancing bzw. Lastverteilung in diesen LAGs überhaupt gibt.
Letzteres ist ein Indiz dafür das diese auch richtig funktionieren. Relevant ist hier der LACP Status den man im Setup GUI oder mit Show Kommandos abfragen kann.
Die aktive Lastverteilung der LAGs kannst du mit einem kleinen SNMP Tool wie SNMP TG
http://leonidvm.chat.ru
relativ schnell ohne Aufwand grafisch checken auf deinen Switches !
Damit hast du dann gewissheit das alles sauber funktioniert.
Bitte warten ..
Mitglied: MrNetman
26.02.2013 um 10:33 Uhr
Hi Ozer,

Löblich, die Überlegungen.
Vor dem Umbau teste bitte ob die 2GBit Performance in der aktuellen Konfiguration erreichbar ist. Dazu musst du auf mindestens 2 Cients Netio gleichzeitig starten.
Wenn du nicht so weit kommst, dann klappt dein Momentanes Teaming schlecht oder gar nicht.
Dann ist Teaming und LACP das Stichwort, an dem du arbeiten sollst. Allerdings sind mir auch schon fabrikneue Cat6-Kabel (noname) untergekommen, die statt 1GBit/s nur 300Mbit/s geschafft haben.

Für dein zweites Szenario sehe ich irgendwie schwarz, da die Switches von verschiedenen Herstellern und verschiedenen Typen sind. Hier ist vorherzusehen, dass die Performance einbricht. Das ist leicht vorstell- und prüfbar. Für jeden neuen Weg müssen Pakete als unbekannt und damit als Broadcast zum Lernen verschickt werden.
Prüfung: Wireshark an einen beliebigen Port. Sobald dort sinnvolle Pakete auftreten gibt es ein Problem. Echte Broadcasts sind erlaubt.
Außerdem macht es nicht Sinn, die Serververbindungen auf mehr als 2 Switches zu verteilen (SW1, SW2, SW3)

Gruß
Netman
Bitte warten ..
Mitglied: ozer
26.02.2013 um 11:07 Uhr
Hallo,

vielen Dank für das erste Feedback.

Wir haben leider derzeit noch eine flache Struktur ohne Vlan Segmentierung. Werde ich demnächst in Angriff nehmen.

Ich weiss leider auch nicht was du mit Kurzschlusslink meinst.
Der Sinn / Unsinn ;) ist eigentlich derjenige das ich die Last von einem Switch auf 2 verteilen möchte und mich auch so etwas gegen Ausfall absichere. Mit 802.3ad ist das wohl nicht realisierbar. Die Broadcom Karten haben aber neben der Option 802.3ad auch das "broadcom smart load balancing and failover". Wenn ich also Link aggregations auf dem Switch zu den Server löse und dann die von mir geplante Umstellung durchführe, wäre dass dann immer noch eine Verschlimmbesserung?
Einer meiner Sorgen ist halt auch dass ich mir Schleifen ohne Ende baue, wobei das mit aktiviertem Spanning Tree ja kein Problem darstellen sollte. Ich weiss halt nur nicht wie ich das im laufenden Betrieb testen kann
Die LADs werde ich mir anschauen und weiter berichten, dass wird aber erst wieder morgen etwas ;)

Netio hab ich laufen lassen, bestätigt mir halt wie gesagt die 250Mbit von Server to Server, Gleiches Switch. Per UDP komme ich sogar auf 550Mbit. Eines hat mich jedoch gewundert. Von Client to Server bekomme ich teilweise sogar 113MByte also knapp 900Mbit was ja eigentlich Top ist, wenn man bedenkt dass hier gerade Betrieb ist. Ich werde gleich mal die Kabel tauschen und dann melde ich mich auf jeden Fall nochmal.
Bitte warten ..
Mitglied: MrNetman
26.02.2013 um 11:21 Uhr
Nun deine Test beweisen eine falsche Serverkonfiguration. Sieh dir das BRadcom Tool genau an und lies die Konfiguration.
Was passiert bei SLB:
Der Client fordert Daten an und der Server leifert sie an IF1 aus. Der nächste Client will Daten, der Server muss jetz fürs LB (Load Balancing) an IF2 ausliefern. Da der Switch das aber nicht weiß, wird das Antwortpaket erst einmal gebroadcastet und alle weiteren Switche tun das logischerweise auch. Danach kennt man den Weg und der Verkehr läuft ingeregelten Bahnen. Client 3 fragt jetzt an udn wird wieder auf IF1 bedient. Die Broadcast - Learning-Prozedur startet wieder.
Im günstigen Fall hast du nur eine mangelnde Performance trotz höherer Bandbreite. Im ungünstigsten Fall, kannst du dein komplettes Netz mit diesen unnötigen "Broadcasts" dicht machen.

Bei Netio kann man auch die Anzahl der gleichzeitigen Verbindungen einstellen. Je mehr gleichzeitige Verbindungen, desto niedriger die Datenrate - dank der Konfiguration.

Gruß
Netman
Bitte warten ..
Mitglied: ozer
26.02.2013 um 16:59 Uhr
Hab mir jetzt die Logs durchgesehen und es war wie aqui gesagt hatte. Ein Teaming hat anscheinend nicht funktioniert und dann Loops auf dem Netzwerk verursacht. Ein Löschen und wieder neu einrichten hat dann geholfen

Danke an euch beide ;)
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Cisco IOS Load Balancing
gelöst Frage von PharITLAN, WAN, Wireless2 Kommentare

Hallo allerseits, bevor ich mir einen zweiten Internetanschluss anschaffe, wollte ich mal folgendes fragen: Mein Cisco 891er hat nur ...

Windows Netzwerk
Round Robin und Load Balancing
gelöst Frage von tukawi06Windows Netzwerk9 Kommentare

Nabend zusammen, ich experimentiere wieder etwas rum und habe mir mal 6 virtuelle Maschinen aufgesetzt. DC01 DC02 Terminal Server01 ...

DNS
Load Balancing - Webservice Server
gelöst Frage von eyetSolutionsDNS1 Kommentar

Hallo, ich habe 2 Webservice Server in einem Rechenzentrum: Server 1 - NAT Adresse = 1.1.1.1 Server 2 - ...

Flatrates
Load Balancing mit Ip Anschlüssen
Frage von GTRDRIVERFlatrates12 Kommentare

Hallo zusammen wir haben hier folgende Ausgangssituation: -VDSL50 Anschluss der Telekom - Router Fritzbox (lokales Netz (192.168.0.x) - Die ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 9 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 12 StundenAdministrator.de Feedback10 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...