Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Ms access 2010, berechnetes feld

Mitglied: badni12

badni12 (Level 1) - Jetzt verbinden

18.08.2014, aktualisiert 08:41 Uhr, 1026 Aufrufe, 6 Kommentare

Hallo

Habe das englische MS ACCESS 2010

wenn ich das mache zeigt er mir bei einigen leeren Felder, von denen ich berechne, im berechneten Feld "#Type!" an.

kennt jemand das Problem?


dann habe ich gedacht ich mach das mit einem Wenn einfach weg

so schaut meine expression aus:

=IIf(IsEmpty( [gesamt] );"";*100)

funktioniert aber auch nicht, da kommt die Fehlermeldung "The expression you entered contains invalid syntax"

würde mich freuen wenn mir wer helfen kann

lg
badni

Mitglied: 06Down
18.08.2014, aktualisiert um 08:42 Uhr
Hallo,

wenn ich das mache...
Wenn du was machst?

so schaut meine expression aus:
=IIf(IsEmpty( [gesamt] );"";*100)

Versuche mal Folgendes:
01.
=IIf(IsNull([gesamt]);"";[gesamt]*100)
Gruß
Jens
Bitte warten ..
Mitglied: badni12
18.08.2014 um 08:41 Uhr
Hallo jens

danke schon mal für die antwort

zur ersten frage, wenn ich das normal mache d.h. einfach nur [gesamt]*100 reinschreibe


hier kommt auch eine fehlermeldung
"The expression could not be saved because its result type, such as binary or NULL, is not supported by the server.

lg
badni
Bitte warten ..
Mitglied: 06Down
18.08.2014, aktualisiert um 08:50 Uhr
Hi,

hier kommt auch eine fehlermeldung
"The expression could not be saved because its result type, such as binary or NULL, is not supported by the server.

Bei dem Vorschlag den ich Dir gemacht habe?

Gruß

Edit: Oh, schon als gelöst markiert. Hatte ich nicht gesehen...
Bitte warten ..
Mitglied: badni12
18.08.2014, aktualisiert um 08:58 Uhr
hallo

das mit dem gelöst war ein versehen, habs bereits zurückgesetzt..

bei deinem Vorschlag ja..

wenn ich statt "", 0 einsetze zeigt er mir das nicht mehr an

IIf(IsEmpty([gesamt]);0;[gesamt]*100)

allerdings ändert sich in der Tabelle nichts
d.h. bei leere felder zeigt er mir nicht 0 an, sondern nichts und ein paar mal eben "#Type!"



edit:
mit
IIf(IsNull([gesamt]);0;[gesamt]*100)
funktionert das mit 0

nur "#Type!" schreibt er noch immer rein...


lg
Bitte warten ..
Mitglied: 06Down
18.08.2014, aktualisiert um 09:09 Uhr
Hi,

IIf(IsNull([gesamt]);0;[gesamt]*100)

Es funktioniert auch:
01.
IIf(IsNull([gesamt]);"";[gesamt]*100)
Welche Werte sind denn in [gesamt] enthalten, bei denen bei der Rechenoperation "#Type!" steht?
Ich hoffe das [gesamt] als Datentyp "Zahl" hat, sonst kann es zu Problemen kommen.

lg
Bitte warten ..
Mitglied: badni12
18.08.2014, aktualisiert um 09:41 Uhr
hallo

problem wurde gelöst :p

ich habe im formular als standard wert "" eingestellt gehabt, da gesamt textformat ist
habe stattdessen 0 geschrieben
jetzt funktionierts

danke
lg
badni
Bitte warten ..
Ähnliche Inhalte
Microsoft Office

MS Access 2010, verknüpfen von 2 Feldern

gelöst Frage von badni12Microsoft Office4 Kommentare

Hallo Ich habe ein kleines Problem Ich arbeite mit der Tabelle "Gesamt" In der Tabelle Gesamt gibt es das ...

Microsoft Office

Access 2010 Feld kann nur einmal definiert werden

gelöst Frage von BoomBastiMicrosoft Office

Hallo liebe Admins, ich versuche mit einer Abfrage mehrere Tabellen miteinander zu verknüpfen. Es sind genau 6 Tabellen. Alles ...

Microsoft Office

MS Access 2003 Zwischensumme im Bericht falsch berechnet

Frage von greatmgmMicrosoft Office

Hallo zusammen, ja vor genau dem oben genannten Phänomen stehe ich jetzt. Leider habe ich nur noch die PDFs ...

Microsoft Office

Problem mit Summe aus berechnetem Feld in PivotTable

Frage von cramtroniMicrosoft Office10 Kommentare

Guten Tag zusammen, ich habe ein Problem, und zwar habe ich mir über eine ODBC-Verbindung eine PivotTable erstellt und ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 6 StundenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 6 StundenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Viren und Trojaner
Neue Avira Management Console Egosecure
Information von OSelbeck vor 1 TagViren und Trojaner1 Kommentar

Hallöchen zusammen, ich weiß nicht, wer von euch noch Avira einsetzt Wir haben ein paar Kunden Avira hatte ja ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 1 TagDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Postfach Einbindung Betriebs-rat -Arzt, Bewerbung .
Frage von YellowcakeExchange Server15 Kommentare

Hey ich habe da mal eine Denksport Aufgabe bekommen Genutzt wird ein Exchange Server 2010. hier gibt es den ...

Datenschutz
Telematikinfrastruktur Erfahrungsaustausch
Frage von MOS6581Datenschutz12 Kommentare

Moin, unter meinen Kunden befinden sich auch einige Ärzte, welche sich künftig mit der Telematikinfrastruktur-Geschichte der Gematik herumärgern dürfen. ...

Windows Server
Delgegierte OU via RDP verwalten - Objektverwaltung zuweisen
gelöst Frage von TOAOICEWindows Server12 Kommentare

Hallo, ich habe folgendes Problem. Ich möchte in meiner Domäne (Server2016), einer Gruppe (OUAdmin) Berechtigungen auf die OU Test ...

Windows Server
Downgrade von Windows Server 2016 auf 2012 - Wie vorgehen?
Frage von EstefaniaWindows Server12 Kommentare

Guten Ich habe eine Frage an Erfahrene unter euch. Durch einen InPlace Upgrade wurde Windows Server 2012 auf die ...