Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MSI Installationsaufruf aus der Registry

Mitglied: pctester

pctester (Level 1) - Jetzt verbinden

13.02.2012 um 14:31 Uhr, 5553 Aufrufe, 9 Kommentare

Experten gefordert..

Hallo

Ich habe hier ein Problem mit dem Windows Installer. Hintergrund:
Ich habe einen neuen Rechner Referenzrechner eingerichtet, auf dem die Software perfect FTP von der Firma ViennaSoft installiert wurde.
Nach Fertigstellung aller weiteren Einstellungen wurde das System mit SysPrep bearbeitet. Nach dem erstellen und verteilen des WIM-Images,
habe ich mich an dem neu eingerichteten Rechner lokal als Administrator angemeldet. Die Domänenmitgliedschaft wird manuell eingerichtet und
der Rechner wird neu gestartet.

Ab der ersten und allen weiteren Neustarts/Anmeldungen als Domänenbenutzer kommt dann das Problem:

Es wird der Windows Installer gestartet, der offensichtlich versucht eine INstallation fertig zu stellen. Dabei kommt als erstes die Fehlermeldung:

Die Funktion die Sie verwenden möchten, befindet sich auf einer Netzressource die nicht zur Verfügung steht

Dann bietet der Installer mir einen Pfad an: c:\users\name\AppData\Local\Temp\_is802\InternetSoftwarePak.msi

Diesen Pfad existiert nicht auf der Maschine. Auch das MSI Paket gibt es nicht. Genausowenig wie in den Installationsquellen der Software.

Ich vermute ohne weitere Zusammenhänge zu erkennen, das dieser Aufruf aus der Registry stammt. Ich habe mal die Registry nach diesem Pfad bzw.
Installationspaket durchforstet. Dabei sind zwei Einträge gefunden worden. Der eine in der HKLM\Software\Microsoft\Windows\CurrentVersion\uninstall
und der zweite HKCU\Software\Microsoft\Installer\Products\. Weitere Einträge wurden nicht gefunden. Die beiden gefundenen wurden entfernt.

Leider behebt das nicht mein Problem. Nach der nächsten Anmeldung kommt diese Fehlermeldung wieder.

Meine Vermutung ist, das noch irgendetwas in der Registry steht, das diese Installation ausführen will.

Meine Frage nun:
Was könnte noch ein Einträge vorhanden sein, was nicht auf den ersten Blick erkennbar ist?
Gibt es irgendwelche zusammenhänge mit einem Domänenkonto und einer Installation (Wenn man sich lokal anmeldet kommt dieser Fehler nicht) ?

Vielen Dank im voraus
Mitglied: drwalemc
13.02.2012 um 14:36 Uhr
Hallo

Start -> Ausführen -> msconfig eingeben und mit Enter bestätigen!... Im Register Systemstart hast du alles was beim Starten von Windows abgeht. Ev. Hats du dort mehr Infos. Pfad zu registry sollte auch dort stehen!

Gruss
drwalemc
Bitte warten ..
Mitglied: pctester
13.02.2012 um 14:39 Uhr
Leider ist das nicht so einfach. Auch die RUN-Sektionen in de Registry sind leer. Es wurde für diesen Test alles gelöscht was drinsteht.
MSCONFIG war das erste was ich versucht habe.
Bitte warten ..
Mitglied: Pjordorf
13.02.2012 um 14:42 Uhr
Hallo,

Zitat von pctester:
Ich habe einen neuen Rechner Referenzrechner eingerichtet, auf dem die Software perfect FTP von der Firma ViennaSoft installiert wurde.
Als welcher Benutzer?

Nach Fertigstellung aller weiteren Einstellungen wurde das System mit SysPrep bearbeitet.
Aha.

Dann bietet der Installer mir einen Pfad an: c:\users\name\AppData\Local\Temp\_is802\InternetSoftwarePak.msi
Also ein Vista oder Win 7 System was du da hast, oder? Der Benutzer name von oben ist ein lokaler Benutzer den du zur Installation verwendet hast. Dessen Verzeichniss (name) und natürlich alle anderen wie AppData ist aber von Sysprep entfernt worden, somit auch keine Quellen der Installationspakete welche jetzt gesucht werden nachdem die Software einen Benutzerwechsel erkennt. Ist diese Software für dein OS freigegeben? ist diese Software korrekt für alle Installiert worden?

Diesen Pfad existiert nicht auf der Maschine.
Klar, siehe Sysprep.

Auch das MSI Paket gibt es nicht. Genausowenig wie in den Installationsquellen der Software.
Ist doch nur eine Temporäre Installationsdatei. Beobachte doch mal was deine Software bei der Installation macht und wo diese ihre Pakete ablegt.

Ich vermute ohne weitere Zusammenhänge zu erkennen, das dieser Aufruf aus der Registry stammt.
Ja.

Leider behebt das nicht mein Problem. Nach der nächsten Anmeldung kommt diese Fehlermeldung wieder.
Wie auch. Die will neue Teile Installieren / nachinstallieren

Gibt es irgendwelche zusammenhänge mit einem Domänenkonto und einer Installation (Wenn man sich lokal anmeldet kommt dieser Fehler nicht) ?
Na also. Benutzer <> Benutzer. Jeder <> Benutzer.

Und, lässt sich diese Software so auch korrekt Installieren?

Gruß,
Peter
Bitte warten ..
Mitglied: 60730
13.02.2012 um 14:43 Uhr
moin,

"experten gesucht"...

Da ist aber der richtige Experte schon am Zuge....

Angenommen, wir sprechen über W7, das orakelt man anhand der WIM Zeile....

Egal...

Ich nehme weiterhin an, du hast keinen lokalen Benutzer eingerichtet und daher ist es sehr naheliegend, dass jeder Benutzer unter dessen Konto diese Software x nicht installiert ist - ein paar einstellungen nachholen möchte, damit das auch für diesen klappt.

Das löschen des betreffenden Astes unter HKLM\Software\Microsoft\Windows\CurrentVersion\uninstall sagt mir - du suchst einen Experten, der dir zeigt, wie man grundsätzlich als Admin mit Windows arbeitet.

Stundenlohn?
Nein - ich machs nicht.

Gruß
Bitte warten ..
Mitglied: pctester
13.02.2012 um 15:22 Uhr
Ich suche keinen Experten der mir grundsätzlich zeigt wie ein Admin arbeitet...Wenn du der Fachmann bist, was ich nicht in Frage stellen möchte, dann antworte doch konstruktiv oder lasse es...

Wie ich sehe habe ich nicht alle erforderlichen Daten angegeben. Hole ich hiermit nach

Das Betriebssystem ist Windows 7 Professional incl. aller Updates
Der Referenzrechner ist unter dem lokalen Administratorkonto erstellt worden. Für das anschliessende SysPrep ist die Installation "generalisiert" (/generalize) worden.
In der sysprep.xml ist das lokale Administratorkonto aktivert und mit einem Passwort versehen worden. Es funktioniert alles. In dem verteilten Image funktioniert alles so
wie es gewünscht ist. Alle Icons und Menueiträge sind dort wo sie sein sollten. Auch wenn der Rechner an der Domäne ist funktioniert alles soweit normal. Ausser eben diese Installer-Meldung.

Woraus resultieren noch Installationsaufrufe aus der Registry ?

Um die Kritik von Timo nochmal aufzugreifen: Nein ich habe nicht den gesamten Zweig gelöscht, sondern lediglich die Untereinträge die eindeutig auf das Produkt zurückzuführen sind.

Vielen Dank im Vorraus
Bitte warten ..
Mitglied: 60730
13.02.2012 um 18:26 Uhr
Zitat von pctester:
Ich suche keinen Experten der mir grundsätzlich zeigt wie ein Admin arbeitet...

Dann "nochmal" mit anderem Wortlaut.

"Pappa; Charlie hat gesagt, sein Vater hat gegoogelt und dieses Ominöse FTProgramm gefunden.
Charlies Pappa hat sich dann mal in dem Forum ungesehen und weiß jetzt, dass da ganz tolle aktuelle Sachen über luscious boobs Kari Wuhrer stehen und sein Vater sagte, Alta Falta - datt issne jeflägde Fehrein - öschis, oder Schluchtenscheixxer.."

Und Pappas Charlie hat gesagt, dass er sowas voll toll findet
	Aufgrund eines Versionswechsels wird der Download der aktuellen Version nicht mehr angeboten. 
 
Ab 15.2.2012 wird die neue Version 8 hier zum Download abgelegt werden.
Von daher.... Nimm n ordentliches FTP Programm, oder nimm das aus der Sysprep raus, es ist eh veraltet und - je nachdem ob oder ob nicht - der Fehler von dieser Weichware kommt - kriegst du den eh nicht anders weg.

Ich kann nach durchsicht des Hersteller Forums "verstehen", warum du dich nicht an die gewendet hast, sondern an uns.
Wenn die nicht mal in Ihrem eigenen Forum nach dem rechten sehen, wie kriegen die dann Ihre Software gebacken?

Gruß
Bitte warten ..
Mitglied: pctester
13.02.2012 um 20:17 Uhr
Nun, das Problem ist da leider etwas anders gelagert. Das ominöse internet Paket ist auch in den Quellen der Firma Viennasoft offensichtlich nicht als msi PAket zu bekommen. Da dieser Fehler aber erst nach dem Rollout mit fast 100 Rechnern und der damit verbundenen Domänenanbindung aufgefallen ist, ist hier wirklich der allerletzte Plan,die Rechner mit einer geänderten Platte neu zu installieren. Ziel meiner Bemühungen ist eigendlich primär eigendlich nur diese doofe Fehlermeldung wegzubekommen. Das es sich mit dem FTP Programm um einen Griff ins Klo handelt ist mir klar. Gott sei Dank haben ich diesen nicht zu verantworten..
Die Firma selbst ist mehrfach erfolglos angeschrieben worden. Im Internet gibt es keinen einzigen Fall, be dem bei gleicher Problemlage eine Lösung mit angeboten wurde. Ich habe sicherlich schon viel gegoogelt, und das naheliegenste mich bei der Firma selbst mal umzusehen zuerst getan. Ich hoffe dass das Charlie seinem Pappa mal klarmachen kann. Frage ihn doch einfach mal, auch wenn es nicht die saubere Lösung ist, wie man solche Installationsaufrufe aus der Registry unterbindet...

Vielen Dank im voraus
Bitte warten ..
Mitglied: 60730
13.02.2012 um 21:56 Uhr
oh njee...
Zitat von pctester:
Nun, das Problem ist da leider etwas anders gelagert. Das ominöse internet Paket ist auch in den Quellen der Firma Viennasoft
offensichtlich nicht als msi PAket zu bekommen.
  • das wird eine temporäre msi sein, die in einem anderen Paket "versteckt" ist...
Da dieser Fehler aber erst nach dem Rollout mit fast 100 Rechnern und der damit verbundenen Domänenanbindung aufgefallen ist, ist hier wirklich der allerletzte Plan....
  • Autsch und der Bock ist vorher beim testen nie aufgefallen?
PCTester suggerierte mir irgendwie was anderes
Ziel meiner Bemühungen ist eigendlich primär eigendlich nur diese doofe Fehlermeldung wegzubekommen.
  • nunja - diese Meldung ist zu xx % eher nicht das Problem, sondern das etwas nicht richtig läuft und so die Meldung erzeugt wird.

Die Firma selbst ist mehrfach erfolglos angeschrieben worden. Im Internet gibt es keinen einzigen Fall, be dem bei gleicher
Problemlage eine Lösung mit angeboten wurde.
  • also ist dieser Bock schon über den Berg?
  • Und vielleicht auch der Grund, warum die Ihre Weiche Ware nicht mehr im Angebot haben?
Ich hoffe dass das Charlie seinem Pappa mal klarmachen kann. Frage ihn doch einfach mal..
  • Der Enkel von Charlys Pappa würde dir raten - solange du den Uninstallstring nicht gelöscht hast, die Ware mal zu deinstallieren und GodFilezilla zu nehmen.
Bitte warten ..
Mitglied: pctester
14.02.2012 um 08:31 Uhr
Guten Morgen

Bei uns im Haus ist es üblich, das sogenannte Koordinatoren für ihren eigenen Bereich ihre Platten selbst anpassen können. Das heisst im Deteil das diese, die man durchaus auch als Fachleute bezeichnen kann, Einstellungen und Zusatzinstallationen an einem Grundsysstem vornehmen können, und das fertige Ergebnis als Masterimage freigeben. Dazu gehören in der Regel auch alle erdenklichen Tests. Warum das vorher nicht aufgefallen ist, entzieht sich meiner Kenntnis. Diese freigegebene Installation wird dann ungesehen vom ADV Service mit Sysprep & Co zu einem verteilbaren WIM-Image "gewandelt" und an den Roll-Out Dienstleister weitergegeben. Die Verantwortung für Funktion des Images liegt bei diesem Koordinator. So wurde eben dieser Gau mit auf die Platte und somit auch zum Rollout gebracht. Das Schlimme ist eigendlich nur, das die gültigen Proxyeinstellungen keinen FTP Verkehr zulassen und somit ein FTP Programm gänzlich hier im Haus sinnlos ist. Das diese Vorgehensweise bei künftigen Erstellungen von Masterimages überarbeitet und gegengeprüft werden erklärt sich von selbst....

Jetzt liegt die Karre aber schon im Graben. Dieses Schxxxxprodukt lässt sich nicht einmal deinstallieren. Weder ein Eintrag in der Softwareverwaltung noch über ein Menueintrag. Von daher der Testversuch am offenen Herzen alle Einträge aus der Registry zu entfernen die über die Suchfunktion mit dieser Software in Verbindung zu bringen ist....alles erfolglos. Ich kenne auch nicht wirklich irgendwelche Zusammenhänge die den Aufruf des Installers aus der Registry heraus rechtfertigen...

Vieleicht hat Charlies Pappa noch eine UrTantenEnkelinenNichte die mir einen flüstern kann wie ich diese DOOFE MELDUNG WEGBEKOMME.........*confused

Vielen Dank im voraus
Bitte warten ..
Ähnliche Inhalte
Windows Installation
MSI erstellen
gelöst Frage von Romble88Windows Installation6 Kommentare

Hallo, ich habe einige Dateien und Reg-Werte die ich gerne zum MSI zusammen führen würde. Welche Tools gibt es ...

Installation
Datum in MSI einfügen mit Orca
Frage von knomusInstallation5 Kommentare

Hallo, ich habe eine MSI Datei. Diese soll das aktuelle Datum in die Registry schreiben. Dazu habe ich die ...

Windows 7
MSI Erstellung - WInINSTALL
gelöst Frage von CiscarWindows 730 Kommentare

Hallo allerseits, Ich führe zur Zeit ein Projekt zur MSI - Paketerstellung & Softwareverteilung durch. Laut dem Handelsüblichen PDF ...

Windows Server
Automatische Software Installation .MSI
gelöst Frage von Hendrik2586Windows Server8 Kommentare

Hello nochmal @ all! Ihr seit langsam sicher schon alle genervt von mir aber ich habe da ein weiteres ...

Neue Wissensbeiträge
Router & Routing

Olle Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 7 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 20 StundenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Microsoft Office

MS Office 2019 ohne OneNote - OneNote App speichert nur in Cloud

Information von Deepsys vor 1 TagMicrosoft Office6 Kommentare

Microsoft zeigt deutlich wohin alles bei Ihnen geht, OneNote 2019 wird es nicht mehr geben, und die Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Windows 10
Windows 10 Startmenü-Einstellungen Systemweit festlegen
Frage von flotautWindows 1013 Kommentare

Guten Morgen liebe Admins, wir möchten bei uns am Lehrstuhl demnächst auf Windows 10 umsteigen. Wir installieren unsere PC's ...

LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless12 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...