Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

net use lpt1: /delete funktioniert nicht

Mitglied: timh

timh (Level 1) - Jetzt verbinden

18.01.2007 um 12:45 Uhr, 9944 Aufrufe

Hallo,
ich habe folgende Situtation.

An einem W2K Server ist per Printserver ein Nadeldrucker angeschlossen, installiert und fürs Netzwerk freigegeben.
Der W2K-Server gibt also den Nadeldrucker frei und die Client-PCs (WinXP Prof.) bauen lediglich eine Verbindung zum Server auf.
Das funktioniert soweit einwandfrei.

Nun wird eine branchenspezifische Software benutzt, welche auf dem Server liegt (muss nicht installiert werden - einfach nur ein großes Verzeichnis mit Datenbank-Anwendung) und per Netzwerkverbindung von den Clients gestartet wird. Soweit so gut!
Die Software will bestimmte Sachen auf dem Nadeldrucker ausdrucken. Aufgrund einiger Probleme beim Ausdruck (Schriftbild, Absätze etc.), gibt der Hersteller vor, die LPT1 Schnittstelle einfach per "net use" auf die Freigegebene Drucker-Ressource des Servers umzuleiten.
Das funktioniert auch soweit einwandfrei per "net use lpt1: \\SERVER\FREIGABENAME"
Sobald ich nun den Drucker mit der Software ansprechen will, hängt sich die ganze Arbeitsstation auf..... Nach dem resetten des PCs (was anderes geht nicht mehr) wird dann plötzlich die Seite gedruckt.
Der Drucker ist dann auch sofort automatisch wieder verbunden (Windows "merkt" sich ja die Einstellung). ABER: Ich kann den Drucker per "net use lpt1: /delete" nicht mehr trennen..., der Client hängt sich wieder auf...! Auch wenn ich das "merken" mit "/persistant:no" ausschalte und manuell verbinde habe ich das gleiche Problem...! Ich kann also nicht manuell trennen und auch nicht ausdrucken.

Nun zu den Benutzernamen: Auf dem Server gibt es 2 Namen: "Administrator" und "User"
Auf den Clients "Admin" und "User". Alle Benutzer haben inzwischen aufgrund meiner Verzweiflung sowohl auf dem Server als auch auf den Clients lokale Administratorrechte!!!
Sobald ich mich aber auf den Clients mit einem 3. Namen "Administrator" (für Testzwecke mal erstellt) mit Administratorrechte anmelde (dieser Name ist ja auch genauso auf dem Server), geht es alles einwandfrei (verbinden, drucken, trennen, verbinden, drucken....- alles kein Problem)
Mit anderen Worten: Client mit "Administrator" anmelden, Server hat auch "Administrator" und es geht. Client mit "User" anmelden, Server hat auch "User" und es geht nicht. Client mit "Admin" anmelden, Server hat "Admin" nicht und es geht auch nicht.
Habe auch sogar schon versucht die LPT1-Schnittstelle zu deaktivieren, da ja nur Administrator diese Schnittstelle mit net use umleiten dürfen...bringt aber auch nix.

Bin echt verzweifelt, da ich ja eigentlich nicht überall Adminrechte vergeben möchte und auch nicht überall einen "Administrator" anmelden möchte...

Vielen Dank für Eure Hilfe!!!
Ähnliche Inhalte
Batch & Shell
NET USE LPT1
Frage von MiStBatch & Shell4 Kommentare

Guten Morgen, ich nutze einen Netzwertdrucker den ich per NET USE auf LPT1 auf einem Klient angelegt habe. Da ...

Windows 10

Win 10 "net use" Serverscript funktioniert nicht

Frage von SpleanifyWindows 1010 Kommentare

Hallo zusammen, Wir setzen in unserer bisherigen Infrastruktur ein CMD-Script mit "net use" Befehlen für die Einbindung von freigegebenen ...

Windows 7

Net use mit gui

Frage von Lebowski23Windows 71 Kommentar

Hallo, folgendes Problem: In einem Netzwerk existiert ein LDAP-Server mit Samba, der für einige Rechner auch als Domain-Server dient. ...

Windows Netzwerk

Printerumleitung mittels net use wollen nicht

Frage von orrybeachWindows Netzwerk6 Kommentare

Ich habe einige Arbeitsstationen von Windows XP auf Win 7 umgestellt. Leider läuft noch ein altes DOS-Programm, welches unter ...

Neue Wissensbeiträge
Sicherheit
Adminrechte dank Bug in Intel HD Graphics Treiber
Information von DerWoWusste vor 9 StundenSicherheit

Intel HD graphics 4200 und neuer (4400, 4600 520,530,620, 630,) sind auf jeden Fall betroffen und bereinigte Treiber sind ...

Router & Routing

Endlich: Reines Kabel-TV Modem in D erhältlich !

Information von aqui vor 3 TagenRouter & Routing10 Kommentare

Mit dem Technicolor TC4400-EU Modem sind nun auch Breitband Router ohne integriertes Modem oder Firewalls wie z.B. die pfSense ...

Netzwerkgrundlagen
The Illustrated TLS Connection
Information von Lochkartenstanzer vor 3 TagenNetzwerkgrundlagen1 Kommentar

Moin, Unter findet man eine gelungene Erläuterung von TLS. Fördert sehr das verständnis darüber, was da passiert. lks

Windows 10

Zuverlässiger Remove-AppxProvisionedPackage Ausführen in W10-1803

Tipp von NetzwerkDude vor 5 TagenWindows 104 Kommentare

Moin, Remove-AppxProvisionedPackage hat in 1709 recht zuverlässig funktioniert, in 1803 ist es leider so das es gerne mail failed ...

Heiß diskutierte Inhalte
Windows Server
AD User wird immer wieder gesperrt
Frage von YellowcakeWindows Server20 Kommentare

Hey ich habe einen User (ein GL User - Natürlich was denn sonst) der immer wieder gesperrt wird. Ich ...

Windows Netzwerk
Gruppenrichtlinie für einen PC deaktivieren
gelöst Frage von Florian961988Windows Netzwerk14 Kommentare

Hallo, kleines Problem und immoment finde ich dazu keine Lösung oder mir fällt nicht ein, wie ich es suche ...

Switche und Hubs
OpenSource oder Freeware zur Verwaltung von Switchen
gelöst Frage von JonskezSwitche und Hubs12 Kommentare

Hallo, gibt eine kostenlose Verwaltungssoftware für Switche (überwiegend HP/Aruba)? Es sollte möglich sein, aus der Ferne z.B. die Firmware ...

Festplatten, SSD, Raid
LSI 9361 Controller, versehentlich virtual Drive am Controller gelöscht
Frage von pixel24Festplatten, SSD, Raid12 Kommentare

Hallo zusammen, gibt es hier einen Experten der sich gut mit LSI MegaRAID auskennt? Ich habe versehentlich im Controller-BIOS ...