Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

openvpn problem

Mitglied: Closed

Closed (Level 1) - Jetzt verbinden

20.12.2006, aktualisiert 11:40 Uhr, 7048 Aufrufe, 2 Kommentare

hallo erstmal. also ich hab so ziemlich alle tuts und auch das openvpn buch durchgelesen, aber hab trotzdem noch ein paar probleme:

also hier erstmal die config dateien

server
[quote]

mode server
tls-server

  1. Port
port 1194

  1. TCP oder UDP?
#proto tcp-server
proto udp


#tls-auth c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ta.key 0


  1. tun oder tap?
  2. Das tun Device erstellt einen IP Tunnel,
  3. während das tap Device einen Ethernet Tunnel erstellt.
#tun or tap device
#tun is an IP tunnel,
#tap an ethernet tunnel
dev tap
dev-node openvpn

#Our Server IP
ifconfig 10.0.0.1 255.255.255.0

#dynamic clients from 10.0.0.2-10.0.0.254
ifconfig-pool 10.0.0.2 10.0.0.254

#Die pakete werden auf dieser größe gekapselt
#tap-mtu 1500
#tap-mtu-extra 32
#fragment 1300
mssfix

#Paths to the certs
ca c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ca.crt
cert c:\\Programme\\OpenVPN\\easy-rsa\\keys\\Server.crt
key c:\\Programme\\OpenVPN\\easy-rsa\\keys\\Server.key
dh c:\\Programme\\OpenVPN\\easy-rsa\\keys\\dh1024.pem

#Tests the connection with a ping like paket. (wait=120sec)
keepalive 10 120

#Authenication
auth SHA1

#Our encryption algorithm
#cipher aes-256-ecb
#openvpn --show-ciphers for testing

#comp
comp-lzo

#Logging
status openvpn-status.log
verb 3
persist-key
persist-tun
[/quote]


Client
[quote]

tls-client
float
dev tap
dev-node openvpn
nobind

#MTU
#tun-mtu 1500
#fragment 1300

#tcp oder udp
proto udp

#Server IP
remote ca.homeftp.org 1194

#force authentication
#WICHTIG: hier den COMMON Name vom Server Zertifikat nehmen!
tls-remote Server
ns-cert-type server

ca c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ca.crt
cert c:\\Programme\\OpenVPN\\easy-rsa\\keys\\client.crt
key c:\\Programme\\OpenVPN\\easy-rsa\\keys\\client.key

#tls-auth c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ta.key 1

auth SHA1
#cipher aes-256-cbc
comp-lzo
resolv-retry infinite


verb 3
persist-key
persist-tun
[/quote]


so nun die log file
[quote]

Tue Dec 19 19:26:50 2006 192.168.2.7:1227 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Dec 19 19:26:50 2006 192.168.2.7:1227 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Tue Dec 19 19:26:50 2006 192.168.2.7:1227 [Client] Peer Connection Initiated with 192.168.2.7:1227
Tue Dec 19 19:26:53 2006 Client/192.168.2.7:1227 MULTI: Learn: 00:ff:4f:92:48:3f -> Client/192.168.2.7:1227
Tue Dec 19 19:26:55 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:06 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:16 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:26 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:36 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:46 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
[/quote]


das connection reset by peer verstehe ich nicht. merkwürdig ist halt dass ich das ganze derzeit auf einer virtuellen Maschine teste. es funktioniet auch alles. kann also beide rechner pingen. sowohl vom client aus den client und server. vom server aus auch jeweils client und server.
die monitore im system tray sind grün.

teste ich nun dieselbe config übers inet, so sind die monitore beim client gelb. kann das daran liegen dass ein port nicht korrekt freigeschaltet wurde? das ist das was ich vermute. hab die einstellungen allerdings richtig auf dem router eingestllt. habe auch ma sämtliche firewalls deinstalliert zu testzwecken. kein erfolg.

hatte in einer quelle noch gefunden dass die fehlermeldung eventuell an udp liegen kann. hab das ganze auf txp umgestellt und da erhalte ich dann dass der tcp-handshake fehlschlägt.

bitte helft mir. das kann ja eigentlich nur an der config liegen. was mache ich da falsch? bin für jede anregung und hilfe sehr dankbar. hab dieselbe frage auch schon im openvpn forum gepostet. falls dort eine antwort kommt, werde ich die lösung hier auch reinposten für diejenigen die es interessiert
Mitglied: Andynix
20.12.2006 um 10:34 Uhr
1.) Versuchs mal hiermit (es geht)
http://a-sawicki.de/cms/index.php?option=com_content&task=category& ...
2.) Portweiterleitung am Router auch eingestellt ?
3.) Ich habe schon mir am einen Speedport 700W (Telekom) 2 Stunden den Kopf zerbrochen und nicht geschaft ! (es wurde nicht benötigt und ich habe es sein lassen)
Bitte warten ..
Mitglied: Closed
20.12.2006 um 11:40 Uhr
jo port weiterleitung ist aktiviert. gucke mir die page ma an, aber hab wirklich schon sau viel jetz gelesen. hab auch alles mögliche an configs ausprobiert und die zertifikate auch nochmal neu erstellt. kanne s mir nicht erklären.

hab jetz ma auf tcp umgestellt. merkwürdig ist hier dass der dhcp des openvpnservers anscheinend nciht funktioniert. vergebe ich dem tap device eine netzip klappt es.

das ist alles wirklich sehr sehr merkwürdig

danke aber schonmal
Bitte warten ..
Ähnliche Inhalte
Router & Routing
OpenVPN Installation Routing Problem
Frage von intaneRouter & Routing48 Kommentare

Huhu, ich habe Schwierigkeiten bei der Installation von OpenVPN auf einen Win10 Rechner. Auf dem Rechner ist eine Software ...

Router & Routing
Openvpn Routing Problem
Frage von Luciver1981Router & Routing6 Kommentare

Hallo und guten Morgen, ich habe ein Problem mit dem Routing von meinen Openvpn Site to Site. Haupstandort: Server ...

Router & Routing
OpenVPN Problem Route fehlt
Frage von morrasenRouter & Routing10 Kommentare

Mein Problem: Ich komme vom Client (172.16.0.2) nicht auf den Rechner 192.168.178.57, wenn dieser mit dem OpenVPN-Server (10.8.0.1)verbunden ist. ...

Router & Routing

OpenVPN Problem - ASUS RT-AC56U als OpenVpn Server hinter Fritzbox 7390

Frage von JJJandeRouter & Routing10 Kommentare

Hallo ich habe ein Problem mit der Einrichtung meines OpenVPN Servers auf einem Asus Router mit Merlin FW, vielleicht ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 21 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 2 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk13 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...