Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenVPN: TLS Error: local/remote TLS keys are out of sync:

Mitglied: nEmEsIs

nEmEsIs (Level 2) - Jetzt verbinden

23.05.2006, aktualisiert 26.02.2007, 15135 Aufrufe, 1 Kommentar

Hallo Gemeinde,
ich habe ein Problem mit meinem OpenVPN Server.
Erst mal die Konfigurationen:

Server:
[Server Config Start]
  1. The IP address on which your OpenVPN server listens
#local 192.168.36.1
proto udp
port 5000
dev tap
comp-lzo

tls-server
dh /etc/openvpn/keys/dh512.pem
ca /etc/openvpn/keys/ca.crt
cert /etc/openvpn/keys/server.crt
key /etc/openvpn/keys/server.key
#crl-verify /etc/openvpn/keys/crl.pem
#tls-auth /etc/openvpn/keys/ta.key 0

mode server
server
ifconfig 10.1.0.1 255.255.255.0
client-to-client
max-clients 100
keepalive 20 60
persist-tun
persist-key
verb 3
status /etc/openvpn/status.log
status-version 2
push "keepalive 20 60"
push "echo "
push "echo Wilkommen im ***-Privat VPN !"
push "echo "

[Server Config End]

Client:
[Client Config Start]
remote 192.168.36.109 5000

;Umbenennen in die Zertifikatsnummern
cert 04.crt
key 04.key

; Das War's!
ca ca.crt
;http-proxy-retry # retry on connection failures
;http-proxy [proxy server] [proxy port #]
verb 1
comp-lzo
;tls-auth ta.key 1
persist-key
persist-tun
nobind
proto udp
;dev-node MyTap
dev tap
client
up-delay

[Client Config End]

Struktur:

VPN-Server W2k Gateway 1 W2k Gateway 2
(192.168.36.1:5000) ------- (192.168.36.99) (192.168.36.109)-+
Gentoo Linux (192.168.44.62) ------- (192.168.44.63) |
|
WXP Client |
(192.168.36.100)--+
Port 5000

Jetzt hab ich mit dem Programm CCProxy auf Gateway 2 ein PortForwarding von port 5000 nach 192.168.44.62:5000 und auf Gateway 1 ein PortForwarding auf 192.168.36.1:5000 gelegt.
Verstanden? Ich hoffe mal.
So jetzt sollte die UDP Verbindung von 192.168.36.100 über GW2 und GW1 nach 192.168.36.1 laufen.

Wenn ich jetzt den Server gestartet habe und mich mit dem Client verbinden wil kommt Folgendes:

Client:

Tue May 23 23:35:26 2006 Re-using SSL/TLS context
Tue May 23 23:35:26 2006 LZO compression initialized
Tue May 23 23:35:26 2006 UDPv4 link local: [undef]
Tue May 23 23:35:26 2006 UDPv4 link remote: 192.168.36.109:5000
Tue May 23 23:35:41 2006 SIGTERM[hard,] received, process exiting

Server:



May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 Re-using SSL/TLS context
May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 LZO compression initialized
May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 Control Channel MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:135 ET:32 EL:0 AF:3/1 ]
May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 Local Options hash (VER=V4): 'f7df56b8'
May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 Expected Remote Options hash (VER=V4): 'd79ca330'
May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 TLS: Initial packet from 192.168.36.99:1554, sid=02df3ac9 c606596e
May 23 23:42:25 S23 openvpn[13294]: 192.168.36.99:1554 TLS Error: local/remote TLS keys are out of sync: 192.168.36.99:1554 [1]
May 23 23:42:25 S23 openvpn[13294]: read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
May 23 23:42:25 S23 openvpn[13294]: read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
May 23 23:42:26 S23 openvpn[13294]: read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
May 23 23:42:26 S23 openvpn[13294]: read UDPv4 [ECONNREFUSED]: Connection refused (code=111)




OK, ist jetzt leider nicht so ganz gelungen meine beschreibung, iss aber auch komplex.

Es sei noch angemerkt, im selben Netzt mit 192.168.36.1 verbindet der client ohne weiteres.

Ich habe da noch ne Vermutung: es gibt ja noch die Option "nobind" in der client Config. Vielleicht muss ich ja den Port 5000 angeben.
Aber ich weiss net wie...

So, jetzt bitte, bitte Vorschläge!
Mitglied: 2795
26.02.2007 um 16:01 Uhr
Hi,

da ist ein Punkt den ich nicht verstehe.
Beim Client ist der Port 5000 eingetragen. Im Log vom Server steht
der Port 1554 drin. Vielleicht muss ich das nicht verstehen?
Aber welche Einstellungen hast du in deiner Firewall vorgenommen?

Gruß
Kerl
Bitte warten ..
Ähnliche Inhalte
Netzwerke
OpenVPN TLS
Frage von 121851Netzwerke4 Kommentare

Hallo zusammen, habe mir mir einen OpenVPN Server aufgesetzt und der funktioniert. Habe jetzt mal in die Logdatei gesehen ...

Router & Routing

PfSense mit OpenVPN - in Testumgebung - Fehler TLS Error: TLS key negotiation failed

gelöst Frage von crankcorp86Router & Routing2 Kommentare

Hallo, ich habe dank guter Empfehlungen nun eine pfSense Firewall/Router mit Alix Board. Es funktioniert sehr gut, nun wollte ...

Firewall

Pfsense OpenVpn TLS Failure

gelöst Frage von medikopterFirewall12 Kommentare

Hallo zusammen, ich habe ein Problem mit OpenVPN. Server: Ich bekomme in Client den Fehler : In den Logs ...

Sicherheit

PfSense: OpenVPN Error

Frage von thomasreischerSicherheit5 Kommentare

Hallo zusammen, versuche nun schon seit einer Ewigkeit eine VPN Verbindung zur PfSense herzustellen Vorgegangen bin ich nach dieser ...

Neue Wissensbeiträge
Sicherheit
Adminrechte dank Bug in Intel HD Graphics Treiber
Information von DerWoWusste vor 7 StundenSicherheit

Intel HD graphics 4200 und neuer (4400, 4600 520,530,620, 630,) sind auf jeden Fall betroffen und bereinigte Treiber sind ...

Router & Routing

Endlich: Reines Kabel-TV Modem in D erhältlich !

Information von aqui vor 3 TagenRouter & Routing10 Kommentare

Mit dem Technicolor TC4400-EU Modem sind nun auch Breitband Router ohne integriertes Modem oder Firewalls wie z.B. die pfSense ...

Netzwerkgrundlagen
The Illustrated TLS Connection
Information von Lochkartenstanzer vor 3 TagenNetzwerkgrundlagen1 Kommentar

Moin, Unter findet man eine gelungene Erläuterung von TLS. Fördert sehr das verständnis darüber, was da passiert. lks

Windows 10

Zuverlässiger Remove-AppxProvisionedPackage Ausführen in W10-1803

Tipp von NetzwerkDude vor 5 TagenWindows 104 Kommentare

Moin, Remove-AppxProvisionedPackage hat in 1709 recht zuverlässig funktioniert, in 1803 ist es leider so das es gerne mail failed ...

Heiß diskutierte Inhalte
Windows Server
AD User wird immer wieder gesperrt
Frage von YellowcakeWindows Server20 Kommentare

Hey ich habe einen User (ein GL User - Natürlich was denn sonst) der immer wieder gesperrt wird. Ich ...

Windows Netzwerk
Gruppenrichtlinie für einen PC deaktivieren
gelöst Frage von Florian961988Windows Netzwerk14 Kommentare

Hallo, kleines Problem und immoment finde ich dazu keine Lösung oder mir fällt nicht ein, wie ich es suche ...

Festplatten, SSD, Raid
LSI 9361 Controller, versehentlich virtual Drive am Controller gelöscht
Frage von pixel24Festplatten, SSD, Raid12 Kommentare

Hallo zusammen, gibt es hier einen Experten der sich gut mit LSI MegaRAID auskennt? Ich habe versehentlich im Controller-BIOS ...

Switche und Hubs
OpenSource oder Freeware zur Verwaltung von Switchen
gelöst Frage von JonskezSwitche und Hubs12 Kommentare

Hallo, gibt eine kostenlose Verwaltungssoftware für Switche (überwiegend HP/Aruba)? Es sollte möglich sein, aus der Ferne z.B. die Firmware ...