Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst OWA - Zertifikatsproblem

Mitglied: pyccku

pyccku (Level 1) - Jetzt verbinden

25.03.2008, aktualisiert 18.10.2012, 8084 Aufrufe, 10 Kommentare

Hallo,

folgendes Problem:

Wir haben in der Firma einen Exchange Server laufen auf dem wir OWA betreiben. Der Server verfügt über eine feste IP Adresse. Dazu haben wir bei unserem Provider eine Domainweiterleitung (www.owa-firma.de) auf unseren Server eingerichtet. Das Problem ist nun dass wir auch für www.owa-firma.de ein Zertifikat erstelle haben, was nicht das tut was es eigentlich tun sollte. Jedes Mal wenn mann www.owa-firma.de eingibt kommt eine Warnmeldung dass mann nicht mit www.owa-firma.de kommuniziert sondern mit der IP-Adresse vom Server (mann wird direkt auf die IP-Adresse weitergeleitet, ist eine einfache HTTP-Weiterleitung).

Hier ein Screenshot von der Meldung:
fee944f31c25f652552e386413cf738d-unbenanntwi9 - Klicke auf das Bild, um es zu vergrößern

Wie kann ich das Problem lösen?
Mitglied: filippg
25.03.2008 um 21:11 Uhr
Hallo,

ist dir die Fehlerursache bewusst? Der Browser meckert immer, wenn in der Adresszeile etwas anderes steht als im Zertifikat. Und wenn ihr eine HTTP-Weiterleitung habt, dann steht ja die IP-Adresse in der Addresleiste.
Um den richtigen Name in die Adressleiste zu bekommen fallen mir erstmal zwei Lösungen ein:
1. OWA in einem Frame ausführen. Auf dem Server beim Provider wird eine html-Datei mit einem Frameset hinerlegt, als Source wird euer Server (IP) angegeben. Kann nur gut sein, dass sich OWA dagegen sträubt. Außerdem gibt es Probleme, wenn OWA ein neues Fenster aufmacht. Also: für diesen Fall keine gute Lösung (ausprobieren kannst du es ja mal). Lieber die technisch korrekte Lösung:
2. Anpassen der DNS-Einträge. Euer Provider soll den DNS-Eintrag für die URL so anpassen, dass direkt auf euren Server verwiesen wird. Ich gehe mal davon aus, dass ihr eine statische IP habt, dann ist das kein Problem. Bietet auch jeder besser Provider an, notfalls einfach die Domain zu einem anderen Provider umziehen.

Gruß

Filipp
Bitte warten ..
Mitglied: Dani
25.03.2008 um 21:22 Uhr
Abend,
Das Problem ist nun dass wir auch für www.owa-firma.de ein Zertifikat erstelle haben
Habt ihr das an euerem Windows Server ausgestellt oder im Internet bei VeriSign & Co. gekauft?!
Falls selbstgemacht, ist der Fehler klar. Das Zertifikat ist nirgends bei den Zertserver bekannt und darum meckert auch jeder Browser. Sonst könntest du selber Zertifikate fälschen!
Schau dir einfach mal - im Firefox sehr schön zum Vergleichen - das Zertifikat von https://www.administrator.de/ an und dann deines. Dann siehst du den Unterschied.

Falls ihr das Zerti gekauft habt, Folge fillippg....


Grüße
Dani
Bitte warten ..
Mitglied: pyccku
25.03.2008 um 22:03 Uhr
Hallo,

ist dir die Fehlerursache bewusst? Der
Browser meckert immer, wenn in der
Adresszeile etwas anderes steht als im
Zertifikat. Und wenn ihr eine
HTTP-Weiterleitung habt, dann steht ja die
IP-Adresse in der Addresleiste.
Um den richtigen Name in die Adressleiste zu
bekommen fallen mir erstmal zwei
Lösungen ein:
1. OWA in einem Frame ausführen. Auf
dem Server beim Provider wird eine html-Datei
mit einem Frameset hinerlegt, als Source wird
euer Server (IP) angegeben. Kann nur gut
sein, dass sich OWA dagegen sträubt.
Außerdem gibt es Probleme, wenn OWA ein
neues Fenster aufmacht. Also: für diesen
Fall keine gute Lösung (ausprobieren
kannst du es ja mal). Lieber die technisch
korrekte Lösung:
2. Anpassen der DNS-Einträge. Euer
Provider soll den DNS-Eintrag für die
URL so anpassen, dass direkt auf euren Server
verwiesen wird. Ich gehe mal davon aus, dass
ihr eine statische IP habt, dann ist das kein
Problem. Bietet auch jeder besser Provider
an, notfalls einfach die Domain zu einem
anderen Provider umziehen.

Gruß

Filipp


Hallo,

erstmal danke für die Lösungsvorschläge. Das mit dem Frame hab ich mir auch schon überlegt, leider klappt das ganze nicht so wie es soll, der Fehler kommt trotzdem.
Den zweiten Lösungsvorschlag hatte ich auch schon im Kopf, hab mich bei unserem Provider (1und1) aber noch nicht informiert ob das möglich ist. Hierzu hätte ich gleich eine Frage, der Provider leitet dann die Domain einfach an unsere IP-Adresse weiter, OWA ist aber unter http://ipadresse/exchange zu erreichen, wie kriege ich das wiederum in den Griff? kann der Provider auch direkt auf einen virtuellen Ordner weiterleiten?


MfG
Bitte warten ..
Mitglied: pyccku
25.03.2008, aktualisiert 18.10.2012
Abend,
> Das Problem ist nun dass wir auch
für www.owa-firma.de ein Zertifikat
erstelle haben
Habt ihr das an euerem Windows Server
ausgestellt oder im Internet bei VeriSign
& Co. gekauft?!
Falls selbstgemacht, ist der Fehler klar.
Das Zertifikat ist nirgends bei den
Zertserver bekannt und darum meckert auch
jeder Browser. Sonst könntest du selber
Zertifikate fälschen!
Schau dir einfach mal - im Firefox sehr
schön zum Vergleichen - das Zertifikat
von https://www.administrator.de/ an und dann
deines. Dann siehst du den Unterschied.

Falls ihr das Zerti gekauft habt, Folge
fillippg....


Grüße
Dani


Hallo,

@ Dani

ich habe das Zertifikat bei Startcom erstellt. Hierzu gibt es auch eine Anleitung
https://www.administrator.de/wissen/ssl-aktivierung-des-exchange-owa-200 ...

MfG
Bitte warten ..
Mitglied: filippg
25.03.2008 um 22:08 Uhr
ich gleich eine Frage, der Provider leitet
dann die Domain einfach an unsere IP-Adresse
weiter, OWA ist aber unter
http://ipadresse/exchange zu erreichen, wie
kriege ich das wiederum in den Griff? kann
der Provider auch direkt auf einen virtuellen
Ordner weiterleiten?

Nein. Der Provider kann dann nicht auf einen bestimmten Unterordner verweisen.
Wieder zwei Lösungen:
1. Du hinterlegst im Root eine HTTP-Weiterleitung auf das Unterverzeichnis. Da der Server gleich bleibt gibt das mit dem Zertifikat keine Probleme.
2. Du legst das virtual Directory des IIS entsprechend fest, so dass die URL in Zukunft also das /exchange nicht mehr benötigt. Weiß ich auch nicht auswenig wie das geht.

Gruß

Filipp
Bitte warten ..
Mitglied: Dani
25.03.2008 um 22:14 Uhr
Nein. Der Provider kann dann nicht auf einen bestimmten Unterordner verweisen.
Indirekt...du könntest einfach eine Subdomain outlook.deinedomain.de einrichten. Dort wiederrum ein Auto. Verweis auf https://deineip/exchange/. Somit kann sich das jeder MA merken. Unser Provider supportet sowas... Finde zwar nicht gerade sauber, aber es ist für die MA am Einfachsten.


Grüße
Dani
Bitte warten ..
Mitglied: pyccku
25.03.2008 um 22:39 Uhr


2. Du legst das virtual Directory des IIS
entsprechend fest, so dass die URL in Zukunft
also das /exchange nicht mehr benötigt.
Weiß ich auch nicht auswenig wie das
geht.

Gruß

Filipp

Gibt es dazu irgendwo eine Anleitung? Ich bin leider Anfänger auf diesem Gebiet...


Welche Provider sind bei solchen Sachen eigentlich empfehlenswert?


Und mal eine andere Frage, wenn ich ein Zertifikat selber erstelle, habe ich dann irgendwelche Nachteile außer dass die Mitarbeiter dann dauert eine Meldung kriegen dass das Zertifikat von einer nicht vertrauenswürdigen Stelle ausgestellt wurde?

MfG
Bitte warten ..
Mitglied: Dani
26.03.2008 um 09:23 Uhr
Moin,
also das mit dem virutellen Verzeichnis klappt nur, wenn dein Provider die Subdomain in seinem DNS auf deine feste IP-Adresse unlenkt. Somit brauchst du eigentlich nur im virtuellen Host eine Umleitung auf die http://ip/exchange/ machen. Jedoch ist das eigentlich das selbe wie ich schon beschrieben habe, nur dass eben alles beim Provider liegt und du somit ein Problem weniger hast.

Welche Provider sind bei solchen Sachen eigentlich empfehlenswert?
Also wir haben z.B. alle Kundenprojekte, egal wie verrückt diese sind, bei einem kl. Hoster. Wenn du Interesse hast, schreib einfach ne PN. Ich poste ungern Providerlinks in Beiträge.


Grüße
Dani
Bitte warten ..
Mitglied: pyccku
26.03.2008 um 11:47 Uhr
Moin,
also das mit dem virutellen Verzeichnis
klappt nur, wenn dein Provider die Subdomain
in seinem DNS auf deine feste IP-Adresse
unlenkt. Somit brauchst du eigentlich nur im
virtuellen Host eine Umleitung auf die
http://ip/exchange/ machen. Jedoch ist das
eigentlich das selbe wie ich schon
beschrieben habe, nur dass eben alles beim
Provider liegt und du somit ein Problem
weniger hast.
Grüße
Dani

Hallo,

erstmal vielen Danke für Hilfe.

Wir haben keine Subdomain sondern eine normale Domain alá www.owa-firma.de die mittlerweile direkt, durch einen A-Record, auf die IP von unserem Server weiterleitet. Das heisst wenn ich im Browser www.owa-firma.de/exchange eingebe lande ich direkt im OWA. Das mit der Umleitung auf http://ip/exchange scheint unser Provider nicht zu unterstützen, deswege müsste ich wissen wie ich das direkt auf dem Exchange einrichten kann.

MfG
Bitte warten ..
Mitglied: pyccku
26.03.2008 um 12:46 Uhr

Hallo,

erstmal vielen Danke für Hilfe.

Wir haben keine Subdomain sondern eine
normale Domain alá www.owa-firma.de
die mittlerweile direkt, durch einen
A-Record, auf die IP von unserem Server
weiterleitet. Das heisst wenn ich im Browser
www.owa-firma.de/exchange eingebe lande ich
direkt im OWA. Das mit der Umleitung auf
http://ip/exchange scheint unser Provider
nicht zu unterstützen, deswege
müsste ich wissen wie ich das direkt auf
dem Exchange einrichten kann.

MfG

Ok Problem wurde gelöst, hier eine Anleitung. Ist nur eine simple Weiterleitung unter den Eigenschaften der Standardwebseite im IIS.
http://support.microsoft.com/kb/319878/de

MfG
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Zertifikatsproblem
Frage von gk3000Exchange Server1 Kommentar

Hallo ! Bitte um Hilfe. Irgendwas ist bei meinem Exchange Zertifikat falsch. (Fehlermeldung: dieses zertifikat ist nicht gültig hostname ...

Verschlüsselung & Zertifikate
SSL oder Zertifikatsproblem bei Handy?
Frage von PedantVerschlüsselung & Zertifikate7 Kommentare

Hallo, erst seit relativ kurzer Zeit habe ich bei meinem Handytarif auch eine Datenflat, nicht wegen des Handys, sondern ...

Windows Server
Zertifikatsproblem mit Radius
gelöst Frage von Dom1091Windows Server1 Kommentar

Guten Abend, hätte etwas bedarf an Hilfe. habe ein WLAN aufgebaut bei dem die Authentifizierung über Windows Radius. Aufgrund ...

Windows Server
Zertifikatsproblem Secunia CSI
Frage von IviewWindows Server1 Kommentar

Hallo, dieses Forum ist sehr gut und so manche Hilfe habe ich schon bekommen. Ausgangssituation: Vorhanden ist ein Windows ...

Neue Wissensbeiträge
E-Mail
Neueste Masche der Bad Guys: Offene Erpressung
Information von the-buccaneer vor 1 TagE-Mail14 Kommentare

"Warum den komplizierten Weg über einen Kryptotrojaner nehmen, wenn man die Leute auch direkt erpressen kann?" haben sich wohl ...

Viren und Trojaner
Neues ct-desinfect 2018 erschienen
Information von Lochkartenstanzer vor 1 TagViren und Trojaner

Moin, heise hat eine neues Sonderheft Desinfect veröffentlicht (9,90€/12,90€) . Falls jemand öfter mal Kisten "säubern" muß ist das ...

Sicherheit

Ransomware legt Fluginformationssystem des Airport Bristol lahm

Information von kgborn vor 1 TagSicherheit

Da war wohl eine Wochenend-Schicht für die Flughafen IT angesagt. Ein Ransomware-Befall bzw. ein Hackerangriff sorgte dafür, dass drei ...

Windows 10

Windows 10 Microcode-Updates (13.9.2018) und WSUS- bzw. KB-Artikel-Chaos

Information von kgborn vor 3 TagenWindows 10

Es gibt neue #Microcode #Updates #KB4100347, #KB4090007, #KB4091663, #KB4091664 und #KB4091666 für Intel CPUs für #Windows10 - und jede ...

Heiß diskutierte Inhalte
Firewall
Blocken illegaler Film-Streams
gelöst Frage von CoreknabeFirewall19 Kommentare

Moin Wissende, unsere kleine Hochschule möchte gern das illegale Streaming von Kinofilmen und Serien unterbinden. Wir sperren bisher alle ...

Windows Server
2012 R2 Server Keine Anmeldung möglich Meldung: Laut den Sicherheitsrichtlinien auf diesem PC sollen informationen zur letzten interaktiven Anmeldung angezeigt werden
Frage von Speedy18A4Windows Server17 Kommentare

Hallo, ich habe vor einigen Wochen einen zweiten Domain Controller zu meiner Domain hinzugefügt. Funktionierte alles wunderbar. Auch die ...

iOS
Virus auf iphone
Frage von jensgebkeniOS16 Kommentare

hallo gemeinschaft, habe einen virus auf meinem iphone es kommen zwei meldungsfenster 1. online-2018-software-free.win 2. wpform.com - please click ...

Video & Streaming
Günstige Alternative zu Barco ClickShare
Frage von Leo-leVideo & Streaming15 Kommentare

Hallo zusammen, wir suchen eine vernünftige Lösung, um bei uns die Kabelage zu beseitigen und um einfach etwas komfortabler ...