Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

PPPoE Verbindungsaufbau durch GRE Tunnel?

Mitglied: 82848

82848 (Level 1)

23.09.2009 um 15:56 Uhr, 4399 Aufrufe, 3 Kommentare

Hallo wir haben dieses Beispiel ausprobiert und es funktioniert so weit, wenn man den PCs auf beiden Seiten die passenden Gateways einträgt, aber wie bekommt man einen PPPoE Verbindungsaufbau durch einen GRE Tunnel.
Ist es möglich einen Broadcast zur Initialisierung eines PPPoE Verbindungsaufbaus (auf Layer2) transparent auf die andere Tunnelseite zu bekommen?
PPPoE Client und PPPoE-Server sind nämlich räumlich getrennt, aber über ein "Transfernetz" miteinander verbunden, nun sollen die Broadcasts aber gezielt vom Client zum Server, ohne dabei durch den Rest des Netzes zu wildern...

berlin(config)#int tunnel 0
berlin(config-if)#ip address 192.168.222.1 255.255.255.0
berlin(config-if)#tunnel source 172.16.0.1
! Die Quelle für den Tunnel, also die
! IP des physikalischen Interfaces von Berlin
berlin(config-if)#tunnel destination 172.22.0.1
! Die Zieladresse für den Tunnel, also die
! IP des physikalischen Interfaces von Kreuzberg
berlin(config-if)#tunnel mode gre ip
berlin(config-if)#no shutdown
berlin(config-if)#exit
berlin(config)#ip route 192.168.55.0 255.255.255.0 tunnel 0
! Der Traffic zu 192.168.55.0/24 wird durch den Tunnel geschickt
berlin(config)#ip route 172.22.0.0 255.255.255.0 s0
! Die Zieladresse des Tunnels (also Kreuzberg)
! muss auf Berlin bekannt sein (entweder über ein
! Routing Protokoll oder wie in diesem Beispiel über statische Routen)


kreuzberg(config)#int tunnel 0
kreuzberg(config-if)#ip address 192.168.222.2 255.255.255.0
kreuzberg (config-if)#tunnel source 172.16.0.1
! Die Quelle für den Tunnel, also die
! IP des physikalischen Interfaces von Kreuzberg
kreuzberg (config-if)#tunnel destination 172.22.0.1
! Die Zieladresse für den Tunnel, also die
! IP des physikalischen Interfaces von Berlin
kreuzberg (config-if)#tunnel mode gre ip
kreuzberg (config-if)#no shutdown
kreuzberg (config-if)#exit
kreuzberg (config)#ip route 192.168.0.0 255.255.255.0 tunnel 0
! Der Traffic zu 192.168.0.0/24 wird durch den Tunnel geschickt
kreuzberg (config)#ip route 172.16.0.0 255.255.255.0 s0
! Die Zieladresse des Tunnels (also Berlin)
! muss auf Kreuzberg bekannt sein (entweder über ein
! Routing Protokoll oder wie in diesem Beispiel über statische Routen)

Dank im voraus
Mitglied: aqui
23.09.2009 um 16:03 Uhr
PPPoE ist ein Point to Point Protocoll wie der Name das schon selber sagt. Es ist also zu bezeifeln das das über einen gerouteten GRE Tunnel rennt. Wenn dann vermutlich nur wenn man bridged über den GRE.

Das sieht nach einem Cisco aus oben ?! Was sagt denn ein debup gre hast du dir das schon mal angesehen wenn der PPPoE Verbindungsaufbau startet.
Hast du alternativ mal ein Bridging Probiert über den GRE sofern das überhaupt zu konfigurieren ist ?!
Bitte warten ..
Mitglied: 82848
23.09.2009 um 16:51 Uhr
Leider wird Bridging über Tunnel Interface nicht unterstützt.
Und nu?
Bitte warten ..
Mitglied: dog
23.09.2009 um 21:41 Uhr
MikroTik-Router bieten genau für sowas EoIP-Tunnel, was aber ein properitäres Feature ist.
Ähnliches sollte aber auch mit L2TP möglich sein...
Bitte warten ..
Ähnliche Inhalte
Router & Routing

Jumbo-Frames über GRE-Tunnel i.V.m. MPLS möglich?

gelöst Frage von LordGurkeRouter & Routing3 Kommentare

Hallo, ich habe hier zwei Standorte, die normalerweise per angemieteter MPLS verbunden sind. Über diesen Transport sind auch Jumbo-Frames ...

DSL, VDSL

Telekom PPPoE Tunnel bricht ständig zusammen

gelöst Frage von Phill93DSL, VDSL13 Kommentare

Hallo, seit gestern morgen bricht mein PPPoE Tunnel zur Telekom reproduzierbar zusammen. Nach jedem Verbinden hab ich ca 5 ...

Windows Netzwerk

IPSec VPN oder GRE

gelöst Frage von winlinWindows Netzwerk21 Kommentare

Hi (2*gelöst)^34 Edit Biber Verkürzte "gelöst"-Schreibweise /Edit

LAN, WAN, Wireless

FritzBOX VPN FritzBox kein Verbindungsaufbau

gelöst Frage von Dett18LAN, WAN, Wireless17 Kommentare

Einen schönen Sonnigen guten Tag liebe Gemeinde. Leider habe ich ein VPN Problem zwischen zwei Fritz!Boxen. Nach einer Woche ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs9 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Debian
Wie finde ich den betroffenen user
Frage von ProtectedDebian8 Kommentare

Hallo, Wie kann ich den User finden der dies verursacht hat? Betriebsystem ist Debian 7 your Server/Customer with the ...

Voice over IP
Vodafone IP Anlagenanschluss - TK-Anlage einrichten
Frage von BytedreherVoice over IP8 Kommentare

Moin Zusammen, wir hatten gestern bei uns die Umstellung auf den neuen IP Anschluss bei Vodafone. Vodafone IP Anlagenanschluss ...