Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem bei start explorer aus einer Batch

Mitglied: onegasee59

onegasee59 (Level 2) - Jetzt verbinden

11.06.2013, aktualisiert 10:20 Uhr, 1870 Aufrufe, 10 Kommentare

Hallo,

habe da ein ungelöstes Problem beim NEU-Starten des Explorers.

Ich benutze eine batch die ich direkt auf eine ext Festplatte packe und von dort starte per Verknüpfung als Adiminstrator - sonst funktioniert es nicht bei WIN 7.

ich nutze das Tool aus Sysinternals

01.
"%startpfad%pskill.exe" explorer.exe 
02.
start "" explorer.exe
Soweit funktioniert alles ... ABER nach dem Neustart des Explorers fehlen im Systray etliche Programme /Symbole.

Wie kann man das korrigieren?



vielen Dank für jeden Tip



Mitglied: 106543
11.06.2013 um 10:21 Uhr
Hi,

ich kann dir leider nicht weiterhelfen, aber mal eine Fage
wieso den Explorer überhaupt killen und neu starten ? :D

Grüße
Exze
Bitte warten ..
Mitglied: onegasee59
11.06.2013, aktualisiert um 11:52 Uhr
Weil der Explorer während der Batch-Aktion im Hintergrund geöffnet ist. Ich will aber nach Beenden der Batch auf der ext Fesplatte das der Explorer geschlossen und der Desktop wie nach Neustart des Rechners wiederhergestellt wird.
Bitte warten ..
Mitglied: colinardo
11.06.2013, aktualisiert um 10:42 Uhr
Hallo onegasee59,
Zitat von onegasee59:
Soweit funktioniert alles ... ABER nach dem Neustart des Explorers fehlen im Systray etliche Programme /Symbole.

Wie kann man das korrigieren?
nur durch Abmelden und wieder Anmelden...
Das liegt meistens an den Programmierern die diesen Zustand in Ihren Programmen nicht berücksichtigen ...

Grüße Uwe
Bitte warten ..
Mitglied: Penny.Cilin
11.06.2013 um 10:56 Uhr
Hallo,

Du beendest den Explorer des Anwenders und startest einen neuen Process als Administrator.
Wenn den ursprünglichen Desktop des Anwenders wiederherstellen willst, brauchst Du nur den Explorer unter dem Kontext des Benutzer neu zu starten.
Du kannst als Benutzer den Explorer, welcher unter Deinem Kontext aktiv ist auch selber beenden und neu starten.
Dazu brauchst auch nicht die Sysinternals Tools. Das kannst Du unter Win 7 auch mit Bordmitteln machen.

Mittels
tasklist | find/i "Explorer"
ermittels Du die Process ID. Und mittels
taskkill <pid>
beendest Du den Process.
Machst Dir eine kleine Batchdatei unn fertisch...


Gruss Penny.
Bitte warten ..
Mitglied: onegasee59
11.06.2013, aktualisiert um 11:31 Uhr
Hallo colinardo

Mist -- sowas dachte ich mir schon fast.

OK muss ich wohl damit leben.

Trotzdem Danke
Bitte warten ..
Mitglied: onegasee59
11.06.2013, aktualisiert um 12:02 Uhr
Hallo Penny

Die Batch muss ja schon als Admin gestartet werden - sonst funktioniert sie nicht unter WIN 7
Und ich muss gewähleisten das die batch unter WIN XP bis WIN 8 funktioniert.
Daher ist sind mir pstools aus sysinternals lieber.

Der letzte Schritt - schließen des Explorers und wiederherstellen des Desktop wie nach einem Rechnerneustart funktioniert ja auch insoweit das der Desktop wiederhergestellt wird.
Auch die Taskleiste hat danach wieder alle Symbole, aber im Systray (rechts) sind leider nicht mehr alle Symbole vorhanden.

Dabei ist es übrigens unerheblich ob mit oder ohne Bordmittel.

Es muss einen Zusammenhang zwischen Explorer, Taskleiste und Systray geben - nur welchen?

Ich befürchte colinardo wird recht behalten - per Batch wohl so nicht realisierbar.

Trotzdem Danke
Bitte warten ..
Mitglied: Penny.Cilin
11.06.2013 um 12:18 Uhr
Zitat von onegasee59:
Hallo Penny

Die Batch muss ja schon als Admin gestartet werden - sonst funktioniert sie nicht unter WIN 7

Wieso muß die Batch als Admin gestartet werden?
Hast Du mal probiert, via Task Manager den Explorer zu canceln und neu zu starten?
Da benötigst Du auch keine Adminbereechtigungen.


Gruss Penny.
Bitte warten ..
Mitglied: goscho
11.06.2013 um 12:33 Uhr
Mahlzeit
Zitat von Penny.Cilin:
> Zitat von onegasee59:
> ----
> Hallo Penny
>
> Die Batch muss ja schon als Admin gestartet werden - sonst funktioniert sie nicht unter WIN 7

Wieso muß die Batch als Admin gestartet werden?
Hast Du mal probiert, via Task Manager den Explorer zu canceln und neu zu starten?
Da benötigst Du auch keine Adminbereechtigungen.
Es ist sogar so, dass man nicht mal eben einen Explorer als Admin auf W7/8 starten kann.
Hier steht es besser beschrieben.
Bitte warten ..
Mitglied: colinardo
11.06.2013, aktualisiert um 12:42 Uhr
Leute bitte lest mal die Frage, darum gehts hier jetzt doch gar nicht ...
Fakt ist, das die Taskleisten-Symbole von bestimmten Programmen nach dem Absturz des Explorers nicht wieder erscheinen, weil das jeweilige Programm dieses Event nicht implementiert hat und somit beim Neustart der Shell die Symbole nicht vorhanden sind, die Programme aber weiterhin im Hintergrund laufen.
Hatte das selbe Problem bei einem eigenen Programm. Man kann dieses Windows-Event abfangen und beim Neustart der Shell das Icon wiederherstellen.
Bitte warten ..
Mitglied: onegasee59
11.06.2013, aktualisiert um 13:39 Uhr
Zitat von colinardo:
Leute bitte lest mal die Frage, darum gehts hier jetzt doch gar nicht ...
Fakt ist, das die Taskleisten-Symbole von bestimmten Programmen nach dem Absturz des Explorers nicht wieder erscheinen, weil das
jeweilige Programm dieses Event nicht implementiert hat und somit beim Neustart der Shell die Symbole nicht vorhanden sind, die
Programme aber weiterhin im Hintergrund laufen.
Hatte das selbe Problem bei einem eigenen Programm. Man kann dieses Windows-Event abfangen und beim Neustart der Shell das Icon
wiederherstellen.


Danke - Du hast es verstanden.
Die Symbole fehlen, die Programme Tools selbst sind weiterhin im Hintergrund am Arbeiten.
Ok also lebe ich damit - es gibt schlimmeres

Danke an Alle fürs mitmachen.

Ich markiere dann mal gelöst

mfg
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Problem mit Batch - starten einer Exe
Frage von jan99Batch & Shell2 Kommentare

Moin ! ich habe auf einem Server eine EXE liegen die immer lokal aktuell gestartet werden soll und dafür ...

Batch & Shell

Batch aus Batch mit anderen Rechten starten

gelöst Frage von thilo-55Batch & Shell15 Kommentare

Hallo zusammen, bin schier am verzweifeln: System ist Win7 mit Benutzer "User" mit user-rechten und "Admin" mit admin-rechten (wer ...

Webbrowser

Starte bei Opera ein Browser Spiel und will über Internet Explorer starten

Frage von icechillaWebbrowser2 Kommentare

Guten Abend, folgendes Problem ich möchte bei Opera ein Brower Spiel starten dabei wird dann das Spiel für den ...

Webbrowser

Internet Explorer schliesst direkt bei Start

Frage von gabeBUWebbrowser10 Kommentare

Hallo Zusammen Ich habe eine WIndows 8.1 64-Bit maschine mit aktuellen Updates. Leider kann ich meinen Internet Explorer nicht ...

Neue Wissensbeiträge
Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 2 StundenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 5 StundeniOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 2 TagenSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++28 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL19 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...

Hyper-V
HyperV DC + DNS + AC
gelöst Frage von HardstylesHyper-V16 Kommentare

Hallo kann mir jemand sagen wieso meine Domänen Computer kein Internetzugang erhalten? Ich hab hier ein Server wo die ...