Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit einer CSS-Datei

Mitglied: 4263

4263 (Level 1)

01.11.2004, aktualisiert 12.11.2004, 6178 Aufrufe, 6 Kommentare

WICHITG: Die normalen Klammern sind in der richtigen Datei solche Klammern: {} ausser diese bei "rgb(0,0,0)". das gleichheitszeichen (=) wird zu einem doppelpunkt ( und solche [ ] werden zu solchen < > !!
das ist nötig, das der browser alles als Text und nicht als Befehl aufnimmt.

hallo zusammen!

ich habe heute mal ne neue css datei für meine homepage gemacht, abe rirgendwie funktioniert sie nicht so ganz. ich kann sie hier leider nicht reinschreinben, da es der browser sonst nicht anzeigt, sondern einfach alles untendran auslässt....

auf jeden fall beginnt sie etwa so:

BODY
(
background-color= rgb(0,0,0);
FONT-FAMILY: Arial, Helvetica
)

ganz oben würde noch [style] stehen.
nun zu meinem problem: ich wollte einen schwarzen hintergrund, und da rgb(0,0,0) schwarz ist, habe ich das auch so eigegeben. nun bleibt der hintergrund aber trozdem weiss. dazu kommt, dass es auch nicht Arial sondern sonst eine schrift (glaube Times New Roman) anzeigt wird. auch das sollte es ja nicht, da Arial an erster stelle steht. wieso das?

ich habe es dann so versucht:

MAIN-BODY
(
background-color= rgb(0,0,0)
)
BODY
(
background-color= rgb(0,0,0);
FONT-FAMILY= Arial, Helvetica
color= #FF9F00
)

jetzt läuf alles. aber wieso ist das nötig? ich kenne keine "professionelle" css datei, die das hat.


greets racer2004
Mitglied: Midivirus
07.11.2004 um 20:26 Uhr
Hallöle!

Ich verweise gern auf die Seite http://style-sheets.de/css/ welche mir damals CSS beigebracht hat ... die ist sogar besser, als mein Lehrer es mir in Informatik beibringen wollte.

zu deinem kleinen Problem:
die Parameter zu jeder Klasse werden mit geschweiften Klammern geöffnet!

BODY{background-color:black;}

dieses bewirkt, dass der BG immer schwarz ist, fügst du da jetzt noch einen zusätzlichen Paramter:

BODY{background-color:black;font-family:'comic sans ms';}

ein, so ist die Hauptschriftart sogar auch noch festgelegt.

Bei Fragen, einfach posten! oder direkt an meine Mailadresse!

Midivirus
Bitte warten ..
Mitglied: 4263
08.11.2004 um 20:04 Uhr
hi midvirius!

ich habe es schon in geschweiften klammern geschrieben.

aber ich weiss ja auch nicht, jetzt hab ich mal background-color: black geschrieben, und es ging... naja, ich weiss halt auch nicht. ich rgb(0,0,0) nicht das selbe??

greets racer2004
Bitte warten ..
Mitglied: Midivirus
09.11.2004 um 21:39 Uhr
Also auf der von mir bekanntgegebener URL steht alles... wie du die Tags handhaben sollst!

Also erstmal darfst du da kein "=" Zeichen setzen, sondern der ":" ist das Trennzeichen:

background-color:rgb(0,0,0);

oder halt

background-color:black

Schau dir mal die Doku an, die iz geilo!

Wie lautet die URL deiner Seite??? Kann mir das dann mal anschauen!

Midivirus
Bitte warten ..
Mitglied: 4263
12.11.2004 um 11:58 Uhr
hi nochmal
Bitte warten ..
Mitglied: 4263
12.11.2004 um 11:58 Uhr
hi nochmal
Bitte warten ..
Mitglied: 4263
12.11.2004 um 12:02 Uhr
sorry wegen dem vorhin... ich habe TAB gedrückt, und dann eingabetaste, und weg war es...

also, ich habe ganz oben geschrieben, dass = zu : wird, steht da.... danke nochmals, aber es geht jetzt. tolle seite, kann man gut lernen

die URL zu meiner page: http://www.racer2004.ch.vu aber das ist noch die alte, ich mache ebe gerade eine neue jetzt mit css datein und flashs, etc.... kannst ja mal reinschauen. und nicht vergessen: immer ins GB schreiben


greets racer2004
Bitte warten ..
Ähnliche Inhalte
HTML

CSS 3 - "viewport" Kein gültiges CSS?

gelöst Frage von ukodusHTML2 Kommentare

Hey Leute, gerade hab ich den Code (@viewport { }) durch den CSS-Überprüfer ) durchgejagt und er entgegnete: "Einlese-Fehler ...

CSS

CSS Problem

gelöst Frage von michi1983CSS2 Kommentare

Hallo Admins, eventuell kann mir ja hier einer weiterhelfen, ich stehe offenbar auf der Leitung. Auf folgender Website (die ...

CSS

Hilfe bei CSS

gelöst Frage von emeriksCSS8 Kommentare

Hi, vorne weg: Bin in HTML und CSS nicht so die Leuchte. Ich will bloß ein paar Reports erstellen ...

CSS

CSS Verständnisproblem

gelöst Frage von 127944CSS14 Kommentare

Hallo liebe CSS-Gurus, ich habe diesen Code 1:1 übernommen. (ich versuche noch immer mich in CSS einzuarbeiten) Was kann ...

Neue Wissensbeiträge
Windows 10

Blackscreen nach dem Update von 1809 auf 1809 wenn der Rechner aus dem Standby gestartet wird

Tipp von FSX2010 vor 19 StundenWindows 104 Kommentare

Habt ihr den Samsung Treiber "Samsung_NVM_Express_Driver_3.0" installiert sollte dieser für 1809 deinstalliert werden da dieser nicht kompatibel ist. Der ...

Utilities
Teamviewer 14 Verbindungsprobleme mit Proxy
Tipp von PeterleB vor 2 TagenUtilities

Nach dem Umstieg von Version 13 auf 14 wollte sich TV nicht mehr mit dem Netz verbinden, ignorierte offenbar ...

Administrator.de Feedback
Unsere Datenbank wurde umgestellt
Information von Frank vor 2 TagenAdministrator.de Feedback5 Kommentare

Hallo User, ich habe in der Nacht unsere Datenbank umgestellt. D.h. neue Version (MySQL 8) und andere Örtlichkeit. Sollte ...

Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 4 TagenSonstige Systeme8 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Heiß diskutierte Inhalte
Vmware
Gebrauchten ESXi- Server verkaufen: Festplatten DSGVO-konform löschen?
Frage von l.scheperVmware20 Kommentare

Hallo, wir möchten einen gebrauchten FUJITSU Server verkaufen. Auf dieser Maschine ist noch ein installiertes ESXi 5.1 und ne ...

Router & Routing
Dediziertes ISP -Routing
gelöst Frage von niLuxxRouter & Routing13 Kommentare

Liebe Community, Ich hätte eine kurze Frage an euch. Durch verschiedene Umstände kann es nun sein, dass sich zwei ...

Samba
Linux Server und Windows Linux Client
gelöst Frage von 137898Samba12 Kommentare

Hallo, ich bräuchte dringend bei der Aufgabe etwas Hilfe. Die Firma XYZ besteht auf zwei Abteilungen Logistik und Technik ...

Windows Server
Windows Server 2012 R2 Komponentenspeicher wurde beschädigt. Inplace Upgrade?
Frage von DeRo93Windows Server11 Kommentare

Hallo liebes Forum, Wir besitzen einen Domänencontroller der auf einem Windows Server 2012 R2 läuft. Dadurch, dass alle Windows ...