Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit einer CSS-Datei

Mitglied: 4263

4263 (Level 1)

01.11.2004, aktualisiert 12.11.2004, 6161 Aufrufe, 6 Kommentare

WICHITG: Die normalen Klammern sind in der richtigen Datei solche Klammern: {} ausser diese bei "rgb(0,0,0)". das gleichheitszeichen (=) wird zu einem doppelpunkt ( und solche [ ] werden zu solchen < > !!
das ist nötig, das der browser alles als Text und nicht als Befehl aufnimmt.

hallo zusammen!

ich habe heute mal ne neue css datei für meine homepage gemacht, abe rirgendwie funktioniert sie nicht so ganz. ich kann sie hier leider nicht reinschreinben, da es der browser sonst nicht anzeigt, sondern einfach alles untendran auslässt....

auf jeden fall beginnt sie etwa so:

BODY
(
background-color= rgb(0,0,0);
FONT-FAMILY: Arial, Helvetica
)

ganz oben würde noch [style] stehen.
nun zu meinem problem: ich wollte einen schwarzen hintergrund, und da rgb(0,0,0) schwarz ist, habe ich das auch so eigegeben. nun bleibt der hintergrund aber trozdem weiss. dazu kommt, dass es auch nicht Arial sondern sonst eine schrift (glaube Times New Roman) anzeigt wird. auch das sollte es ja nicht, da Arial an erster stelle steht. wieso das?

ich habe es dann so versucht:

MAIN-BODY
(
background-color= rgb(0,0,0)
)
BODY
(
background-color= rgb(0,0,0);
FONT-FAMILY= Arial, Helvetica
color= #FF9F00
)

jetzt läuf alles. aber wieso ist das nötig? ich kenne keine "professionelle" css datei, die das hat.


greets racer2004
Mitglied: Midivirus
07.11.2004 um 20:26 Uhr
Hallöle!

Ich verweise gern auf die Seite http://style-sheets.de/css/ welche mir damals CSS beigebracht hat ... die ist sogar besser, als mein Lehrer es mir in Informatik beibringen wollte.

zu deinem kleinen Problem:
die Parameter zu jeder Klasse werden mit geschweiften Klammern geöffnet!

BODY{background-color:black;}

dieses bewirkt, dass der BG immer schwarz ist, fügst du da jetzt noch einen zusätzlichen Paramter:

BODY{background-color:black;font-family:'comic sans ms';}

ein, so ist die Hauptschriftart sogar auch noch festgelegt.

Bei Fragen, einfach posten! oder direkt an meine Mailadresse!

Midivirus
Bitte warten ..
Mitglied: 4263
08.11.2004 um 20:04 Uhr
hi midvirius!

ich habe es schon in geschweiften klammern geschrieben.

aber ich weiss ja auch nicht, jetzt hab ich mal background-color: black geschrieben, und es ging... naja, ich weiss halt auch nicht. ich rgb(0,0,0) nicht das selbe??

greets racer2004
Bitte warten ..
Mitglied: Midivirus
09.11.2004 um 21:39 Uhr
Also auf der von mir bekanntgegebener URL steht alles... wie du die Tags handhaben sollst!

Also erstmal darfst du da kein "=" Zeichen setzen, sondern der ":" ist das Trennzeichen:

background-color:rgb(0,0,0);

oder halt

background-color:black

Schau dir mal die Doku an, die iz geilo!

Wie lautet die URL deiner Seite??? Kann mir das dann mal anschauen!

Midivirus
Bitte warten ..
Mitglied: 4263
12.11.2004 um 11:58 Uhr
hi nochmal
Bitte warten ..
Mitglied: 4263
12.11.2004 um 11:58 Uhr
hi nochmal
Bitte warten ..
Mitglied: 4263
12.11.2004 um 12:02 Uhr
sorry wegen dem vorhin... ich habe TAB gedrückt, und dann eingabetaste, und weg war es...

also, ich habe ganz oben geschrieben, dass = zu : wird, steht da.... danke nochmals, aber es geht jetzt. tolle seite, kann man gut lernen

die URL zu meiner page: http://www.racer2004.ch.vu aber das ist noch die alte, ich mache ebe gerade eine neue jetzt mit css datein und flashs, etc.... kannst ja mal reinschauen. und nicht vergessen: immer ins GB schreiben


greets racer2004
Bitte warten ..
Ähnliche Inhalte
HTML

CSS 3 - "viewport" Kein gültiges CSS?

gelöst Frage von ukodusHTML2 Kommentare

Hey Leute, gerade hab ich den Code (@viewport { }) durch den CSS-Überprüfer ) durchgejagt und er entgegnete: "Einlese-Fehler ...

CSS

CSS Problem

gelöst Frage von michi1983CSS2 Kommentare

Hallo Admins, eventuell kann mir ja hier einer weiterhelfen, ich stehe offenbar auf der Leitung. Auf folgender Website (die ...

CSS

Hilfe bei CSS

gelöst Frage von emeriksCSS8 Kommentare

Hi, vorne weg: Bin in HTML und CSS nicht so die Leuchte. Ich will bloß ein paar Reports erstellen ...

CSS

CSS Verständnisproblem

gelöst Frage von 127944CSS14 Kommentare

Hallo liebe CSS-Gurus, ich habe diesen Code 1:1 übernommen. (ich versuche noch immer mich in CSS einzuarbeiten) Was kann ...

Neue Wissensbeiträge
Windows Netzwerk

CGM Praxisarchiv funktioniert auf Clients nach Update auf 4.14 nicht mehr

Tipp von MOS6581 vor 9 StundenWindows Netzwerk

Moin, ein Kunde setzt das CGM-Praxisarchiv ein. Mehrplatzinstallation mit SQL-Server. Nachdem letzte Woche auf die 4.14 aktualisiert wurde, funktionierte ...

Windows 10

Win 10 - Storage Sense - neues herstellerseitiges Cleaning-Tool statt cleanmgr

Tipp von mathu vor 15 StundenWindows 101 Kommentar

Vermutlich ab dem Oktoberrelease wird eine neue Speicherbereinigungssuftware ausgeliefert von Microsoft. Cleanmgr.exe soll angeblich aber noch weiter parallel verfügbar ...

E-Mail
Neueste Masche der Bad Guys: Offene Erpressung
Information von the-buccaneer vor 1 TagE-Mail15 Kommentare

"Warum den komplizierten Weg über einen Kryptotrojaner nehmen, wenn man die Leute auch direkt erpressen kann?" haben sich wohl ...

Viren und Trojaner
Neues ct-desinfect 2018 erschienen
Information von Lochkartenstanzer vor 1 TagViren und Trojaner1 Kommentar

Moin, heise hat eine neues Sonderheft Desinfect veröffentlicht (9,90€/12,90€) . Falls jemand öfter mal Kisten "säubern" muß ist das ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Kombiniere mehrere 4G Router zu einem Netzwerk - Anwendung kleine LAN (10-20 Leute)
Frage von HulkTheHeroLAN, WAN, Wireless22 Kommentare

Guten Mittag liebes Administrator - Fourm, ich hoffe ich habe das richtige Thema ausgewählt - ansonsten bitte gerne verschieben ...

Firewall
Blocken illegaler Film-Streams
gelöst Frage von CoreknabeFirewall20 Kommentare

Moin Wissende, unsere kleine Hochschule möchte gern das illegale Streaming von Kinofilmen und Serien unterbinden. Wir sperren bisher alle ...

Windows Server
2012 R2 Server Keine Anmeldung möglich Meldung: Laut den Sicherheitsrichtlinien auf diesem PC sollen informationen zur letzten interaktiven Anmeldung angezeigt werden
Frage von Speedy18A4Windows Server19 Kommentare

Hallo, ich habe vor einigen Wochen einen zweiten Domain Controller zu meiner Domain hinzugefügt. Funktionierte alles wunderbar. Auch die ...

iOS
Virus auf iphone
Frage von jensgebkeniOS17 Kommentare

hallo gemeinschaft, habe einen virus auf meinem iphone es kommen zwei meldungsfenster 1. online-2018-software-free.win 2. wpform.com - please click ...