Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst VLANs einrichten

Mitglied: sKrejci

sKrejci (Level 1) - Jetzt verbinden

22.02.2008, aktualisiert 26.02.2008, 22012 Aufrufe, 5 Kommentare

Hallo!

Ich hatte vor einiger Zeit einen Artikel gepostet, der mir sehr weitergeholfen hat (VLANs etc.).

Jetzt habe ich mich einigermaßen damit beschäftigt und auch viele Artikel zu diesem Thema hier und auf anderen Foren gelesen, aber leider funktioniert meine Konfiguration nicht so wie sie sollte:

Ich habe auf einem HP ProCurve 2626 mehrere VLANs eingerichtet:
  • VLAN 10: Port 1, 2, 3, 4 untagged, 21, 22, 23, 24 tagged
  • VLAN 20: Port 5, 6, 7, 8 untagged, 21, 22, 23, 24 tagged
usw.

Auf Port 21 - 24 hängen die Server. Am DHCP-Server habe ich für die VLANs die Bereiche 192.168.10.x/24, 192.168.20.x/24 eingerichtet sowie für das "Server-Netz" (DEFAULT_VLAN am Switch) 192.168.0.x/24. Am Switch habe ich den einzelnen VLANS die statischen IP-Adressen 192.168.0.253 für das Servernetz, und für die VLANs die 192.168.10.253/24 bzw. 192.168.20.253/24 manuell festgesetzt.

Die Netzwerkkarten an den Servern sind übrigens alle 802.1q - fähig (Intel-Karten). Als Default Gateway am Switch ist die IP-Adresse des PDC-Emulators eingetragen, auf dem u.a. DHCP, DNS und das AD laufen.

Meinem (bisherigen) Verständnis nach sollte diese Konfiguration eigentlich arbeiten, oder? Wenn ich aber einen Client an eines der VLANs anhänge, bekommt er allerdings nicht mal eine IP-Adresse. Am Netzwerkmonitor am DHCP-Server sehe ich zwar die ARP- und DHCP-Requests, aber es kommt nix mehr zum Client durch. Wo übersehe ich da einen Konfig-Fehler?

Danke, Stefan
Mitglied: aqui
22.02.2008 um 10:55 Uhr
Soweit ist deine Konfig OK, sofern du bei der Einrichtung der Server folgendes Tutorial unbedingt beachtet hast:

https://www.administrator.de/VLAN_Routing_%C3%BCber_802.1q_Trunk_auf_MS_ ...

Einer deiner Server ist ja nun auch der Router der zwischen diesen VLANs routet, denn der 2626 ist ein reiner Layer 2 Switch der NICHT selber zwischen den VLANs routen kann !
Du solltest also darauf achten, das nur ein Server der Router ist von deinen insgesamt 4 Servern !
Also nur ein Server sollte fürs Routing freigeschaltet sein.
Wie das geht steht hier für XP:
http://support.microsoft.com/?scid=kb%3Bde%3B315236&x=7&y=14
bzw. hier für Win 2000:
http://support.microsoft.com/?scid=kb%3Bde%3B315236&x=7&y=14
Bei 2k3 muss lediglich RAS Routing aktiviert werden.
Bei den restlichen 3 Servern sollte das deaktiviert bleiben !

Vorzugsweise sollte das der Server sein der am wenigsten zu tun hat in deinem Netz, denn ein Packet Forwarding stellt eine zusätzliche Belastung dar für einen Server.

Das Default Gateway aller Clients in einem deiner VLANs 10 oder 20 zeigt nun nicht auf einen emulierten PDC oder sowas, sondern schlicht und einfach auf die IP Adresses dieses Servers in dem betreffenden VLAN bzw. VLAN Interface !!! (Der Server ist ja der Router !) Wie gesagt das gilt für die IP Adressen aller Clients im jeweiligen VLAN Netz (was sie ja wohl eh per DHCP bekommen...) und auch die Switches (Mangement IP Adressen). Vermutlich meintest du das aber wohl mit der "emulierten" Adresse bzw. Interface ?!

Bezüglich DHCP kann es sein das du auf dem Windows Server noch ein DHCP Relay freischalten musst, denn DHCP Requests werden normalerweise nicht über einen Router übertragen, da das UDP Broadcasts sind.
Ein Quercheck mit statischen IP Adressen und Gateway auf 2 Testclients in VLAN 10 und 20 sollte das schnell verifizieren !
Wie man das macht mit dem Relay Agent sagt dir die MS Knowledgebase hier:

http://support.microsoft.com/?scid=kb%3Bde%3B232703&x=13&y=8

Damit sollte eigentlich dein Netzwerk problemlos spielen !
Bitte warten ..
Mitglied: sKrejci
22.02.2008 um 12:11 Uhr
DANKE Aqui!

Ich könnt wirklich nicht behaupten, nicht viel gesucht zu haben, aber gleich dein erster Link auf das Tutorial hat mir gefehlt - die NIC-Konfiguration.
Was noch nicht funktioniert ist das Routen. RRAS ist zwar aktiviert und alle Netze eingetragen, aber kein Pi(ep)ng geht von einem ins andere Netz.

Danke nochmals für deine Hilfe! Stefan
Bitte warten ..
Mitglied: aqui
22.02.2008 um 12:32 Uhr
Dann funktioniert dein Routing auf dem Server nicht und da ist dann dein Ansatz zum Suchen ! Ein FW Problem auf Server oder Client ist aber auch möglich !

Die MS Knowledgebase sagt dies sofern du Win 2k3 zum Routen benutzt (ansonsten gelten die o.a. URLs !)

http://technet2.microsoft.com/windowsserver/de/library/620a4940-df13-4d ...

Wenn die Server IP im jeweiligen VLAN die .254 hat, dann sieht ein Testszenario mit statischen Adressen so aus:

Client 1 in VLAN 10:
IP: 192.168.10.1, Maske: 255.255.255.0, Gateway: 192.168.10.254 (routender Server)

Client 2 in VLAN 20:
IP: 192.168.20.1, Maske: 255.255.255.0, Gateway: 192.168.20.254 (routender Server)

  • Ping von Client 1 an sich selbst und 192.168.10.254 sollte klappen.
  • Ping von Client 2 an sich selbst und 192.168.20.254 sollte klappen.
  • Ping von Client 1 an Client 2 sollte nun auch klappen.

Funktioniert der letzte Punkt nicht hast du definitiv ein Routing Problem oder.... ein Firewall Problem auf den Clients !!
Um letzteres auszuschliessen, solltest du die FW erstmal temporär abschalten ! Oder...das jeweils andere Netz in der lokalen FW komplett freigeben, da die FW dies sonst natürlich blockt !!
Ausserdem solltest du sicherstellen, das ICMP in den erweiterten Eigenschaften der FW freigeschaltet ist. (Haken bei "auf eingehende Echo Reply Anforderungen antworten" setzen !)

Danach sollte eigentlich alles einwandfrei laufen.
Bitte warten ..
Mitglied: sKrejci
25.02.2008 um 13:42 Uhr
Hi!

Thx für die Tips. Hab ich alles - schon und jetzt nochmal - ausprobiert. Irgendwo ist da der Hund drinnen. Das wusste ich eh schon. Wenn ich z.B. die IP-Eigenschaften auf egal welcher Netzwerkkarte am Server schließe, meldet er mir den Warnhinweis mit den mehreren Standardgateways (dass diese zwar Redundanz brächten, aber nur wenn sie im selben Netz sind etc.). Dabei finde ich nirgendwo ein zweites, unterschiedliches Standardgateway eingetragen.
Ist das Standardgateway eigentlich NIC-abhängig? Sprich braucht jede NIC ihr eigenes DG oder braucht man nur eine DG für alle eingebauten NICs? Ich hab zwar schon meinen Informationsstand dazu, aber der könnt ja durchwegs mal fehlerhaft sein

Nochmals zurück zu den VLANs: Wenn ich auf einer Netzwerkkarte z.B. 2 VLANs einrichte, dann erscheint noch ein dritter Netzwerkadapter, bei dem die TCP/IP-Eigenschaften ausgeschalten sind. Verstehe ich das richtig, dass dies sozusagen ein "Verwaltungs-NIC" für die VLANs ist?
Und zweitens: Muss ich für das am Switch standardmäßig verwendete DEFAULT-VLAN mit ID 1 ebenfalls ein VLAN am Netzwerkadapter einrichten? Denn ohne diesem hat's nicht funktioniert...

LGs Stefan
Bitte warten ..
Mitglied: aqui
26.02.2008 um 00:38 Uhr
Der Standaradapter ist das native VLAN was per default die ID 1 hat. Die Packete dieses VLANs werden untagged also ohne das 802.1q Tag im Ethernet Frame übertragen.
Wenn du Traffic nur in den anderen VLANs ausser der ID 1 hast kannst du das auch deaktiviert lassen. Es kann aber sein das manche Kartentreiber dann die gesamte Karte runternehmen also solltest du es ggf. ruhig aktiv lassen. Stören tut es nicht.

Hilfe gibt dir dieses Turtorial:

https://www.administrator.de/VLAN_Routing_%C3%BCber_802.1q_Trunk_auf_MS_ ...

Und hier gibts was zu den VLAN Grundlagen und Einrichtung :

http://www.heise.de/netze/Fiktive-Netzwerke--/artikel/77832
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
3. VLan einrichten
Frage von Mui8289LAN, WAN, Wireless2 Kommentare

Ich habe zwei VLans bereits mit Hilfe dieses Forums zum laufen gebracht. VLAN 1 = interne Computer nutzen den ...

Switche und Hubs
Switch VLAN einrichten
gelöst Frage von TastuserSwitche und Hubs8 Kommentare

Hallo, ich habe einen Switch mit VLAn-Funktion, verstehe jedoch nicht ganz wie das funktioniert. Folgende Punkte sind vorhanden: - ...

Router & Routing
Mikrotik für VLAN einrichten
gelöst Frage von 113726Router & Routing87 Kommentare

Hallo, heute ist mein Mikrotik 951-2n gekommen. Ich habe dann das Tutorial mir zur Brust genommen: Jetzt hängt es ...

Router & Routing
Probleme beim Einrichten von VLANs
Frage von BdreischuelerRouter & Routing2 Kommentare

Guten Tag liebe Community, ich bin gerade dabei, 2 Netzwerke die mit VLANS getrennt werden aufzubauen. Dabei habe ich ...

Neue Wissensbeiträge
SAN, NAS, DAS
QNAP NAS Datenschutz-Loop nach Firmware-Update
Tipp von vanTast vor 7 StundenSAN, NAS, DAS1 Kommentar

Moin, im allgemeinen Trend seine geänderten Datenschutzbedingungen den Kunden zukommen zu lassen kam die Firma QNAP auf die glorreiche ...

Datenschutz
DSGVO Datenschutzgesetz
Anleitung von 1Werner1 vor 8 StundenDatenschutz4 Kommentare

Moin, ja was ist das, da ist die DSGVO Datenschutzverordnung. Wie das Gesetz gibt es schon 2 Jahre? Nun ...

CPU, RAM, Mainboards
Neverending story
Tipp von keine-ahnung vor 1 TagCPU, RAM, Mainboards1 Kommentar

Da kommt man mit dem fixen gar nicht mehr hinterher und die CPU erreichen wieder Rechenleistungen im Bereich des ...

Multimedia & Zubehör
AVM Fritz USB WLAN Sticks schneller einschalten
Tipp von NetzwerkDude vor 3 TagenMultimedia & Zubehör4 Kommentare

Die AVM Fritz WLAN Sticks haben in der Firmware 2 Modis: Einmal als Massenspeicher und einmal als WLAN Netzwerkkarte ...

Heiß diskutierte Inhalte
PHP
Nach Umzug zu 1und1 bekomme ich beim Eintrag in die DB Tabelle folgenden Fehler
gelöst Frage von jensgebkenPHP35 Kommentare

INSERT command denied to user 'dbo45342345342231244'@'112.127.102.073' for table 'orders'

LAN, WAN, Wireless
Powerline über zwei Stockwerke optimieren
gelöst Frage von DultusLAN, WAN, Wireless33 Kommentare

Guten Morgen liebes Forum, ich hätte einmal eine Frage bezüglich Powerline Adapter: Mein Problem ist seit gestern präsent, da ...

Windows Userverwaltung
Problem mit Benutzerprofil
Frage von lieferscheinWindows Userverwaltung24 Kommentare

Guten Tag liebe Community, folgendes Problem habe ich: User meldet sich auf Client A an - sein Homelaufwerk verbindet. ...

Off Topic
DISKUSSION: Was bringt der Disclaimer "Wenn Sie nicht der Empfänger sind."
Frage von N8DragonOff Topic21 Kommentare

So oder ähnlich, lese ich immer wieder Kleingedrucktes am Ende diverser Mails. Letzten Endes wollen sie mir alle sagen, ...