Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst W2k3 Server, DOS-Programm und mehr als 1 Benutzer ist Langsam

Mitglied: BrickTop

BrickTop (Level 1) - Jetzt verbinden

11.01.2006, aktualisiert 18.07.2008, 9010 Aufrufe, 18 Kommentare

Hallo,

super Forum Habe hier schon sehr viele gute Ratschläge befolgt - Vielen Dank dafür.
Nun habe ich folgendes Problem und vielleicht hat ein anderer Admin noch eine Idee?!

Server: W2k3 - Workstations XP - FastEthernet-Netzwerk (Switch von LevelOne)
Auf dem Server ist unser Warenwirtschaftsprg. gespeichert. Ist ein DOS-Programm aber das lief bis jetzt (Server NT, WS: W98) super. Seit der Umstellung auf W2k3 und XP läuft das Programm nur dann schnell, wenn nur einer in dem Programm arbeitet

Sobald >1 Benutzer mit dem Programm arbeiten, wird es sehr langsam - Er pausiert bei Eingaben (sobald er was vom Server benötigt) teilweise 1-2 Sekunden. Das seltsame daran: Das ist nicht immer so... Manchmal geht es gewohnt schnell. Umstellung auf 100MBit Half brachte auch nichts (empfiehlt der Hersteller der Software)

SMB signieren wenn angefordert=Aktiv / SMB immer signieren = Deaktivert (Bei Server und WS über GPO habe ich auch schon ausprobiert. Brachte nichts.

Habe schon so einiges probiert - Brachte alles nichts. DNS / NetBios ist da und läuft auch 100%
Bin da echt bald am Ende...

Für jeden Ratschlag/Tip bin ich echt dankbar... Die Leute in der Firma jammern bereits...

Lg
BrickTop

p.S: Gibt es da eine Einstellung die ich übersehen habe? Wie z.B: SHARED USE = FAST ?!
Mitglied: Biber
11.01.2006 um 20:13 Uhr
Moin BrickTop,

ist ein bisschen früh, um da weise Tipps zu geben..
Dazu müsste man/frau wenigstens wissen, was für eine Applikation aus ungefähr welchem Entstehungszeitraum das war.

Die meisten dieser WW-Programme aus älteren Tagen sind ja Clipper-Programme, die wiederum auch damals schon eine Menge (Applikations-unabhängige) Parameter vorgesehen hatten für Speichernutzung/temporäres Verzeichnis/ max. File Handles und ähnliches und/oder sich über externe Variablen oder config-Dateien beeinflussen ließen.

Ohne solche dokumentierten Parameter sehe ich wenig Chancen - so auf Verdacht lassen sich bestenfalls die Umgebungsvariablen für TEMP/TMP überprüfen (ob die lokal sind oder ob er etwa einen Netzwerkordner für die temporären Trümmer nutzt) und ob vielleicht die Anzahl FileHandles in der config.nt der Engpass ist.

Das Share-Verhalten (also die Behandlung von verschiedenen Prozessen/Usern geöffneter Dateien) bekommst Du IMHO nicht mehr konform zur damaligen SHARE.exe hin bei Windowsversionen diesseits von WinNT.

Gibt es noch Details über die Applikation?`
Gruß Biber
Bitte warten ..
Mitglied: Samtpfote
11.01.2006 um 20:49 Uhr
1. wenn Clipper-App schließe ich mich Biber an: config.sys Finetuning...
2. Versuchs doch mal mit den Kompatibilitätseinstellungen bei der exe.
Bitte warten ..
Mitglied: BrickTop
11.01.2006 um 21:19 Uhr
@Biber
Vielen Dank erstmal für Deine Hilfe. Die Anwendung ist eine alte Warenwirtschaft (Erstmalig so um 1983 entwickelt. Die DOS Version wurde jedoch noch bis ca. 97/98 gepflegt. Zum Einsatz kommt Datenbanktechnik von MicroFocus. Geschrieben ist die Software (glaube ich) mit Cobol)

Die Idee mit der Config.NT hatte ich (... vergessen) noch gar nicht. Das werde ich morgen in der Firma gleich mal testen.

Temp sollte lokal sein - Werde ich morgen aber auch nochmal nachschauen.

@Samtpfote
Auch Dir thx. Config.Nt wird gecheckt - Kompatibilitätseinstellungen hatte ich probiert - Bringen nichts.

Werde das morgen mal probieren und berichten (Für evtl. weitereführende Hilfe wäre ich dankbar)

Gruß
BrickTop
Bitte warten ..
Mitglied: Samtpfote
11.01.2006 um 21:27 Uhr
Habe bei einem Kunden in einer W2K3/XP Umgebung eine ca. 20 jährige Cobol App mit folgenden Werten in der Config.NT am Laufen:

FILES=100
FCBS=25,25
STACKS=9,128

Es gab am Anfang erhebliche Probleme durch Verzögerungen beim Zugriff.... ich kann mich leider nicht mehr erinnern, wodurch ich es zum Laufen gebracht habe... wenn Du möchtest kann ich ein wenig recherchieren. (BTrieve Datenbank + Novell 3.12 Server)

A.
Bitte warten ..
Mitglied: Biber
11.01.2006 um 21:56 Uhr
@BrickTop/@Kitkat
FILES=100 --> ist auf jeden Fall sinnvoll
FCBS --> diese File Control Blocks: ja bei Baujahr '83... aber nicht mehr verwendet bei DOS'en nach 3.3; schaden aber auch nicht.
Stacks=9,128 oder auch höher (15,256)
eventuell noch Buffers=40 dazu.

@all:
Mit den Kompatibilitäts-Optionen hatte ich auch schon mal rumexperimentiert.
Ich konnte ABSOLUT KEINE Effekte feststellen, weder positiv noch negativ.
Haben die bei irgendjemand schon mal geholfen?
Bitte warten ..
Mitglied: Samtpfote
11.01.2006 um 22:18 Uhr
@Nager:
jaaaaaaaaaa.... es gab ein paar alte windows 3.1 programme die ich sonst nicht zum Laufen gebracht hätte.
Bitte warten ..
Mitglied: Biber
11.01.2006 um 22:24 Uhr
>>es gab ein paar alte windows 3.1 programme die ich sonst nicht zum Laufen gebracht hätte.

Na, wenn Du Deine Krallen funkeln lässt, laufen die freiwillig...
Glaube nicht, dass M$'s Kompat-Features was damit zu tun haben

Grüße an die Samtigste
Biber
Bitte warten ..
Mitglied: BrickTop
12.01.2006 um 21:42 Uhr
@Biber
Vielen Dank - Die Werte haben etwas mehr Leistung gebracht (Besonders das mit dem Stacks - man das sind ja echt noch die tollen alten DOS-Sachen...) - so toll wie unter NT läuft das aber nicht mehr... Wird wohl doch Zeit für die Windows-Version
Werde da noch ein wenig mehr dran bauen. Nachdem ich heute morgen (hatte noch keinen Kaffee...) versehentlich in der Konsole del *.* eingegeben habe ; Sollte eigentlich *.pif draus werden... Hmmm Letzte Datensicherung war ja 2 Tage her ($#$§")

@All
Auch euch vielen Dank für die vielen Ratschläge!

Also mit den Kompatibilitäts-Optionen habe ich auch noch NIE was bemerkt... Tolles Feature, so wertvoll wie Eisregen

Gruß
BrickTop
Bitte warten ..
Mitglied: Biber
12.01.2006 um 21:52 Uhr
*lacht*
>>... versehentlich in der Konsole del *.* ....

Du hast es gut...
...brauchst nicht mehr lange überlegen, ob Du am Wochenende ins Kino oder in die Disco gehst...

Werde an Dich denken.. *feixxxxxxxx
Bitte warten ..
Mitglied: Praktiken
10.04.2007 um 13:36 Uhr
Auch wenn schon älter:

Hier des Rätsels Lösung:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]

SharingViolationDelay = dword:0
SharingViolationRetries = dword:0

LanmanServer\Parameters\EnableOpLocks = 0
LanmanServer\Parameters\EnableOpLockForceClose = 1
LanmanServer\Parameters\CachedOpenLimit = 0
LanmanServer\Parameters\UseEnableOpLocks = 0
LanmanWorkstation\Parameters\UseOpportunisticLocking = 0
LanmanWorkstation\Parameters\UtilizeNtCaching = 0

und schon laufen alle alten DOS-Programme wieder mit der gewohnten Geschwindigkeit.
Bitte warten ..
Mitglied: 53114
05.09.2007 um 15:45 Uhr
Auch wenn schon älter:

Hier des Rätsels Lösung:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]

SharingViolationDelay = dword:0
SharingViolationRetries = dword:0

LanmanServer\Parameters\EnableOpLocks = 0
LanmanServer\Parameters\EnableOpLockForceClose
= 1
LanmanServer\Parameters\CachedOpenLimit = 0

LanmanServer\Parameters\UseEnableOpLocks = 0

LanmanWorkstation\Parameters\UseOpportunisticLocking
= 0
LanmanWorkstation\Parameters\UtilizeNtCaching
= 0

und schon laufen alle alten DOS-Programme
wieder mit der gewohnten Geschwindigkeit.

Habe dieses Problem auf XP-Clients auch. Der Server ist W2K, ebenso die meisten Clients (auf denen alles tadellos läuft). Leider muß ich für SWX jetzt XP-Clients haben.

Das bei uns verwendete Programm ist ein Windowsprogramm, das ein Menü anbietet. Aus diesem heraus werden dann einzelne DOS-Programme gestartet.

Ich habe auf den XP-Clients die o.g. Werte eingetragen, aber es stellt sich leider keine Besserung ein... Hat noch jemand eine Idee? Das Gejammere nervt schon.
Bitte warten ..
Mitglied: BrickTop
05.09.2007 um 15:50 Uhr
Möchte Dich ja nicht beunruhigen aber wir haben da keine vernünftige Lösung für gefunden. Habe jetzt auf die Windows-Version umgestellt…

Solltest Du jedoch etwas finden, wie es anders läuft – Bitte noch mal melden. Bin da immer noch interessiert dran.

Gruß
BrickTop

Das nölen der Benutzer ging mir echt an die Substanz… Ich kann Dich verstehen!
Bitte warten ..
Mitglied: Praktiken
05.09.2007 um 16:32 Uhr
> Auch wenn schon älter:
>
> Hier des Rätsels Lösung:
>
>
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
>
> SharingViolationDelay = dword:0
> SharingViolationRetries = dword:0
>
> LanmanServer\Parameters\EnableOpLocks =
0
>
LanmanServer\Parameters\EnableOpLockForceClose
> = 1
> LanmanServer\Parameters\CachedOpenLimit
= 0
>
>
LanmanServer\Parameters\UseEnableOpLocks = 0
>
>
LanmanWorkstation\Parameters\UseOpportunisticLocking
> = 0
>
LanmanWorkstation\Parameters\UtilizeNtCaching
> = 0
>
> und schon laufen alle alten
DOS-Programme
> wieder mit der gewohnten
Geschwindigkeit.

Habe dieses Problem auf XP-Clients auch. Der
Server ist W2K, ebenso die meisten Clients
(auf denen alles tadellos läuft). Leider
muß ich für SWX jetzt XP-Clients
haben.

Das bei uns verwendete Programm ist ein
Windowsprogramm, das ein Menü anbietet.
Aus diesem heraus werden dann einzelne
DOS-Programme gestartet.

Ich habe auf den XP-Clients die o.g. Werte
eingetragen, aber es stellt sich leider keine
Besserung ein... Hat noch jemand eine Idee?
Das Gejammere nervt schon.

Diese Eintrage müssen auf dem SERVER geändert werden
Bitte warten ..
Mitglied: 53114
05.09.2007 um 22:06 Uhr
Diese Eintrage müssen auf dem SERVER geändert werden

Also: das scheint echt was zu bringen, ich hab allerdings das Gefühl, daß die W2K-Clients jetzt (etwas) langsamer sind. Außerdem noch eine Sache: die "Datenbank" läuft über Dateifreigaben, d.h. lesen geht immer, schreiben nur, wenn grad kein anderer an dem Datensatz in der .dat-Datei wurstelt. Es gibt da jetzt hoffentlich nicht die Gefahr, daß ich da Beschädigungen reinbekomme?

Danke nochmal und Gruß
Bitte warten ..
Mitglied: Praktiken
06.09.2007 um 09:36 Uhr
Das Sperren des Datensatzes während der Bearbeitung ist vollkommen richtig und normal. Beim w2k und w2k3 Server hat microsoft das locking der Dateien wieder einmal willkürlich geändert. Das hat zur Folge, das Dateien die im 16Bit Dos-Modus vom Client auf dem Server geöffnet werden, vom Server gelockt werden. Bis hierhin noch normal. Dann jedoch, wenn die Datei vom Client wieder "losgelassen" wurde, waren diese bis zu 10 sekunden weiterhin gelockt. Während dieser Zeit hatten andere Clienten keinen Zugriff darauf und hatten somit hänger oder blieben während dieser Zeit einfach stehen. Das Ändern der Parameter behebt dieses Problem. Das File wird unmittelbar nach Zugriff wieder freigegeben.

Zum Thema: Die Clients scheinen jetzt langsamer zu sein: Hast Du die Einträge, die Du ja zunächst an den Clients statt am Server vorgenommen hast auch wieder rückgängig gemacht?
Bitte warten ..
Mitglied: 53114
06.09.2007 um 10:38 Uhr
OK, gut. Ich hatte nur die Befürchtung, daß das Sperren nicht mehr richtig funktioniert. Und weshalb ich das am Server ändern mußte, der mit W2K-Clients ja einwandfrei funktionierte, ist mir noch nicht klar. Hab jetzt allerdings leider auch keine Zeit, mich damit groß auseinander zu setzen. Hauptsache, das Genöle hört auf.
@BrickTop: Versuch das mal, bei mir geht es jetzt.

Zum Thema: Die Clients [d.h. W2K-Clients. Kollege] scheinen jetzt langsamer zu sein: Hast Du die Einträge,
die Du ja zunächst an den Clients statt am Server vorgenommen hast auch wieder
rückgängig gemacht?
Jetzt ja. Aber noch nicht getestet... War wohl auch nur so ein Gefühl.

Herzlichen Dank jedenfalls!
Bitte warten ..
Mitglied: 53114
13.06.2008 um 09:22 Uhr
Zu diesem Thread habe ich auch noch mal eine Frage.

Bei uns haben wir festgestellt, daß bestimmte Sachen in dem DOS-Programm unter XP deutlich langsamer sind als unter W2K. Wir haben dann testweise die Shares, die das DOS-Programm braucht, auf einen Samba-Server umgezogen, aber das brachte auch gar nichts. (Wir hatten auf dem W2K3-Server SMB-Signierung deaktiviert und den Tipp von Praktiken angewandt).

Jetzt haben wir uns mal den Netzwerkverkehr angesehen und festgestellt, daß unter XP eine viel größere Anzahl sehr kleiner Pakete als unter W2K übertragen werden und also auch viel weniger große Pakete (MTU ist bei beiden Clients auf standardmäßig 1500 eingestellt).

Hat da jemand eine Idee?

Danke und Grüße
Bitte warten ..
Mitglied: 53114
18.07.2008 um 08:44 Uhr
Habe endlich die Lösung gefunden!
Es liegt am sogenannten Opportunistic Locking (hier gut erklärt: http://www.superbase.com/services_tech_support_oplocks.htm )!

Schaltet man das serverseitig aus, sollte das Problem weitgehend behoben sein.

Dazu muß man einen Registry-Key am SERVER eintragen (wie auch im Beitrag unter dem Link oben beschrieben):

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

EnableOplocks REG_DWORD 0 oder 1
Default: 1 (true)

Diesen Wert muß man auf 0 setzen!!

Wenn dieser DWORD-Wert nicht existiert, einfach anlegen und auf 0 setzen.


Am CLIENT kann man das auch machen, hier gibt es folgenden Schlüssel:

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MRXSmb\Parameters

OplocksDisabled REG_DWORD 0 oder 1
Standard: 0 (nicht deaktiviert)

Diesen Wert auf 1 setzen.

Wenn dieser DWORD-Wert nicht existiert, wie oben schon gesagt einfach anlegen und auf 1 setzen.


Grüße
Bitte warten ..
Ähnliche Inhalte
Java
Programm in Java immer langsam?
Frage von imebroJava29 Kommentare

Hallo, zunächst mal: Ich bin kein Programmierer ;-) Wir haben nun ein neues Programm, welches Antragsdaten verarbeitet. Ebenso werden ...

Batch & Shell

Programm wird sehr langsam ausgeführt

gelöst Frage von Peter32Batch & Shell19 Kommentare

Hallo, ich habe ein kleines Programm gebastelt (mit Anfängerskills!), welches erst überprüft, wieviele Benutzer angemeldet sind und wenn mehr ...

Windows 10

Programm immer als anderer Benutzer ausführen

Frage von Ghost108Windows 108 Kommentare

Hallo zusammen, hatte vor kurzem noch Win 7 Prof und bin auf Win 10 Pro umgestiegen. Früher hatte ich ...

Windows Server

Programm-Instanz von anderen Benutzer übernehmen

Frage von Crischi94Windows Server4 Kommentare

Hallo zusammen, wieder einmal stehe ich vor einer simpel erscheinenden Frage, die aber wahrscheinlich ziemlich schwierig sein wird. Ich ...

Neue Wissensbeiträge
Netzwerkmanagement
Win 10 - wiederaufnahme in Domäne scheitert
Anleitung von Seesturm vor 7 StundenNetzwerkmanagement1 Kommentar

Ich habe ein kleines Netzwerk mit einem Domänencontroller Server 2012 R2. Die meisten Rechner laufen unter Windows 7. Vor ...

Internet

Europa baut Zensurinfrastruktur auf: EU-Parlament stimmt für Upload-Filter, Leistungsschutzrecht und gegen KI-Forschung

Information von Frank vor 1 TagInternet7 Kommentare

Eine sehr schlechte Entscheidungen für die Zukunft Europas ist gefallen: Der Rechtsausschuss im EU-Parlament stimmte heute morgen in einer ...

Windows 10

Mikrofon von Headset geht nach Update auf Windows 10 1803 nicht mehr

Tipp von Deepsys vor 3 TagenWindows 102 Kommentare

Ich verwende ein Plantronics Headset das per USB mit dem Windows 10 PC verbunden ist. Damit kann ich auch ...

Video & Streaming

Ruckelfreies Fernsehen auf Smartphone oder Tablet - in SD oder gar HD - Eine Alternative zum Fritz DVB-C Receiver

Anleitung von power-user vor 3 TagenVideo & Streaming9 Kommentare

Wer kennt das nicht: Man möchte gemütlich auf dem Balkon sitzen und vielleicht grillen und dabei das WM-Spiel gucken ...

Heiß diskutierte Inhalte
Instant Messaging
Whats App Business am PC einsetzen
Frage von thomasreischerInstant Messaging30 Kommentare

Hallo zusammen, wir würden demnächst gerne WhatsApp Business verwenden um den Kontakt zwischen Kunden und Mitarbeitern zu erleichtern. Natürlich ...

Windows 7
Windows 7 Benutzer wechsel nicht möglich
gelöst Frage von OSelbeckWindows 727 Kommentare

Hallo, ich habe hier einen Windows 7 Rechner, der in der Domäne war. Jetzt passiert beim starten, das ich ...

Windows Netzwerk
IP-Adresskonflikt
Frage von Turbo-MasterWindows Netzwerk24 Kommentare

Hallo zusammen, ich habe ein Problem mit unserem Netzwerk unter Windows Server. Ständig erhalten wir die Meldung, dass ein ...

Festplatten, SSD, Raid
RAID auflösen Synology DS213j!
gelöst Frage von Hendrik2586Festplatten, SSD, Raid19 Kommentare

Guten Morgen meine Lieben! :) Diese Frage wird sich sicherlich schon der ein oder andere gestellt haben. Es geht ...