Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Webserver, Apache 2 auf Debian Lenny liefert extrem langsam Seiten aus

Mitglied: yogitee

yogitee (Level 1) - Jetzt verbinden

10.09.2009, aktualisiert 13:44 Uhr, 13508 Aufrufe, 5 Kommentare

Hallo zusammen, seit ein paar Tagen stelle ich fest, das der Seitenaufbau auf den Seiten von meinem Server extrem langsam ist. Ich kann in der Statusleiste von Firefox sehen das er sofort nach aufrufen eines Links die Hälfte fertig geladen hat, doch der Rest dauert manchmal bis zu 20 sec.

Als erstes habe ich geprüft ob ich Packetloss habe, meine Leitung und die Leitung zum Server hin, sowie das Rechenzentrum hat keine Probleme. Die Serverlast CPU liegt bei 5% wenn überhaupt mal so viel und Arbeitsspeicher habe ich noch 1 GB Frei. Anbindung ist 100MBit von denen nur ein KBit Bereich genutzt wird. Trotz allem ist der Seitenaufbau von Seiten mit fehlerlosem HTML/ CSS und maximaler Größe von 200-300 Kb katastrophal.

Nun würde es mich nicht wundern wenn ich etwas geupdatet hätte oder ähnliches, aber ich habe nichts geupdatet oder verändert, doch trotz dem liefert er auf einmal die Seiten so ewig lahm aus...was mich wundert und ein wenig fuchsig macht ist die Tatsache das vor knapp ner Woche noch alles Prima war...

Irgendwelche merkwürdigen Transaktionen fanden auch nicht statt, Spam oder DoS Attacken...

Läuft irgendwo ein Speicher voll beim Apache oder irgendwelche Temporären Dateien die ich löschen müsste?

Der SSH Zugang lahmt auch ein wenig rum der war auch mal schneller...

Kommt das alles jemand bekannt vor?

Hat jemand eine Idee wo ich mal nachsehen könnte?



Ich steh gerade ein wenig auf´m Schlauch.


Hier noch ein paar Daten:

Debian Lenny 5.0.1
Apache 2.2.9
Bind 9

Anbindung 100Mbit
Dualcore 3,6 GHz 64Bit
4GB RAM HT

* Update: Hab gerade mal nen Relaytest gemacht ob da irgendwas am Courier Mailserver fehlkonfiguriert ist und mein Server evtl. Spammt aber das tut er nicht. Dienst bzw. der ganze Server wurde auch neu gestartet...*

In den Logfiles habe ich außer dem üblichen Schmodder auch nichts auffälliges gesehen, nur eben Dateien die nicht vorhanden sind oder Seiten die es nicht gibt war da nichts besonderes.... Sehr mysteriös alles...Aber Danke für den Tipp
Mitglied: kaiand1
10.09.2009 um 13:10 Uhr
Dienste/Server mal neugetsratet?
Unstabiele Pakete eingespielt?
Konfigs geändert?
Logfiles ne abweichung drinne? Errorlogs?
Bitte warten ..
Mitglied: Driver401
10.09.2009 um 15:36 Uhr
Da läuft aber nicht zufällig Wordpress drauf? Oder ein anderes CMS, das vielleicht ähnliche Probleme hat?
http://wp-magazin.ch/2009/01/15/123-http-transport/
Bitte warten ..
Mitglied: yogitee
12.09.2009 um 17:55 Uhr
Danke für den Tipp mit dem CMS, tatsächlich habe ich einige laufen, Joomla und ein paar Wiki und Galerie Scripte, doch keines der von mir verwendeten Scripte benutzt diese PHP Klasse.

Ich habe auch noch einmal die Logs studiert und immer noch nichts ungewöhnliches sehen können.

Wie kann es denn sein das urplötzlich alles so lahmt?
Bitte warten ..
Mitglied: Driver401
14.09.2009 um 13:31 Uhr
Also Du schreibst,

nach aufrufen eines Links die Hälfte fertig geladen hat,
doch der Rest dauert manchmal bis zu 20 sec

was auch darauf hindeuten kann, dass Du in Deinen Seiten Abrufe von anderen Seiten drin hast - soll heißen, er lädt Deine Seite bis zu einem bestimmten Code, wo er auf fremde Server zugreifen muss, dann macht er weiter (z.B. als einfachstes Beispiel ein Wetterwidget o.ä.).
Falls diese andere Adresse nicht erreichbar ist.....

Nur 'ne Idee.
Bitte warten ..
Mitglied: yogitee
14.09.2009 um 16:34 Uhr
Wir haben den Wurm gefunden, den Fehler hat ein nicht korrekt funktionierender DNS Server verursacht.

Nach dem wir diesen Second Server in der, resolv.conf auskommentiert hatten, war alles wieder paletti.

Danke auch noch mal an Driver401 für den Tipp Hätte es bestimmt auch sein können
Bitte warten ..
Ähnliche Inhalte
Microsoft
Apache läuft extrem langsam
Frage von 116108Microsoft24 Kommentare

Hallo zusammen Da Xampp nicht dafür gemacht ist eine Website online zu stellen, habe ich mich für WAMP-Stack von ...

Apache Server

Apache 2 Debian Zertifikat von GeoTrust installieren

gelöst Frage von zeroblue2005Apache Server3 Kommentare

Hallo Zusammen, nach dem ich jetzt von GeoTrust mein echtes Zerti bekommen habe, möchte ich nicht nur meinen IIS, ...

HTML

Seitenaufbau beschleunigen - Apache Webserver

gelöst Frage von mabue88HTML5 Kommentare

Hallo, und schon wieder habe ich eine Frage, die ich selbst nicht beantworten kann. Ich habe einen Apache-Server. Eine ...

Windows 10

FTP ist extrem langsam

Frage von grkaWindows 103 Kommentare

Hallo ich habe ein Windows 10 System und meine Internetverbindung über die Fritzbox 7490 hat folgende Werte: Download: bis ...

Neue Wissensbeiträge
Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 2 StundenSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 9 StundenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 12 StundeniOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Heiß diskutierte Inhalte
Batch & Shell
Powershell: Im AD nach Rechnern mit bestimmten IP-Adressen suchen
gelöst Frage von Raven42Batch & Shell36 Kommentare

Hallo zusammen, ich suche nach einer Möglichkeit nach Computern im AD zu suchen , deren IP-Adresse mit 10.11.12. beginnt. ...

C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++34 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

Windows Server
Alten DC entfernen
Frage von smartinoWindows Server24 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...