Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Webserver zeigt keinen Content trotz Dyndns funktion

Mitglied: content

content (Level 1) - Jetzt verbinden

07.04.2005, aktualisiert 30.01.2006, 7298 Aufrufe, 16 Kommentare

Hallo Leute,

kämpfe gerade mit nachfolgender Situation :

1. Apache Webserver installiert und lokal auch anprechbar

2. Dyndns Account erstellt bei dyndns.org.

3. Demnach auf den Router den dyndns dienst eingerichtet .. hat er akzeptiert und auch aufgelößt !

4. Auf dem Router den Virtuellen Server eingerichtet also :
Service "HTTP" ; Public IP "217.21.31.12"; Public Port "80" auf den Privaten Port "80" ; Protocol "TCP" Private IP "192.168.0.100"
--> damit habe ich gehofft auf den Router die Anfragen auf den Webserver zu leiten ...


Resultat : Keine Anzeige der Webseite ... / obwohl die dyndns adresse anpingbar ist und diese mit dem Router identisch ist.

Irgendwo liegt der Wurm noch begraben :/

Regards
content
Mitglied: leknilk0815
07.04.2005 um 20:18 Uhr
Hi,
ich kenne das Menü Deines Routers nicht, aber hast Du eine statische IP? Eher wohl nicht. Daher wird die angabe der 217.21.....IP wohl nicht funktionieren, da die sich nach spätestens 24h ändert. Ich kann Dir nur sagen, wie es auf meinem Netgear konfiguriert ist.

Dyndns- Konfig sieht gut aus.
Portkonfig:
ich hab bei mir lediglich unter "Ports" den Port 80 auf die IP des Webservers geleitet. Mehr ist nicht zu tun.
Gruß - Toni
P.S.:
Normalerweise sollte der IP- Wechsel über den Router mit Dyndns automatisch funktionieren, aber das bockt manchmal aus undefinierbaren Gründen. Deshalb habe ich bei mir einen Dyndns- Client installiert, seitdem geht es zuverlässig ohne Unterbrechung.
Bitte warten ..
Mitglied: content
07.04.2005 um 20:24 Uhr
Hi Toni,

währe natürlich eine alternative es mit einem client zu probieren ... währe aber schon traurig eine funktion im router bereitzustellen die nich 100 % funktioniert ...

ich werde das angehen um einfach den fehlerkreis zu minimieren ;)

Besitze einen Acer Router ... nix aufregendes sollte aber seine sache machen ...

die weiterleitung habe ich genauso gemacht wie du es an der eingangsmail sehen kannst ... mehr habe ich nicht geroutet ...

ist schon confus das ganze ...

THX
Thomas
Bitte warten ..
Mitglied: leknilk0815
07.04.2005 um 20:34 Uhr
Hi,
ich bin nie dahintergekommen, ob die Nichterreichbarkeit am Router (glaube ich eher nicht) oder an Dyndns lag. Das Problem lies sich lösen, indem man bei Dyndns einfach die aktuelle IP eintrug. Warum zeitweilig kein Update erfolgte, lies sich nicht feststellen, es war halt einfach so.
Der Client auf der folgenden Seite läuft bei mir problemlos.
http://www.nord-vision.de/data/index.php?seite=58#
Gruß - Toni
Bitte warten ..
Mitglied: content
07.04.2005 um 21:08 Uhr
Hi,

habe die Client-Software installiert & konfiguriert ... die dyndns meldet dieser auch erfolgreich an ...

aber immer noch der gleiche undankbare Fehler kein webserver der entgegenimmt .......

Jetzt kann es nicht mehr an der dyndns liegen ... zumal ich auch mit der IP selbst keine Infos bekomme ...

Also kann das übel wohl nur am Router liegen !?!?

werde bei zeiten einen screenshot von der router-konfig hier posten ....
Bitte warten ..
Mitglied: leknilk0815
07.04.2005 um 21:42 Uhr
wie testest Du das eigentlich? Also wenn ich meinen Webserver flachlege, komme ich über Dyndns oder über die DSL- IP übers Internet auf die Konfig- Seite meines Routers. Wie ist das denn bei Dir?
Bitte warten ..
Mitglied: content
08.04.2005 um 03:46 Uhr
wenn der webserver off ist .. bekomme ich die seite des routers nicht angezeit weil ...
der (router-gateway) bei mir nicht auf localhost (192.168.0.1) steht.

wenn der webserver online ist .. geht der content lokal wunderbar ..
auf alle fällle hat es nichts mit dyndns zu tun .... ich kann mir nur vorstellen das er die äußeren anfragen nicht richtig zum internen webserver routet


Anbei mal der screenshot vom Router (Portforwading zum webserver) .. wüßte nicht was ich großartig noch ergänzen könnte ?!?

<img src='/images/articles/beaece9c6052906a6847f9c8c5cd9c6a-router-portforwading.JPG' align='default' hspace='0' vspace='0' border='0'>
Bitte warten ..
Mitglied: leknilk0815
08.04.2005 um 09:12 Uhr
läuft Dein Webserver auf Port 85???
Bitte warten ..
Mitglied: content
08.04.2005 um 12:51 Uhr
Ja momentan läuft dieser auf Port 85 ...
auch wenn ich den Webserver auf Port 80 umkonfiguriere ist die Situation die gleiche ...

grüße
Thomas
Bitte warten ..
Mitglied: leknilk0815
08.04.2005 um 13:23 Uhr
läuft irgend eine Firewall? Testweise mal komplett abschalten
Bitte warten ..
Mitglied: content
08.04.2005 um 13:29 Uhr
nein .. die windows eigene firewall ist ausgeschaltet ... die einzigste firewall ist der router ....

regards
Bitte warten ..
Mitglied: leknilk0815
08.04.2005 um 13:34 Uhr
gibts da nichts zu deaktivieren, bzw. freigeben? Evt. mal alles zulassen, einschränken kann man dann schrittweise.
Bitte warten ..
Mitglied: content
08.04.2005 um 13:47 Uhr
Wenn ich mich nicht täusche kann man explezieht auf dem WIN 2003 Server irgendwo einrichten das Anfragen von aussen in den Server erlaubt werden ...

weiß aber nicht wirklich wo diese Option zu finden ist.
Bitte warten ..
Mitglied: leknilk0815
09.04.2005 um 12:31 Uhr
könnte auch sein, versuch mal, Dich lokal auf einem Client als User ohne besondere Domänenrechte anzumelden und dann versuchen, ob Du auf Deinen Webserver kommst, evt. ist die Rechtevergabe nicht korrekt und kommst deshalb von aussen (anonym) nicht drauf.
Bitte warten ..
Mitglied: miscmike
09.04.2005 um 16:06 Uhr
Hallo ,

ich bin neu hier, weil ich nach einem ähnlichen Problem gesucht habe.
Hier meine Erfahrungen :

1. Überprüfe, ob in den NAT Einstellungen des Routers die Umleitung auf Deinen Webserver korrekt ist.
2. Sollte der Webserver auf Port 80 reagieren, so versuche den Port für die Webadministration deines Routers zu ändern (z.B. auf Port 85). Das hat bei mir geholfen, da der Router wahrscheinlich nicht mehr wusste, ob nun er oder der Webserver gemeint war
Zumindest solltest Du niemals denselben Port für verschiedene Rechner im Netz verwenden
(Router=Rechner)

Als Beispiel das es funktioniert, sieh mal auf die Seite http://www.tsv-leuna.de , dort unter Galerie.
Alle Bilder, die du dort siehst sind mit der o.g. Konfiguration erreichbar.

Nochmal zu Dyndns : Der Client deines Routers stellt lediglich sicher, das er (der Router) immer unter dem namen xxxx.dyndns.org erreichbar ist. Alles Weitere mußt Du immer unter NAT einstellen.
Sollte das alles nicht klappen und Dein Router erlaubt die Einstellung einer DMZ (demilitarized zone), so gib mal testweise die IP deines Webservers dort an. Damit sollte für diesen PC überhaupt keine Sperre mehr vorhanden sein.


MfG

Mike
Bitte warten ..
Mitglied: RoL
23.12.2005 um 21:44 Uhr
Ich hab den selben ACER-Router und das selbe Problem.
Es liegt wohl definitiv am Router, weil wenn ich den Webserver direkt an das DSL-Modem hänge, also ohne Router dazwischen, dann kann ich auch über die Globale-IP auf den Webserver zugreifen so wie es normalerweise sein sollte.
Sobald der Router dazwischen ist geht leider nix mehr....

Hast du das Problem in der Zwischenzeit vielleicht schon lösen können, oder hat noch jemand einen Tip?

Hab schon Virtual Server mit HTTP 80 - Apache Webserver, FileZilla - FTP 21 usw probiert.. geht aber irgendwie nix... *grml*
Das umstellen der lokalen IP des Webservers auf DMZ hab ich auch probiert -> selbes ergebnis.... sch*** Kiste

Jemand nen Tipp?? ich werfs jetzt dann in die Ecke wenns nicht bald geht... *G*
Bitte warten ..
Mitglied: Midivirus
30.01.2006 um 19:55 Uhr
Also irgendwie peilt ACER es dann anscheinend nich!

Warum lässt man den Router dann nich einfach weg???

Gruß
Midivirus
Bitte warten ..
Ähnliche Inhalte
Windows Server

SBS 2011 Sicherungdatenträger mit wbadmin zeigt unzulässige Funktion

gelöst Frage von Rolf-Hanka.ITDWindows Server5 Kommentare

Hallo Leute, zum System: Es handelt sich hier um einen Windows Small Business Server 2011. Diesen Sichere ich mit ...

Webentwicklung

DynDNS ohne dynDNS-Provider

gelöst Frage von itebobWebentwicklung5 Kommentare

Ich habe eine Möglichkeit gefunden, die aktuelle Router-IP-Adresse an ein Skript auf meinem Webspace zu übermitteln. ich habe bei ...

Tipps & Tricks

CMS content absichern gegen Datenklau?

Frage von winIT3264Tipps & Tricks7 Kommentare

Hallo zusammen, ich habe eine alte HTML Webseite mit gut recherchierten Daten die auch Akzeptanz gefunden hat. Diese Seite ...

Outlook & Mail

Problemchen bei Outlook Content

Frage von TechnoXOutlook & Mail2 Kommentare

Guten Morgen, es kommt gelegentlich vor das User sich melden, klagen das sie keine Anhänge in ihrem Outlook öffnen ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 9 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 14 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

Visual Studio
Singletone Objekt in Datei speichern
gelöst Frage von it4baerVisual Studio13 Kommentare

Hallo, ist es möglich ein Singleton-Objekt zu "serialisieren" und dann in eine Datei zu speichern um es später wieder ...