Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Windows 7 deaktiviert während der Eingabe das aktive Fenster

Mitglied: dodyou

dodyou (Level 1) - Jetzt verbinden

05.04.2014, aktualisiert 06.04.2014, 12819 Aufrufe, 7 Kommentare

Seit vergangener Woche werden Texteingaben über die Tastatur dadurch erschwert, dass das Fenster, in dem die Eingabe des Textes erfolgt,plötzlich wie von Geisterhand deaktiviert wird, Es wird kein anderes sichtbares Fenster aktiviert. Zum Biespiel wurde die Eingabe dieser ersten zwei Zeilen dieses Post zweimal dadurch unterbrochen, dass der Cursor auf einmal weg war. Nach ein bis zwei Sekunden springt der Cursor dann wieder von selbst in das Eingabefenster zurück. Wenn man nicht die ganze Zeit auf den Bildschim schaut merkt man es erst beim anschließenden Lesen - der entsprechende Text fehlt dann einfach (Beispiel: soeben war das Wort "Lesen -" auf "L -" reduzuiert.

Die Beobachtung des blinkenden Curosr im Notepad ergab, dass die Unterbrechung 1 bis 15 Sek, dauern kann (Zeitraum zwischen letzten Blinken und Wiederuafnahme des Blinkens des Cursors), der Abstand zwichen den Unterbrechungen ziemlich genau 30 Sek. sind.

Folgende Fehlerursachen schließe ich aus:
- Fehler in der Tastatur - habe zwei unterschiedliche "eingebaute" und zwei USB-Tastaturen ausprobiert, gleiches Phänomen
- Mein Virenschutzprogemm (testhalber alles deaktiviert, dennoch tritt das Phänomen auf)

Webrecherche ergibt, dass das Problem auch unter XP auftrat, und immer wieder die Dateien ctfmon.exe und wermgr.exe in Verdacht gerieten, da - wie auch bei mir - im Taskmanafger diese beiden ganz kurz im zeitlichen Zusammenhang mit dem "Aussetzer" erscheinen. Das liegt aber wohl eher daran, dass sie den "Aussetzer" registrieren.

Den Trick. mittels screenshot im Zeitpunkt des Aussetzers den Übeltäter zu identifzieren, habe ich erfolglos probiert.

Vermuten mag man, dass der Fehler mit einem kürlzlich erfolgten Update zusammenhängt. Das blöde ist, dass keinen früheren Systemwiederherstellungspunkt habe da nach Einbau einer SDD vor etwas über einer Woche der alte Sicherungsort nicht mehr vorhanden ist.

Was also tun?

Herzlichen Dank für freundlliche Hilfe!

Laptop Dell Latitude E6400 mit 8 GB Arbeitsspeicher, 500 GB Festplatte, OS auf SDD Samsung 840 EVO 250 GB, AHCI Mode deaktiv, NTFS, Win 7 Prof 64 bit alle Updates
Mitglied: Sheogorath
05.04.2014 um 17:22 Uhr
Moin,

du könntest mal im Taskmanager schauen, welche Prozesse laufen und dann nach und nach abschalten und schauen, ob es weiterhin auftritt.
Ich würde zunächst nur Userprozesse prüfen und dann die Systemprozesse. Ich vermute es ist irgendein Freeware-Programm, welches auf irgendwas prüft.

Gruß
Chris
Bitte warten ..
Mitglied: dodyou
05.04.2014 um 22:14 Uhr
Danke für den Tip - das ist aber schwieriger als sich anhört, da es üdie 100 Prozesse sind, die da laufen. Und es kann passieren, dass sie wieder automatisch gestartet werden, wenn ich sie beende. und ich muss nach dem Abschalten a mindestens 20 Sek. warten, ob es geholfen hat.

Gibt es keine Möglichkiet, da ein Protokoll mitlaufen zu lassen, dass einem dann sagt, welches Programm da quer schießt? Schließlich merken ctfmon.exe und wermgr.exe ja, dass da was passiert.
Danke soweit - aber eine Protokollmöglichkeit würde da wirklich hfelen, Irgendeine Idee dazu?
Bitte warten ..
Mitglied: Sheogorath
05.04.2014 um 22:28 Uhr
Moin,

nun ja, wie gesagt, nimm mal die System Prozesse weg, da bleiben vielleicht noch 50 übrig, dort kannst du explor.exe und alles Programme wegstreichen, bei denen der Fehler auftritt, jetzt bliebt garnicht mehr so viel übrig. schau mal nach Programmen, die minimiert oder im Systray laufen, dann na dem Rest.

Du solltest es auf 15-20 beschränken können. vielleicht sogar nur 10.

Gruß
Chris
Bitte warten ..
Mitglied: jsysde
LÖSUNG 06.04.2014, aktualisiert um 15:37 Uhr
Moin.
Zitat von dodyou:
[...]Vermuten mag man, dass der Fehler mit einem kürlzlich erfolgten Update zusammenhängt. Das blöde ist, dass keinen
früheren Systemwiederherstellungspunkt habe da nach Einbau einer SDD vor etwas über einer Woche der alte Sicherungsort
nicht mehr vorhanden ist.[...]
Verstehe ich das richtig, du hast dein laufendes OS von HD=>SSD portiert und seit dem tritt dieser Fehler auf?
Sind dabei irgendwelche "Dienstprogramme" für die SSD mit installiert worden? Oder neue IntelRST/IME-Treiber?

Schau dir mal mit DevManPro die installierten, aber nicht (mehr) vorhandenen Geräte im Device Manager an - irgendwas auffälliges?

Cheers,
jsysde
Bitte warten ..
Mitglied: dodyou
06.04.2014, aktualisiert um 15:42 Uhr
Moin moin,

Zitat von jsysde:
Verstehe ich das richtig, du hast dein laufendes OS von HD=>SSD portiert und seit dem tritt dieser Fehler auf?
Ja, dafür gibt es von Samsung ein Portierungstool "Samsung Datas Migration". Nein, das Problem trat erst später auf..
Sind dabei irgendwelche "Dienstprogramme" für die SSD mit installiert worden?
Ja, Samsung Magician for SSD performance managment. Für eine optimlaste Performance müsste ich auf meinem Laptop auch noch AHCI aktivieren, weiss aber nicht wie das geht. Glaube aber nicht dass das die Problemursache ist.
Schau dir mal mit DevManPro die installierten, aber nicht (mehr) vorhandenen Geräte im Device Manager an - irgendwas
auffälliges?
Nein, nicht auffälliges. Danke für den Hinweis auf DevManPro, der ein Tool "Problemaufzeichnung" mit umfast; und das zeichnet, währrend der Cursor im Notepad stand bzw. ich den Text bearbeitete, folgendes auf - man beachte Probleamaufzeichnung 3, die den Moment bescheibt, in dem das Editor-Fenster inaktiv wurde):

Problemaufzeichnung 1: Klick mit der linken Maustaste durch Benutzer in "Unbenannt - Editor"
Programm: Editor, 6.1.7601.17514 (win7sp1_rtm.101119-1850), Microsoft Corporation, NOTEPAD.EXE, NOTEPAD.EXE
Benutzeroberflächenelemente: Unbenannt - Editor, Notepad
Problemaufzeichnung 2: Tastatureingabe durch Benutzer in "Unbenannt - Editor" [EINGABE ... NACH-LINKS NACH-LINKS NACH-LINKS NACH-LINKS NACH-LINKS ENTF NACH-RECHTS ...]
Programm: Editor, 6.1.7601.17514 (win7sp1_rtm.101119-1850), Microsoft Corporation, NOTEPAD.EXE, NOTEPAD.EXE
Benutzeroberflächenelemente: Edit, Unbenannt - Editor, Notepad
Problemaufzeichnung 3: Tastatureingabe durch Benutzer in "PlainText" [POS1]
Programm: Windows Problem Reporting, 6.1.7600.16385 (win7_rtm.090713-1255), Microsoft Corporation, WERMGR.EXE -QUEUEREPORTING_SVC C:\PROGRAMDATA\MICROSOFT\WINDOWS\WER\REPORTQUEUE\APPCRASH_PLAINTEXT.EXE_82D91573FA89CDA5E295A7ABACB49B81E02CB3_0C557F0F, WERMGR.EXE
Benutzeroberflächenelemente: Abbrechen, Button, CtrlNotifySink, DirectUIHWND, PlainText, #32770
Problemaufzeichnung 4: Klick mit der linken Maustaste durch Benutzer in "Unbenannt - Editor"
Programm: Editor, 6.1.7601.17514 (win7sp1_rtm.101119-1850), Microsoft Corporation, NOTEPAD.EXE, NOTEPAD.EXE
Benutzeroberflächenelemente: Edit, Unbenannt - Editor, Notepad

Was bedeutet das?

Besten Danke für freundlche Untertützung!
Bitte warten ..
Mitglied: jsysde
06.04.2014 um 15:57 Uhr
Mahlzeit.

Hmmm.... wirf mal die SSD-Tools von der Platte und installiere mal aktuelle Chipsatz-Treiber + IntelRST + IME (sofern das ein Intel-Chipsatz ist, wovon ich mal ganz platt ausgehe). Dann lade den Standard-AHCI-Treiber von MS und stelle im BIOS den Modus von "Compatibility" auf "AHCI" um. Unter Windows 7 klappt das im Gegensatz zu XP ohne Neuinstallation.

Wenn die Kiste dann hochgefahren ist, lädst du dir den aktuellen AHCI-Treiber und installierst sie - Windows wird dann noch mehrfach neu starten (wollen), dann noch mal schauen, ob das Problem noch besteht.

Cheers,
jsysde
Bitte warten ..
Mitglied: dodyou
06.04.2014, aktualisiert um 16:13 Uhr
Habe jetzt einmal in das in der Fehlermeldung angezeigte Protokoll im Verzeichnis C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_plaintext.exe_82d91573fa89cda5e295a7abacb49b81e02cb3_0f1c66cd geschaut (mit dem Editor, das ist ein einfacher Text). Dort heisst es
UI[2]=C:\ELO\prog\OcrTextReader\plaintext.exe
UI[3]=PlainText funktioniert nicht mehr
Daraufhin habe ich in der Compuiterveraltung den Dienst "ELOprofessional OCR Textreader" deaktiviert - und das Problem taucht nicht mehr auf. Diesen Text konnte ich durchschreiben, ohne dass das Fenster zwischendurch inaktiv wurde.
Den Dienst habe ich jetzt von Autostart auf Manuel gestellt.

Den Rest soll jetzt das Team von ELO klären.

@ jsysde: das mit der Chipsatzunterstützung und Aktivierung von AHCI mach ich dann ein anderes Mal ...

@ jsysde & Christoph.Kern
Danke für Eure Unterstützung.

Wenn das Problem auch Morgen nicht mehr da ist werde ich das Problem hier aus gelöst markieren. Den Thread halte ich aber für erhlatenswert, da er einen gangbaren Lösungsweg beschreibt,
Bitte warten ..
Ähnliche Inhalte
Windows 7

Fenster nach Eingabe von gpresult verschwindet

gelöst Frage von CoscosWindows 71 Kommentar

Hallo, wenn ich den Befehl "gpresult /r" bei einem WIN7 PC in der Domäne eingebe, wird das DOS Fenster ...

Windows 7

Wie kann man ein Fenster in Windows 7 sperren?

Frage von grillinator95Windows 72 Kommentare

Wie kann man ein bestimmtes Fenster in einer Software sperren? Wie reden hier von Windows 7, gibt es dazu ...

Windows 7

Wie den Eingabefokus auf aktivem Fenster fixieren? (Win7)

gelöst Frage von owalkerWindows 74 Kommentare

Hallo, wie bekomme ich es hin, daß andere Programme nicht den Fokus (Wo landen die Tastatureingaben) vom aktivem Fenster ...

Windows 7

Beim abschalten eines Bildschirms werden alle Fenster auf den aktiven geschoben

Frage von Tealk144Windows 720 Kommentare

Morgen zusammen, in der Arbeit habe ich 2 Bildschirme, wenn ich den ersten oder zweiten wegschalte dann schiebt er ...

Neue Wissensbeiträge
Server-Hardware
HP iLO ist gefährdet (iLO 4))
Tipp von AlFalcone vor 46 MinutenServer-Hardware

Gemäss Twitter und Heise gibt es eine Angriffsmöglichkeit auf iLO iLO ist gefährdet Copyright © und alle Rechte liegen ...

CMS
Erneut kritische Zero-Day-Lücke in Drupal
Tipp von Reini82 vor 9 StundenCMS

Laut einem Bericht auf t3n gibt es eine Schwere Sicherheitslücke in Drupal die auch schon ausgenutzt wird. Betroffen sind ...

Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 1 TagSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 1 TagWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

Heiß diskutierte Inhalte
Ausbildung
Wie gelingt ein guter Einstieg in die FiSi-Ausbildung? (Umschulung)
Frage von SiAnKoAusbildung27 Kommentare

Schönen guten Tag, ich bin SiAnKo und habe seit dem 1.04.2018 eine Umschulung als FiSi angefangen. Ich möchte natürlich ...

Windows Server
Alten DC entfernen
gelöst Frage von smartinoWindows Server27 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...

Batch & Shell
Mit Powershell den Inhalt einer Excel mit einer Text Datei abgleichen
gelöst Frage von Bommi1961Batch & Shell21 Kommentare

Hallo zusammen, ich muss den Inhalt einer Excel Datei (Mappe1) mit dem Daten einer Text Datei abgleichen. Die Daten ...

Router & Routing
Subnetzmaske vergrößern
gelöst Frage von groovesurferRouter & Routing17 Kommentare

Hallo, hat jemand schonmal getestet was passiert, wenn man die Subnetzmaske bei laufendem Betrieb (wenn user im Netzwerk verbunden ...