Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows NT 4.0 - Device Null defekt

Mitglied: MikeB

MikeB (Level 1) - Jetzt verbinden

08.10.2004, aktualisiert 13.10.2004, 7574 Aufrufe, 10 Kommentare

Hallo

Hab ein Problem mit Device Null auf unseren NT 4 Server.

Wenn sich in einer Batch-Datei sich die Ausgabeumleitung auf Device Null befindet ( >null ), dann meldet das System "Das System kann die angegebene Datei nicht finden". Wenn ich nun die Ausgabeumleitung entferne kommt diese Meldung nicht mehr.

Nun könnte man meinen, daß diese Anweisung ja sowieso eigentlich überflüssig ist. Im Prinzip ist das ja auch so, aber leider laufen bei uns ständig aktualisierte Batch-Dateien, die diesen Eintrag beinhalten, und somit ständig aufgrund dieser Einträge unsere Updates fehlschlagen weil eben dieses "Device Null" nicht mehr vorhanden oder defekt ist.

Wer kann mir sagen ich ich dieses "blöde" Device Null wieder instandsetzen kann.

thx
MikeB
Mitglied: alaska
08.10.2004 um 15:18 Uhr
du hast einen klitzekleinen Fehler gemacht
null heißt es unter den IX-ern
bei Windows heist das Device nul (mit EINEM L)
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 15:59 Uhr
Da "Null" eigentlich gar nichts ist, also kein Device oder eine Ausgabeeinheit kann da auch nichts kaputt gehen. Hast Du schon mal den Server neu gestartet - oft wirkt das schon Wunder ;.) ...

Gruß

Atti
Bitte warten ..
Mitglied: MikeB
08.10.2004 um 16:08 Uhr
in den Konfigurationsdateien steht "blabla... > nul"

Server wurde schon mehrmals rebootet
Bitte warten ..
Mitglied: MikeB
08.10.2004 um 16:11 Uhr
was ich bis jetzt schon herausgefunden hab:

nul ist ein device das vom OS mit der datei null.sys geladen wird.

Unter Systemsteuerung-Geräte ist das Gerät Null nicht vorhanden (auf einem vergleichbaren Server aber schon)

wie kann ich die null.sys nachträglich laden ???
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 16:30 Uhr
Du hast Recht, unter NT 4.0 wird das als Dienst angezeigt, bei Dir nicht mehr? Kannst Du nicht mal die Null.sys von einem anderen Server auf Deinen kopieren und den dann neu starten, wenn diese Datei wirklich nicht mehr vorhanden ist?

Gruß

Atti
Bitte warten ..
Mitglied: MikeB
08.10.2004 um 16:35 Uhr
ich hab jetzt mal versuchsweise die null.sys von nem anderen Server kopiert. Vorhanden war sie ja aber ich vermute halt das sie nen knax hat. Mit dem Reboot ist das aber nicht so einfach - im Moment arbeiten "ein paar leutchen" am Server also kann ich erst über Nacht booten. Mal sehen was er am Montag spricht.

Dann werd ich entscheiden ob ich ihn noch mag oder nicht *fg* *ausfensterwerfdann*
Bitte warten ..
Mitglied: MikeB
11.10.2004 um 08:13 Uhr
hab null.sys von anderem Rechner draufkopiert aber das hat leider auch nichts gebracht
Bitte warten ..
Mitglied: Atti58
11.10.2004 um 08:46 Uhr
Sieh mal auf einem Rechner, auf dem "Null" geht, in der Registry nach, wie dieser Dienst gestartet wird und vergleiche (exportiere) diese Einträge mit denen auf Deinem defekten System.

Gruß

Atti
Bitte warten ..
Mitglied: MikeB
12.10.2004 um 15:48 Uhr
So hab jetzt mal die Registrierungseinträge neu eingefügt - heut Nacht läuft ein Reboot - ich hoffe das alles klappt

wenn nicht hab ich morgen ganz viel arbeit

wenns geklappt hat werde ich hier genau posten was und wo ich Einträge gemacht hab
Bitte warten ..
Mitglied: MikeB
13.10.2004 um 14:05 Uhr
jubel - er tut es wieder

hier wie versprochen wo einträge ich importiert hab:

HKEY_LOCAL_MACHINE\SYSTEM\ControlSetxxx\Services

xxx = 001 oder 002 oder 003 je nachdem was vorhanden ist

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

und hier welche ich importiert hab (am Beispiel CurrentControlSet):

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Null]
"Type"=dword:00000001
"Start"=dword:00000001
"Group"="Base"
"ErrorControl"=dword:00000001
"Tag"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Null\Enum]
"0"="Root\\LEGACY_NULL\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001

Vorraussetzung dafür ist das "Root\\LEGACY_NULL\\0000" existiert
Bitte warten ..
Ähnliche Inhalte
Windows XP

Windows XP - Mit Windows NT 4.0 erstellte Basisvolumes

Frage von MetacrawlerWindows XP1 Kommentar

Hallo, ich versuche gerade mittels MDT 2013 Update 1 in einer VM eine Windows XP testinstallation durchzuführen. Ich habe ...

Windows XP

Microsoft Windows NT 4.0 Workstation inkl. SP6

gelöst Frage von JordanWindows XP7 Kommentare

Hallo zusammen, ich bin verzweifelt auf der Suche nach einem Installationsmedium mit Microsoft Windows NT 4.0 Workstation, das SP6 ...

Windows Tools

Icloud für Windows 4.0 auch für Vista?

Frage von ArafatWindows Tools4 Kommentare

Hallo Zusammen, Apple hat vor kurzem die Systemsteuerung 4.0 für die iCloud zum Download freigegeben. Das Programm an sich ...

Verschlüsselung & Zertifikate

NT-Password (NT Hash) unter Windows generieren

gelöst Frage von PedantVerschlüsselung & Zertifikate7 Kommentare

Hallo, es muss doch irgendwie möglich sein ein NT-Password (einen NT-Hash) unter Windows zu erzeugen!? Es ist doch ein ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 18 StundenPeripheriegeräte1 Kommentar

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 1 TagWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 1 TagWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 3 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Humor (lol)
Freitagsfrage: Was tun, wenn der Admin der DAU ist?
gelöst Frage von VoiperHumor (lol)32 Kommentare

Moin Zusammen, Eine nicht ganz ernst gemeinte Frage an die Außendienstler unter uns. Zusammenfassung: Ein Inhouse Admin ruft bei ...

Windows Netzwerk
LTE Modul - Kein Internet trotz Verbindung
Frage von killtecWindows Netzwerk19 Kommentare

Hallo, ich habe hier ein Dell 7390 2-in-1 mit W10 Pro wo ich nachträglich eine LTE-Karte (Original Dell DW5811e ...

Peripheriegeräte
Guter "Router" für simples NAT gesucht
gelöst Frage von fisi-pjmPeripheriegeräte13 Kommentare

Hi, ich bin derzeit auf der Suche nach einem kleinen Gerät, welches ich vor eine Firewall klemmen kann, welches ...

Windows 10
Bild oder Wasserzeichen über Wallpaper
gelöst Frage von TiloklomWindows 1011 Kommentare

Hallo liebe Community, ein Bekannter von mir hat eine Firma mit rund 15 Clients (Windows 10 Pro 64x) diese ...