Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

1 Laptop, 1 IP-Adresse u 2 Namen

Frage Sicherheit Sicherheits-Tools

Mitglied: KgFmB

KgFmB (Level 1) - Jetzt verbinden

17.09.2009 um 10:48 Uhr, 6284 Aufrufe, 15 Kommentare

habe ich den ersten Schizophrenen Laptop?

Hallo zusammen,
hab ein kleines Phänomen was ich nicht ganz nachvollziehen kann,
wo mein Denkfehler ist oder etwas übersehen habe.

Habe 2 Laptopnamen NAME1 und NAME2.
Im ActiveDirectory steht aber nur NAME1.
NAME2 taucht nicht auf.

Folgendes:

Schritt 1:
Ich bin an einem beliebigen PC der Domäne und mache mittels Konsole ein Ping

Ping NAME1

Erhalte die Rückmeldung gefunden mit IP 10.20.30.64
und er ist am Netzwerk.

Schritt 2:
Ich mache einen Ping auf den zweiten Laptop

Ping NAME2

Erhalte die Rückmeldung gefunden mit IP 10.20.30.64
und er ist am Netzwerk.

Jetzt beginne ich mich schonmal zu wundern.
Zwei PC Namen und eine IP?? Nicht möglich.

Okay ich mache mich auf die suche nach dem ersten Laptop den ich finde.

Mittels Konsole und IPCONFIG /ALL
stelle ich fest, der Laptop der vor mir steht hat den Namen NAME1 und die IP 10.20.30.64.

Wir nutzen hier ein Remotetool, mit dem wir mittels Namen auf den Laptop uns schalten können.
Also ich nutze dann NAME2 und lande doch auf den PC NAME1.

Schritt 3:
Gut, denk ich mir, entferne ich das Netzwerkkabel vom Laptop NAME1 und wiederhole Schritt 1 und 2.
Der andere Laptop NAME2 ist ja nicht auffindbar.

Aber diesmal bekomme ich zwar die Meldung über die gefundene IP, aber keine Antwort.
Bei beiden Namensversuche.

Schritt 4:
Stecke Kabel wieder ein.
Und ich erhalte sowohl von einem auch dem anderen Antwort.

Schritt 5:
Denk ich mir so, mach ich eine Laufwerksverknüpfung zum NAME2 und prüf mal die angemeldeten User.
Gemacht, getan und schon befinde ich mich auf dem Laptop NAME1

Schritt 6:
Prüfe ich die komplette Registry von NAME1, ob irgend ein Eintrag mit NAME2 vorhanden ist.

-> nichts drin.

Schritt 7:
Wir nutzen DHCP. Gut löschen wir den Eintrag und lassen NAME1 eine neue IP beziehen.

Schritt 8:
Ich wiederhole meine ersten Pingversuche.
Und ich stelle fest:

NAME1 bekommt eine neue IP und NAME2 hat ebenfalls die gleiche IP.

Schritt 9:
Denk ich mir okay, entfernen wir NAME1 aus der Domäne, löschen das Computerkonto im Active Directory
und fügen ihn wieder neu hinzu.

PING-Versuch:
Wieder das gleiche
NAME1 und NAME2 haben wieder die gleiche IP.



Soweit zu meinen Vorgängen.
Hat jemand einen Lösungsvorschlag oder einen Ansatz wonach ich noch suchen kann?
Oder hab ich wirklich einen Schizophrenen Laptop?

Danke im voraus

KgFmB
Mitglied: manuel-r
17.09.2009 um 10:55 Uhr
Und wo genau war jetzt das Phänomen?
Ziemlich klassischer Fehler im DNS. Dort steht das eine Notebook höchstwahrscheinlich mit den beiden Namen drin. Hat wohl irgendwann entweder jemand manuell eingetragen oder es hat was mit der Aktualisierung nicht geklappt.
Oder das Notebook steht noch mit einem alten Namen in deinem lokalen DNS-Cache. Für Abhilfe sorgt da ein beherztes ipconfig /flushdns auf der Kommandozeile.

Manuel
Bitte warten ..
Mitglied: 2hard4you
17.09.2009 um 11:07 Uhr
Hallo,

Name 2 kann auch ein DNS-Alias sein, auch dort zu finden.

Gruß

24
Bitte warten ..
Mitglied: manuel-r
17.09.2009 um 11:11 Uhr
Name 2 kann auch ein DNS-Alias sein, auch dort zu finden
Was dann aber ein gewisses Maß an Absicht erfordert. Von selbst kommen Aliase ja nicht ins DNS.Bevor der OP den löscht sollte er also mal mit den Leuten reden, die potentiell dafür in Frage kommen den Alias angelegt zu haben
Bitte warten ..
Mitglied: KgFmB
17.09.2009 um 11:21 Uhr
Hallo Manuel,

tja so einfach macht es mir diese Sache nicht.

Laut DNS gibt es für die IP nur einen Eintrag und zwar NAME1.
NAME2 taucht nirgends dort auf
Hab ich auch schon gedacht.
Auch den zweiten DNS Server geprüft. Kein Eintrag für NAME2

Und auch auf das leeren des lokalen Cache, tauchen immer noch beide Namen mit der gleichen IP auf.

Dieses Phänomen taucht ja nicht nur an einem PC auf, von dem ich den PING mache.
Bitte warten ..
Mitglied: NilsvLehn
17.09.2009 um 11:28 Uhr
kannst du mal verfremdlich aufschreiben, wie deine 2 Namen aussehen, denn ich kann mir unter Name1 und Name2 nix vorstellen. Könntest du das ein bissel genauer beschreiben?
Bitte warten ..
Mitglied: manuel-r
17.09.2009 um 11:34 Uhr
Vielleicht auch ganz banal in der hosts eingetragen?!
Hast du beim pingen von einem anderen Client den gleichen Effekt?
Bitte warten ..
Mitglied: KgFmB
17.09.2009 um 11:38 Uhr
Im Grunde ist es egal wie ich die zwei Namen schreibe.
Fakt ist ich habe zwei Hostnamen, die per PING-Befehl auf ein und die selbe IP Adresse aufgelöst und gefunden werden, obwohl ich nur einen Laptop finde.

Wie beschrieben:
Wenn ich eine Netzlaufwerksverknüpfung erstelle mit dem Hostname für NAME2 und C$
lande ich auf der C-Partition von Laptop NAME1.

Auch wenn ich ein NET SEND an NAME2 schicke, kommt es am Laptop NAME1 an.
Bitte warten ..
Mitglied: KgFmB
17.09.2009 um 11:39 Uhr
Jupp, daher schloss ich auch eine Problem an der lokalen-DNS aus
Bitte warten ..
Mitglied: SlainteMhath
17.09.2009 um 11:39 Uhr
Hi,

"ping" ist zum testen der DNS Namendauflösung nicht geeignet, da hier u.U. die IP über Netbios ermittelt wird.

Teste bitte folgendens:

1. nslookup IP
2. nslookup NAME1
3. nslookup NAME2

und poste mal die ergebnisse.

/EDIT: und dann das ganze per NetBios/WINS:
1. NBTSTAT IP
2. NBTSTAT NAME1
3. NBTSTAT NAME2

Benutzt ihr WINS? evtl kommt der "falsche" name vom WINS Server

lg,
Slainte
Bitte warten ..
Mitglied: KgFmB
17.09.2009 um 12:04 Uhr
Also momentan ist der Laptop nicht am Netzwerk, daher auch ZEITÜBERSCHREITUNGEN per PING.

Aber beim NSLOOKUP auf NAME2
Erhalte ich als Antwort vom Server

Klar die Daten vom Server und statt die Daten des Laptops

*** NAME2 wurde von DNSServer nicht gefunden: Non-existent domain

Wärend ich mit NSLOOKUP NAME1 den vollständigen Namen sowie dieIP-Adresse erhalte.

Und per NBTSTAT Befehl erhalte ich nur
Host nicht gefunden.

Was aber für mich z.Z. klar ist, da der Laptop vom Netzwerk getrennt ist.
Bitte warten ..
Mitglied: SlainteMhath
17.09.2009 um 12:08 Uhr
Ok, NAME2 ist also kein DNS, sondern eher ein Netbios Name.

Und per NBTSTAT Befehl erhalte ich nur
Host nicht gefunden.
Was aber für mich z.Z. klar ist, da der Laptop vom Netzwerk getrennt ist.
dann nimm den Laptop mal ans Netz und versuch's nochmal und poste bitte das Ergebnis.

Nur mal am Rande: Virtuelle Maschinen o.Ä. laufen nicht auf der Kiste, oder?
Bitte warten ..
Mitglied: KgFmB
17.09.2009 um 13:20 Uhr
Okay ich kann nun bestätigen, das ich per NSLOOKUP auf NAME2 die Rückmeldung

*** NAME2 wurde von DNSServer nicht gefunden: Non-existent domain

erhalte.

Und bei NBSTAT -A NAME2

Die Rückmeldung kein Host erhalte.

Hingegegen bei
NBSTAT -A NAME1
eine NetBIOS-Namentabelle des Remotecomputers erhalte.
Bitte warten ..
Mitglied: KgFmB
17.09.2009 um 13:21 Uhr
Nein keine Virtuelle Maschine o.Ä.
Bitte warten ..
Mitglied: super-skunk
17.09.2009 um 13:41 Uhr
Sorry habe die Antwort, die ich hatte überlesen......Sie steht schon da.
Bitte warten ..
Mitglied: KgFmB
17.09.2009 um 16:46 Uhr
So ich hab glaub ich den Übeltäter.

Es war wirklich der WINS-Server.

Dort befand sich doch tatsächlich der Eintrag mit dem Hostnamen und der IP Adresse
des bereits für den NAME1 reservierten Laptops.

Nach der Entfernung funktionierte auch der PING auf NAME2 nichtmehr.

Ich danke allen, die Mitgerätselt und mich unterstützt haben.
Dank an SlainteMhath mit dem Hinweis "WINS"

Bleibt nur noch zu sagen....

Schade doch kein Schizophrener Laptop.



Gruß
KgFmB
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst TP-Link WA501G als Client einrichten - Keine IP Adresse wir bezogen (14)

Frage von bestelitt zum Thema LAN, WAN, Wireless ...

E-Mail
gelöst Falsche SMTP Server IP Adresse (6)

Frage von laster zum Thema E-Mail ...

Batch & Shell
Hostname bzw IP-Adresse in Excel eintragen (12)

Frage von EgonFrenz zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...