Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Abfrage von Variable (User-Input)

Frage Entwicklung Batch & Shell

Mitglied: -heny-

-heny- (Level 1) - Jetzt verbinden

04.03.2008, aktualisiert 06.03.2008, 10808 Aufrufe, 4 Kommentare

Hallo,

ich habe ein kleines Problem mit einem Skript, welches den User erst einer Variable einen Wert zuweisen lässt (SET /p) und diesen daraufhin abfragt. Je nach Usereingabe sollen unterschiedliche Aktionen durchgeführt werden.

Beispiel #1 (funktioniert problemlos)
01.
        :settingsmenu 
02.
        set /p menupoint=!%lang%inputmenupoint! 
03.
        if "%menupoint%"=="1" goto languagemenu 
04.
        if "%menupoint%"=="2" goto teamnamesmenu 
05.
        if "%menupoint%"=="3" goto leaguelabelsmenu 
06.
        if /i "%menupoint%"=="B" goto mainmenu 
07.
        echo. 
08.
        echo !%lang%invalidinput! 
09.
        echo. 
10.
        pause 
11.
        goto settingsmenu
Im ersten Beispiel funktioniert alles so, wie ich es möchte. Weist der User der Variable den Wert "1" zu, so geht es zur Sprungmarke "languagemenu", bei "2" zu "teamnamesmenu", bei "3" zu "leaguelabelsmenu" und bei "B" zur Sprungmarke "mainmenu". Wird ein anderer Wert bei der Userabfrage eingegeben, so wird dem User auf dem Bildschirm mitgeteilt, dass er eine valide Eingabe zu machen hat. Auch beim Wert "", also einer leeren Eingabe, wird die Sprungmarke "settingsmenu" samt Fehlermeldung (s. echo's) aufgerufen.

Beispiel #2 (funktioniert nicht komplett)
01.
        set /p menupoint=!%lang%inputmenupoint! 
02.
        if "%menupoint%"=="1" ( 
03.
            call :editcfgline settings.cfg 6 lang=leng 
04.
            goto languagemenu 
05.
06.
        if "%menupoint%"=="2" ( 
07.
            call :editcfgline settings.cfg 6 lang=lger 
08.
            goto languagemenu 
09.
10.
        if /i "%menupoint%"=="B" goto settingsmenu 
11.
        echo. 
12.
        echo !%lang%invalidinput! 
13.
        echo. 
14.
        pause 
15.
        goto languagemenu
Im zweiten Beispiel funktioniert der erste Teil auch problemlos. Bei einer Eingabe von "1" führt er den Inhalt der Bedingungsgruppierung durch, ebenso bei der Zuweisung "2". Die Eingabe von "B" resultiert, wie gewünscht, in einem Aufruf der Sprungmarke "settingsmenu". Gibt der User andere Buchstaben/Eingaben ein, so wird die Fehlermeldung auf dem Bildschirm angezeigt und die Sprungmarke "languagemenu" aufgerufen. So weit, so gut. Weist der User der Variable allerdings keinen Inhalt zu, also "", so reagiert das Skript mit einem Aufruf der Sprungmarke "languagemenu", allerdings ohne Ausgabe der Fehlermeldung (s. echo's). Entferne ich die beiden If-Gruppierungen aus dem Skript, so funktioniert alles tadellos.

Woran liegt dies? Verzögerte Erweiterungen sind in der Batch-Datei natürlich aktiviert, wobei die !%lang%xyz!-Variablen eingelesene Strings aus einer Textdatei repräsentieren.

Gruß,
heny
Mitglied: -heny-
05.03.2008 um 01:32 Uhr
Wie ich herausgefunden habe scheint das Problem damit zusammenzuhängen, dass die Befehle der IF-Abfragen IMMER ausgeführt werden, egal ob die Bedingung zutrifft oder nicht. Es scheint daran zu liegen, dass die Variable nicht definiert ist, wenn man ihr "" zuweist. Warum dann die Befehle innerhalb der IF-Gruppierungen dennoch ausgeführt werden ist mir nicht ersichtlich.

Einen Workaround kann man schaffen, indem man die Variable vor der Userabfrage vordefiniert, z.B.:

01.
        set menupoint=UNDEFINED 
02.
        set /p menupoint=!%lang%inputmenupoint!
Gruß,
heny
Bitte warten ..
Mitglied: Biber
05.03.2008 um 12:48 Uhr
Hmm, -heny-,

Woran liegt dies? Verzögerte Erweiterungen sind in der Batch-Datei natürlich aktiviert, ...

Vielleicht ist das das Problem.
Hast Du evtl diese Batch-Datei über eine weitere Instanz der CMD.exe mit "cmd /v:on dieseBatch.bat" aufgerufen?

Anders gefragt: steht explizit ein "...setlocal EnableDelayedExpansion" am Anfang der Batchdatei?

Grüße
Biber
Bitte warten ..
Mitglied: -heny-
05.03.2008 um 17:33 Uhr
Ich habe nun probiert, die Batch-Datei mit ausgeschalteten verzögerten Erweiterungen laufen zu lassen. Dies resultiert im gleichen Verhalten.

01.
[...] 
02.
    setlocal EnableDelayedExpansion 
03.
[...]
Ich nutze obigen Befehl nicht in der ersten Zeile (also z.B. "@echo off & setlocal EnableDelayedExpansion"), sondern erst ein paar Zeilen später. Das hat aber keine Auswirkungen, da vorher nur Kommentare stehen.

Gruß,
heny
Bitte warten ..
Mitglied: Biber
06.03.2008 um 07:38 Uhr
Moin -heny-,

kann so auch die Fehlerursache nicht erkennen.
Wenn Du willst, dann sende mal den Batchschnipsel im Original an meine im Profil angegebene Mailaddresse.

Grüße
Biber
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Batch & Shell
gelöst Batch Abfrage Vergleiche mit Variable goto (4)

Frage von Zunaras zum Thema Batch & Shell ...

Windows Server
User-ID zu Application Crash

Frage von pablovic zum Thema Windows Server ...

Router & Routing
Radius für 15 User direkt über Mikrotik- oder Ubiquiti-Router (4)

Frage von Muesliriegel zum Thema Router & Routing ...

Windows 8
gelöst Active Directory Default User.v2 Profile - Windows 8.1 Apps Error (4)

Frage von adm2015 zum Thema Windows 8 ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...