Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access Suchengine funktioniert nicht richtig.

Frage Microsoft Microsoft Office

Mitglied: spiderman19

spiderman19 (Level 1) - Jetzt verbinden

11.10.2004, aktualisiert 15.10.2004, 5053 Aufrufe, 1 Kommentar

Hallo,

ich habe ein Problem bei einer Access Datenbank. In einer Tabelle mit Personaldaten soll nach allen Eigenschaften gesucht werden können, also z.B. Vorname, zweiter Vorname, Nachname, Straße, Staatsbürgerschaft, usw.
Die gefundenen Objekte sollen dann in einer Listbox angezeigt werden.
Wenn jetzt aber jemand z.B. keinen zweiten Vorname hat, oder eben irgendeine Eigenschaft in der Tabelle leer ist, wird die gesamte Person erst gar nicht angezeigt, egal ob nach nichts ("") oder nach irgendeinem Begriff gesucht wird.
Das Codestück sieht folgendermaßen aus:



strSQL = "SELECT PersonalNr, Vorname, Nachname, Staatsbürgerschaft" _
& " FROM Personal" _
& " WHERE ((Personal.Anrede) LIKE '*" & strKrit0 & "*')" _
& " AND ((Personal.Vorname) LIKE '*" & strKrit2 & "*')" _
& " AND ((Personal.ZweiterVorname) LIKE '*" & strKrit3 & "*')"

Me!Liste0.RowSource = strSQL




Durch SELECT PersonalNr, Vorname, Nachname, Staatsbürgerschaft werden die PersonalNr, der Vorname, der Nachname und die Staatsbürgerschaft in der Listbox angezeigt.
Gesucht wird in der Tabelle Personal (FROM Personal).
strKrit0, strKrit2, strKrit3 sind Variablen die den zu suchenden Begriff enthalten, also
wenn strKrit2 = "Stefan" ist sollen alle Personen die mit Vornamen Stefan heißen angezeigt werden.

Also noch mal zusammengefasst wenn eine Person eine Eigenschaft nicht hat nach der gesucht werden kann, also z.B. keinen zweiten Vornamen wird diese Person, egal wonach gesucht wird, nicht angezeigt.

danke im Voraus
Mitglied: spiderman19
15.10.2004 um 18:32 Uhr
habs schon gelöst
Lösung findet ihr unter:
http://support.microsoft.com/default.aspx?scid=kb%3Bde%3BD45182
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Raid funktioniert nicht richtig (20)

Frage von Roadrunner777 zum Thema Windows Server ...

Windows Server
Faxserver funktioniert vom Client aus nicht richtig (9)

Frage von CharlyXL zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...