Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access Suchengine funktioniert nicht richtig.

Frage Microsoft Microsoft Office

Mitglied: spiderman19

spiderman19 (Level 1) - Jetzt verbinden

11.10.2004, aktualisiert 15.10.2004, 5037 Aufrufe, 1 Kommentar

Hallo,

ich habe ein Problem bei einer Access Datenbank. In einer Tabelle mit Personaldaten soll nach allen Eigenschaften gesucht werden können, also z.B. Vorname, zweiter Vorname, Nachname, Straße, Staatsbürgerschaft, usw.
Die gefundenen Objekte sollen dann in einer Listbox angezeigt werden.
Wenn jetzt aber jemand z.B. keinen zweiten Vorname hat, oder eben irgendeine Eigenschaft in der Tabelle leer ist, wird die gesamte Person erst gar nicht angezeigt, egal ob nach nichts ("") oder nach irgendeinem Begriff gesucht wird.
Das Codestück sieht folgendermaßen aus:



strSQL = "SELECT PersonalNr, Vorname, Nachname, Staatsbürgerschaft" _
& " FROM Personal" _
& " WHERE ((Personal.Anrede) LIKE '*" & strKrit0 & "*')" _
& " AND ((Personal.Vorname) LIKE '*" & strKrit2 & "*')" _
& " AND ((Personal.ZweiterVorname) LIKE '*" & strKrit3 & "*')"

Me!Liste0.RowSource = strSQL




Durch SELECT PersonalNr, Vorname, Nachname, Staatsbürgerschaft werden die PersonalNr, der Vorname, der Nachname und die Staatsbürgerschaft in der Listbox angezeigt.
Gesucht wird in der Tabelle Personal (FROM Personal).
strKrit0, strKrit2, strKrit3 sind Variablen die den zu suchenden Begriff enthalten, also
wenn strKrit2 = "Stefan" ist sollen alle Personen die mit Vornamen Stefan heißen angezeigt werden.

Also noch mal zusammengefasst wenn eine Person eine Eigenschaft nicht hat nach der gesucht werden kann, also z.B. keinen zweiten Vornamen wird diese Person, egal wonach gesucht wird, nicht angezeigt.

danke im Voraus
Mitglied: spiderman19
15.10.2004 um 18:32 Uhr
habs schon gelöst
Lösung findet ihr unter:
http://support.microsoft.com/default.aspx?scid=kb%3Bde%3BD45182
Bitte warten ..
Neuester Wissensbeitrag
Server-Hardware

Welchen Serverschrank brauche ich? - Hier ein kleine Entscheidungshilfe

(6)

Anleitung von serverschrank24 zum Thema Server-Hardware ...

Ähnliche Inhalte
Datenbanken
gelöst Access Abfrage funktioniert nach Tabellenänderung nicht mehr (1)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Datenbanken
Access Import funktioniert nicht mehr (2)

Frage von FISI-Neuling92 zum Thema Datenbanken ...

Windows Server
Faxserver funktioniert vom Client aus nicht richtig (9)

Frage von CharlyXL zum Thema Windows Server ...

Heiß diskutierte Inhalte
Off Topic
Mein Arbeitsplatz wurde Outgesourced (36)

Frage von Schroedingers.Katze zum Thema Off Topic ...

Router & Routing
ASUS RT-AC68 Router Firewall Fehlfunktion? (25)

Frage von pk-911 zum Thema Router & Routing ...

Windows Server
gelöst Windows Server Sicherung wirre Meldungen (21)

Frage von DKowalke zum Thema Windows Server ...

Windows 10
gelöst GPO wird bei manchen Rechnern nicht übernommen (20)

Frage von Hanuta zum Thema Windows 10 ...