Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Active Directory setspn Problem

Frage Microsoft Windows Server

Mitglied: Pate661

Pate661 (Level 1) - Jetzt verbinden

26.06.2011 um 10:20 Uhr, 10160 Aufrufe, 5 Kommentare

Hallo liebe Community,

ein weiteres Problem, das mich gerade auf Trab hält ist folgendes:

Über BPA bekomme ich in unserem Exchange 2007 folgende Fehlermeldung:

"Das Computerkonto für ´STMPSVC/SERVER.xxxxxxx.local wurde in Active Directory nicht gefunden
Für kein Computerkonto in Active Directory wurde 'ServicePrincipalName' auf 'SMTPSVC/SERVER.xxxxx.local' festgelegt. Dies führt zu Kerberos-Authentifizierungsfehlern, wenn Server 'SERVER.xxxxx.local' versucht, eine SMTP-Verbindung mit einem anderen Hub-Transport-Server herzustellen."



Ich habe dazu auch schonmal ein bisschen im Web gesucht und bin hier auf die setspn.exe gestoßen.

Wenn ich allerdings den Befehl:

setspn.exe -A SMTPSVC/ SERVER.xxxxxxx.local

in die Verwaltungsshell eingebe kommt folgender Fehler:

"FindDomainForAccount: Fehler bei "DSGetDcNameWithAccountW"
Konto Server.xxxxxx.local wurde nicht gefunden"

Was mache ich falsch?

Wäre super, wenn mir hier jemand Unterstützung geben könnte!

Vielen Dank im Voraus!
Mitglied: mexx
10.11.2011 um 10:08 Uhr
Hast Du das Problem gefunden? Ich versuche den Paramenter L um SPNs aufzulisten und erhalte die gleiche Meldung, dass das Konto nicht existieren würde, was natürlich nicht richtig ist.
Bitte warten ..
Mitglied: Pate661
10.11.2011 um 10:54 Uhr
Hallo Mexx,

leider besteht das Problem weiterhin. Bin etwas ratlos...
Bitte warten ..
Mitglied: clever26
14.11.2011 um 20:17 Uhr
Hallo, ihr müsst darauf achten ob es ein normaler Benutzeraccount oder ein Computeraccount ist.

Wenn du die Fehlermeldung "DSGetDcNameWithAccountW" tippe ich mal das es sich um einen Computeraccount handelt. Diese werden mit einem "$" am Ende gekennzeichnet.

Also Computername$ und normale Benutzer einachen nur Name

lg Clever26
Bitte warten ..
Mitglied: mexx
15.11.2011 um 10:45 Uhr
Das kann ich leider nicht bestätigen. Ich hab es ausprobiert. Mit einen "$" am Ende des Namens, kommt bei den Befehl setspn -L XYZ die Fehlermeldung

FindDomainForAccount: Fehler beim Aufrufen von DsGetDcNameWithAccountW mit dem Rückgabewert 0x00000525.
Konto XYZ$ wurde nicht gefunden.

Es handelt sich aber definitiv um ein Benutzerkonto.
Bitte warten ..
Mitglied: clever26
15.11.2011 um 13:05 Uhr
setspn prüft immer den sAMAccountnamen, vielleicht ist der ja anders?

"Start -> verwaltung -> avtive directory-benutzer und -Computer" kann man unter "Ansicht -> erweiterte Features " ein zusätzliches Feld zu den Eigenschaften der Computer- und Benutzer anzeigen lassen, den Attribute-Editor. Hier vielleicht einmal den sAMAccountName überprüfen und schauen ob Service-Principals gesetzt sind oder nicht.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Active Directory-Problem nach Disaster Recovery
Frage von RalphMichelsWindows Server14 Kommentare

Hallo, nach einem notwendigen Disaster Recovery - einer vollständigen Wiederherstellung eines Win2012-DC aus einem per Symantec BackupExec erstellten Backup ...

Windows Netzwerk
Active Directory bzw. DNS Problem
gelöst Frage von RomanWindows Netzwerk20 Kommentare

Hallo zusammen, ich betreibe einen Server mit Server 2008R2 System. Soweit alles gut. Wenn ich im Servermanager unter Rollen ...

Windows Server
Active Directory Vertrauensstellung
Frage von ukulele-7Windows Server11 Kommentare

Ich muss sagen das ist meine erste Vertrauensstellung. Ich habe sie in unserer alten AD ads.domain.local Windows 2003 und ...

Windows Server
Mit Tastenkürzel im Active Directory navigieren?
gelöst Frage von Fish01Windows Server3 Kommentare

Hallo! Folgender Fall als Beispiel: Habe in einer OU ca. 100 User und möchte zB: bei jedem User kontrollieren, ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 19 StundenBatch & Shell8 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 21 StundenHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 1 TagMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 1 TagSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Bitlocker nach Verschlüsselung nicht mehr aufrufbar!
gelöst Frage von alexlazaWindows 1013 Kommentare

Hallo, ich besitze ein HP ZBook 17 G4 mit einem Windows 10 Pro Betriebssystem. Bei diesem Problem handelt sich, ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Windows Server
Sichere Remote Desktop Verbindung wie?
gelöst Frage von nuss33Windows Server11 Kommentare

Hallo zusammen, eins vorweg: Ich besitze einen privaten Windows Server 2008 R2 zu Hause im Netzwerk er wird nicht ...