Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Active Directory setspn Problem

Frage Microsoft Windows Server

Mitglied: Pate661

Pate661 (Level 1) - Jetzt verbinden

26.06.2011 um 10:20 Uhr, 9772 Aufrufe, 5 Kommentare

Hallo liebe Community,

ein weiteres Problem, das mich gerade auf Trab hält ist folgendes:

Über BPA bekomme ich in unserem Exchange 2007 folgende Fehlermeldung:

"Das Computerkonto für ´STMPSVC/SERVER.xxxxxxx.local wurde in Active Directory nicht gefunden
Für kein Computerkonto in Active Directory wurde 'ServicePrincipalName' auf 'SMTPSVC/SERVER.xxxxx.local' festgelegt. Dies führt zu Kerberos-Authentifizierungsfehlern, wenn Server 'SERVER.xxxxx.local' versucht, eine SMTP-Verbindung mit einem anderen Hub-Transport-Server herzustellen."



Ich habe dazu auch schonmal ein bisschen im Web gesucht und bin hier auf die setspn.exe gestoßen.

Wenn ich allerdings den Befehl:

setspn.exe -A SMTPSVC/ SERVER.xxxxxxx.local

in die Verwaltungsshell eingebe kommt folgender Fehler:

"FindDomainForAccount: Fehler bei "DSGetDcNameWithAccountW"
Konto Server.xxxxxx.local wurde nicht gefunden"

Was mache ich falsch?

Wäre super, wenn mir hier jemand Unterstützung geben könnte!

Vielen Dank im Voraus!
Mitglied: mexx
10.11.2011 um 10:08 Uhr
Hast Du das Problem gefunden? Ich versuche den Paramenter L um SPNs aufzulisten und erhalte die gleiche Meldung, dass das Konto nicht existieren würde, was natürlich nicht richtig ist.
Bitte warten ..
Mitglied: Pate661
10.11.2011 um 10:54 Uhr
Hallo Mexx,

leider besteht das Problem weiterhin. Bin etwas ratlos...
Bitte warten ..
Mitglied: clever26
14.11.2011 um 20:17 Uhr
Hallo, ihr müsst darauf achten ob es ein normaler Benutzeraccount oder ein Computeraccount ist.

Wenn du die Fehlermeldung "DSGetDcNameWithAccountW" tippe ich mal das es sich um einen Computeraccount handelt. Diese werden mit einem "$" am Ende gekennzeichnet.

Also Computername$ und normale Benutzer einachen nur Name

lg Clever26
Bitte warten ..
Mitglied: mexx
15.11.2011 um 10:45 Uhr
Das kann ich leider nicht bestätigen. Ich hab es ausprobiert. Mit einen "$" am Ende des Namens, kommt bei den Befehl setspn -L XYZ die Fehlermeldung

FindDomainForAccount: Fehler beim Aufrufen von DsGetDcNameWithAccountW mit dem Rückgabewert 0x00000525.
Konto XYZ$ wurde nicht gefunden.

Es handelt sich aber definitiv um ein Benutzerkonto.
Bitte warten ..
Mitglied: clever26
15.11.2011 um 13:05 Uhr
setspn prüft immer den sAMAccountnamen, vielleicht ist der ja anders?

"Start -> verwaltung -> avtive directory-benutzer und -Computer" kann man unter "Ansicht -> erweiterte Features " ein zusätzliches Feld zu den Eigenschaften der Computer- und Benutzer anzeigen lassen, den Attribute-Editor. Hier vielleicht einmal den sAMAccountName überprüfen und schauen ob Service-Principals gesetzt sind oder nicht.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Erkennung und -Abwehr
Virenschutz - Meinungen (25)

Frage von honeybee zum Thema Erkennung und -Abwehr ...

Windows 10
Welches OS für Firmengeräte? (17)

Frage von MarkusVH zum Thema Windows 10 ...

Server-Hardware
gelöst Erfahrungswerte Hardwaresupport physikalische Server (16)

Frage von Devilx zum Thema Server-Hardware ...

Exchange Server
SBS2011: POP3-Connector 10 MB Grenze Email Benachrichtigung (15)

Frage von bogi1102 zum Thema Exchange Server ...