Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ALTIRIS Deployment Server, Silent Installation

Frage Microsoft Windows Server

Mitglied: Kikaha

Kikaha (Level 1) - Jetzt verbinden

30.01.2014, aktualisiert 14:24 Uhr, 2219 Aufrufe, 13 Kommentare, 2 Danke

Hallo,
meine Firma hat einem Kunden Hardware ca. 400 Hardware-Einheiten verkauft. Leider wurde wohl im Vorfeld nicht getestet, ob eine "Silent Installation" von dem benötigten Treiber möglich ist. Silent Installation geht leider nicht. Ich habe jetzt eine Lösung erarbeitet, die eine Silent Installation ermöglicht. Leider ist es dazu notwendig, dass ein Benutzer eingeloggt ist. Erst jetzt habe ich erfahren, dass unser Kunde für die Installation einen "ALTIRIS Deployment Server" einsetzt.

Hier noch mal stichpunktartig mein Scenatio:
- mein Kunde muss einen Treiber als Silent Installation für ein Gerät auf ca. 400 Windows 7 Embedded- PC's installieren
- der Treiber selbst bietet keine Möglichkeit, sich im Silent-Modus zu installieren
- ich habe eine Lösung erarbeitet (wie darf ich nicht sagen ....) wenn man die Dateien auf die Windows7--Maschine kopiert, sich auf die Maschine einloggt und ausführt
- er verwendet zum Installieren einen Altiris Server

Und hier mal der "Hammer": Der Lieferant der Hardware ist nicht willens/ in der Lage, auch gegen Bezahlung einen Treiber für eine "Silent Installation" zu machen. "setup.exe /S /v /qn" funktioniert übrigens nicht.

Kennt jemand eine Lösung, wie man den Treiber installiert bekommt sprich beispielsweise wie man einen "Login" mit Altiris machen kann so dass die "Silent Installation möglich ist? Andere Lösungsvorschläge werden natürlich auch gerne angenommen.

Edit:
- Das OS ist Windows 7 embedded und nicht XP (sorry)
Edit 2:
- Mein selbstgebautes "Setup" startet das eigentliche Setup-Programm vom Treiber und drückt dann automatisiert die entsprechenden Buttons. Wenn mein Setup von Altiris gestartet wird sieht man, dass das Setup vom Treiber aufgerufen wird. Es werden wohl leider nicht die Buttons automatisiert gedrückt.
- Der Hersteller ist nichts bekanntes (so viel kann ich noch sagen)

Vielen Dank schon mal
Mitglied: certifiedit.net
30.01.2014 um 12:08 Uhr
Hallo,

bitte mehr infos:
Was für ein Hersteller, was für Treiber? Warum Windows XP?

LG
Bitte warten ..
Mitglied: Sheogorath
30.01.2014 um 12:27 Uhr
Moin,

wie wäre es mit der Holzhammermethode also Differnzanalyse und fertig.

ansonsten könntest du versuchen die Treiberdaten zu exportieren und eben selbst einbinden z.B. per Autoit mit FileInstall() .

Gruß
Chris
Bitte warten ..
Mitglied: tkr104
30.01.2014 um 12:41 Uhr
Moin,

diesen automatischen Login mit Adminrechten würde ich nicht machen wollen wenngleich es gehen sollte da man beliebige Scripte ausführen kann. Welche Version des DS ist es denn? Warum nimmst du den Treiber nicht auseinander und packst ein MSI?

P.S.: Wenn du hier wirklich Hilfe erwartest musst du schon Informationen rausrücken.

VG,

Thomas
Bitte warten ..
Mitglied: Kikaha
30.01.2014 um 14:01 Uhr
Hallo,
Hersteller darf ich nicht nennen (ist leider so).

Upps. Hab mich mit dem Betriebssystem leider geirrt. Es handelt sich um Windows 7 embedded (macht das jetzt einen großen Unterschied?). Es handelt sich um ein Gerät mit USB-Anschluss. Der Treiber macht dann USB zu Seriell

Gruß
Bitte warten ..
Mitglied: certifiedit.net
30.01.2014, aktualisiert um 14:04 Uhr
Zitat von Kikaha:

Hallo,
Hersteller darf ich nicht nennen (ist leider so).

Upps. Hab mich mit dem Betriebssystem leider geirrt. Es handelt sich um Windows 7 embedded (macht das jetzt einen großen
Unterschied?). Es handelt sich um ein Gerät mit USB-Anschluss. Der Treiber macht dann USB zu Seriell

Gruß

Ohne Hersteller keine große Hilfeleistung möglich.

Ich erwarte ja auch nicht, dass mir jemand hilft, wenn ich sage mein Emailserver geht nicht (beispielhaft), ohne, dass ich sage um welchen Hersteller und welche Version es sich handelt.

Zum Unterschied zwischen Windows XP und Windows 7 zum Windows 7 Embedded...ja, das macht einen marginalen Unterschied.

Imho suchst du hier daher falsch, du brauchst ggf. ein Partner, der das Rollout übernimmt. Da kann man dann auch ganz offen reden (muss).
Bitte warten ..
Mitglied: Kikaha
30.01.2014 um 15:45 Uhr
Zitat von tkr104:

Moin,

diesen automatischen Login mit Adminrechten würde ich nicht machen wollen wenngleich es gehen sollte da man beliebige Scripte
ausführen kann. Welche Version des DS ist es denn? Warum nimmst du den Treiber nicht auseinander und packst ein MSI?

P.S.: Wenn du hier wirklich Hilfe erwartest musst du schon Informationen rausrücken.

VG,

Thomas

Wie funktioniert das mit dem automatischen Login? Wenn das zielführend ist wäre mir auch schon viel geholfen. Die DS-Version weiß ich jetzt leider nicht genau; ich glaube 6.9 . Meinen Kunden möchte ich jetzt ungern befragen da er auf die Lösung wartet....

Wie packe ich denn ein MSI?

Beim Installieren werden 2 Ordner im Temp- Bereich angelegt

Ordner 1:
0x0409.ini
0x0411.ini
1033.MST
"Setup2".msi (Name gändert!
ISSetup.dll
Setup.INI
_ISMSIDEL.INI

Dieses Setup2.msi meckert beim Aufrufen und sagt "This Installation cannot be run directly launching the MSI package. You must run Setup.exe.

Ordner 2:
devcon.exe
devcon_amd64.exe
dwcom.exe
dwserial.cat
dwserial.inf
dwserial.sys
dwserial_amd64.cat
dwserial_amd64.inf
dwserial_amd64.sys
dwsuninst.exe
dwsuninst_amd64.exe
dwuninst.exe
dwuninst_amd64.exe
dwusb.cat
dwusb.inf
dwusb.sys
dwusb8.cat
dwusb_amd64.cat
dwusb_amd64.inf
dwusb_amd64.sys
dwusb_win8_x86.inf
ISBEW64.exe
ISRT.dll
setup.exe
setup.inx
String1033.txt
_isres_0x0409.dll

"Setup.exe /S /v/qn" funktioniert nicht obwohl das bei "Setup /?" so angezeigt wird :=(

Wenn das Gerät angeschlossen wurde wird im Gerätemanager bei der RS232-Schnittstelle als Treiber "dwserial.sys" angezeigt. Ich glaube aber, dass "dwusb" bestimmt auch gebraucht wird oder?
Bitte warten ..
Mitglied: tkr104
30.01.2014 um 16:14 Uhr
Zitat von Kikaha:

ISSetup.dll

Dann scheint das ja ein Installshield Setup zu sein, das kann man ziemlich sicher Silent installieren.
Vgl. http://publib.boulder.ibm.com/tividd/td/framework/GC32-0804-00/en_US/HT ...
und dann natürlich für dich adaptieren...

VG,

Thomas
Bitte warten ..
Mitglied: Kikaha
31.01.2014 um 15:00 Uhr
Zitat von tkr104:

> Zitat von Kikaha:
>
> ISSetup.dll

Dann scheint das ja ein Installshield Setup zu sein, das kann man ziemlich sicher Silent installieren.
Vgl. http://publib.boulder.ibm.com/tividd/td/framework/GC32-0804-00/en_US/HT ...
und dann natürlich für dich adaptieren...

VG,

Thomas
Konnte leider erst jetzt weiter probieren.
Deine Lösung funktioniert leider nicht! Die Parameter -r und -f1 werden nicht akzeptiert.
Aus /S /V/qn schliesse ich, dass es sich um ein "InstallShield + MSI" handelt (siehe auch http://wiki.win-lite.de/index.php?title=Allgemein:Unbeaufsichtigte_Inst ...)

Bei Setup.exe /? kommt folgende Hilfe:
/L language ID
/S Hide initialization dialog. For silent mode use: /S /v/qn.
/V parameters to MsiExec.exe
/UA<url to InstMsiA.exe>
/UW<url to InstMsiW.exe>
/UM<url to msi package>
/US<url to IsScript.msi>

"Setup.exe /S /v /qn", "Setup.exe /SP-" funktioniert nicht! Es kommt zwar keine Fehlermeldung aber der Treiber wird nicht installiert. Das Prompt an in der Eingabeaufforderung wird quasi sofort wieder angezeigt. Stellungnahme des Herstellers (bei /S /v/qn): Steht nicht in der Anleitung dass das funktioniert.

Bei "Setup.exe /V/quit", "Setup.exe /V/qb, "Setup.exe /V/qr passiert quasi das gleiche wie bei Setup.exe ohne Parameter; es werden Benutzereingaben verlangt.
"Setup.exe /V/passive" ==> "Invalid commandline"

"Setup.exe /VerySilent" Error 1629 Invalid commandline

Evtl. hilft doch nur die "Snapshot"- Methode :=( . Oder hast du (jemand) noch eine Idee?
Bitte warten ..
Mitglied: tkr104
31.01.2014 um 15:48 Uhr
Moin,

lt deinem Link heist der korrekte Aufruf

01.
"Setup.exe" /s /v"/qn"
Bist du sicher das du das mit den Anfuehrungszeichen genau so eingegeben hast?

VG,

Thomas
Bitte warten ..
Mitglied: Kikaha
31.01.2014 um 16:05 Uhr
Zitat von tkr104:

Moin,

lt deinem Link heist der korrekte Aufruf

01.
"Setup.exe" /s /v"/qn"
Bist du sicher das du das mit den Anfuehrungszeichen genau so eingegeben hast?

VG,

Thomas

Hab's eben noch mal getestet. Hab mich leider nicht vertippt. Das Prompt an der Eingabeaufforderung kommt quasi sofort. Es macht auch keinen Unterschied, ob die Buchstaben GROß oder klein geschrieben sind und oder die Anführungszeichen drin sind. Das Setup wird wohl sofort wieder beendet da beim nächsten Test keine Fehlermeldung kommt wie "Es ist noch eine Installation aktiv".

Gruß
Bitte warten ..
Mitglied: Sheogorath
31.01.2014 um 16:54 Uhr
Moin,

wie ich schon sagte, nimm die Holzhammer Methode, differenzanalyse, daraus das Paket fertig. Du bist schneller, wenn du alle Änderungen durchgehst und auf Sinn prüfst als zu warten, dass der Silentinstall für das Setup vom Himmel fällt. Je nach Bedarf kannst du eine MSI erstellen und sogar die Konfiguration, wenn du sie denn benötigst gleich mit verbauen.

Gruß
Chris
Bitte warten ..
Mitglied: tkr104
31.01.2014 um 16:59 Uhr
Zitat von Sheogorath:

Moin,

wie ich schon sagte, nimm die Holzhammer Methode, differenzanalyse, daraus das Paket fertig. Du bist schneller, wenn du alle
Änderungen durchgehst und auf Sinn prüfst als zu warten, dass der Silentinstall für das Setup vom Himmel
fällt. Je nach Bedarf kannst du eine MSI erstellen und sogar die Konfiguration, wenn du sie denn benötigst gleich mit
verbauen.

Gruß
Chris

Da schliesse ich mich an, offensichtlich bastelst du ja schon eine Weile an dem Problem. Das aufzeichnen duerfte bei nem Treiber relativ fix gehen...

VG,

Thomas
Bitte warten ..
Mitglied: Kikaha
31.01.2014 um 17:11 Uhr
Zitat von tkr104:

> Zitat von Sheogorath:
>
> Moin,
>
> wie ich schon sagte, nimm die Holzhammer Methode, differenzanalyse, daraus das Paket fertig. Du bist schneller, wenn du alle
> Änderungen durchgehst und auf Sinn prüfst als zu warten, dass der Silentinstall für das Setup vom Himmel
> fällt. Je nach Bedarf kannst du eine MSI erstellen und sogar die Konfiguration, wenn du sie denn benötigst gleich
mit
> verbauen.
>
> Gruß
> Chris

Da schliesse ich mich an, offensichtlich bastelst du ja schon eine Weile an dem Problem. Das aufzeichnen duerfte bei nem Treiber
relativ fix gehen...

VG,

Thomas

Wird ich wohl machen (müssen). Ich denk hoffentlich dran euch mitzuteilen, wie die ganze Aktion ausgegangen ist. Kann aber erst in ein paar Tagen mich an der "Holzhammermethode" versuchen.

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...