Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Angebundenes CSS funktioniert nach Link nicht mehr

Frage Entwicklung HTML

Mitglied: fugu

fugu (Level 2) - Jetzt verbinden

04.08.2016 um 11:20 Uhr, 569 Aufrufe, 4 Kommentare

Moin Com,

ich habe das Problem, dass beim einem Link auf die gleiche Seite zum Ausführen eines Scripts das CSS nicht mehr mit angebunden wird.

Zunächst der Code:
01.
<p><strong>Neue Datensicherung erstellen: </strong><a href="<?php echo $_SERVER['PHP_SELF']; ?>/?exec=yes"><img src="../gfx/floppy-disk.png"></a></p> 
02.
... 
03.
<?php if(isset($_GET['exec'])) {...
Beim Klick auf den Link wird die Seite korrekt neu aufgerufen, das Script auch ausgeführt, aber das CSS greift nicht mehr.
Klicke ich dann auf der falsch bzw. garnicht CSS formatierten Zielseite auf einen der Navigations-Punkte sehen die Links wie folgt aus:

http://domain.de/admin/db-backup.php/db-backup.php

Irgendwie ist aus der "db-backup.php" über den Link ein Verzeichnissprung geworden... und ich stehe gerade völlig im Wald... Warum?

Vielen Dank im voraus für einen Tip.

Greetz, Fugu
Mitglied: atze187
04.08.2016, aktualisiert um 11:48 Uhr
Hi,

die Datei wird nicht gefunden (404): /_css/template.css

Und statt PHP_SELF wäre REQUEST_URI wohl besser.

Gruß,
André
Bitte warten ..
Mitglied: fugu
04.08.2016 um 12:00 Uhr
Danke für die schnelle Antwort. Aber...
Code geändert:
01.
<a href="<?php echo $_SERVER['REQUEST_URI']; ?>/?exec=yes">
Gleiches Problem...

Fugu
Bitte warten ..
Mitglied: atze187
LÖSUNG 04.08.2016 um 12:16 Uhr
Ach, ist der Slash vor dem Fragezeichen das Problem?

Kann es sein dass das ganze gar nicht domain.de läuft?
Bitte warten ..
Mitglied: fugu
04.08.2016 um 12:19 Uhr
Jau... Betriebsblind gewesen... den hab ich echt übersehen...
DANKE !! :D
Bitte warten ..
Ähnliche Inhalte
CSS
gelöst Silbentrennung in CSS (1)

Frage von honeybee zum Thema CSS ...

Entwicklung
gelöst IOS WebApp lädt CSS nicht mit (2)

Frage von maddig zum Thema Entwicklung ...

CSS
gelöst CSS: Menü ein- und ausblenden (6)

Frage von honeybee zum Thema CSS ...

Suse
gelöst SquidGuard filtert CSS (3)

Frage von killtec zum Thema Suse ...

Neue Wissensbeiträge
LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte