Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Angebundenes CSS funktioniert nach Link nicht mehr

Frage Entwicklung HTML

Mitglied: fugu

fugu (Level 2) - Jetzt verbinden

04.08.2016 um 11:20 Uhr, 474 Aufrufe, 4 Kommentare

Moin Com,

ich habe das Problem, dass beim einem Link auf die gleiche Seite zum Ausführen eines Scripts das CSS nicht mehr mit angebunden wird.

Zunächst der Code:
01.
<p><strong>Neue Datensicherung erstellen: </strong><a href="<?php echo $_SERVER['PHP_SELF']; ?>/?exec=yes"><img src="../gfx/floppy-disk.png"></a></p> 
02.
... 
03.
<?php if(isset($_GET['exec'])) {...
Beim Klick auf den Link wird die Seite korrekt neu aufgerufen, das Script auch ausgeführt, aber das CSS greift nicht mehr.
Klicke ich dann auf der falsch bzw. garnicht CSS formatierten Zielseite auf einen der Navigations-Punkte sehen die Links wie folgt aus:

http://domain.de/admin/db-backup.php/db-backup.php

Irgendwie ist aus der "db-backup.php" über den Link ein Verzeichnissprung geworden... und ich stehe gerade völlig im Wald... Warum?

Vielen Dank im voraus für einen Tip.

Greetz, Fugu
Mitglied: atze187
04.08.2016, aktualisiert um 11:48 Uhr
Hi,

die Datei wird nicht gefunden (404): /_css/template.css

Und statt PHP_SELF wäre REQUEST_URI wohl besser.

Gruß,
André
Bitte warten ..
Mitglied: fugu
04.08.2016 um 12:00 Uhr
Danke für die schnelle Antwort. Aber...
Code geändert:
01.
<a href="<?php echo $_SERVER['REQUEST_URI']; ?>/?exec=yes">
Gleiches Problem...

Fugu
Bitte warten ..
Mitglied: atze187
LÖSUNG 04.08.2016 um 12:16 Uhr
Ach, ist der Slash vor dem Fragezeichen das Problem?

Kann es sein dass das ganze gar nicht domain.de läuft?
Bitte warten ..
Mitglied: fugu
04.08.2016 um 12:19 Uhr
Jau... Betriebsblind gewesen... den hab ich echt übersehen...
DANKE !! :D
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(2)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Systemdateien
Warum System auf "C:" (29)

Frage von DzumoPRO zum Thema Windows Systemdateien ...

Cloud-Dienste
gelöst Bitcoins minen über Nacht? (16)

Frage von 1410640014 zum Thema Cloud-Dienste ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...