Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Anmeldeskript soll Benutzer abgleichen. Klappt aber nicht.

Frage Entwicklung Batch & Shell

Mitglied: seventy

seventy (Level 1) - Jetzt verbinden

15.11.2006, aktualisiert 20:32 Uhr, 4269 Aufrufe, 3 Kommentare

Ich versuche per Batch ein Anmeldeskript zu erstellen, welches beim Start die Netzlaufwerke verbindet. (Info: keine Domäne/nur Workgroup) Natürlich soll nicht jeder Nutzer die gleichen Netzlaufwerke bekommen, also hab ich folgendes versucht, aber es klappt nicht:

if "%username%"=="Name des Nutzers"
net use .....

Was mache ich falsch? Bin noch neu auf dem Gebiet und die Recherche bei Google und hier hat nichts treffendes zu Tage gefördert.

Danke im Voraus!

Björn
Mitglied: bastla
15.11.2006 um 20:15 Uhr
Hallo Björn!

Versuch es einmal so:
01.
if /i "%username%"=="Name des Nutzers" net use ...
Das /i sorgt dafür, dass nicht zwischen Groß- und Kleinschreibung unterschieden wird. Im übrigen kannst Du Dir durch die Eingabe von "set u" (das "u", damit nur die mit "u" beginnenden Systemvariablen angezeigt werden) die Schreibweise des Benutzernamens zur Kontrolle anzeigen lassen.

HTH
bastla
Bitte warten ..
Mitglied: Egbert
15.11.2006 um 20:20 Uhr
Hallo

dann mach doch mal

if "%USERNAME%"=="name" net use ...

Gruß
Egbert
Bitte warten ..
Mitglied: seventy
15.11.2006 um 20:32 Uhr
Vielen Dank! Jetzt hat es geklappt, der Teufel ist ein Eichhörnchen. =)

Wünsch' Euch noch einen netten Abend!

Björn
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...